source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 1637

Revision 1637, 24.8 KB checked in by inagaki, 14 years ago (diff)

update: KDE 4.5.0, digikam

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       K Desktop Environment - Runtime
5Summary(ja):   K デスクトップ環境 - ランタイム
6Version:       4.5.0
7Release:       1%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebase-runtime-%{version}.tar.bz2
15Source1:       khelpcenter.desktop
16
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18Patch2:        kdebase-runtime-4.2.85-knetattach.patch
19Patch3:        kdebase-runtime-4.1.1-iconthemes-inherit.patch
20Patch5:        kdebase-runtime-4.3.1-manpath.patch
21# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
22Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
23
24## 4.5 Upstream patches
25# backport of 1160390, fixed: start call to cagibi only in next event loop, could be started
26# in on-demand load by a d-bus call ourself, so d-bus connection has a mutex locked already
27Patch100: kdebase-runtime-4.5.0-kioslave.patch
28Patch101: kdebase-runtime-4.4.0-virtuosoconverter.patch
29
30
31# when kdesu was removed, this is/should-be only temporary
32Provides:  kdebase4-runtime = %{version}-%{release}
33Obsoletes: kdebase4-runtime < %{version}-%{release}
34
35# knotify4 provides dbus service org.freedesktop.Notifications too
36Provides: desktop-notification-daemon
37
38Requires: kdepimlibs >= %{version}
39Requires: eject
40Requires: %{name}-libs = %{version}-%{release}
41# KHelpcenter requires htdig for building search indices
42Requires: htdig
43
44# ensure default/fallback icon theme present
45# beware of bootstrapping, there be dragons
46Requires: oxygen-icon-theme >= %{version}
47
48BuildRoot:     %{_tmppath}/%{name}-%{version}-root
49BuildRequires: alsa-lib-devel
50BuildRequires: attica-devel
51BuildRequires: bzip2-devel
52BuildRequires: clucene-core-devel
53BuildRequires: exiv2-devel
54BuildRequires: hal-devel
55BuildRequires: kdelibs4-devel >= %{version}
56BuildRequires: kdepimlibs-devel >= %{version}
57BuildRequires: libsmbclient-devel
58BuildRequires: libXScrnSaver-devel
59BuildRequires: OpenEXR-devel
60BuildRequires: openslp-devel
61BuildRequires: openssl-devel
62BuildRequires: pkgconfig
63BuildRequires: polkit-qt-devel
64BuildRequires: pulseaudio-libs-devel
65BuildRequires: qimageblitz-devel
66BuildRequires: shared-desktop-ontologies-devel
67BuildRequires: soprano-devel >= 2.3.0
68BuildRequires: xine-lib-devel libxcb-devel
69BuildRequires: xorg-x11-font-utils
70BuildRequires: xorg-x11-proto-devel
71%if %{?_dist_release} != "vl4" && %{?_dist_release} != "vl5"
72BuildRequires: libssh-devel >= 0.4.2
73BuildRequires: xz-devel
74%endif
75BuildRequires: zlib-devel
76
77%if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
78Conflicts: kdebase3
79%endif
80
81%description
82Core runtime for the K Desktop Environment 4.
83
84
85%package libs
86Summary: Runtime libraries for %{name}
87Summary(ja): %{name} のランタイムライブラリ
88Group:   System Environment/Libraries
89Requires: kdelibs4 >= %{version}
90Requires: kdepimlibs >= %{version}
91#Requires: %{name} = %{version}-%{release}
92# cagibi is runtime dep, a dbus service
93Requires: cagibi
94
95%description libs
96%{summary}.
97
98
99%package flags
100Summary: Geopolitical flags
101Group: User Interface/Desktops
102Requires: %{name} = %{version}-%{release}
103
104%description flags
105%{summary}.
106
107
108%prep
109%setup -q -n kdebase-runtime-%{version}
110
111%patch1 -p1 -b .searchproviders-shortcuts
112%patch2 -p1 -b .knetattach
113%patch3 -p1 -b .iconthemes-inherit
114#patch5 -p1 -b .manpath
115%patch6 -p1 -b .home_onlyshowin_kde
116
117%patch100 -p1 -b .kioslave
118%patch101 -p1 -b .virtuosoconverter
119
120%build
121mkdir -p %{_target_platform}
122pushd %{_target_platform}
123unset QTDIR || : ; . /etc/profile.d/qt4.sh
124%cmake \
125    -DCMAKE_BUILD_TYPE=release \
126    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
127    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
128    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
129    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
130    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
131    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
132    ..
133popd
134
135make %{?_smp_mflags} -C %{_target_platform}
136
137
138%install
139rm -rf $RPM_BUILD_ROOT
140
141make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
142
143# kdesu symlink
144ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
145
146# omit hicolor index.theme, use one from hicolor-icon-theme
147rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
148
149# remove country flags because some people/countries forbid some other
150# people/countries' flags :-(
151%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
152
153# install this service for KDE 3 applications
154# NOTE: This is not a standard .desktop file, but an "almost standard" one
155#       installed into a KDE-3-specific directory, as usual for KDE 3 services,
156#       so we can't use desktop-file-install for it.
157install -p -D %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
158
159# FIXME: -devel type files, omit for now
160rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%post
166touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
167touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
168
169%posttrans
170gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
171gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
172update-desktop-database -q &> /dev/null ||:
173update-mime-database %{_datadir}/mime &> /dev/null
174
175%postun
176if [ $1 -eq 0 ] ; then
177    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
178    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
179    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
180    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
181    update-desktop-database -q &> /dev/null ||:
182    update-mime-database %{_datadir}/mime &> /dev/null
183fi
184
185%post libs -p /sbin/ldconfig
186%postun libs -p /sbin/ldconfig
187
188
189%files
190%defattr(-,root,root,-)
191%{_sysconfdir}/dbus-1/system.d/*
192%{_sysconfdir}/xdg/menus/kde-information.menu
193%{_bindir}/*
194# omit ksvgtopng which kdelibs3 includes
195%if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
196%exclude %{_bindir}/ksvgtopng
197%endif
198# FIXME(?), currently contains cmake/modules -- Rex
199%{_datadir}/kde4/apps/*
200%{_datadir}/config/*.knsrc
201%{_datadir}/autostart/nepomukserver.desktop
202%{_datadir}/config.kcfg/
203%{_datadir}/dbus-1/interfaces/*
204%{_datadir}/dbus-1/services/*
205%{_datadir}/dbus-1/system-services/*
206%{_datadir}/icons/default.kde4
207%{_datadir}/kde4/services/*
208%{_datadir}/kde4/servicetypes/*
209%{_datadir}/mime/packages/network.xml
210%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
211%{_datadir}/sounds/*
212%{_libdir}/kconf_update_bin/*
213%{_libdir}/libkdeinit4_*.so
214%{_libdir}/kde4/kcm_*.so
215%{_libdir}/kde4/kded_*.so
216%{_libexecdir}/kde4/*
217%{_libdir}/strigi/*
218%{_mandir}/man1/*
219%{_mandir}/man8/*
220%{_datadir}/icons/hicolor/*/*/*
221%{_docdir}/HTML/en/*
222%{_datadir}/applications/kde4/Help.desktop
223%{_datadir}/applications/kde4/knetattach.desktop
224%{_datadir}/config/kshorturifilterrc
225%{_datadir}/desktop-directories/*.directory
226%{_datadir}/emoticons/kde4/
227%{_datadir}/locale/en_US/entry.desktop
228%{_datadir}/locale/l10n/
229%{_datadir}/locale/currency/
230%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
231%{_datadir}/services/khelpcenter.desktop
232
233%files libs
234%defattr(-,root,root,-)
235%{_libdir}/attica_kde.so
236%{_libdir}/libkwalletbackend.so.*
237%{_libdir}/libmolletnetwork.so.*
238%{_libdir}/kde4/*.so
239# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
240%exclude %{_libdir}/kde4/kcm_*.so
241%exclude %{_libdir}/kde4/kded_*.so
242%{_libdir}/kde4/plugins/phonon_platform/
243#{_libdir}/kde4/plugins/styles/
244
245%if 0%{?flags}
246%files flags
247%defattr(-,root,root,-)
248%{_datadir}/locale/l10n/*/flag.png
249%endif
250
251
252%changelog
253* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
254- new upstream release
255- added Patch100 from Fedora
256  - backport to fix the freeze of kded on first use of the network:/kio-slave
257
258* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
259- new upstream release
260- added Conflicts: kdebase3 at Vine Linux 5
261
262* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
263- new upstream release
264
265* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
266- rebuilt with exiv2-0.19
267
268* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
269- new upstream release
270
271* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
272- new upstream release
273
274* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
275- new upstream release
276- built with new toolchain
277
278* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
279- new upstream release
280
281* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
282- new upstream release
283
284* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
285- new upstream release
286- used %%cmake macro
287
288* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
289- Initial build for Vine Linux
290
291* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
292- respin
293
294* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
295- 4.3.0
296
297* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
298- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
299
300* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
301- 4.3rc3
302
303* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
304- respin (soprano-2.3.0)
305- License: LGPLv2+
306
307* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
308- 4.3rc2
309
310* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
311- drop unneeded BR: ImageMagick (#509241)
312
313* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
314- don't start nepomuk server unconditionally (#487322)
315
316* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
317- 4.3rc1
318
319* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
320- KDE-4.3 beta2 (4.2.90)
321
322* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
323- Drop old Fedora < 8 conditionals
324
325* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
326- file conflicts with kdepim
327
328* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
329- KDE 4.3 beta 1
330
331* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
332- fix persistent systray notifications (#485796)
333
334* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
335- -flags subpkg
336- koji/noarch hacks dropped
337
338* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
339- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
340
341* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
342- KDE 4.2.2
343
344* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
345- flags subpkg (not enabled)
346- optimize scriptlets
347
348* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
349- fix PulseAudio cmake detection
350
351* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
352- 4.2.1
353
354* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
355- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
356
357* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
358- #486059 -  missing dependency on htdig
359
360* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
361- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
362
363* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
364- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
365
366* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
367- own %%_kde4_datadir/locale/l10n/
368
369* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
370- respun tarball
371
372* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
373- Files not trashed to the correct location in Dolphin/Konqueror
374  (#481598, kdebug#178479)
375- omit --with-samba crud
376
377* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
378- 4.2.0
379- +BR: pulseaudio-libs-devel xine-lib-devel
380- -BR: giflib-devel pcre-devel
381
382* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
383- tarball respin
384- drop extraneous deps (that are in kdelibs)
385
386* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
387- 4.2rc1
388
389* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
390- include %%_bindir/kdesu symlink
391
392* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
393- 4.2beta2
394
395* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
396- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
397  and should be in a -devel package if it gets shipped)
398
399* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
400- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
401
402* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
403- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
404
405* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
406- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
407
408* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
409- 4.1.80
410- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
411- BR cmake >= 2.6.2
412- Use 'make install/fast'
413- Drop subpkg phonon-backend-xine and related file entries: this has to be
414  part of phonon now that it moved there
415- Drop xine-lib-devel BR
416- Add libkwalletbackend to files list
417- Drop _default_patch_fuzz 2
418
419* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
420- apply upstream patch to fix X crash when disabling compositing
421
422* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
423- 4.1.3
424
425* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
426- apply upstream patch, kioexec processes never terminate
427
428* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
429- fix broken audio-backend-jack.svgz
430
431* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
432- add missing icons
433
434* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
435- make VERBOSE=1
436- respin against new(er) kde-filesystem
437- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
438
439* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
440- 4.1.2
441
442* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
443- fix inherit issue in iconthemes, preview icons
444  do not show
445
446* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
447- fix #460710, knetattach is kio_remote's wizard program, don't show
448  it in the menu.
449
450* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
451- 4.1.1
452
453* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
454- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
455
456* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
457- crash fix when stopping a service that is not yet initialized
458
459* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
460- don't remove autostart directory on F8- (does not conflict, fixes build
461  failure due to nepomukserver.desktop listed in filelist but not found)
462
463* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
464- 4.1.0
465
466* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
467- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
468
469* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
470- 4.0.99
471
472* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
473- respin
474
475* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
476- -phonon-backend-xine: new subpkg
477
478* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
479- 4.0.98
480
481* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
482- 4.0.85
483
484* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
485- 4.0.84
486
487* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
488- 4.0.83 (beta2)
489
490* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
491- 4.0.82
492
493* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
494- add searchproviders-shortcuts for redhat bugzilla
495
496* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
497- 4.1 beta 1
498
499* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
500- BR new minimum version of soprano-devel
501
502* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
503- update to 4.0.72 (4.1 alpha 1)
504- drop upstreamed deinterlace-crash patch
505- drop khelpcenter patch (fixed upstream)
506- update Phonon PulseAudio patch
507- drop Fedora 7 support
508- update file list
509
510* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
511- omit conflicting icons (kde3_desktop=1 case)
512
513* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
514- oxygen-icon-theme: build noarch
515
516* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
517- %%post/%%postun: hicolor icon theme scriptlets
518
519* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
520- only omit hicolor index.theme (#439374)
521
522* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
523- fix khelpcenter, search plugins/settings in correct path (#443016)
524
525* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
526- respin (at f13's request)
527
528* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
529- pulseaudio patch (use as default, if available)
530
531* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
532- don't crash if we don't have deinterlacing support in xine-lib (#440299)
533
534* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
535- rebuild for the new %%{_kde4_buildtype}
536
537* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
538- update file list for _kde4_libexecdir
539
540* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
541- 4.0.3
542
543* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
544- don't own %%_kde4_docdir/HTML/en/
545
546* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
547- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
548- include noarch build hooks (not enabled)
549
550* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
551- BR libxcb-devel everywhere (including F7)
552
553* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
554- if building for a KDE 4 desktop, include the khelpcenter.desktop service
555  description for KDE 3 here so help works in KDE 3 apps
556
557* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
558- 4.0.2
559
560* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
561- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
562
563* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
564- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
565  (kio_smb itself is already GPLv2+)
566
567* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
568- 4.0.1
569
570* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
571- respun tarball
572
573* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
574- update to 4.0.0
575- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
576
577* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
578- kde-3.97.0
579
580* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
581- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
582
583* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
584- build without libxcb in F7 as we STILL don't have it (see #373361)
585
586* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
587- no longer set kde3_desktop on F9
588- update file list for !kde3_desktop (Sebastian Vahl)
589- don't ship country flags even for full version (as in kdebase 3)
590
591* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
592- kde-3.96.2
593
594* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
595- kde-3.96.1
596
597* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
598- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
599
600* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
601- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
602
603* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
604- kde-3.96.0
605
606* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
607- kdebase-runtime-3.95.2
608
609* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
610- kdebase-runtime-3.95.0
611
612* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
613- Provides: oxygen-icon-theme ...
614
615* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
616- patch dolphin.desktop to get Dolphin to start from the menu
617
618* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
619- update to 3.94.0
620
621* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
622- don't make this the default kdebase on F9 yet
623- drop ExcludeArch: ppc64 (#300601)
624
625* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
626- ExcludeArch: ppc64 (#300601)
627- update description
628
629* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
630- add missing BR alsa-lib-devel
631
632* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
633- remove files which conflict with KDE 3
634- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
635- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
636
637* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
638- update to 3.93.0
639- drop kde4home patch (no longer applied)
640- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
641- remove kdebase-kdm Obsoletes/Provides (for the same reason)
642- remove KDM (and KDM session) setup code (for the same reason)
643- remove rss-glx conflict (Plasma is now in kdebase-workspace)
644- remove redhat-startkde patch (startkde is now in kdebase-workspace)
645- remove kde4-opt.sh (all the code in it is commented out)
646- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
647- remove bogus BRs on automake and libtool
648- remove workspace-only BRs
649- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
650- remove workspace files and directories
651- handle icons (moved from kdelibs4)
652- add mkdir %%{buildroot} in %%install
653
654* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
655- use macros.kde4
656- License: GPLv2
657
658* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
659- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
660- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
661- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
662
663* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
664- consolekit_kdm patch (#228111, kde#147790)
665- update startkde patch
666
667* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
668- kde-3.92 (kde-4-beta1)
669
670* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
671- fix startkde
672- add env/shutdown directory
673
674* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
675- kde4.desktop: fix session Name
676
677* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
678- cleanup/fix kde4.desktop
679- kdepimlibs4->kdepimlibs
680
681* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
682- fix %%_sysconfdir for %%_prefix != /usr case.
683
684* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
685- updated kde4home.diff
686- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
687
688* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
689- kde-3.91.0
690- CMAKE_BUILD_TYPE=debug
691
692* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
693- specfile cleanup (%%prefix issues mostly)
694
695* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
696- update to 3.90.1
697- bump cmake BR to 2.4.5 as required upstream now
698- don't set execute bits by hand anymore, cmake has been fixed
699- use multilibs in /opt/kde4
700- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
701- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
702  in case we want to drop the Rs on these from kdelibs4-devel
703- consistently add all BRs as -devel Rs, not just almost all, until we can
704  figure out which, if any, are really needed
705- BR libsmbclient-devel instead of samba on F>=7, EL>=6
706
707* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
708- restore minimum version requirement for cmake
709- build against libxklavier on EL5
710- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
711
712* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
713- +eXecute perms for %%{_prefix}/lib/*
714
715* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
716- rebuild for patched FindKDE4Internal.cmake
717
718* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
719- update to 3.80.3
720- update and improve parallel-installability patch
721- drop obsolete joydevice.h patch
722- remove translations of "KDE" without the "4" from kde4.desktop
723- resync BR and -devel Requires
724- don't set LD_LIBRARY_PATH
725- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
726- fix missing underscore in _datadir
727- install kde4.desktop in install, not prep
728- fix invalid syntax in kde4.desktop
729
730* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
731- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
732- compiling with QA_RPATHS=0x0003; export QA_RPATHS
733
734* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
735- parallel build support
736- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
737- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
738- spec file cleanups and added clean up in %%install
739- fixed PATH for libkdecore.so.5; cannot open shared object file;
740- added Logitech mouse support
741- added dbus-devel, hal-devel and more as BR
742- fixed broken joydevice.h - Kevin Kofler
743- added file kde4.desktop
744
745* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
746- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
747- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.