source: projects/specs/trunk/k/kdebase-runtime/kdebase-runtime-vl.spec @ 5383

Revision 5383, 27.2 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%define flags 1
2
3Name:          kdebase-runtime
4Summary:       KDE Runtime
5Summary(ja):   KDE ランタイム
6Version:       4.7.4
7Release:       2%{?_dist_release}
8
9# http://techbase.kde.org/Policies/Licensing_Policy
10License:       LGPLv2+
11Group:         User Interface/Desktops
12URL:           http://www.kde.org/
13
14Source0:       ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kde-runtime-%{version}.tar.bz2
15
16# add shortcuts for search provider
17Patch1:        kdebase-runtime-4.1.x-searchproviders-shortcuts.patch
18
19# make icontheme inherit working, https://bugs.kde.org/59901
20Patch3:        kdebase-runtime-4.6.90-iconthemes-inherit.patch
21
22# add OnlyShowIn=KDE  to Desktop/Home.desktop (like trash.desktop)
23Patch6:        kdebase-runtime-4.3.3-home_onlyshowin_kde.patch
24
25# correct path for htsearch
26Patch7:        kdebase-runtime-4.5.3-htsearch.patch
27
28# Launch compiz via compiz-manager so we get window decorations and
29# other such decadent luxuries (AdamW 2011/01)
30Patch8:        kdebase-runtime-4.5.95-compiz.patch
31
32# add overrides in default manpath
33Patch9:        kdebase-runtime-4.3.4-man-overrides.patch
34
35## upstream patches
36
37Provides:  kdebase4-runtime = %{version}-%{release}
38Provides:  kde-runtime = %{version}-%{release}
39Obsoletes: kdebase4-runtime < %{version}-%{release}
40
41Obsoletes: nepomukcontroller
42Provides:  nepomukcontroller = 0.2-5%{?_dist_release}
43
44# knotify4 provides dbus service org.freedesktop.Notifications too
45Provides: desktop-notification-daemon
46
47BuildRoot:     %{_tmppath}/%{name}-%{version}-root
48BuildRequires: alsa-lib-devel
49BuildRequires: attica-devel >= 0.1.4
50BuildRequires: bzip2-devel
51BuildRequires: chrpath
52BuildRequires: clucene-core-devel
53BuildRequires: doxygen
54BuildRequires: exiv2-devel >= 0.12
55BuildRequires: glib2-devel
56BuildRequires: kdelibs4-devel >= %{version}
57BuildRequires: kdepimlibs-devel >= %{version}
58BuildRequires: libcanberra-devel
59#BuildRequires: libqzeitgeist-devel
60BuildRequires: libsmbclient-devel
61BuildRequires: libssh-devel >= 0.4.2
62BuildRequires: libXpm-devel
63BuildRequires: libXScrnSaver-devel
64BuildRequires: NetworkManager-devel
65BuildRequires: OpenEXR-devel
66BuildRequires: openslp-devel
67BuildRequires: openssl-devel
68BuildRequires: pkgconfig
69BuildRequires: polkit-qt-devel
70BuildRequires: pulseaudio-libs-devel
71BuildRequires: qimageblitz-devel
72BuildRequires: shared-mime-info >= 0.40
73BuildRequires: shared-desktop-ontologies-devel >= 0.6.50
74BuildRequires: soprano-devel >= 2.6.50
75BuildRequires: xine-lib-devel libxcb-devel
76BuildRequires: xorg-x11-font-utils
77BuildRequires: xorg-x11-proto-devel
78BuildRequires: xz-devel
79BuildRequires: zlib-devel
80
81Requires: eject
82Requires: %{name}-libs = %{version}-%{release}
83Requires: %{name}-flags = %{version}-%{release}
84# KHelpcenter requires htdig for building search indices
85Requires: htdig
86# ensure default/fallback icon theme present
87# beware of bootstrapping, there be dragons
88Requires: oxygen-icon-theme >= %{version}
89
90# some items moved -workspace -> -runtime
91Conflicts: kdebase-workspace < 4.5.80
92
93%description
94Core runtime for KDE 4.
95
96%description -l ja
97KDE 4 の中心となるランタイム部分です.
98
99%package devel
100Summary:  Developer files for %{name}
101Summary(ja): %{name} の開発用ファイル
102Group:    Development/Libraries
103Requires: %{name}-libs = %{version}-%{release}
104
105%description devel
106%{summary}.
107
108%description -l ja devel
109%{name} の開発用ファイルです.
110
111%package libs
112Summary: Runtime libraries for %{name}
113Summary(ja): %{name} のランタイムライブラリ
114Group:   System Environment/Libraries
115Requires: kdelibs4 >= %{version}
116Requires: kdepimlibs >= %{version}
117# cagibi is runtime dep, a dbus service
118Requires: cagibi
119
120%description libs
121%{summary}.
122
123%description -l ja libs
124%{name} のランタイムライブラリです.
125
126%package flags
127Summary: Geopolitical flags
128Group: User Interface/Desktops
129Requires: %{name}-libs = %{version}-%{release}
130BuildArch: noarch
131
132%description flags
133%{summary}.
134
135
136%prep
137%setup -q -n kde-runtime-%{version}
138
139%patch1 -p1 -b .searchproviders-shortcuts
140%patch3 -p1 -b .iconthemes-inherit
141%patch6 -p1 -b .home_onlyshowin_kde
142%patch7 -p1 -b .htsearch
143%patch8 -p1 -b .config
144%patch9 -p1 -b .man-overrides
145
146%build
147mkdir -p %{_target_platform}
148pushd %{_target_platform}
149%cmake \
150    -DCMAKE_BUILD_TYPE=release \
151    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
152    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
153    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
154    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
155    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
156    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
157    ..
158popd
159
160make %{?_smp_mflags} -C %{_target_platform}
161
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
167
168# kdesu symlink
169ln -s %{_libexecdir}/kde4/kdesu $RPM_BUILD_ROOT%{_bindir}/kdesu
170
171# omit hicolor index.theme, use one from hicolor-icon-theme
172rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
173
174# remove country flags because some people/countries forbid some other
175# people/countries' flags :-(
176%{!?flags:rm -f $RPM_BUILD_ROOT%{_datadir}/locale/l10n/*/flag.png}
177
178# install this service for KDE 3 applications too
179mkdir $RPM_BUILD_ROOT%{_datadir}/services
180ln -s %{_datadir}/kde4/services/khelpcenter.desktop \
181      $RPM_BUILD_ROOT%{_datadir}/services/khelpcenter.desktop
182
183# FIXME: -devel type files, omit for now
184rm -vf  $RPM_BUILD_ROOT%{_libdir}/lib{kwalletbackend,molletnetwork}.so
185
186# rpaths
187# use chrpath hammer for now, find better patching solutions later -- Rex
188chrpath --list   $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so ||:
189chrpath --delete $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_platform/kde.so
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
196touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
197
198%posttrans
199gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
200gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
201update-desktop-database -q &> /dev/null ||:
202update-mime-database %{_datadir}/mime &> /dev/null
203
204%postun
205if [ $1 -eq 0 ] ; then
206    touch --no-create %{_datadir}/icons/crystalsvg &> /dev/null || :
207    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
208    gtk-update-icon-cache %{_datadir}/icons/crystalsvg &> /dev/null || :
209    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
210    update-desktop-database -q &> /dev/null ||:
211    update-mime-database %{_datadir}/mime &> /dev/null
212fi
213
214%post libs -p /sbin/ldconfig
215%postun libs -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root,-)
220%{_sysconfdir}/dbus-1/system.d/*
221%{_sysconfdir}/xdg/menus/kde-information.menu
222%{_bindir}/*
223# omit ksvgtopng which kdelibs3 includes
224%if %{?_dist_release} == "vl5"
225%exclude %{_bindir}/ksvgtopng
226%endif
227%{_datadir}/kde4/apps/*
228%exclude %{_datadir}/kde4/apps/cmake/
229%{_datadir}/config/*.knsrc
230%{_datadir}/autostart/nepomukcontroller.desktop
231%{_datadir}/autostart/nepomukserver.desktop
232%{_datadir}/config.kcfg/
233%{_datadir}/dbus-1/interfaces/*
234%{_datadir}/dbus-1/services/*
235%{_datadir}/dbus-1/system-services/*
236%{_datadir}/icons/default.kde4
237%{_datadir}/kde4/services/*
238%{_datadir}/kde4/servicetypes/*
239%{_datadir}/mime/packages/network.xml
240%{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
241%{_datadir}/sounds/*
242%{_libdir}/kconf_update_bin/*
243%{_libdir}/libkdeinit4_*.so
244%{_libdir}/kde4/kcm_*.so
245%{_libdir}/kde4/kded_*.so
246%{_libexecdir}/kde4/drkonqi
247#{_libexecdir}/kde4/installdbgsymbols.sh
248%{_libexecdir}/kde4/kcmremotewidgetshelper
249%{_libexecdir}/kde4/kdeeject
250%{_libexecdir}/kde4/kdesu
251%attr(2755,root,nobody) %{_libexecdir}/kde4/kdesud
252%{_libexecdir}/kde4/kdontchangethehostname
253%{_libexecdir}/kde4/khc_docbookdig.pl
254%{_libexecdir}/kde4/khc_htdig.pl
255%{_libexecdir}/kde4/khc_htsearch.pl
256%{_libexecdir}/kde4/khc_indexbuilder
257%{_libexecdir}/kde4/khc_mansearch.pl
258%{_libexecdir}/kde4/kioexec
259%{_libexecdir}/kde4/knetattach
260%{_mandir}/man1/*
261%{_mandir}/man8/*
262%{_datadir}/icons/hicolor/*/*/*
263%{_docdir}/HTML/en/*
264%{_datadir}/applications/kde4/Help.desktop
265%{_datadir}/applications/kde4/knetattach.desktop
266%{_datadir}/applications/kde4/nepomukbackup.desktop
267%{_datadir}/applications/kde4/nepomukcontroller.desktop
268%{_datadir}/config/kshorturifilterrc
269%{_datadir}/desktop-directories/*.directory
270%{_datadir}/emoticons/kde4/
271%{_datadir}/locale/l10n/
272%{_datadir}/locale/currency/
273%{_datadir}/ontology/kde/
274%{?flags:%exclude %{_datadir}/locale/l10n/*/flag.png}
275%{_datadir}/services/khelpcenter.desktop
276
277%files devel
278%defattr(-,root,root,-)
279%{_includedir}/*
280%{_libdir}/libnepomuksync.so
281%{_datadir}/kde4/apps/cmake/modules/*.cmake
282
283%files libs
284%defattr(-,root,root,-)
285%{_libdir}/attica_kde.so
286%{_libdir}/libknotifyplugin.so
287%{_libdir}/libkwalletbackend.so.*
288%{_libdir}/libmolletnetwork.so.*
289%{_libdir}/libnepomukcommon.so
290%{_libdir}/libnepomukdatamanagement.so
291%{_libdir}/libnepomuksync.so.*
292%{_libdir}/kde4/*.so
293%{_libdir}/kde4/imports/
294# FIXME: Is this a good idea? Won't multilib apps need KCMs, too?
295%exclude %{_libdir}/kde4/kcm_*.so
296%exclude %{_libdir}/kde4/kded_*.so
297%{_libdir}/kde4/plugins/phonon_platform/
298
299%files flags
300%defattr(-,root,root,-)
301%{_datadir}/locale/l10n/*/flag.png
302
303
304%changelog
305* Mon Jan  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-2
306- rebuilt without libqzeitgeist
307
308* Tue Dec 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
309- new upstream release
310
311* Sun Oct 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
312- new upstream release
313
314* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
315- new upstream release
316- built with exiv2-0.21.1
317
318* Tue Jun 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
319- new upstream release
320
321* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-2
322- rebuilt with libsmbclient-3.5.8
323
324* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
325- new upstream release
326
327* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-2
328- added BR: libXpm-devel
329
330* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.0-1
331- new upstream release
332- added devel subpackage
333
334* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.1-1
335- new upstream release
336- updated summary
337- dropt Patch100
338
339* Mon Aug 16 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.0-1
340- new upstream release
341- added Patch100 from Fedora
342  - backport to fix the freeze of kded on first use of the network:/kio-slave
343
344* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.5-1
345- new upstream release
346- added Conflicts: kdebase3 at Vine Linux 5
347
348* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.3-1
349- new upstream release
350
351* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-2
352- rebuilt with exiv2-0.19
353
354* Mon Apr 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.2-1
355- new upstream release
356
357* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.1-1
358- new upstream release
359
360* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.4.0-1
361- new upstream release
362- built with new toolchain
363
364* Mon Nov 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.3-1
365- new upstream release
366
367* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.2-1
368- new upstream release
369
370* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.1-1
371- new upstream release
372- used %%cmake macro
373
374* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.3.0-3
375- Initial build for Vine Linux
376
377* Tue Aug 04 2009 Than Ngo <than@redhat.com> - 4.3.0-2
378- respin
379
380* Thu Jul 30 2009 Than Ngo <than@redhat.com> - 4.3.0-1
381- 4.3.0
382
383* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.98-2
384- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
385
386* Wed Jul 22 2009 Than Ngo <than@redhat.com> - 4.2.98-1
387- 4.3rc3
388
389* Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.96-2
390- respin (soprano-2.3.0)
391- License: LGPLv2+
392
393* Thu Jul 09 2009 Than Ngo <than@redhat.com> - 4.2.96-1
394- 4.3rc2
395
396* Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.95-3
397- drop unneeded BR: ImageMagick (#509241)
398
399* Mon Jun 29 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.95-2
400- don't start nepomuk server unconditionally (#487322)
401
402* Thu Jun 25 2009 Than Ngo <than@redhat.com> - 4.2.95-1
403- 4.3rc1
404
405* Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.90-1
406- KDE-4.3 beta2 (4.2.90)
407
408* Tue Jun 02 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 4.2.85-3
409- Drop old Fedora < 8 conditionals
410
411* Tue May 19 2009 Than Ngo <than@redhat.com> - 4.2.85-2
412- file conflicts with kdepim
413
414* Wed May 13 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.85-1
415- KDE 4.3 beta 1
416
417* Thu Apr 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-4
418- fix persistent systray notifications (#485796)
419
420* Wed Apr 01 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.2-3
421- -flags subpkg
422- koji/noarch hacks dropped
423
424* Wed Apr 01 2009 Than Ngo <than@redhat.com> - 4.2.2-2
425- drop kdebase-runtime-4.2.1-pulseaudio-cmake.patch
426
427* Mon Mar 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.2-1
428- KDE 4.2.2
429
430* Fri Mar 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.1-3
431- flags subpkg (not enabled)
432- optimize scriptlets
433
434* Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.1-2
435- fix PulseAudio cmake detection
436
437* Fri Feb 27 2009 Than Ngo <than@redhat.com> - 4.2.1-1
438- 4.2.1
439
440* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
441- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
442
443* Wed Feb 18 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.2.0-7
444- #486059 -  missing dependency on htdig
445
446* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-6
447- -libs: include %%{_kde4_libdir}/libkwalletbackend.so.* here
448
449* Thu Feb 12 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-5
450- Req: %%{name}-libs%%{?_isa} for multilib sanity (#456926)
451
452* Mon Feb 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-4
453- own %%_kde4_datadir/locale/l10n/
454
455* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-3
456- respun tarball
457
458* Mon Jan 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-2
459- Files not trashed to the correct location in Dolphin/Konqueror
460  (#481598, kdebug#178479)
461- omit --with-samba crud
462
463* Thu Jan 22 2009 Than Ngo <than@redhat.com> - 4.2.0-1
464- 4.2.0
465- +BR: pulseaudio-libs-devel xine-lib-devel
466- -BR: giflib-devel pcre-devel
467
468* Tue Jan 13 2009 Rex Dieter <rdieter@fedoraproject.org> 4.1.96-2
469- tarball respin
470- drop extraneous deps (that are in kdelibs)
471
472* Wed Jan 07 2009 Than Ngo <than@redhat.com> - 4.1.96-1
473- 4.2rc1
474
475* Mon Dec 22 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.85-2
476- include %%_bindir/kdesu symlink
477
478* Thu Dec 11 2008 Than Ngo <than@redhat.com> 4.1.85-1
479- 4.2beta2
480
481* Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-5
482- don't ship libkwalletbackend.so devel symlink (conflicts with kdelibs3-devel,
483  and should be in a -devel package if it gets shipped)
484
485* Thu Nov 27 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-4
486- BR strigi-devel >= 0.5.11.1 because 0.5.11 is broken
487
488* Thu Nov 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.80-3
489- readd still relevant part of the Phonon PulseAudio patch (for the KCM)
490
491* Wed Nov 19 2008 Than Ngo <than@redhat.com> 4.1.80-2
492- drop kdebase-runtime-4.0.72-pulseaudio.patch/icons, it's part of phonon
493
494* Fri Nov 19 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 4.1.80-1
495- 4.1.80
496- Drop upstreamed patch kdebase-runtime-4.1.2-kioexec.patch
497- BR cmake >= 2.6.2
498- Use 'make install/fast'
499- Drop subpkg phonon-backend-xine and related file entries: this has to be
500  part of phonon now that it moved there
501- Drop xine-lib-devel BR
502- Add libkwalletbackend to files list
503- Drop _default_patch_fuzz 2
504
505* Thu Nov 13 2008 Than Ngo <than@redhat.com> 4.1.3-5
506- apply upstream patch to fix X crash when disabling compositing
507
508* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
509- 4.1.3
510
511* Tue Oct 14 2008 Than Ngo <than@redhat.com> 4.1.2-5
512- apply upstream patch, kioexec processes never terminate
513
514* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-4
515- fix broken audio-backend-jack.svgz
516
517* Tue Sep 30 2008 Than Ngo <than@redhat.com> 4.1.2-3
518- add missing icons
519
520* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
521- make VERBOSE=1
522- respin against new(er) kde-filesystem
523- grow -libs, kde4 styles are unavailable for i386 applications (#456826)
524
525* Fri Sep 26 2008 Rex Dieter <rdieter@fedoraproject.org. 4.1.2-1
526- 4.1.2
527
528* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-3
529- fix inherit issue in iconthemes, preview icons
530  do not show
531
532* Mon Sep 01 2008 Than Ngo <than@redhat.com> 4.1.1-2
533- fix #460710, knetattach is kio_remote's wizard program, don't show
534  it in the menu.
535
536* Thu Aug 28 2008 Than Ngo <than@redhat.com> 4.1.1-1
537- 4.1.1
538
539* Wed Aug 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-3
540- fix PA not being default in the Xine backend (KCM part, see phonon-4.2.0-4)
541
542* Tue Aug 12 2008 Than Ngo <than@redhat.com> 4.1.0-2
543- crash fix when stopping a service that is not yet initialized
544
545* Fri Jul 25 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-1.1
546- don't remove autostart directory on F8- (does not conflict, fixes build
547  failure due to nepomukserver.desktop listed in filelist but not found)
548
549* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
550- 4.1.0
551
552* Wed Jul 23 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-2
553- phonon-backend-xine: drop Obsoletes/Requires upgrade hack
554
555* Fri Jul 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.99-1
556- 4.0.99
557
558* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-4
559- respin
560
561* Mon Jul 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-3
562- -phonon-backend-xine: new subpkg
563
564* Thu Jul 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.98-1
565- 4.0.98
566
567* Sun Jul 06 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.85-1
568- 4.0.85
569
570* Fri Jun 27 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.84-1
571- 4.0.84
572
573* Thu Jun 19 2008 Than Ngo <than@redhat.com> 4.0.83-1
574- 4.0.83 (beta2)
575
576* Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.82-1
577- 4.0.82
578
579* Thu Jun 05 2008 Than Ngo <than@redhat.com> 4.0.80-2
580- add searchproviders-shortcuts for redhat bugzilla
581
582* Mon May 26 2008 Than Ngo <than@redhat.com> 4.0.80-1
583- 4.1 beta 1
584
585* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-2
586- BR new minimum version of soprano-devel
587
588* Tue May 06 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.72-1
589- update to 4.0.72 (4.1 alpha 1)
590- drop upstreamed deinterlace-crash patch
591- drop khelpcenter patch (fixed upstream)
592- update Phonon PulseAudio patch
593- drop Fedora 7 support
594- update file list
595
596* Mon Apr 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10.1
597- omit conflicting icons (kde3_desktop=1 case)
598
599* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-10
600- oxygen-icon-theme: build noarch
601
602* Thu Apr 17 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-9
603- %%post/%%postun: hicolor icon theme scriptlets
604
605* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-8
606- only omit hicolor index.theme (#439374)
607
608* Thu Apr 17 2008 Than Ngo <than@redhat.com> 4.0.3-7
609- fix khelpcenter, search plugins/settings in correct path (#443016)
610
611* Tue Apr 15 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-6
612- respin (at f13's request)
613
614* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-5
615- pulseaudio patch (use as default, if available)
616
617* Sat Apr 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-4
618- don't crash if we don't have deinterlacing support in xine-lib (#440299)
619
620* Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-3
621- rebuild for the new %%{_kde4_buildtype}
622
623* Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.3-2
624- update file list for _kde4_libexecdir
625
626* Fri Mar 28 2008 Than Ngo <than@redhat.com> 4.0.3-1
627- 4.0.3
628
629* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-5
630- don't own %%_kde4_docdir/HTML/en/
631
632* Thu Mar 20 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.2-4
633- oxygen-icon-theme, oxygen-icon-theme-scalable pkgs
634- include noarch build hooks (not enabled)
635
636* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-3
637- BR libxcb-devel everywhere (including F7)
638
639* Fri Mar 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-2
640- if building for a KDE 4 desktop, include the khelpcenter.desktop service
641  description for KDE 3 here so help works in KDE 3 apps
642
643* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-1
644- 4.0.2
645
646* Mon Feb 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-3
647- %%files: don't own %%_kde4_libdir/kde4/plugins (thanks wolfy!)
648
649* Sat Feb 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.1-2
650- reenable kio_smb everywhere (including F9) now that we have a GPLv3 qt4
651  (kio_smb itself is already GPLv2+)
652
653* Wed Jan 30 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.1-1
654- 4.0.1
655
656* Tue Jan 08 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 4.0.0-2
657- respun tarball
658
659* Mon Jan 07 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.0-1
660- update to 4.0.0
661- update file list, don't remove renamed khotnewstuff.knsrc for KDE 3 desktop
662
663* Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.97.0-1
664- kde-3.97.0
665
666* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-4
667- disable kioslave/smb (f9+, samba-3.2.x/gplv3 ickiness)
668
669* Sun Dec 02 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-3
670- build without libxcb in F7 as we STILL don't have it (see #373361)
671
672* Sat Dec 01 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.96.2-2
673- no longer set kde3_desktop on F9
674- update file list for !kde3_desktop (Sebastian Vahl)
675- don't ship country flags even for full version (as in kdebase 3)
676
677* Thu Nov 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.2-1
678- kde-3.96.2
679
680* Tue Nov 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.1-1
681- kde-3.96.1
682
683* Sun Nov 18 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-3
684- fix %%files (unpackaged %%_libdir/strigi/strigiindex_sopranobackend.so)
685
686* Sat Nov 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-2
687- BR: clucene-core-devel libsmbclient-devel libXScrnSaver-devel
688
689* Thu Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.96.0-1
690- kde-3.96.0
691
692* Fri Nov 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.2-1
693- kdebase-runtime-3.95.2
694
695* Wed Nov 07 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.95.0-1
696- kdebase-runtime-3.95.0
697
698* Fri Nov 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.94.0-3
699- Provides: oxygen-icon-theme ...
700
701* Thu Oct 25 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-2
702- patch dolphin.desktop to get Dolphin to start from the menu
703
704* Fri Oct 19 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.94.0-1
705- update to 3.94.0
706
707* Thu Oct 4 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-5
708- don't make this the default kdebase on F9 yet
709- drop ExcludeArch: ppc64 (#300601)
710
711* Fri Sep 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-4
712- ExcludeArch: ppc64 (#300601)
713- update description
714
715* Thu Sep 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-3
716- add missing BR alsa-lib-devel
717
718* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-2
719- remove files which conflict with KDE 3
720- move devel symlinks to %%{_kde4_libdir}/kde4/devel/
721- Conflicts with KDE 3 versions of dolphin pre d3lphin rename
722
723* Wed Sep 12 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.93.0-1
724- update to 3.93.0
725- drop kde4home patch (no longer applied)
726- drop KDM ConsoleKit patch (KDM is now in kdebase-workspace)
727- remove kdebase-kdm Obsoletes/Provides (for the same reason)
728- remove KDM (and KDM session) setup code (for the same reason)
729- remove rss-glx conflict (Plasma is now in kdebase-workspace)
730- remove redhat-startkde patch (startkde is now in kdebase-workspace)
731- remove kde4-opt.sh (all the code in it is commented out)
732- remove kde4-xdg_menu_prefix.sh (only needed for kdebase-workspace)
733- remove bogus BRs on automake and libtool
734- remove workspace-only BRs
735- add BR qimageblitz-devel, xine-lib-devel (all), libxcb-devel (F8+)
736- remove workspace files and directories
737- handle icons (moved from kdelibs4)
738- add mkdir %%{buildroot} in %%install
739
740* Tue Aug 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-4
741- use macros.kde4
742- License: GPLv2
743
744* Mon Jul 30 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.92.0-3
745- bump rss-glx Conflicts because the conflict is still there in 0.8.1.p-7.fc8
746- rss-glx conflict only needed if "%%{_prefix}" == "/usr"
747- consolekit_kdm patch only needs BR dbus-devel, not ConsoleKit-devel
748
749* Mon Jul 30 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-2
750- consolekit_kdm patch (#228111, kde#147790)
751- update startkde patch
752
753* Sat Jul 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.92.0-1
754- kde-3.92 (kde-4-beta1)
755
756* Wed Jul 25 2007 Than Ngo <than@redhat.com> - 3.91.0-6
757- fix startkde
758- add env/shutdown directory
759
760* Thu Jul 19 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-5
761- kde4.desktop: fix session Name
762
763* Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-4
764- cleanup/fix kde4.desktop
765- kdepimlibs4->kdepimlibs
766
767* Thu Jun 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-3
768- fix %%_sysconfdir for %%_prefix != /usr case.
769
770* Thu Jun 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-2
771- updated kde4home.diff
772- CMAKE_BUILD_TYPE=RelWithDebInfo (we're already using %%optflags)
773
774* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
775- kde-3.91.0
776- CMAKE_BUILD_TYPE=debug
777
778* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-2
779- specfile cleanup (%%prefix issues mostly)
780
781* Sun May 13 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.90.1-1
782- update to 3.90.1
783- bump cmake BR to 2.4.5 as required upstream now
784- don't set execute bits by hand anymore, cmake has been fixed
785- use multilibs in /opt/kde4
786- add BR openssl-devel, NetworkManager-devel, bluez-libs-devel
787- add explicit BRs on strigi-devel, zlib-devel, bzip2-devel, libpng-devel
788  in case we want to drop the Rs on these from kdelibs4-devel
789- consistently add all BRs as -devel Rs, not just almost all, until we can
790  figure out which, if any, are really needed
791- BR libsmbclient-devel instead of samba on F>=7, EL>=6
792
793* Fri Mar 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-4
794- restore minimum version requirement for cmake
795- build against libxklavier on EL5
796- don't set QT4DIR and PATH anymore, qdbuscpp2xml has been fixed
797
798* Mon Mar 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.80.3-3
799- +eXecute perms for %%{_prefix}/lib/*
800
801* Fri Feb 23 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-2
802- rebuild for patched FindKDE4Internal.cmake
803
804* Wed Feb 21 2007 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.3-1
805- update to 3.80.3
806- update and improve parallel-installability patch
807- drop obsolete joydevice.h patch
808- remove translations of "KDE" without the "4" from kde4.desktop
809- resync BR and -devel Requires
810- don't set LD_LIBRARY_PATH
811- set QT4DIR and PATH so CMake's direct $QT4DIR/qdbuscpp2xml calls work
812- fix missing underscore in _datadir
813- install kde4.desktop in install, not prep
814- fix invalid syntax in kde4.desktop
815
816* Wed Nov 29 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.3.20061003svn
817- dropped -DCMAKE_SKIP_RPATH=TRUE from cmake
818- compiling with QA_RPATHS=0x0003; export QA_RPATHS
819
820* Sun Nov 26 2006 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 3.80.2-0.2.20061003svn
821- parallel build support
822- added -DCMAKE_SKIP_RPATH=TRUE to cmake to skip rpath
823- dropped qt4-devel >= 4.2.0, kdelibs4-devel as BR
824- spec file cleanups and added clean up in %%install
825- fixed PATH for libkdecore.so.5; cannot open shared object file;
826- added Logitech mouse support
827- added dbus-devel, hal-devel and more as BR
828- fixed broken joydevice.h - Kevin Kofler
829- added file kde4.desktop
830
831* Sun Oct 08 2006 Kevin Kofler <Kevin@tigcc.ticalc.org> 3.80.2-0.1.20061003svn
832- first Fedora RPM (parts borrowed from the OpenSUSE kdebase 4 RPM and the Fedora kdebase 3 RPM)
833- apply parallel-installability patch
Note: See TracBrowser for help on using the repository browser.