source: projects/specs/trunk/k/kde-partitionmanager/kde-partitionmanager-vl.spec @ 1407

Revision 1407, 3.8 KB checked in by inagaki, 14 years ago (diff)

NEW: kaffeine, kde-partitionmanager, knemo, yakuake

Line 
1## Renamed due to the too generic name of the application
2
3Name:           kde-partitionmanager
4Summary:        KDE Partition Manager
5Summary(ja):    KDE パーティションマネージャ
6Version:        1.0.2
7Release:        2%{?_dist_release}
8
9Group:          Applications/Administration
10License:        GPLv2+
11URL:            http://www.kde.org/applications/system/kdepartitionmanager/
12Source0:        http://downloads.sourceforge.net/project/partitionman/partitionmanager/1.0.2/partitionmanager-%{version}.tar.bz2
13
14## upstreamable patches
15# Fix DSO patches
16Patch10:        CMakeLists.txt.DSO.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  kdelibs4-devel
20BuildRequires:  parted-devel
21BuildRequires:  e2fsprogs-devel
22BuildRequires:  libuuid-devel
23BuildRequires:  libblkid-devel
24BuildRequires:  pkgconfig
25BuildRequires:  gettext
26BuildRequires:  cmake
27Requires:       parted
28Requires:       e2fsprogs
29
30%global kde4_version %((kde4-config --version 2>/dev/null || echo "KDE 4.4.5") | grep ^KDE | cut -d' ' -f2)
31
32#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
33
34%description
35KDE Partition Manager is a utility program to help you manage the disk devices,
36partitions and file systems on your computer. It allows you to easily create,
37copy, move, delete, resize without losing data, backup and restore partitions.
38 
39KDE Partition Manager supports a large number of file systems,
40including ext2/3/4, reiserfs, NTFS, FAT16/32, jfs, xfs and more.
41 
42It makes use of external programs to get its job done, so you might have to
43install additional software (preferably packages from your distribution)
44to make use of all features and get full support for all file systems.
45
46%prep
47%setup -q -n partitionmanager-%{version}
48## Due to the name change
49mv src/partitionmanager.desktop src/kde-partitionmanager.desktop
50mv src/kcm/kcm_partitionmanager.desktop src/kcm/kcm_kde-partitionmanager.desktop
51sed -i 's,partitionmanager.desktop,kde-partitionmanager.desktop,' src/CMakeLists.txt
52
53%patch10 -p0
54
55%build
56mkdir -p %{_target_platform}
57pushd %{_target_platform}
58unset QTDIR || : ; . /etc/profile.d/qt4.sh
59%{cmake} \
60    -DCMAKE_BUILD_TYPE=release \
61    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
62    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
63    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
64    ..
65popd
66
67make %{?_smp_mflags} -C %{_target_platform}
68
69%install
70rm -rf %{buildroot}
71make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
72%find_lang partitionmanager --with-kde
73
74%check
75desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop
76
77%clean
78rm -rf %{buildroot}
79
80%post
81touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
82
83%posttrans
84gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
85
86%postun
87if [ $1 -eq 0 ] ; then
88touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90fi
91
92%files -f partitionmanager.lang
93%defattr(-,root,root,-)
94%doc README COPYING CHANGES
95%{_bindir}/partitionmanager*
96%{_libdir}/*.so
97%{_datadir}/applications/kde4/%{name}.desktop
98%{_datadir}/icons/hicolor/*/*/*.png
99%{_datadir}/kde4/apps/partitionmanager
100## %{_kde4_datadir}/kde4/services/kcm_kde-partitionmanager.desktop
101
102
103%changelog
104* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-2
105- Initial build for Vine Linux
106
107* Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.2-1
108- bugfix release
109
110* Wed Mar 31 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.2
111- rebuild for new parted
112
113* Sun Feb 14 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.1
114- DSO fix for rawhide
115
116* Mon Jan 25 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1
117- New upstream source
118
119* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-2
120- Moved desktop-file-validate to %%install
121- Removed superfluous BR qt4-devel
122
123* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-1
124- Initial Fedora release
125
Note: See TracBrowser for help on using the repository browser.