source: projects/specs/trunk/k/kde-partitionmanager/kde-partitionmanager-vl.spec @ 10570

Revision 10570, 4.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           kde-partitionmanager
2Summary:        KDE Partition Manager
3Summary(ja):    KDE パーティションマネージャ
4Version:        1.0.3
5Release:        4%{?_dist_release}
6
7Group:          Applications/Administration
8License:        GPLv2+
9URL:            http://partitionman.sourceforge.net/
10
11Source0:        http://downloads.sourceforge.net/project/partitionman/partitionmanager/1.0.3/partitionmanager-%{version}.tar.bz2
12
13Patch0:         partitionmanager-1.0.3-r1263692.patch
14
15## upstreamable patches
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  kdelibs4-devel
19BuildRequires:  parted-devel
20BuildRequires:  e2fsprogs-devel
21%if %{?_dist_release} !="vl5"
22BuildRequires:  libuuid-devel
23BuildRequires:  libblkid-devel
24BuildRequires:  libatasmart-devel
25%endif
26BuildRequires:  pkgconfig
27BuildRequires:  gettext
28BuildRequires:  cmake
29Requires:       parted
30Requires:       e2fsprogs
31
32%global kde4_version %((kde4-config --version 2>/dev/null || echo "KDE 4.4.5") | grep ^KDE | cut -d' ' -f2)
33
34#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
35
36%description
37KDE Partition Manager is a utility program to help you manage the disk devices,
38partitions and file systems on your computer. It allows you to easily create,
39copy, move, delete, resize without losing data, backup and restore partitions.
40 
41KDE Partition Manager supports a large number of file systems,
42including ext2/3/4, reiserfs, NTFS, FAT16/32, jfs, xfs and more.
43 
44It makes use of external programs to get its job done, so you might have to
45install additional software (preferably packages from your distribution)
46to make use of all features and get full support for all file systems.
47
48%prep
49%setup -q -n partitionmanager-%{version}
50%patch0 -p1
51## Due to the name change
52mv src/partitionmanager.desktop src/kde-partitionmanager.desktop
53#mv src/kcm/kcm_partitionmanager.desktop src/kcm/kcm_kde-partitionmanager.desktop
54sed -i 's,partitionmanager.desktop,kde-partitionmanager.desktop,' src/CMakeLists.txt
55
56%build
57mkdir -p %{_target_platform}
58pushd %{_target_platform}
59
60%{cmake} \
61    -DCMAKE_BUILD_TYPE=release \
62    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
63    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
64    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
65    ..
66popd
67
68make %{?_smp_mflags} -C %{_target_platform}
69
70%install
71rm -rf %{buildroot}
72make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
73%find_lang partitionmanager --with-kde
74
75%check
76desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop
77
78%clean
79rm -rf %{buildroot}
80
81%post
82touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
83
84%posttrans
85gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
86
87%postun
88if [ $1 -eq 0 ] ; then
89touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
90gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
91fi
92
93%files -f partitionmanager.lang
94%defattr(-,root,root,-)
95%doc README COPYING CHANGES
96%{_bindir}/partitionmanager*
97%{_libdir}/*.so
98%{_libdir}/kde4/pmlibpartedbackendplugin.so
99%{_datadir}/applications/kde4/%{name}.desktop
100%{_datadir}/icons/hicolor/*/*/*.png
101%{_datadir}/kde4/apps/partitionmanager
102%{_datadir}/kde4/services/pmlibpartedbackendplugin.desktop
103%{_datadir}/kde4/servicetypes/pmcorebackendplugin.desktop
104## %{_kde4_datadir}/kde4/services/kcm_kde-partitionmanager.desktop
105
106
107%changelog
108* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-4
109- rebuild with gcc-5.4.0
110
111* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
112- rebuild with parted-3.1
113
114* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
115- add Patch0 (partitionmanager-1.0.3-r1263692.patch)
116- add BuildRequires: libatasmart-devel
117
118* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1
119- new upstream release
120
121* Fri Jul 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-3
122- disabled BR: libuuid-devel, libblkid-devel on Vine Linux 5
123
124* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-2
125- Initial build for Vine Linux
126
127* Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.2-1
128- bugfix release
129
130* Wed Mar 31 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.2
131- rebuild for new parted
132
133* Sun Feb 14 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.1
134- DSO fix for rawhide
135
136* Mon Jan 25 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1
137- New upstream source
138
139* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-2
140- Moved desktop-file-validate to %%install
141- Removed superfluous BR qt4-devel
142
143* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-1
144- Initial Fedora release
145
Note: See TracBrowser for help on using the repository browser.