source: projects/specs/trunk/k/kbd/kbd-vl.spec @ 8084

Revision 8084, 13.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
2Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
3Name: kbd
4Version: 1.12
5Release: 22%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
9Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
10#Source2: kbdrate.apps
11#Source3: kbdrate.pam
12Source4: kbd-latsun-fonts.tar.bz2
13Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
14BuildRequires: bison, flex, gettext
15BuildRoot: %{_tmppath}/%{name}-root
16Patch0: kbd-1.12-sparc.patch
17Patch1: kbd-1.08-compose.patch
18Patch2: kbd-1.08-terminal.patch
19Patch3: kbd-1.08-rukbd.patch
20Patch4: kbd-1.12-setfont-man.patch
21Patch5: kbd-1.12-Meta_utf8.patch
22Patch6: kbd-1.12-nostrip.patch
23Patch7: kbd-1.12-alias.patch
24Patch8: kbd-1.12-dir.patch
25Patch9: kbd-1.12-no-user-map.patch
26Patch10: kbd-1.12-resizecon-man.patch
27Patch11: kbd-1.12-gr-el.patch
28Patch12: kbd-1.12-keycodes-man.patch
29Obsoletes: console-tools open
30Provides: console-tools open
31Conflicts: util-linux < 2.11r-9
32Requires(pre): initscripts >= 5.86-1
33ExcludeArch: s390 s390x
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The %{name} package contains tools for managing a Linux
40system's console's behavior, including the keyboard, the screen
41fonts, the virtual terminals and font files.
42
43%prep
44
45%setup -q -a 4
46%patch0 -p1 -b .sparc
47%patch1 -p1
48%patch2 -p1 -b .terminal
49%patch3 -p1
50%patch4 -p1 -b .man
51%patch5 -p1 -b .Meta_utf8
52%patch6 -p1 -b .nostrip
53%patch7 -p1 -b .alias
54%patch8 -p1 -b .dir
55%patch9 -p1 -b .no-user-map
56%patch10 -p1 -b .resizecon-man
57%patch11 -p1 -b .gr-el
58%patch12 -p1 -b .keycodes-man
59
60# 7-bit maps are obsolete; so are non-euro maps
61pushd data/keymaps/i386
62mv qwerty/fi.map qwerty/fi-old.map
63cp qwerty/fi-latin9.map qwerty/fi.map
64cp qwerty/pt-latin9.map qwerty/pt.map
65cp qwerty/sv-latin1.map qwerty/se-latin1.map
66
67mv azerty/fr.map azerty/fr-old.map
68cp azerty/fr-latin9.map azerty/fr.map
69
70cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
71popd
72
73# Default to latarcyrheb-sun16 font for unicode
74perl -pi -e 's/LatArCyrHeb-16/latarcyrheb-sun16/' src/unicode_start
75
76%build
77export OLD_PO_FILE_INPUT=yes
78
79# We don't use % {configure} because the ./configure included here does not
80# understand most of the options.
81CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
82./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
83
84# Override CFLAGS because this configure ignores them anyway, and LDFLAGS
85# because it defaults to -s, but that's a build policy decision.
86make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91# Basic install.
92make install DESTDIR=$RPM_BUILD_ROOT
93
94# The rhpl keyboard layout table is indexed by kbd layout names, so we need a
95# Korean keyboard
96ln -s us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty/ko.map.gz
97
98# Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
99for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
100  mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
101done
102
103# Some microoptimization
104sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
105        $RPM_BUILD_ROOT/bin/unicode_start
106
107
108# Set up kbdrate to be userhelpered.
109#mkdir -p $RPM_BUILD_ROOT%{_sbindir}
110#mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
111#mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
112#mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
113#ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
114#install -c -m644 %{SOURCE2} \
115#       $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
116#install -c -m644 %{SOURCE3} \
117#       $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
118rm -f %{buildroot}/%{_bindir}/kbdrate
119
120# Link open to openvt
121ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
122
123%find_lang %{name}
124
125%clean
126[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
127
128%triggerun -- kbd < 1.08-10.2
129/sbin/chkconfig --del keytable || :
130
131%files -f %{name}.lang
132%defattr(-,root,root)
133%doc CHANGES CREDITS README doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
134/bin/*
135%{_bindir}/*
136%{_mandir}/*/*
137/lib/kbd
138
139%changelog
140* Mon Dec 30 2013 oji TOYODA <bsyamato@sea.plala.or.jp> 1.12-22
141- rebuild with VineSeed environment
142
143* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
144- applied new versioning policy, spec in utf-8
145
146* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
147- initial build for Vine Linux based on Fedora package.
148
149* Tue Jan  9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
150- Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
151  Resolves: #220151
152
153* Thu Dec  7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
154- Document that setkeycodes doesn't affect USB keyboards and that the kernel
155  doesn't provide the raw scan codes by default
156  Resolves: #211803
157
158* Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
159- Ship "el" translation instead of the obsolete "gr" translation
160  Resolves: #210749
161- Fix %% quoting in %%changelog
162
163* Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
164- Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
165
166* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
167- Obsoletes/Provides open
168- Create a symlink from open to openvt
169
170* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
171- rebuild
172
173* Sun Jul  9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
174- Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
175  <dennis@ausil.us>)
176
177* Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
178- Fix missing BuildRequires (#193406)
179
180* Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
181- Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
182  <kmori@redhat.com>)
183
184* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
185- bump again for double-long bug on ppc(64)
186
187* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
188- rebuilt for new gcc4.1 snapshot and glibc changes
189
190* Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
191- Fix build with new coreutils
192- Hardcode paths in unicode_start to avoid a few file lookups (#178329)
193- Drop unnecessary Prereq: sed mktemp
194
195* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
196- rebuilt
197
198* Thu Dec  1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
199- Don't reload the keymap in unicode_start (#172425)
200
201* Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
202- Don't ship character set lists (they are already in glibc-common) and an
203  obsolete copy of kbd.FAQ
204
205* Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
206- Don't attempt to open directories as source files (#141634, original patch by
207  Paul Nasrat)
208
209* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
210- Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
211
212* Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
213- Fix violation of C aliasing rules (#150440)
214
215* Sun Mar  6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
216- Don't run ldconfig
217- Don't strip executables
218
219* Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
220- Rebuild with gcc4
221
222* Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
223- Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
224  (patch by Jochen Schmitt)
225- Don't ship patch backup files, simpler way
226
227* Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
228- Don't ship a patch backup file
229- Mention in setfont.8 that 512-glyph fonts reduce the number of available
230  colors (#140935, patch by Dmitry Butskoj)
231- Remove "Meta_acute" from German keymaps (#143124)
232- Make the %%triggerun script condition more precise, ignore failure of the
233  script
234
235* Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
236- rebuilt
237
238* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
239- rebuilt
240
241* Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
242- update to 1.12
243
244* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
245- rebuilt
246
247* Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
248- remove speakup patch at request of author
249
250* Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
251- remove keytable init script (#106783)
252
253* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
254- bump for RHEL
255
256* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
257- apply the rukbd patch (#78218)
258
259* Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
260- don't print "plus before..." warnings about non-supported capslock
261  in unimode <Andries.Brouwer@cwi.nl> (#81855)
262
263* Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
264- replaced Russian keyboard map with working UTF-8 equivalent (#79338)
265
266* Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
267- make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
268- fix swedish keymap; se, not sv (#88791)
269- add fr-latin0 legacy alias of fr-latin-9 (#88324)
270- add ".map" ext to filename param of init script (#90562)
271
272* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
273- rebuilt
274
275* Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
276- build new rpm
277
278* Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
279- ExcludeArch mainframe
280
281* Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
282- remove condrestart from initscript
283
284* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
285- rebuilt
286
287* Fri Dec  6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
288- only output terminal unicode init sequence if both stdout and stderr are
289  connected to terminals, so that it doesn't show up when script outputs
290  get piped to files
291
292* Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
293- update to 1.08
294- drop updates which went mainline
295
296* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
297- add detached signature
298- remove directory names from PAM configuration so that the same config file
299  can be used for any arch on multilib systems
300
301* Wed Sep  4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
302- don't munge /etc/sysconfig/i18n
303
304* Tue Sep  3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
305- don't run setsysfont in upgrade trigger on console-tools
306
307* Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
308- use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
309  instead of old LatArCyrHeb-16 chars
310- add Euro character to latarcyrheb-sun16
311- use latarcyrheb-sun16 by default in unicode_start script
312
313* Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
314- add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
315
316* Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
317- needs to conflict with older util-linux packages
318  (kbdrate moved between packages)
319
320* Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
321- remove Evil Hack in favor of slightly-less-evil-hack in initscripts
322
323* Tue Jul  9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
324- fix speakup keymap names
325
326* Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
327- Evil hack to make setfont work correctly on all consoles (#68018)
328
329* Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
330- move unicode_stop to /bin too
331- fix path to loadkeys in keytable.init
332- add in speakup keymaps
333
334* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
338- fix incorrect path in console.apps configuration file
339
340* Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
341- move some more stuff to /bin (unicode_start and dependencies)
342
343* Thu May 23 2002 Tim Powers <timp@redhat.com>
344- automated rebuild
345
346* Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
347- Rebuild in new environment
348
349* Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
350- Oops, actually list the pam files in %%files
351
352* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
353- Add and consolehelper'ify kbdrate
354
355* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
356- Re-remove kbdrate
357
358* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
359- Fix build in current environment
360- Get rid of kbdrate, it's in util-linux these days
361
362* Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
363- added a patch (Patch4) that allows --tty= in setfont
364- modified patch not to break translations
365
366* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
367- Add cyrillic patches from leon@geon.donetsk.ua (#47144)
368
369* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
370- Fix "Alt+AltGr=Compose" in qwertz-keyboards
371
372* Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
373- Fix "make install" and init script (#45327)
374
375* Sat Jun 16 2001 Than Ngo <than@redhat.com>
376- update to 1.0.6
377- use %%{_tmppath}
378- use find_lang
379- support new gettext
380- remove some patch files, which are included in 1.0.6
381- fix to use RPM_OPT_FLAGS
382
383* Thu May  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
384- Fix up resizecons
385
386* Wed May  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
387- Build everything, obsoletes console-tools
388- s/Copyright:/License:/
389- License is GPL, not just distributable
390- Add our compose mappings from old console-tools
391- Add triggerpostun -- console-tools magic to get sane fonts and mappings
392
393* Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
394- initial packaging for kbdrate
Note: See TracBrowser for help on using the repository browser.