source: projects/specs/trunk/k/kbd/kbd-vl.spec @ 12371

Revision 12371, 16.2 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

dbus-glib-0.110-1

dstat-0.7.4-1

firefox-68.7.0-1

iso-codes-4.4-1

kbd-2.2.0-1

libdb-5.3.28-12

libsmbios-2.4.3-1

par2cmdline-0.8.1-1

sgml-common-0.6.3-42

smem-1.5-1

thunderbird-68.7.0-1

Line 
1%global convert_xkb 0
2
3# {_exec_prefix}/lib/kbd is correct even on x86_64.
4# It is traditionally used for kdb data (console fonts, keymaps, ...).
5# It is not used for any shared objects/executables.
6%global kbd_datadir /lib/kbd
7
8Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
9Summary(ja): コンソール(キーボードや仮想ターミナル等)を設定するツール群
10Name: kbd
11Version: 2.2.0
12Release: 1%{?_dist_release}
13Group: System Environment/Base
14Vendor: Project Vine
15Distribution: Vine Linux
16
17License: GPL
18Source0: https://www.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.xz
19Source1: kbd-latsun-fonts.tar.bz2
20Source2: kbd-latarcyrheb-32.tar.bz2
21Source3: xml2lst.pl
22Source4: vlock.pamd
23Source5: kbdinfo.1
24Source6: cz-map.patch
25Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
26BuildRequires: bison, flex, gettext, pam-devel
27%if 0%{convert_xkb}
28BuildRequires: console-setup
29%endif
30BuildRoot: %{_tmppath}/%{name}-root
31# Patch0: puts additional information into man pages
32Patch0: kbd-1.15-keycodes-man.patch
33# Patch1: sparc modifications
34Patch1: kbd-1.15-sparc.patch
35# Patch2: adds default unicode font to unicode_start script
36Patch2: kbd-1.15-unicode_start.patch
37# Patch3: add missing dumpkeys option to man page
38Patch3: kbd-1.15.3-dumpkeys-man.patch
39# Patch4: fixes decimal separator in Swiss German keyboard layout, bz 882529
40Patch4: kbd-1.15.5-sg-decimal-separator.patch
41# Patch5: adds xkb and legacy keymaps subdirs to loadkyes search path, bz 1028207
42Patch5: kbd-1.15.5-loadkeys-search-path.patch
43# Patch6: don't hardcode font used in unicode_start, take it from vconsole.conf,
44#   bz 1101007
45Patch6: kbd-2.0.2-unicode-start-font.patch
46# Patch7: fixes issues found by static analysis
47Patch7:         kbd-2.0.4-covscan-fixes.patch
48# Patch8: fix flags
49Patch8:         kbd-2.2.0-fix-flags.patch
50# Patch9: workaround -Werror=format-security build error
51Patch9:         kbd-2.2.0-format-security.patch
52
53Obsoletes: console-tools open
54Provides: console-tools open
55Conflicts: util-linux < 2.11r-9
56Requires(pre): initscripts >= 5.86-1
57ExcludeArch: s390 s390x
58
59%description
60The %{name} package contains tools for managing a Linux
61system's console's behavior, including the keyboard, the screen
62fonts, the virtual terminals and font files.
63
64%prep
65
66%setup -q -a 1 -a 2
67cp -fp %{SOURCE3} .
68cp -fp %{SOURCE6} .
69%patch0 -p1 -b .keycodes-man
70%patch1 -p1 -b .sparc
71%patch2 -p1 -b .unicode_start
72%patch3 -p1 -b .dumpkeys-man
73%patch4 -p1 -b .sg-decimal-separator
74%if 0%{convert_xkb}
75%patch5 -p1 -b .loadkeys-search-path
76%endif
77%patch6 -p1 -b .unicode-start-font
78%patch7 -p1 -b .covscan-fixes
79%patch8 -p1 -b .fix-flags
80%patch9 -p1 -b .format-security
81
82# 7-bit maps are obsolete; so are non-euro maps
83pushd data/keymaps/i386
84cp qwerty/pt-latin9.map qwerty/pt.map
85cp qwerty/sv-latin1.map qwerty/se-latin1.map
86
87mv azerty/fr.map azerty/fr-old.map
88cp azerty/fr-latin9.map azerty/fr.map
89
90cp azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
91
92# Rename conflicting keymaps
93mv fgGIod/trf.map fgGIod/trf-fgGIod.map
94mv olpc/es.map olpc/es-olpc.map
95mv olpc/pt.map olpc/pt-olpc.map
96mv qwerty/cz.map qwerty/cz-qwerty.map
97popd
98
99# remove obsolete "gr" translation
100pushd po
101rm -f gr.po gr.gmo
102popd
103
104# Convert to utf-8
105iconv -f iso-8859-1 -t utf-8 < "ChangeLog" > "ChangeLog_"
106mv "ChangeLog_" "ChangeLog"
107
108%build
109export OLD_PO_FILE_INPUT=yes
110
111# We don't use % {configure} because the ./configure included here does not
112# understand most of the options.
113CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
114#./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
115%configure --prefix=%{_prefix} --datadir=%{kbd_datadir} --mandir=%{_mandir} --localedir=%{_datadir}/locale --enable-nls
116make %{?_smp_mflags}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120
121# Basic install.
122make install DESTDIR=$RPM_BUILD_ROOT
123
124# ro_win.map.gz is useless
125rm -f $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/ro_win.map.gz
126
127# Create additional name for Serbian latin keyboard
128ln -s sr-cy.map.gz $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/sr-latin.map.gz
129
130# The rhpl keyboard layout table is indexed by kbd layout names, so we need a
131# Korean keyboard
132ln -s us.map.gz $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/i386/qwerty/ko.map.gz
133
134# Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
135mkdir -p $RPM_BUILD_ROOT/bin
136for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop loadkeys ; do
137
138  mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin/
139done
140
141# Some microoptimization
142sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
143        $RPM_BUILD_ROOT/bin/unicode_start
144
145# Link open to openvt
146ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
147ln -s openvt.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/open.1.gz
148
149# install kbdinfo manpage
150gzip -c %SOURCE5 > $RPM_BUILD_ROOT/%{_mandir}/man1/kbdinfo.1.gz
151
152# Move locale files to correct place
153cp -r $RPM_BUILD_ROOT%{kbd_datadir}/locale/ $RPM_BUILD_ROOT%{_datadir}/locale
154rm -rf $RPM_BUILD_ROOT%{kbd_datadir}/locale
155
156# Install PAM configuration for vlock
157mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
158install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/vlock
159
160%if 0%{convert_xkb}
161# Move original keymaps to legacy directory
162mkdir -p $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/legacy
163mv $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/{amiga,atari,i386,include,mac,ppc,sun} $RPM_B
164UILD_ROOT%{kbd_datadir}/keymaps/legacy
165
166# Convert X keyboard layouts to console keymaps
167mkdir -p $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb
168perl xml2lst.pl < /usr/share/X11/xkb/rules/base.xml > layouts-variants.lst
169while read line; do
170  XKBLAYOUT=`echo "$line" | cut -d " " -f 1`
171  echo "$XKBLAYOUT" >> layouts-list.lst
172  XKBVARIANT=`echo "$line" | cut -d " " -f 2`
173  ckbcomp "$XKBLAYOUT" "$XKBVARIANT" | gzip > $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xk
174b/"$XKBLAYOUT"-"$XKBVARIANT".map.gz
175done < layouts-variants.lst
176
177# Convert X keyboard layouts (plain, no variant)
178cat layouts-list.lst | sort -u >> layouts-list-uniq.lst
179while read line; do
180  ckbcomp "$line" | gzip > $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/"$line".map.gz
181done < layouts-list-uniq.lst
182
183# wipe converted layouts which cannot input ASCII (#1031848)
184zgrep -L "U+0041" $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/* | xargs rm -f
185
186# Rename the converted default fi (kotoistus) layout (#1117891)
187gunzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi.map.gz
188mv $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi.map $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xk
189b/fi-kotoistus.map
190gzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/fi-kotoistus.map
191
192# Fix converted cz layout - add compose rules
193gunzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map.gz
194patch $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map < %{SOURCE6}
195gzip $RPM_BUILD_ROOT%{kbd_datadir}/keymaps/xkb/cz.map
196%endif
197
198%find_lang %{name}
199
200%clean
201[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
202
203%triggerun -- kbd < 1.08-10.2
204/sbin/chkconfig --del keytable || :
205
206%files -f %{name}.lang
207%defattr(-,root,root)
208%license COPYING
209%doc ChangeLog AUTHORS README docs/doc/kbd.FAQ*.html docs/doc/font-formats/*.html docs/doc/utf/utf* docs/doc/dvorak/*
210/bin/*
211%{_bindir}/*
212%{_mandir}/*/*
213%{kbd_datadir}
214%config(noreplace) %{_sysconfdir}/pam.d/vlock
215
216
217%changelog
218* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
219- new upstream release.
220- imported Patch7-9 from rawhide.
221
222* Sun Sep 24 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
223- new upstream release.
224
225* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12-22
226- rebuild with VineSeed environment
227
228* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.12-21vl5
229- applied new versioning policy, spec in utf-8
230
231* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-21vl1
232- initial build for Vine Linux based on Fedora package.
233
234* Tue Jan  9 2007 Miloslav Trmac <mitr@redhat.com> - 1.12-21
235- Add a "ko" (Korean) keyboard layout, equivalent to the "us" layout
236  Resolves: #220151
237
238* Thu Dec  7 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-20
239- Document that setkeycodes doesn't affect USB keyboards and that the kernel
240  doesn't provide the raw scan codes by default
241  Resolves: #211803
242
243* Tue Oct 31 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-19
244- Ship "el" translation instead of the obsolete "gr" translation
245  Resolves: #210749
246- Fix %% quoting in %%changelog
247
248* Fri Sep 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-18
249- Add a missing tilde to U+00E3 in latarcyrheb-sun16.psfu (#204470)
250
251* Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.12-17
252- Obsoletes/Provides open
253- Create a symlink from open to openvt
254
255* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.12-16.1
256- rebuild
257
258* Sun Jul  9 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-16
259- Don't include <asm/kbdio.h> on SPARC (#198040, patch by Dennis Gilmore
260  <dennis@ausil.us>)
261
262* Mon May 29 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-15
263- Fix missing BuildRequires (#193406)
264
265* Mon Mar 27 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-14
266- Don't install resizecons.8 on non-x86 (#186877, patch by Keiichi Mori
267  <kmori@redhat.com>)
268
269* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.2
270- bump again for double-long bug on ppc(64)
271
272* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.12-13.1
273- rebuilt for new gcc4.1 snapshot and glibc changes
274
275* Fri Jan 20 2006 Miloslav Trmac <mitr@redhat.com> - 1.12-13
276- Fix build with new coreutils
277- Hardcode paths in unicode_start to avoid a few file lookups (#178329)
278- Drop unnecessary Prereq: sed mktemp
279
280* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
281- rebuilt
282
283* Thu Dec  1 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-12
284- Don't reload the keymap in unicode_start (#172425)
285
286* Fri Nov 11 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-11
287- Don't ship character set lists (they are already in glibc-common) and an
288  obsolete copy of kbd.FAQ
289
290* Fri May 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-10
291- Don't attempt to open directories as source files (#141634, original patch by
292  Paul Nasrat)
293
294* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
295- Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
296
297* Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
298- Fix violation of C aliasing rules (#150440)
299
300* Sun Mar  6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
301- Don't run ldconfig
302- Don't strip executables
303
304* Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-6
305- Rebuild with gcc4
306
307* Sun Feb 20 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-5
308- Put "Meta_acute" back in German keymaps, just ignore it in (loadkeys -u)
309  (patch by Jochen Schmitt)
310- Don't ship patch backup files, simpler way
311
312* Sat Feb 19 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-4
313- Don't ship a patch backup file
314- Mention in setfont.8 that 512-glyph fonts reduce the number of available
315  colors (#140935, patch by Dmitry Butskoj)
316- Remove "Meta_acute" from German keymaps (#143124)
317- Make the %%triggerun script condition more precise, ignore failure of the
318  script
319
320* Mon Feb 14 2005 Adrian Havill <havill@redhat.com>
321- rebuilt
322
323* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
324- rebuilt
325
326* Thu Feb 26 2004 Adrian Havill <havill@redhat.com>
327- update to 1.12
328
329* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
330- rebuilt
331
332* Wed Jan 14 2004 Bill Nottingham <notting@redhat.com> 1.08-12
333- remove speakup patch at request of author
334
335* Fri Oct 10 2003 Bill Nottingham <notting@redhat.com> 1.08-11
336- remove keytable init script (#106783)
337
338* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10.1
339- bump for RHEL
340
341* Tue Aug 12 2003 Adrian Havill <havill@rtedhat.com> 1.08-10
342- apply the rukbd patch (#78218)
343
344* Thu Jul 31 2003 Adrian Havill <havill@redhat.com> 1.08-9
345- don't print "plus before..." warnings about non-supported capslock
346  in unimode <Andries.Brouwer@cwi.nl> (#81855)
347
348* Wed Jul 30 2003 Adrian Havill <havill@redhat.com> 1.08-8
349- replaced Russian keyboard map with working UTF-8 equivalent (#79338)
350
351* Thu Jul 24 2003 Adrian Havill <havill@redhat.com> 1.08-7
352- make euro/latin-9 the default instead of latin-1 and 7-bit (#97013)
353- fix swedish keymap; se, not sv (#88791)
354- add fr-latin0 legacy alias of fr-latin-9 (#88324)
355- add ".map" ext to filename param of init script (#90562)
356
357* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
358- rebuilt
359
360* Thu Mar 06 2003 Florian La Roche <Florian.LaRoche@redhat.de>
361- build new rpm
362
363* Fri Feb 21 2003 Florian La Roche <Florian.LaRoche@redhat.de>
364- ExcludeArch mainframe
365
366* Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
367- remove condrestart from initscript
368
369* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
370- rebuilt
371
372* Fri Dec  6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
373- only output terminal unicode init sequence if both stdout and stderr are
374  connected to terminals, so that it doesn't show up when script outputs
375  get piped to files
376
377* Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
378- update to 1.08
379- drop updates which went mainline
380
381* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
382- add detached signature
383- remove directory names from PAM configuration so that the same config file
384  can be used for any arch on multilib systems
385
386* Wed Sep  4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
387- don't munge /etc/sysconfig/i18n
388
389* Tue Sep  3 2002 Bill Nottingham <notting@redhat.com> 1.06-25
390- don't run setsysfont in upgrade trigger on console-tools
391
392* Thu Aug 29 2002 Jakub Jelinek <jakub@redhat.com> 1.06-24
393- use cyr-sun16 cyrillic chars in latarcyrheb-sun16 font
394  instead of old LatArCyrHeb-16 chars
395- add Euro character to latarcyrheb-sun16
396- use latarcyrheb-sun16 by default in unicode_start script
397
398* Tue Aug 27 2002 Jakub Jelinek <jakub@redhat.com> 1.06-23
399- add back lat[02]-sun16 fonts plus latarcyrheb-sun16 font
400
401* Thu Aug 22 2002 Karsten Hopp <karsten@redhat.de>
402- needs to conflict with older util-linux packages
403  (kbdrate moved between packages)
404
405* Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 1.06-21
406- remove Evil Hack in favor of slightly-less-evil-hack in initscripts
407
408* Tue Jul  9 2002 Bill Nottingham <notting@redhat.com> 1.06-20
409- fix speakup keymap names
410
411* Tue Jul 09 2002 Phil Knirsch <pknirsch@redhat.com> 1.06-19
412- Evil hack to make setfont work correctly on all consoles (#68018)
413
414* Thu Jun 27 2002 Bill Nottingham <notting@redhat.com> 1.06-18
415- move unicode_stop to /bin too
416- fix path to loadkeys in keytable.init
417- add in speakup keymaps
418
419* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
420- automated rebuild
421
422* Tue Jun 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-16
423- fix incorrect path in console.apps configuration file
424
425* Thu May 30 2002 Bill Nottingham <notting@redhat.com> 1.06-14
426- move some more stuff to /bin (unicode_start and dependencies)
427
428* Thu May 23 2002 Tim Powers <timp@redhat.com>
429- automated rebuild
430
431* Mon Feb 25 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-12
432- Rebuild in new environment
433
434* Wed Jan 30 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-11
435- Oops, actually list the pam files in %%files
436
437* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-10
438- Add and consolehelper'ify kbdrate
439
440* Tue Jan 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-9
441- Re-remove kbdrate
442
443* Thu Jan 24 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-7
444- Fix build in current environment
445- Get rid of kbdrate, it's in util-linux these days
446
447* Wed Jul 18 2001 Matt Wilson <msw@redhat.com>
448- added a patch (Patch4) that allows --tty= in setfont
449- modified patch not to break translations
450
451* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-4
452- Add cyrillic patches from leon@geon.donetsk.ua (#47144)
453
454* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-3
455- Fix "Alt+AltGr=Compose" in qwertz-keyboards
456
457* Mon Jun 25 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.06-2
458- Fix "make install" and init script (#45327)
459
460* Sat Jun 16 2001 Than Ngo <than@redhat.com>
461- update to 1.0.6
462- use %%{_tmppath}
463- use find_lang
464- support new gettext
465- remove some patch files, which are included in 1.0.6
466- fix to use RPM_OPT_FLAGS
467
468* Thu May  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-3
469- Fix up resizecons
470
471* Wed May  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.05-2
472- Build everything, obsoletes console-tools
473- s/Copyright:/License:/
474- License is GPL, not just distributable
475- Add our compose mappings from old console-tools
476- Add triggerpostun -- console-tools magic to get sane fonts and mappings
477
478* Tue Apr 17 2001 Erik Troan <ewt@redhat.com>
479- initial packaging for kbdrate
Note: See TracBrowser for help on using the repository browser.