source: projects/specs/trunk/k/k3b/k3b-vl.spec @ 3874

Revision 3874, 8.1 KB checked in by Takemikaduchi, 13 years ago (diff)

kdesdk,k3b: add BR, gdm: update to 2.32.1, gnome-icon-theme: rebuild

RevLine 
[521]1Name: k3b
[1427]2Summary: CD/DVD/Blu-ray burning application for KDE
[1801]3Summary(ja): KDE 向け CD/DVD/Blu-ray 作成アプリケーション
[2775]4Version: 2.0.2
[3874]5Release: 3%{?_dist_release}
[1427]6
[521]7Group: Applications/Archiving
[1427]8License: GPLv2+
[521]9URL: http://www.k3b.org/
10
[1427]11Source0: http://downloads.sourceforge.net/sourceforge/k3b/k3b-%{version}%{?pre}.tar.bz2
12# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
13Source1: ox32-k3b.png
14Source2: k3brc
[521]15
[1427]16ExcludeArch: s390 s390x
[521]17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
[1427]19BuildRequires: desktop-file-utils
20BuildRequires: flac-devel
21BuildRequires: gettext
22BuildRequires: kdelibs4-devel
23BuildRequires: kdemultimedia4-devel
24BuildRequires: libdvdread-devel
25BuildRequires: libmpcdec-devel
26BuildRequires: libmusicbrainz-devel
27BuildRequires: libsamplerate-devel
28BuildRequires: libsndfile-devel
29BuildRequires: libvorbis-devel
[2857]30BuildRequires: libXpm-devel
[1427]31BuildRequires: taglib-devel
32# needed by k3bsetup
33BuildRequires: polkit-qt-devel
[3874]34BuildRequires: soprano-devel
[521]35
[1427]36Requires: cdrecord mkisofs
37Requires: cdrdao
38Requires: dvd+rw-tools
[521]39
[1427]40Obsoletes: k3b-i18n
[521]41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%description
46K3b is a CD and DVD burning application for Linux systems optimized for KDE.
47It provides a comfortable user interface to perform most
48CD/DVD burning tasks like creating an Audio CD from a set of audio files or copying a CD.
49
[1427]50[Notice]
51Please install self-build-k3b-extra package if you want to handle MP3 and WMA files.
52
[521]53%description -l ja
[1427]54K3b は、KDE の為に最適化された Linux システム用の CD/DVD 作成アプリケーションです.
55多様なCD/DVDの作成に快適なユーザーインターフェースを提供します.
56また、音楽データや CD の複製等、音楽 CD を簡単に作成できます.
[521]57
[1427]58K3b にて MP3/WMA ファイルを扱いたい場合は、self-build-k3b-extra パッケージを
59追加でインストールしてください.
[521]60
[1427]61%package libs
62Summary: Runtime libraries for %{name}
[1795]63Summary(ja): %{name} のランタイムライブラリ
[1427]64Group:   System Environment/Libraries
65Requires: kdelibs4 >= 4.4.0
[521]66
[1427]67%description libs
68%{summary}.
[521]69
[1801]70%description -l ja libs
71%{summary}.
72
[521]73%package devel
74Summary: Files for the development of applications which will use %{name}
[1795]75Summary(ja): %{name} 使用するアプリケーションを開発するためのファイル
[521]76Group: Development/Libraries
[1427]77Requires: %{name}-libs = %{version}-%{release}
78Requires: kdelibs4-devel >= 4.4.0
79
[521]80%description devel
81%{summary}.
82
[1801]83%description -l ja devel
84%{summary}.
[1427]85
86%prep
87%setup -q
88
[521]89%build
[1427]90mkdir -p %{_target_platform}
91pushd %{_target_platform}
92unset QTDIR || : ; . /etc/profile.d/qt4.sh
93%{cmake} \
94    -DCMAKE_BUILD_TYPE=release \
95    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
96    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
97    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
98    -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=OFF \
99    -DK3B_BUILD_MAD_DECODER_PLUGIN::BOOL=OFF \
100    -DK3B_BUILD_LAME_ENCODER_PLUGIN:BOOL=OFF \
101    ..
[1801]102#   -DK3B_BUILD_K3BSETUP:BOOL=OFF \
[1427]103popd
[521]104
[1427]105make %{?_smp_mflags} -C %{_target_platform}
[521]106
107
108%install
109rm -rf $RPM_BUILD_ROOT
[1427]110make install/fast -C %{_target_platform} DESTDIR=$RPM_BUILD_ROOT
[521]111
[1427]112%find_lang k3b --with-kde
113%find_lang k3bsetup
[1795]114%find_lang kio_videodvd
[1427]115%find_lang libk3b
[1795]116%find_lang libk3bdevice
[1427]117cat k3bsetup.lang >> k3b.lang
[1795]118cat kio_videodvd.lang >> libk3b.lang
[1427]119cat libk3bdevice.lang >> libk3b.lang
[521]120
[1427]121# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
122if [ ! -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png ]; then
123  echo "NOTICE: %{_datadir}/icons/hicolor/32x32/apps/k3b.png missing, borrowing oxygen version"
124  install -pD -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png
125fi
[521]126
127
[1427]128%check
129desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/k3b.desktop
[521]130
[1427]131%clean
132rm -rf $RPM_BUILD_ROOT
[521]133
134%post
135touch --no-create %{_datadir}/icons/hicolor ||:
136
137%postun
[1427]138if [ $1 -eq 0 ] ; then
139    gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
140    update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
141    update-mime-database %{_datadir}/mime &> /dev/null
142fi
143
144%posttrans
[521]145gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
[1427]146update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
147update-mime-database %{_datadir}/mime &> /dev/null
[521]148
[1427]149%post libs -p /sbin/ldconfig
[521]150
[1427]151%postun libs -p /sbin/ldconfig
152
153
154%files -f k3b.lang
[521]155%defattr(-,root,root,755)
[1427]156%doc README COPYING COPYING.DOC ChangeLog
157%{_sysconfdir}/dbus-1/system.d/*.conf
[521]158%{_bindir}/k3b
159%{_bindir}/k3bsetup
[1427]160%{_libdir}/kde4/*.so
161%{_libexecdir}/kde4/k3bsetuphelper
162%{_datadir}/applications/kde4/k3b.desktop
163%{_datadir}/dbus-1/system-services/*.service
[521]164%{_datadir}/icons/hicolor/*/*/*
[1427]165%{_datadir}/kde4/apps/k3b/
166%{_datadir}/kde4/apps/konqsidebartng/virtual_folders/services/*.desktop
167%{_datadir}/kde4/apps/solid/actions/k3b*.desktop
168%{_datadir}/kde4/services/*.desktop
169%{_datadir}/kde4/services/*.protocol
170%{_datadir}/kde4/services/ServiceMenus/k3b*.desktop
171%{_datadir}/kde4/servicetypes/k3b*.desktop
172%{_datadir}/mime/packages/x-k3b.xml
173%{_datadir}/polkit-1/actions/*.policy
[521]174
[1427]175%files libs -f libk3b.lang
176%defattr(-,root,root,-)
177%{_libdir}/libk3bdevice.so.6*
178%{_libdir}/libk3blib.so.6*
[521]179
180%files devel
181%defattr(-,root,root,-)
[1427]182%{_includedir}/kde4/k3b*.h
183%{_libdir}/libk3bdevice.so
184%{_libdir}/libk3blib.so
[521]185
186%changelog
[3874]187* Fri May 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-3
188- add BuildRequires: soprano-devel
189
[2857]190* Fri Mar  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-2
191- added BR: libXpm-devel
192
[2775]193* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
194- new upstream release
195
[1801]196* Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
197- fixed %%build section to remove qt-devel dependency
198
[1795]199* Wed Sep  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
200- new upstream release
201
[1427]202* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
203- new upstream release
204- updated build dependencies
205
206* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.0.5-6
207- drop required packages to resolve unmet dependency <BTS:VineLinux:797>
208  - Requires: libstdc++2_10, libstdc++2_10-compat, dvdrecord, libzvt
209  - BuildRequires: libzvt-devel
210
[521]211* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-5
212- changed to Requires: self-build-libmad from libmad
213- changed to BuildRequires: self-build-libmad from libmad-devel
214- added Requires: %{name} = %{version}-%{release} in k3b-i18n subpackage
215
216* Sun Jan 18 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-4
217- removed Release: tag of k3b-i18n subpackage
218
219* Sat Jan 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-3
220- rebuild with libdvdread.so.4 for vl4 <BTS:651>
221- spec in utf-8
222- merged the spec of 1.0.5-1vl4 release:
223  - added --with-lame --with-libdvdread in %%configure options
224  - set --vendor="vine" in desktop-file-install
225
226* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1
227- new upstream release
228- change %{_includedir}/k3b
229- drop {_localedir}/*  (i18n)
230- add devel Package
231
232* Fri Jan 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-2vl5
233- It returned it: %{_libdir}/kde3/*.la
234
235* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1vl5
236- new upstream release.
237- spec in utf-8, and applied vine versioning policy.
238- Remove *.la.
239- specfile updates.
240
241*Tue Dec 26 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.17-0vl1
242-new upstream release
243
244*Sun Jun 18 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl3
245-with-k3bsetup=no option is deleted.
246
247*Sat Apr 15 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl1
248-new upstream release
249-Requires -> sox and libsndfile added
250-BuildPreReq -> sox-devel and libsndfile-devel added
251-with-k3bsetup=no option added
252
253*Sun Apr 9 2006 TOSHI <toshi-52@sa.il24.net> 0.12.14-0vl1
254-new upstream release
255
256*Tue Feb 14 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
257-new upstream release
258-Requires -> Libstdc++2_10 and libstdc++2_10-compat added
259
260*Sat Feb 9 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
261-new upstream release
262-added i18n to spec
263
264*Thu Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.3-0vl1
265-new upstream release
266
267* Thu Jul 12 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.2-0vl1
268-new upstream release
269
270* Thu May 30 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12beta2-0vl1
271-1st Release.
Note: See TracBrowser for help on using the repository browser.