source: projects/specs/trunk/k/k3b/k3b-vl.spec @ 2857

Revision 2857, 8.0 KB checked in by inagaki, 13 years ago (diff)

update: k3b, self-build-k3b-extra, shared-desktop-ontologies

Line 
1Name: k3b
2Summary: CD/DVD/Blu-ray burning application for KDE
3Summary(ja): KDE 向け CD/DVD/Blu-ray 作成アプリケーション
4Version: 2.0.2
5Release: 2%{?_dist_release}
6
7Group: Applications/Archiving
8License: GPLv2+
9URL: http://www.k3b.org/
10
11Source0: http://downloads.sourceforge.net/sourceforge/k3b/k3b-%{version}%{?pre}.tar.bz2
12# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
13Source1: ox32-k3b.png
14Source2: k3brc
15
16ExcludeArch: s390 s390x
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: desktop-file-utils
20BuildRequires: flac-devel
21BuildRequires: gettext
22BuildRequires: kdelibs4-devel
23BuildRequires: kdemultimedia4-devel
24BuildRequires: libdvdread-devel
25BuildRequires: libmpcdec-devel
26BuildRequires: libmusicbrainz-devel
27BuildRequires: libsamplerate-devel
28BuildRequires: libsndfile-devel
29BuildRequires: libvorbis-devel
30BuildRequires: libXpm-devel
31BuildRequires: taglib-devel
32# needed by k3bsetup
33BuildRequires: polkit-qt-devel
34
35Requires: cdrecord mkisofs
36Requires: cdrdao
37Requires: dvd+rw-tools
38
39Obsoletes: k3b-i18n
40
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%description
45K3b is a CD and DVD burning application for Linux systems optimized for KDE.
46It provides a comfortable user interface to perform most
47CD/DVD burning tasks like creating an Audio CD from a set of audio files or copying a CD.
48
49[Notice]
50Please install self-build-k3b-extra package if you want to handle MP3 and WMA files.
51
52%description -l ja
53K3b は、KDE の為に最適化された Linux システム用の CD/DVD 作成アプリケーションです.
54多様なCD/DVDの作成に快適なユーザーインターフェースを提供します.
55また、音楽データや CD の複製等、音楽 CD を簡単に作成できます.
56
57K3b にて MP3/WMA ファイルを扱いたい場合は、self-build-k3b-extra パッケージを
58追加でインストールしてください.
59
60%package libs
61Summary: Runtime libraries for %{name}
62Summary(ja): %{name} のランタイムライブラリ
63Group:   System Environment/Libraries
64Requires: kdelibs4 >= 4.4.0
65
66%description libs
67%{summary}.
68
69%description -l ja libs
70%{summary}.
71
72%package devel
73Summary: Files for the development of applications which will use %{name}
74Summary(ja): %{name} 使用するアプリケーションを開発するためのファイル
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77Requires: kdelibs4-devel >= 4.4.0
78
79%description devel
80%{summary}.
81
82%description -l ja devel
83%{summary}.
84
85%prep
86%setup -q
87
88%build
89mkdir -p %{_target_platform}
90pushd %{_target_platform}
91unset QTDIR || : ; . /etc/profile.d/qt4.sh
92%{cmake} \
93    -DCMAKE_BUILD_TYPE=release \
94    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
95    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
96    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
97    -DK3B_BUILD_FFMPEG_DECODER_PLUGIN:BOOL=OFF \
98    -DK3B_BUILD_MAD_DECODER_PLUGIN::BOOL=OFF \
99    -DK3B_BUILD_LAME_ENCODER_PLUGIN:BOOL=OFF \
100    ..
101#   -DK3B_BUILD_K3BSETUP:BOOL=OFF \
102popd
103
104make %{?_smp_mflags} -C %{_target_platform}
105
106
107%install
108rm -rf $RPM_BUILD_ROOT
109make install/fast -C %{_target_platform} DESTDIR=$RPM_BUILD_ROOT
110
111%find_lang k3b --with-kde
112%find_lang k3bsetup
113%find_lang kio_videodvd
114%find_lang libk3b
115%find_lang libk3bdevice
116cat k3bsetup.lang >> k3b.lang
117cat kio_videodvd.lang >> libk3b.lang
118cat libk3bdevice.lang >> libk3b.lang
119
120# k3b app icon missing, https://bugzilla.redhat.com/show_bug.cgi?id=611272
121if [ ! -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png ]; then
122  echo "NOTICE: %{_datadir}/icons/hicolor/32x32/apps/k3b.png missing, borrowing oxygen version"
123  install -pD -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/k3b.png
124fi
125
126
127%check
128desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/k3b.desktop
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post
134touch --no-create %{_datadir}/icons/hicolor ||:
135
136%postun
137if [ $1 -eq 0 ] ; then
138    gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
139    update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
140    update-mime-database %{_datadir}/mime &> /dev/null
141fi
142
143%posttrans
144gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
145update-desktop-database -q %{_datadir}/applications > /dev/null 2>&1 ||:
146update-mime-database %{_datadir}/mime &> /dev/null
147
148%post libs -p /sbin/ldconfig
149
150%postun libs -p /sbin/ldconfig
151
152
153%files -f k3b.lang
154%defattr(-,root,root,755)
155%doc README COPYING COPYING.DOC ChangeLog
156%{_sysconfdir}/dbus-1/system.d/*.conf
157%{_bindir}/k3b
158%{_bindir}/k3bsetup
159%{_libdir}/kde4/*.so
160%{_libexecdir}/kde4/k3bsetuphelper
161%{_datadir}/applications/kde4/k3b.desktop
162%{_datadir}/dbus-1/system-services/*.service
163%{_datadir}/icons/hicolor/*/*/*
164%{_datadir}/kde4/apps/k3b/
165%{_datadir}/kde4/apps/konqsidebartng/virtual_folders/services/*.desktop
166%{_datadir}/kde4/apps/solid/actions/k3b*.desktop
167%{_datadir}/kde4/services/*.desktop
168%{_datadir}/kde4/services/*.protocol
169%{_datadir}/kde4/services/ServiceMenus/k3b*.desktop
170%{_datadir}/kde4/servicetypes/k3b*.desktop
171%{_datadir}/mime/packages/x-k3b.xml
172%{_datadir}/polkit-1/actions/*.policy
173
174%files libs -f libk3b.lang
175%defattr(-,root,root,-)
176%{_libdir}/libk3bdevice.so.6*
177%{_libdir}/libk3blib.so.6*
178
179%files devel
180%defattr(-,root,root,-)
181%{_includedir}/kde4/k3b*.h
182%{_libdir}/libk3bdevice.so
183%{_libdir}/libk3blib.so
184
185%changelog
186* Fri Mar  4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-2
187- added BR: libXpm-devel
188
189* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
190- new upstream release
191
192* Sun Sep 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-2
193- fixed %%build section to remove qt-devel dependency
194
195* Wed Sep  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
196- new upstream release
197
198* Thu Jul 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
199- new upstream release
200- updated build dependencies
201
202* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.0.5-6
203- drop required packages to resolve unmet dependency <BTS:VineLinux:797>
204  - Requires: libstdc++2_10, libstdc++2_10-compat, dvdrecord, libzvt
205  - BuildRequires: libzvt-devel
206
207* Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-5
208- changed to Requires: self-build-libmad from libmad
209- changed to BuildRequires: self-build-libmad from libmad-devel
210- added Requires: %{name} = %{version}-%{release} in k3b-i18n subpackage
211
212* Sun Jan 18 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-4
213- removed Release: tag of k3b-i18n subpackage
214
215* Sat Jan 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.5-3
216- rebuild with libdvdread.so.4 for vl4 <BTS:651>
217- spec in utf-8
218- merged the spec of 1.0.5-1vl4 release:
219  - added --with-lame --with-libdvdread in %%configure options
220  - set --vendor="vine" in desktop-file-install
221
222* Mon Jan 12 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1
223- new upstream release
224- change %{_includedir}/k3b
225- drop {_localedir}/*  (i18n)
226- add devel Package
227
228* Fri Jan 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-2vl5
229- It returned it: %{_libdir}/kde3/*.la
230
231* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.0.5-1vl5
232- new upstream release.
233- spec in utf-8, and applied vine versioning policy.
234- Remove *.la.
235- specfile updates.
236
237*Tue Dec 26 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.17-0vl1
238-new upstream release
239
240*Sun Jun 18 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl3
241-with-k3bsetup=no option is deleted.
242
243*Sat Apr 15 2006 TOSHI <toshi-52@sa.il24.net> 0.12.15-0vl1
244-new upstream release
245-Requires -> sox and libsndfile added
246-BuildPreReq -> sox-devel and libsndfile-devel added
247-with-k3bsetup=no option added
248
249*Sun Apr 9 2006 TOSHI <toshi-52@sa.il24.net> 0.12.14-0vl1
250-new upstream release
251
252*Tue Feb 14 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
253-new upstream release
254-Requires -> Libstdc++2_10 and libstdc++2_10-compat added
255
256*Sat Feb 9 2006 TOSHI <vine-jp@mail.goo.ne.jp> 0.12.10-0vl1
257-new upstream release
258-added i18n to spec
259
260*Thu Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.3-0vl1
261-new upstream release
262
263* Thu Jul 12 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12.2-0vl1
264-new upstream release
265
266* Thu May 30 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.12beta2-0vl1
267-1st Release.
Note: See TracBrowser for help on using the repository browser.