source: projects/specs/trunk/j/jsoncpp/jsoncpp-vl.spec @ 9305

Revision 9305, 5.3 KB checked in by inagaki, 9 years ago (diff)

2015-01-28 Ryoichi INAGAKI <ryo1@…>

  • gl2ps, jsoncpp: new package
  • vtk: updated


Line 
1Name:       jsoncpp
2Version:    0.7.1
3Release:    1%{?_dist_release}
4Summary:    JSON library implemented in C++
5Summary(ja): C++ で実装された JSON ライブラリ
6
7Group:      System Environment/Libraries
8License:    Public Domain or MIT
9URL:        http://sourceforge.net/projects/%{name}/
10Source0:    https://github.com/open-source-parsers/jsoncpp/archive/0.7.1.tar.gz
11Source1:    jsoncpp.pc
12
13Patch0:     asstring.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  python scons doxygen
17BuildRequires:  graphviz
18
19%description
20%{name} is an implementation of a JSON (http://json.org) reader and writer in
21C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
22It is easy for humans to read and write. It is easy for machines to parse and
23generate.
24
25
26%package devel
27Summary:    Development headers and library for %{name}
28Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
29Group:      Development/Libraries
30Requires:   %{name} = %{version}-%{release}
31
32%description devel
33This package contains the development headers and library for %{name}.
34
35
36%package doc
37Summary:    Documentation for %{name}
38Summary(ja): %{name} のドキュメント
39Group:      Documentation
40BuildArch:  noarch
41
42%description doc
43This package contains the documentation for %{name}
44
45
46%prep
47%setup -q
48#%patch0 -dsrc/lib_json -p1
49grep -e "-Wall" SConstruct
50sed 's/CCFLAGS = "-Wall"/CCFLAGS = "%{optflags}"/' -i SConstruct
51sed 's/README\.txt/README\.md/' -i SConstruct
52
53%build
54scons platform=linux-gcc %{?_smp_mflags}
55# Now, lets make a proper shared lib. :P
56g++ -o libjsoncpp.so.0.0.0 -shared -Wl,-soname,libjsoncpp.so.0 buildscons/linux-gcc-*/src/lib_json/*.os -lpthread
57# Build the doc
58python doxybuild.py --with-dot --doxygen %{_bindir}/doxygen
59
60%check
61# Fails due to patch0
62# scons platform=linux-gcc check %{?_smp_mflags}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66install -p -D lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0.0.0
67ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
68ln -s %{_libdir}/lib%{name}.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
69
70install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/json
71install -p -m 0644 include/json/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/json
72mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/html
73for f in AUTHORS LICENSE NEWS.txt README.md; do
74    install -p -m 0644 $f $RPM_BUILD_ROOT%{_docdir}/%{name}
75done
76install -p -m 0644 dist/doxygen/*/*.{html,png} $RPM_BUILD_ROOT%{_docdir}/%{name}/html
77install -d $RPM_BUILD_ROOT%{_libdir}/pkgconfig
78install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
79sed -i 's|@@LIBDIR@@|%{_libdir}|g' $RPM_BUILD_ROOT%{_libdir}/pkgconfig/jsoncpp.pc
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%files
88%{_docdir}/%{name}/
89%exclude %{_docdir}/%{name}/html
90%{_libdir}/lib%{name}.so.0
91%{_libdir}/lib%{name}.so.0.0.0
92
93%files devel
94%{_libdir}/lib%{name}.so
95%{_includedir}/%{name}/
96%{_libdir}/pkgconfig/jsoncpp.pc
97
98%files doc
99%{_docdir}/%{name}/
100
101%changelog
102* Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
103- Initial build for Vine Linux
104
105* Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
106- Allow int values to be converted to string (#1143774)
107
108* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
110
111* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
113
114* Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
115- https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
116  patch to fix duplicated documentation
117
118* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
120
121* Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
122- Changed Summary
123- Added %%doc files to the doc package
124- Added python as an explicit BuildRequires
125
126* Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
127- Added documentation sub-package
128
129* Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
130- Added graphviz as a BuildRequire
131
132* Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
133- Install the corrected library
134
135* Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
136- Added libjsoncpp.so.0
137- Moved the shared lib build to the correct section
138
139* Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
140- Removed doc subpackage
141- Added .pc file
142- Fixed shared lib
143
144* Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
145- Removed static package
146- Preserving timestamp on installed files
147- Added guard grep to the sed expression
148- Removed duplicated doc files
149- Removed dependency on pkgconfig
150- Changed base package group
151
152* Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
153- Changed license field to Public Domain or MIT
154
155* Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
156- Creation of the spec file
157
Note: See TracBrowser for help on using the repository browser.