source: projects/specs/trunk/j/jsoncpp/jsoncpp-vl.spec @ 12428

Revision 12428, 4.8 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

cmake-3.18.0-1

jsoncpp-1.9.3-1

libarchive-3.4.3-1

libzip-1.7.3-1

xz-5.2.5-1

Line 
1Name:           jsoncpp
2Version:        1.9.3
3Release:        1%{?_dist_release}
4Summary:        JSON library implemented in C++
5Summary(ja):    C++ で実装された JSON ライブラリ
6Group:          System Environment/Libraries
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        Public Domain or MIT
11URL:            https://github.com/open-source-parsers/jsoncpp
12Source0:        https://github.com/open-source-parsers/jsoncpp/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  cmake > 3.15.0
16BuildRequires:  python3-devel
17BuildRequires:  python3-rpm-macros
18
19%description
20%{name} is an implementation of a JSON (http://json.org) reader and writer in
21C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
22It is easy for humans to read and write. It is easy for machines to parse and
23generate.
24
25
26%package devel
27Summary:    Development headers and library for %{name}
28Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
29Group:      Development/Libraries
30Requires:   %{name} = %{version}-%{release}
31Obsoletes:  %{name}-doc < 1.0.0
32%description devel
33This package contains the development headers and library for %{name}.
34
35
36%prep
37%autosetup -p1
38
39%build
40mkdir -p %{_target_platform}
41pushd %{_target_platform}
42
43%cmake -DBUILD_STATIC_LIBS=OFF                \
44       -DJSONCPP_WITH_WARNING_AS_ERROR=OFF    \
45       -DJSONCPP_WITH_PKGCONFIG_SUPPORT=ON    \
46       -DJSONCPP_WITH_CMAKE_PACKAGE=ON        \
47       -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF \
48       -DPYTHON_EXECUTABLE="%{__python3}"     \
49       ..
50popd
51%make_build -C %{_target_platform}
52
53
54%check
55%make_build -C %{_target_platform} jsoncpp_check
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60%make_install -C %{_target_platform}
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post -p /sbin/ldconfig
67%postun -p /sbin/ldconfig
68
69%files
70%license AUTHORS LICENSE
71%doc README*
72%{_libdir}/lib%{name}.so.*
73
74%files devel
75%doc doc/*.html
76%{_libdir}/lib%{name}.so
77%{_includedir}/json
78%{_libdir}/cmake/*
79%{_libdir}/pkgconfig/%{name}.pc
80
81
82%changelog
83* Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.3-1
84- new upstream release.
85- dropped Patch0000: fixed in upstream.
86
87* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
88- new upstream release.
89- dropped Source1.
90- dropped Patch0.
91- imported Patch0000 from rawhide.
92- dropped a sub-package "doc".
93
94* Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
95- rebuild with gcc-5.4.0
96
97* Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
98- Initial build for Vine Linux
99
100* Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
101- Allow int values to be converted to string (#1143774)
102
103* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
105
106* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
108
109* Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
110- https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
111  patch to fix duplicated documentation
112
113* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
115
116* Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
117- Changed Summary
118- Added %%doc files to the doc package
119- Added python as an explicit BuildRequires
120
121* Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
122- Added documentation sub-package
123
124* Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
125- Added graphviz as a BuildRequire
126
127* Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
128- Install the corrected library
129
130* Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
131- Added libjsoncpp.so.0
132- Moved the shared lib build to the correct section
133
134* Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
135- Removed doc subpackage
136- Added .pc file
137- Fixed shared lib
138
139* Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
140- Removed static package
141- Preserving timestamp on installed files
142- Added guard grep to the sed expression
143- Removed duplicated doc files
144- Removed dependency on pkgconfig
145- Changed base package group
146
147* Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
148- Changed license field to Public Domain or MIT
149
150* Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
151- Creation of the spec file
152
Note: See TracBrowser for help on using the repository browser.