source: projects/specs/trunk/j/json-c/json-c-vl.spec @ 7171

Revision 7171, 3.4 KB checked in by daisuke, 11 years ago (diff)

json-c:

  • update to 0.10
  • update URL
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define pkg_version 0.10
4%define pkg_release 1%{?_dist_release}
5
6Summary:        A JSON implementation in C
7Name:           json-c
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10
11Source0:        https://github.com/downloads/json-c/json-c/json-c-%{version}.tar.gz
12
13License:        MIT
14Group:          System Environment/Libraries
15URL:            https://github.com/json-c/json-c/wiki
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Takemikaduchi
22
23
24%description
25JSON-C implements a reference counting object model that allows you to easily
26construct JSON objects in C, output them as JSON formatted strings and parse
27JSON formatted strings back into the C representation of JSON objects.
28
29
30%package devel
31Summary:        Development files for json-c
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       pkgconfig
35
36%description devel
37This package contains the libraries and header files that are needed
38for writing applications that are using json-c.
39
40
41%package doc
42Summary:        Documentation for json-c
43Group:          Documentation
44Requires:       %{name} = %{version}-%{release}
45BuildArch:      noarch
46
47%description doc
48This package contains documentation for json-c.
49
50
51%package -n compat32-%{name}
52Summary:        A JSON implementation in C
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55
56%description -n compat32-%{name}
57JSON-C implements a reference counting object model that allows you to easily
58construct JSON objects in C, output them as JSON formatted strings and parse
59JSON formatted strings back into the C representation of JSON objects.
60
61%package -n compat32-%{name}-devel
62Summary:        Development files for json-c
63Group:          Development/Libraries
64Requires:       compat32-%{name} = %{version}-%{release}
65Requires:       pkgconfig
66
67%description -n compat32-%{name}-devel
68This package contains the libraries and header files that are needed
69for writing applications that are using json-c.
70
71
72%prep
73%setup -q
74
75# Hack to get json_object_iterator.c compiled
76sed -e 's/json_object.c/json_object.c json_object_iterator.c/' \
77    -e 's/json_object.h/json_object.h json_object_iterator.h/' \
78    -e 's/json_object.lo/json_object.lo json_object_iterator.lo/' \
79    -i Makefile.in
80
81%build
82%configure --enable-shared --disable-static
83%{__make} %{?_smp_mflags}
84
85%install
86%{__rm} -rf $RPM_BUILD_ROOT
87%{__make} install DESTDIR=$RPM_BUILD_ROOT
88
89%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92%{__rm} -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102%files
103%defattr(-,root,root,-)
104%doc COPYING ChangeLog COPYING NEWS README README.html
105%{_libdir}/libjson.so.*
106
107%files devel
108%defattr(-,root,root,-)
109%{_includedir}/json/*
110%{_libdir}/libjson.so
111%{_libdir}/pkgconfig/json.pc
112
113%files doc
114%defattr(-,root,root,-)
115%doc doc/html/*
116
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-,root,root,-)
120%{_libdir}/libjson.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-,root,root,-)
124%{_libdir}/libjson.so
125%{_libdir}/pkgconfig/json.pc
126%endif
127
128
129%changelog
130* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10-1
131- update to 0.10
132- update URL
133
134* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-2
135- create compat32 sub packages
136
137* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
138- initial build for Vine Linux
139
Note: See TracBrowser for help on using the repository browser.