source: projects/specs/trunk/j/json-c/json-c-vl.spec @ 9311

Revision 9311, 3.7 KB checked in by daisuke, 9 years ago (diff)

json-c: update to 0.11

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define pkg_version 0.11
4%define pkg_release 1%{?_dist_release}
5
6Summary:        A JSON implementation in C
7Name:           json-c
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10
11Source0:        https://github.com/downloads/json-c/json-c/json-c-%{version}.tar.gz
12
13License:        MIT
14Group:          System Environment/Libraries
15URL:            https://github.com/json-c/json-c/wiki
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Takemikaduchi
22
23
24%description
25JSON-C implements a reference counting object model that allows you to easily
26construct JSON objects in C, output them as JSON formatted strings and parse
27JSON formatted strings back into the C representation of JSON objects.
28
29
30%package devel
31Summary:        Development files for json-c
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       pkgconfig
35
36%description devel
37This package contains the libraries and header files that are needed
38for writing applications that are using json-c.
39
40
41%package doc
42Summary:        Documentation for json-c
43Group:          Documentation
44Requires:       %{name} = %{version}-%{release}
45BuildArch:      noarch
46
47%description doc
48This package contains documentation for json-c.
49
50
51%package -n compat32-%{name}
52Summary:        A JSON implementation in C
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55
56%description -n compat32-%{name}
57JSON-C implements a reference counting object model that allows you to easily
58construct JSON objects in C, output them as JSON formatted strings and parse
59JSON formatted strings back into the C representation of JSON objects.
60
61%package -n compat32-%{name}-devel
62Summary:        Development files for json-c
63Group:          Development/Libraries
64Requires:       compat32-%{name} = %{version}-%{release}
65Requires:       pkgconfig
66
67%description -n compat32-%{name}-devel
68This package contains the libraries and header files that are needed
69for writing applications that are using json-c.
70
71
72%prep
73%setup -q
74
75# Hack to get json_object_iterator.c compiled
76sed -e 's/json_object.c/json_object.c json_object_iterator.c/' \
77    -e 's/json_object.h/json_object.h json_object_iterator.h/' \
78    -e 's/json_object.lo/json_object.lo json_object_iterator.lo/' \
79    -i Makefile.in
80
81%build
82autoreconf -fiv
83%configure --enable-shared --disable-static --disable-rpath --enable-rdrand
84%{__make}
85
86%install
87%{__rm} -rf $RPM_BUILD_ROOT
88%{__make} install DESTDIR=$RPM_BUILD_ROOT
89
90%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
91
92%clean
93%{__rm} -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100
101%postun -n compat32-%{name} -p /sbin/ldconfig
102
103%files
104%defattr(-,root,root,-)
105%doc COPYING ChangeLog COPYING NEWS README README.html
106%{_libdir}/libjson.so.*
107%{_libdir}/libjson-c.so.*
108
109%files devel
110%defattr(-,root,root,-)
111%{_includedir}/json/*
112%{_includedir}/json-c/*
113%{_libdir}/libjson.so
114%{_libdir}/libjson-c.so
115%{_libdir}/pkgconfig/json.pc
116%{_libdir}/pkgconfig/json-c.pc
117
118%files doc
119%defattr(-,root,root,-)
120%doc doc/html/*
121
122%if %{build_compat32}
123%files -n compat32-%{name}
124%defattr(-,root,root,-)
125%{_libdir}/libjson.so.*
126%{_libdir}/libjson-c.so.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root,-)
130%{_libdir}/libjson.so
131%{_libdir}/libjson-c.so
132%{_libdir}/pkgconfig/json.pc
133%{_libdir}/pkgconfig/json-c.pc
134%endif
135
136
137%changelog
138* Sat Jan 17 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 0.11-1
139- update to 0.11
140
141* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10-1
142- update to 0.10
143- update URL
144
145* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-2
146- create compat32 sub packages
147
148* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
149- initial build for Vine Linux
150
Note: See TracBrowser for help on using the repository browser.