source: projects/specs/trunk/j/json-c/json-c-vl.spec @ 4878

Revision 4878, 3.0 KB checked in by Takemikaduchi, 13 years ago (diff)

mc: new upstream release
json-c,orc: create compat32 sub package
pywebkitgtk: rebuild with WebKit?-1.6

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define pkg_version 0.9
4%define pkg_release 2%{?_dist_release}
5
6Summary:        A JSON implementation in C
7Name:           json-c
8Version:        %{pkg_version}
9Release:        %{pkg_release}
10
11Source0:        http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
12
13License:        MIT
14Group:          System Environment/Libraries
15URL:            http://oss.metaparadigm.com/json-c/
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Takemikaduchi
22
23
24%description
25JSON-C implements a reference counting object model that allows you to easily
26construct JSON objects in C, output them as JSON formatted strings and parse
27JSON formatted strings back into the C representation of JSON objects.
28
29
30%package devel
31Summary:        Development files for json-c
32Group:          Development/Libraries
33Requires:       %{name} = %{version}-%{release}
34Requires:       pkgconfig
35
36%description devel
37This package contains the libraries and header files that are needed
38for writing applications that are using json-c.
39
40
41%package doc
42Summary:        Documentation for json-c
43Group:          Documentation
44Requires:       %{name} = %{version}-%{release}
45BuildArch:      noarch
46
47%description doc
48This package contains documentation for json-c.
49
50
51%package -n compat32-%{name}
52Summary:        A JSON implementation in C
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55
56%description -n compat32-%{name}
57JSON-C implements a reference counting object model that allows you to easily
58construct JSON objects in C, output them as JSON formatted strings and parse
59JSON formatted strings back into the C representation of JSON objects.
60
61%package -n compat32-%{name}-devel
62Summary:        Development files for json-c
63Group:          Development/Libraries
64Requires:       compat32-%{name} = %{version}-%{release}
65Requires:       pkgconfig
66
67%description -n compat32-%{name}-devel
68This package contains the libraries and header files that are needed
69for writing applications that are using json-c.
70
71
72%prep
73%setup -q
74
75%build
76%configure --disable-static
77%{__make} %{?_smp_mflags}
78
79%install
80%{__rm} -rf $RPM_BUILD_ROOT
81%{__make} install DESTDIR=$RPM_BUILD_ROOT
82
83%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85%clean
86%{__rm} -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92%post -n compat32-%{name} -p /sbin/ldconfig
93
94%postun -n compat32-%{name} -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc COPYING ChangeLog COPYING NEWS README README.html
99%{_libdir}/libjson.so.*
100
101%files devel
102%defattr(-,root,root,-)
103%{_includedir}/json/*
104%{_libdir}/libjson.so
105%{_libdir}/pkgconfig/json.pc
106
107%files doc
108%defattr(-,root,root,-)
109%doc doc/html/*
110
111%if %{build_compat32}
112%files -n compat32-%{name}
113%defattr(-,root,root,-)
114%{_libdir}/libjson.so.*
115
116%files -n compat32-%{name}-devel
117%defattr(-,root,root,-)
118%{_libdir}/libjson.so
119%{_libdir}/pkgconfig/json.pc
120%endif
121
122
123%changelog
124* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-2
125- create compat32 sub packages
126
127* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
128- initial build for Vine Linux
129
Note: See TracBrowser for help on using the repository browser.