source: projects/specs/trunk/j/json-c/json-c-vl.spec @ 4876

Revision 4876, 1.8 KB checked in by Takemikaduchi, 13 years ago (diff)

pulseaudio: new upstream release, json-c: NEW

Line 
1%define pkg_version 0.9
2%define pkg_release 1%{?_dist_release}
3
4Summary:        A JSON implementation in C
5Name:           json-c
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8
9Source0:        http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
10
11License:        MIT
12Group:          System Environment/Libraries
13URL:            http://oss.metaparadigm.com/json-c/
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: Takemikaduchi
20
21
22%description
23JSON-C implements a reference counting object model that allows you to easily
24construct JSON objects in C, output them as JSON formatted strings and parse
25JSON formatted strings back into the C representation of JSON objects.
26
27
28%package devel
29Summary:        Development files for json-c
30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
32Requires:       pkgconfig
33
34%description devel
35This package contains the libraries and header files that are needed
36for writing applications that are using json-c.
37
38
39%package doc
40Summary:        Documentation for json-c
41Group:          Documentation
42Requires:       %{name} = %{version}-%{release}
43BuildArch:      noarch
44
45%description doc
46This package contains documentation for json-c.
47
48
49%prep
50%setup -q
51
52%build
53%configure --disable-static
54%{__make} %{?_smp_mflags}
55
56%install
57%{__rm} -rf $RPM_BUILD_ROOT
58%{__make} install DESTDIR=$RPM_BUILD_ROOT
59
60%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
61
62%clean
63%{__rm} -rf $RPM_BUILD_ROOT
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69%files
70%defattr(-,root,root,-)
71%doc COPYING ChangeLog COPYING NEWS README README.html
72%{_libdir}/libjson.so.*
73
74%files devel
75%defattr(-,root,root,-)
76%{_includedir}/json/*
77%{_libdir}/libjson.so
78%{_libdir}/pkgconfig/json.pc
79
80%files doc
81%defattr(-,root,root,-)
82%doc doc/html/*
83
84
85%changelog
86* Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
87- initial build for Vine Linux
88
Note: See TracBrowser for help on using the repository browser.