source: projects/specs/trunk/j/js/js-vl.spec @ 8085

Revision 8085, 10.4 KB checked in by Takemikaduchi, 10 years ago (diff)

libproxy: new upstream release
others: rebuild

Line 
1#% global hgdate 51702867d932
2
3Summary:        JavaScript interpreter and libraries
4Name:           js
5Version:        1.8.5
6Release:        3%{?hgdate:.hg%{hgdate}}%{?_dist_release}
7# The sources are triple licensed, but when we link against readline which is
8# GPL, the result can only be GPL.
9%if 0%{?_without_readline:1}
10License:        GPLv2+ or LGPLv2+ or MPLv1.1
11%else
12License:        GPLv2+
13%endif
14Group:          Development/Languages
15URL:            http://www.mozilla.org/js/
16Source0:        http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
17Patch0:         js-1.8.5-64bit-big-endian.patch
18Patch1:         js-1.8.5-secondary-jit.patch
19Patch2:         js185-destdir.patch
20Patch3:         js-1.8.5-configure.patch
21Patch4:         js-1.8.5-537701.patch
22Patch5:         js185-arm-nosoftfp.patch
23Provides:               libjs = %{version}-%{release}
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25Buildrequires:  nspr-devel >= 4.7, python, zip
26Buildrequires:  readline-devel, ncurses-devel, autoconf213
27Epoch:          1
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33JavaScript is the Netscape-developed object scripting language used in millions
34of web pages and server applications worldwide. Netscape's JavaScript is a
35superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
36with only mild differences from the published standard.
37
38
39%package devel
40Summary: Header files, libraries and development documentation for %{name}
41Group: Development/Libraries
42Requires: %{name} = %{epoch}:%{version}-%{release}
43Requires: pkgconfig
44Requires: ncurses-devel readline-devel
45Provides: libjs-devel = %{version}-%{release}
46
47%description devel
48This package contains the header files, static libraries and development
49documentation for %{name}. If you like to develop programs using %{name},
50you will need to install %{name}-devel.
51
52
53%prep
54# All patches come from old version and maintainer. I think it is Fedora related only
55%setup -q -n %{name}-%{version}
56%patch0 -p2 -b .64bit-big-endian
57%patch1 -p2 -b .secondary-jit
58%patch2 -p0 -b .destdir
59%patch3 -p1 -b .version
60%patch4 -p1 -b .537701
61%patch5 -p1 -b .armhfp
62cd js
63
64# Rm parts with spurios licenses, binaries
65# Some parts under BSD (but different suppliers): src/assembler
66#rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
67rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
68
69pushd src
70autoconf-2.13
71%configure \
72    --with-system-nspr \
73    --enable-threadsafe \
74%if 0%{!?_without_readline:1}
75        --enable-readline \
76%endif
77
78popd
79
80# Create pkgconfig file
81%{__cat} > libjs.pc << 'EOF'
82prefix=%{_prefix}
83exec_prefix=%{_prefix}
84libdir=%{_libdir}
85includedir=%{_includedir}
86
87Name: libjs
88Description: JS library
89Requires: nspr >= 4.7
90Version: %{version}
91Libs: -L${libdir} -ljs
92Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
93EOF
94
95
96%build
97cd js
98%{__make} %{?_smp_mflags} -C src
99
100%install
101cd js
102%{__make} -C src install DESTDIR=%{buildroot}
103# We don't want this
104%{__rm} -f %{buildroot}%{_bindir}/js-config
105%{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
106%{__rm} -rf %{buildroot}%{_libdir}/*.a
107%{__rm} -rf %{buildroot}%{_libdir}/*.la
108
109%{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
110
111# For compatibility
112# XXX do we really need libjs?!?!?!
113pushd %{buildroot}%{_libdir}
114%{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
115%{__ln_s} libmozjs185.so.1.0 libjs.so.1
116%{__ln_s} libmozjs185.so libmozjs.so
117%{__ln_s} libmozjs185.so libjs.so
118popd
119
120%{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
121
122%clean
123%{__rm} -rf %{buildroot}
124
125
126%post -p /sbin/ldconfig
127
128%postun -p /sbin/ldconfig
129
130
131%files
132%defattr(-,root,root,-)
133%doc js/src/README.html
134%{_bindir}/js
135%{_libdir}/*.so.*
136
137%files devel
138%defattr(-,root,root,-)
139%{_bindir}/jscpucfg
140%{_libdir}/pkgconfig/*.pc
141%{_libdir}/*.so
142%{_includedir}/js
143%{_includedir}/js*.h
144%{_includedir}/*.tbl
145%{_includedir}/js.msg
146%{_includedir}/prmjtime.h
147
148%changelog
149* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-3
150- rebuild with VineSeed environment
151
152* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-2
153- add Patch4 (js-1.8.5-537701.patch) from fedora
154- add Patch5 (js185-arm-nosoftfp.patch) from fedora
155
156* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-1
157- add Patch3 (js-1.8.5-configure.patch)
158- merge spec file with fedora package
159
160  * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
161  - new upstream release
162  - applied new versioning policy
163  - removed no longer provided perlconnect parts.
164
165  * Mon Jun  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
166  - initial build for Vine Linux
167
168
169* Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
170- Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
171- Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
172- Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
173
174* Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
175- Include mozjs185.pc, clean up build
176- Based on work from Christopher Aillon <caillon@redhat.com>
177- Switch to using make install DESTDIR=, instead of hardcoding build rules.
178- Add DESTDIR= patch from GNOME 3.2 jhbuild
179- Make mozjs185 the canonical target for both libmozjs and libmozjs185.
180
181* Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
182- add secondary arch patches from xulrunner
183
184* Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
185- devel subpackage needs to ask for the newly added epoch
186
187* Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
188- Add Epoch: 1 to allow update of 1.70-13 version.
189
190* Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
191- Correct symlink to provide backward capabiliies libjs.so.1
192
193* Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
194- Update to release.
195- Remove unneeded anymore patches.
196- Add backward capability symlink.
197
198* Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
199- Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
200- Gone -DJS_C_STRINGS_ARE_UTF8
201- Add BR autoconf213, change build system to use configure.
202- Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
203- Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
204- Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
205- Add BR python, zip.
206
207* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
209
210* Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
211- Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
212
213* Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
214- updated the va_copy patch for s390
215
216* Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
217- Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
218
219* Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
220- Reformat spec with tabs.
221- By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
222
223* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
227- update the va_copy patch for s390x
228
229* Thu Apr  9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
230- Update description (#487903).
231
232* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
234
235* Wed Jun  4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
236- Add two missing files (#449715)
237
238* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
239- Rebuild for perl 5.10 (again)
240
241* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
242- Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
243- Remove no longer provided perlconnect parts.
244
245* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
246- BR: perl(ExtUtils::Embed)
247
248* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
249- rebuild for new perl
250
251* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
252- Rebuild for new BuildID feature.
253
254* Mon Aug  6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
255- Update License field.
256- Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
257
258* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
259- Include jsopcode.tbl and js.msg in devel (#235481).
260- Install static lib mode 644 instead of 755.
261
262* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
263- Update to 1.60.
264- Rebuild in order to link against ncurses instead of termcap (#226773).
265- Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
266- Change mode of perl library from 555 to 755 (#224603).
267
268* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
269- Fix pkgconfig file (#204232 & dupe #204236).
270
271* Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
272- FC6 rebuild.
273- Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
274
275* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
276- FC5 rebuild.
277
278* Thu Feb  9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
279- Rebuild for new gcc/glibc.
280
281* Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
282- Fix .pc file.
283
284* Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
285- Update to 1.5.0 final.
286- Spec file cleanups.
287- Move docs from devel to main, since we need the license there.
288- Remove no longer needed js-perlconnect.patch.
289- Update js-1.5-va_copy.patch.
290- Include a pkgconfig file (#178993).
291
292* Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
293- Link shared lib with libperl.
294
295* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
296- rebuilt
297
298* Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
299- Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
300
301* Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
302- Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
303
304* Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
305- Include perlconnect.
306- Include readline support, rebuild using "--without readline" to disable.
307- Add libjs* provides for upstream compatibility.
308- Install header files in %%{_includedir} instead of %%{_includedir}/js.
309
310* Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
311- Update to 1.5rc6a.
312
313* Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
314- Initial package. (using DAR)
315
Note: See TracBrowser for help on using the repository browser.