source: projects/specs/trunk/j/js/js-vl.spec @ 9467

Revision 9467, 10.7 KB checked in by inagaki, 9 years ago (diff)

2015-03-24 Ryoichi INAGAKI <ryo1@…>

  • bind, guild, js, unixODBC: rebuilt
  • ed: updated


Line 
1#% global hgdate 51702867d932
2
3Summary:        JavaScript interpreter and libraries
4Summary(ja):    JavaScript インタプリタ及びライブラリ
5Name:           js
6Epoch:          1
7Version:        1.8.5
8Release:        4%{?hgdate:.hg%{hgdate}}%{?_dist_release}
9License:        GPLv2+ or LGPLv2+ or MPLv1.1
10Group:          Development/Languages
11URL:            http://www.mozilla.org/js/
12
13Source0:        http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
14Patch0:         js-1.8.5-64bit-big-endian.patch
15Patch1:         js-1.8.5-secondary-jit.patch
16Patch2:         js185-destdir.patch
17#Patch3:        js-1.8.5-configure.patch
18Patch3:         js-1.8.5-537701.patch
19Patch4:         js185-arm-nosoftfp.patch
20Patch5:         js185-libedit.patch
21Patch6:         0001-Make-js-config.h-multiarch-compatible.patch
22
23Provides:       libjs = %{version}-%{release}
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires:  nspr-devel >= 4.7
26BuildRequires:, python
27BuildRequires:  zip
28BuildRequires:  libedit-devel
29BuildRequires:  ncurses-devel
30BuildRequires:  autoconf213
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34
35%description
36JavaScript is the Netscape-developed object scripting language used in millions
37of web pages and server applications worldwide. Netscape's JavaScript is a
38superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
39with only mild differences from the published standard.
40
41
42%package devel
43Summary: Header files, libraries and development documentation for %{name}
44Summary(ja): %{name} のヘッダファイル、ライブラリ及び開発用ドキュメント
45Group: Development/Libraries
46Requires: %{name} = %{epoch}:%{version}-%{release}
47Requires: pkgconfig
48Requires: ncurses-devel
49Provides: libjs-devel = %{version}-%{release}
50
51%description devel
52This package contains the header files, static libraries and development
53documentation for %{name}. If you like to develop programs using %{name},
54you will need to install %{name}-devel.
55
56
57%prep
58# All patches come from old version and maintainer. I think it is Fedora related only
59%setup -q -n %{name}-%{version}
60%patch0 -p2 -b .64bit-big-endian
61%patch1 -p2 -b .secondary-jit
62%patch2 -p0 -b .destdir
63%patch3 -p1 -b .537701
64%patch4 -p1 -b .armhfp
65%patch5 -p1 -b .libedit
66%patch6 -p1 -b .multiarch
67
68cd js
69
70# Rm parts with spurios licenses, binaries
71# Some parts under BSD (but different suppliers): src/assembler
72#rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
73rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
74
75pushd src
76autoconf-2.13
77popd
78
79# Create pkgconfig file
80%{__cat} > libjs.pc << 'EOF'
81prefix=%{_prefix}
82exec_prefix=%{_prefix}
83libdir=%{_libdir}
84includedir=%{_includedir}
85
86Name: libjs
87Description: JS library
88Requires: nspr >= 4.7
89Version: %{version}
90Libs: -L${libdir} -ljs
91Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
92EOF
93
94
95%build
96cd js/src
97CPPFLAGS="$(pkg-config --cflags libedit)" \
98%configure \
99    --with-system-nspr \
100    --enable-threadsafe \
101    --enable-readline
102
103%{__make} %{?_smp_mflags}
104
105%install
106%{__rm} -rf %{buildroot}
107cd js
108%{__make} -C src install DESTDIR=%{buildroot}
109# We don't want this
110%{__rm} -f %{buildroot}%{_bindir}/js-config
111%{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
112%{__rm} -rf %{buildroot}%{_libdir}/*.a
113%{__rm} -rf %{buildroot}%{_libdir}/*.la
114
115%{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
116
117# For compatibility
118# XXX do we really need libjs?!?!?!
119pushd %{buildroot}%{_libdir}
120%{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
121%{__ln_s} libmozjs185.so.1.0 libjs.so.1
122%{__ln_s} libmozjs185.so libmozjs.so
123%{__ln_s} libmozjs185.so libjs.so
124popd
125
126%{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
127
128%clean
129%{__rm} -rf %{buildroot}
130
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136
137%files
138%defattr(-,root,root,-)
139%doc js/src/README.html
140%{_bindir}/js
141%{_libdir}/*.so.*
142
143%files devel
144%defattr(-,root,root,-)
145%{_bindir}/jscpucfg
146%{_libdir}/pkgconfig/*.pc
147%{_libdir}/*.so
148%{_includedir}/js
149%{_includedir}/js*.h
150%{_includedir}/*.tbl
151%{_includedir}/js.msg
152%{_includedir}/prmjtime.h
153
154%changelog
155* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1:1.8.5-4
156- added Patch5 to build with libedit instead of readline
157
158* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-3
159- rebuild with VineSeed environment
160
161* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-2
162- add Patch4 (js-1.8.5-537701.patch) from fedora
163- add Patch5 (js185-arm-nosoftfp.patch) from fedora
164
165* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-1
166- add Patch3 (js-1.8.5-configure.patch)
167- merge spec file with fedora package
168
169  * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
170  - new upstream release
171  - applied new versioning policy
172  - removed no longer provided perlconnect parts.
173
174  * Mon Jun  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
175  - initial build for Vine Linux
176
177
178* Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
179- Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
180- Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
181- Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
182
183* Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
184- Include mozjs185.pc, clean up build
185- Based on work from Christopher Aillon <caillon@redhat.com>
186- Switch to using make install DESTDIR=, instead of hardcoding build rules.
187- Add DESTDIR= patch from GNOME 3.2 jhbuild
188- Make mozjs185 the canonical target for both libmozjs and libmozjs185.
189
190* Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
191- add secondary arch patches from xulrunner
192
193* Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
194- devel subpackage needs to ask for the newly added epoch
195
196* Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
197- Add Epoch: 1 to allow update of 1.70-13 version.
198
199* Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
200- Correct symlink to provide backward capabiliies libjs.so.1
201
202* Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
203- Update to release.
204- Remove unneeded anymore patches.
205- Add backward capability symlink.
206
207* Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
208- Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
209- Gone -DJS_C_STRINGS_ARE_UTF8
210- Add BR autoconf213, change build system to use configure.
211- Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
212- Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
213- Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
214- Add BR python, zip.
215
216* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
218
219* Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
220- Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
221
222* Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
223- updated the va_copy patch for s390
224
225* Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
226- Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
227
228* Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
229- Reformat spec with tabs.
230- By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
231
232* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
234
235* Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
236- update the va_copy patch for s390x
237
238* Thu Apr  9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
239- Update description (#487903).
240
241* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
243
244* Wed Jun  4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
245- Add two missing files (#449715)
246
247* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
248- Rebuild for perl 5.10 (again)
249
250* Sun Feb  3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
251- Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
252- Remove no longer provided perlconnect parts.
253
254* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
255- BR: perl(ExtUtils::Embed)
256
257* Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
258- rebuild for new perl
259
260* Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
261- Rebuild for new BuildID feature.
262
263* Mon Aug  6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
264- Update License field.
265- Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
266
267* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
268- Include jsopcode.tbl and js.msg in devel (#235481).
269- Install static lib mode 644 instead of 755.
270
271* Fri Feb  2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
272- Update to 1.60.
273- Rebuild in order to link against ncurses instead of termcap (#226773).
274- Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
275- Change mode of perl library from 555 to 755 (#224603).
276
277* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
278- Fix pkgconfig file (#204232 & dupe #204236).
279
280* Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
281- FC6 rebuild.
282- Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
283
284* Mon Mar  6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
285- FC5 rebuild.
286
287* Thu Feb  9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
288- Rebuild for new gcc/glibc.
289
290* Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
291- Fix .pc file.
292
293* Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
294- Update to 1.5.0 final.
295- Spec file cleanups.
296- Move docs from devel to main, since we need the license there.
297- Remove no longer needed js-perlconnect.patch.
298- Update js-1.5-va_copy.patch.
299- Include a pkgconfig file (#178993).
300
301* Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
302- Link shared lib with libperl.
303
304* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
305- rebuilt
306
307* Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
308- Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
309
310* Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
311- Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
312
313* Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
314- Include perlconnect.
315- Include readline support, rebuild using "--without readline" to disable.
316- Add libjs* provides for upstream compatibility.
317- Install header files in %%{_includedir} instead of %%{_includedir}/js.
318
319* Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
320- Update to 1.5rc6a.
321
322* Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
323- Initial package. (using DAR)
324
Note: See TracBrowser for help on using the repository browser.