source: projects/specs/trunk/j/jemalloc/jemalloc-vl.spec @ 11251

Revision 11251, 8.4 KB checked in by tomop, 6 years ago (diff)

jemalloc-5.0.1-1

Line 
1Name:           jemalloc
2Version:        5.0.1
3
4Release:        1%{?_dist_release}
5Summary:        General-purpose scalable concurrent malloc implementation
6Summary(ja):    汎用・スケーラブル・並行な malloc 実装
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://www.canonware.com/jemalloc/
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15Source0:        https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  /usr/bin/xsltproc
19%ifnarch s390
20BuildRequires:  valgrind-devel
21%endif
22
23%description
24General-purpose scalable concurrent malloc(3) implementation.
25This distribution is the stand-alone "portable" implementation of %{name}.
26
27%package devel
28Summary:        Development files for %{name}
29Requires:       %{name} = %{version}-%{release}
30Group:          Development/Libraries
31
32%description devel
33The %{name}-devel package contains libraries and header files for
34developing applications that use %{name}.
35
36%prep
37%setup -q
38
39%build
40%ifarch i686
41%if 0%{?fedora} >= 21
42CFLAGS="%{optflags} -msse2"
43%endif
44%endif
45
46%if 0%{?rhel} && 0%{?rhel} < 7
47export LDFLAGS="%{?__global_ldflags} -lrt"
48%endif
49
50# disable Transparent HugePages on Vine Linux.
51perl -pi -e 's/je_cv_thp=yes/je_cv_thp=no/' configure
52
53%configure
54make %{?_smp_mflags}
55%check
56make check
57
58
59%install
60rm -rf %{buildroot}
61make install DESTDIR=%{buildroot}
62# Install this with doc macro instead
63rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
64
65# None of these in fedora
66find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
67
68
69%clean
70rm -rf %{buildroot}
71
72
73%files
74%defattr(-,root,root,-)
75%license COPYING
76%doc README VERSION
77%doc doc/jemalloc.html
78%{_libdir}/libjemalloc.so.*
79%{_bindir}/jemalloc.sh
80%{_bindir}/jemalloc-config
81%{_bindir}/jeprof
82%{_libdir}/pkgconfig/jemalloc.pc
83
84%files devel
85%defattr(-,root,root,-)
86%{_includedir}/jemalloc
87%{_libdir}/libjemalloc.so
88%{_mandir}/man3/jemalloc.3*
89
90%post
91/sbin/ldconfig
92
93%postun
94/sbin/ldconfig
95
96%changelog
97* Sat Dec 02 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.0.1-1
98- new upstream release.
99
100* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.5.0-1
101- new upstream release.
102
103* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.0-1
104- new upstream release.
105
106* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
107- new upstream release.
108
109* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
110- new upstream release.
111
112* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
113- initial build for Vine Linux.
114
115* Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
116- New upstream release
117
118* Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
119- New upstream release
120- Removed oom test patch, it has been fixed upstream
121
122* Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
123- oom test also fails on 32bit ppc, so patch it out there as well
124
125* Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
126- New upstream release
127- Added a patch removing a non-critical test that fails on i386
128- Removed now included negative bitshift patch.
129
130* Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
131- New upstream release
132- Removed the no-pprof patch, as jemalloc now comes with its own prof variant
133- Removed atomic.h patch for armv5tel. jemalloc now provides a specific
134  variant for armv5tel
135- Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
136- Added -lrt to LDFLAGS for rhel<7
137
138* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
140
141* Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
142- valgrind-devel is not available on s390, closes #1131014
143
144* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
146
147* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
148- bz #1106933 fix only for fedora 21 and above
149
150* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
151- Added valgrind-devel to BuildRequires, fixing bz #974270
152
153* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
154- Added an i686 build fixing bz #1106933
155
156* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
158
159* Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
160- Patch that removes explicit altivec on el5/ppc
161
162* Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
163- New upstream release. This release fixes a critical regression
164
165* Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
166- New upstream release
167- Updated nopprof patch to match new release
168- Fixed a few bogus changelog entries
169
170* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
172
173* Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
174- New upstream release
175
176* Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
177- New upstream release
178- Dropped s390 patch, it's in upstream now.
179
180* Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
181- New upstream release
182 
183* Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
184- New upstream release
185 
186* Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
187- New upstream release
188- Removed ptmalloc_lock_all patch, it is merged upstream
189
190* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
191- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
192
193* Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
194- Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
195  closing #824646
196
197* Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
198- New upstream release
199- Updated no_pprof patch to match new release
200- Updated s390 patch to match new relase
201- Added make check
202- Added new script jemalloc.sh
203- Added a patch for atomic operations on epel5/ppc
204
205* Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
206- Improve ARM patch
207
208* Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
209- no attomics on armv5tel
210
211* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
212- substitute version information in the header (#788517)
213
214* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
216
217* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
218- New upstream release, closes #75618
219
220* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
221- New upstream release
222
223* Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
224- New upstream release, closes #735057
225
226* Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
227- New upstream release, closes #727103
228- Updated no_pprof patch for 2.2.2
229
230* Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
231- New upstream release
232
233* Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
234- New upstream release
235- Updated no_pprof patch for 2.2.0
236
237* Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
238- New upstream release
239
240* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
241- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
242
243* Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
244- New upstream release
245
246* Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
247- New upstream release
248- Updated patch to remove pprof
249- Added html doc and xsltproc as a requirement to build it
250
251* Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
252- fix build on s390
253
254* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
255- Added a patch that removes pprof, as it already exists in the
256  google-perftools package
257- Cosmetic fixes as requested in the package review (rhbz#653682)
258
259* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
260- First cut of an rpm distribution of jemalloc
Note: See TracBrowser for help on using the repository browser.