source: projects/specs/trunk/j/jemalloc/jemalloc-vl.spec @ 11838

Revision 11838, 9.0 KB checked in by tomop, 5 years ago (diff)

jemalloc-5.1.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           jemalloc
4Version:        5.1.0
5
6Release:        1%{?_dist_release}
7Summary:        General-purpose scalable concurrent malloc implementation
8Summary(ja):    汎用・スケーラブル・並行な malloc 実装
9
10Group:          System Environment/Libraries
11License:        BSD
12URL:            http://www.canonware.com/jemalloc/
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildRequires:  /usr/bin/xsltproc
21%ifnarch s390
22BuildRequires:  valgrind-devel
23%endif
24
25%description
26General-purpose scalable concurrent malloc(3) implementation.
27This distribution is the stand-alone "portable" implementation of %{name}.
28
29%package devel
30Summary:        Development files for %{name}
31Requires:       %{name} = %{version}-%{release}
32Group:          Development/Libraries
33
34%description devel
35The %{name}-devel package contains libraries and header files for
36developing applications that use %{name}.
37
38%package -n compat32-jemalloc
39Summary:        General-purpose scalable concurrent malloc implementation
40Summary(ja):    汎用・スケーラブル・並行な malloc 実装
41Group:          System Environment/Libraries
42
43%description -n compat32-jemalloc
44General-purpose scalable concurrent malloc(3) implementation.
45This distribution is the stand-alone "portable" implementation of %{name}.
46
47%prep
48%setup -q
49
50%build
51%ifarch i686
52%if 0%{?fedora} >= 21
53CFLAGS="%{optflags} -msse2"
54%endif
55%endif
56
57%if 0%{?rhel} && 0%{?rhel} < 7
58export LDFLAGS="%{?__global_ldflags} -lrt"
59%endif
60
61# disable Transparent HugePages on Vine Linux.
62perl -pi -e 's/je_cv_thp=yes/je_cv_thp=no/' configure
63
64%configure
65make %{?_smp_mflags}
66%check
67make check
68
69
70%install
71rm -rf %{buildroot}
72make install DESTDIR=%{buildroot}
73# Install this with doc macro instead
74rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
75
76# None of these in fedora
77find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
78
79
80%clean
81rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%license COPYING
87%doc README VERSION
88%doc doc/jemalloc.html
89%{_libdir}/libjemalloc.so.*
90%{_bindir}/jemalloc.sh
91%{_bindir}/jemalloc-config
92%{_bindir}/jeprof
93%{_libdir}/pkgconfig/jemalloc.pc
94
95%files devel
96%defattr(-,root,root,-)
97%{_includedir}/jemalloc
98%{_libdir}/libjemalloc.so
99%{_mandir}/man3/jemalloc.3*
100
101%if %{build_compat32}
102%files -n compat32-jemalloc
103%{_libdir}/libjemalloc.so.*
104%endif
105
106%post
107/sbin/ldconfig
108
109%postun
110/sbin/ldconfig
111
112%changelog
113* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.1.0-1
114- new upstream release.
115- added a sub-package 'compat32-jemalloc'.
116
117* Sat Dec 02 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.0.1-1
118- new upstream release.
119
120* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.5.0-1
121- new upstream release.
122
123* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.0-1
124- new upstream release.
125
126* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
127- new upstream release.
128
129* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
130- new upstream release.
131
132* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
133- initial build for Vine Linux.
134
135* Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
136- New upstream release
137
138* Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
139- New upstream release
140- Removed oom test patch, it has been fixed upstream
141
142* Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
143- oom test also fails on 32bit ppc, so patch it out there as well
144
145* Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
146- New upstream release
147- Added a patch removing a non-critical test that fails on i386
148- Removed now included negative bitshift patch.
149
150* Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
151- New upstream release
152- Removed the no-pprof patch, as jemalloc now comes with its own prof variant
153- Removed atomic.h patch for armv5tel. jemalloc now provides a specific
154  variant for armv5tel
155- Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
156- Added -lrt to LDFLAGS for rhel<7
157
158* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
160
161* Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
162- valgrind-devel is not available on s390, closes #1131014
163
164* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
166
167* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
168- bz #1106933 fix only for fedora 21 and above
169
170* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
171- Added valgrind-devel to BuildRequires, fixing bz #974270
172
173* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
174- Added an i686 build fixing bz #1106933
175
176* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
178
179* Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
180- Patch that removes explicit altivec on el5/ppc
181
182* Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
183- New upstream release. This release fixes a critical regression
184
185* Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
186- New upstream release
187- Updated nopprof patch to match new release
188- Fixed a few bogus changelog entries
189
190* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
191- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
192
193* Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
194- New upstream release
195
196* Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
197- New upstream release
198- Dropped s390 patch, it's in upstream now.
199
200* Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
201- New upstream release
202 
203* Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
204- New upstream release
205 
206* Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
207- New upstream release
208- Removed ptmalloc_lock_all patch, it is merged upstream
209
210* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
212
213* Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
214- Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
215  closing #824646
216
217* Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
218- New upstream release
219- Updated no_pprof patch to match new release
220- Updated s390 patch to match new relase
221- Added make check
222- Added new script jemalloc.sh
223- Added a patch for atomic operations on epel5/ppc
224
225* Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
226- Improve ARM patch
227
228* Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
229- no attomics on armv5tel
230
231* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
232- substitute version information in the header (#788517)
233
234* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
235- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
236
237* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
238- New upstream release, closes #75618
239
240* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
241- New upstream release
242
243* Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
244- New upstream release, closes #735057
245
246* Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
247- New upstream release, closes #727103
248- Updated no_pprof patch for 2.2.2
249
250* Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
251- New upstream release
252
253* Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
254- New upstream release
255- Updated no_pprof patch for 2.2.0
256
257* Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
258- New upstream release
259
260* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
262
263* Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
264- New upstream release
265
266* Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
267- New upstream release
268- Updated patch to remove pprof
269- Added html doc and xsltproc as a requirement to build it
270
271* Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
272- fix build on s390
273
274* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
275- Added a patch that removes pprof, as it already exists in the
276  google-perftools package
277- Cosmetic fixes as requested in the package review (rhbz#653682)
278
279* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
280- First cut of an rpm distribution of jemalloc
Note: See TracBrowser for help on using the repository browser.