source: projects/specs/trunk/j/jemalloc/jemalloc-vl.spec @ 10273

Revision 10273, 8.2 KB checked in by tomop, 8 years ago (diff)

jemalloc-4.1.1-1

Line 
1Name:           jemalloc
2Version:        4.1.1
3
4Release:        1%{?_dist_release}
5Summary:        General-purpose scalable concurrent malloc implementation
6Summary(ja):    汎用・スケーラブル・並行 malloc 実装
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://www.canonware.com/jemalloc/
11Source0:        https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14# ARMv5tel has no atomic operations
15Patch2:         jemalloc-armv5-force-atomic.patch
16# RHEL5/POWER has no atomic operations
17Patch3:         jemalloc-3.0.0.atomic_h_ppc_32bit_operations.patch
18Patch4:         jemalloc-3.6.0.no_explicit_altivec.patch
19
20BuildRequires:  /usr/bin/xsltproc
21%ifnarch s390
22BuildRequires:  valgrind-devel
23%endif
24
25%description
26General-purpose scalable concurrent malloc(3) implementation.
27This distribution is the stand-alone "portable" implementation of %{name}.
28
29%package devel
30Summary:        Development files for %{name}
31Requires:       %{name} = %{version}-%{release}
32Group:          Development/Libraries
33
34%description devel
35The %{name}-devel package contains libraries and header files for
36developing applications that use %{name}.
37
38%prep
39%setup -q
40
41#% patch2 -p1 -b .armv5tel
42%ifarch ppc ppc64
43%if 0%{?rhel} == 5
44%patch3 -b .ppc
45%patch4 -b .ppc
46%endif
47%endif
48
49%build
50%ifarch i686
51%if 0%{?fedora} >= 21
52CFLAGS="%{optflags} -msse2"
53%endif
54%endif
55
56%if 0%{?rhel} && 0%{?rhel} < 7
57export LDFLAGS="%{?__global_ldflags} -lrt"
58%endif
59
60%configure
61make %{?_smp_mflags}
62%check
63make check
64
65
66%install
67rm -rf %{buildroot}
68make install DESTDIR=%{buildroot}
69# Install this with doc macro instead
70rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
71
72# None of these in fedora
73find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
74
75
76%clean
77rm -rf %{buildroot}
78
79
80%files
81%defattr(-,root,root,-)
82%{_libdir}/libjemalloc.so.*
83%{_bindir}/jemalloc.sh
84%{_bindir}/jemalloc-config
85%{_bindir}/jeprof
86%{_libdir}/pkgconfig/jemalloc.pc
87%doc COPYING README VERSION
88%doc doc/jemalloc.html
89%ifarch ppc ppc64
90%if 0%{?rhel} == 5
91%doc COPYING.epel5-ppc
92%endif
93%endif
94
95%files devel
96%defattr(-,root,root,-)
97%{_includedir}/jemalloc
98%{_libdir}/libjemalloc.so
99%{_mandir}/man3/jemalloc.3*
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%changelog
106* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
107- new upstream release.
108
109* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
110- initial build for Vine Linux.
111
112* Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
113- New upstream release
114
115* Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
116- New upstream release
117- Removed oom test patch, it has been fixed upstream
118
119* Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
120- oom test also fails on 32bit ppc, so patch it out there as well
121
122* Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
123- New upstream release
124- Added a patch removing a non-critical test that fails on i386
125- Removed now included negative bitshift patch.
126
127* Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
128- New upstream release
129- Removed the no-pprof patch, as jemalloc now comes with its own prof variant
130- Removed atomic.h patch for armv5tel. jemalloc now provides a specific
131  variant for armv5tel
132- Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
133- Added -lrt to LDFLAGS for rhel<7
134
135* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
137
138* Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
139- valgrind-devel is not available on s390, closes #1131014
140
141* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
143
144* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
145- bz #1106933 fix only for fedora 21 and above
146
147* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
148- Added valgrind-devel to BuildRequires, fixing bz #974270
149
150* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
151- Added an i686 build fixing bz #1106933
152
153* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
155
156* Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
157- Patch that removes explicit altivec on el5/ppc
158
159* Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
160- New upstream release. This release fixes a critical regression
161
162* Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
163- New upstream release
164- Updated nopprof patch to match new release
165- Fixed a few bogus changelog entries
166
167* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
169
170* Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
171- New upstream release
172
173* Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
174- New upstream release
175- Dropped s390 patch, it's in upstream now.
176
177* Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
178- New upstream release
179 
180* Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
181- New upstream release
182 
183* Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
184- New upstream release
185- Removed ptmalloc_lock_all patch, it is merged upstream
186
187* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
189
190* Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
191- Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
192  closing #824646
193
194* Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
195- New upstream release
196- Updated no_pprof patch to match new release
197- Updated s390 patch to match new relase
198- Added make check
199- Added new script jemalloc.sh
200- Added a patch for atomic operations on epel5/ppc
201
202* Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
203- Improve ARM patch
204
205* Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
206- no attomics on armv5tel
207
208* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
209- substitute version information in the header (#788517)
210
211* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
213
214* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
215- New upstream release, closes #75618
216
217* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
218- New upstream release
219
220* Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
221- New upstream release, closes #735057
222
223* Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
224- New upstream release, closes #727103
225- Updated no_pprof patch for 2.2.2
226
227* Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
228- New upstream release
229
230* Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
231- New upstream release
232- Updated no_pprof patch for 2.2.0
233
234* Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
235- New upstream release
236
237* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
239
240* Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
241- New upstream release
242
243* Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
244- New upstream release
245- Updated patch to remove pprof
246- Added html doc and xsltproc as a requirement to build it
247
248* Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
249- fix build on s390
250
251* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
252- Added a patch that removes pprof, as it already exists in the
253  google-perftools package
254- Cosmetic fixes as requested in the package review (rhbz#653682)
255
256* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
257- First cut of an rpm distribution of jemalloc
Note: See TracBrowser for help on using the repository browser.