source: projects/specs/trunk/j/jemalloc/jemalloc-vl.spec @ 10558

Revision 10558, 8.3 KB checked in by tomop, 8 years ago (diff)

jemalloc-4.2.1-1

Line 
1Name:           jemalloc
2Version:        4.2.1
3
4Release:        1%{?_dist_release}
5Summary:        General-purpose scalable concurrent malloc implementation
6Summary(ja):    汎用・スケーラブル・並行な malloc 実装
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://www.canonware.com/jemalloc/
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15Source0:        https://github.com/jemalloc/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18# ARMv5tel has no atomic operations
19Patch2:         jemalloc-armv5-force-atomic.patch
20# RHEL5/POWER has no atomic operations
21Patch3:         jemalloc-3.0.0.atomic_h_ppc_32bit_operations.patch
22Patch4:         jemalloc-3.6.0.no_explicit_altivec.patch
23
24BuildRequires:  /usr/bin/xsltproc
25%ifnarch s390
26BuildRequires:  valgrind-devel
27%endif
28
29%description
30General-purpose scalable concurrent malloc(3) implementation.
31This distribution is the stand-alone "portable" implementation of %{name}.
32
33%package devel
34Summary:        Development files for %{name}
35Requires:       %{name} = %{version}-%{release}
36Group:          Development/Libraries
37
38%description devel
39The %{name}-devel package contains libraries and header files for
40developing applications that use %{name}.
41
42%prep
43%setup -q
44
45#% patch2 -p1 -b .armv5tel
46%ifarch ppc ppc64
47%if 0%{?rhel} == 5
48%patch3 -b .ppc
49%patch4 -b .ppc
50%endif
51%endif
52
53%build
54%ifarch i686
55%if 0%{?fedora} >= 21
56CFLAGS="%{optflags} -msse2"
57%endif
58%endif
59
60%if 0%{?rhel} && 0%{?rhel} < 7
61export LDFLAGS="%{?__global_ldflags} -lrt"
62%endif
63
64%configure
65make %{?_smp_mflags}
66%check
67make check
68
69
70%install
71rm -rf %{buildroot}
72make install DESTDIR=%{buildroot}
73# Install this with doc macro instead
74rm %{buildroot}%{_datadir}/doc/%{name}/jemalloc.html
75
76# None of these in fedora
77find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
78
79
80%clean
81rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%license COPYING
87%doc README VERSION
88%doc doc/jemalloc.html
89%{_libdir}/libjemalloc.so.*
90%{_bindir}/jemalloc.sh
91%{_bindir}/jemalloc-config
92%{_bindir}/jeprof
93%{_libdir}/pkgconfig/jemalloc.pc
94
95%files devel
96%defattr(-,root,root,-)
97%{_includedir}/jemalloc
98%{_libdir}/libjemalloc.so
99%{_mandir}/man3/jemalloc.3*
100
101%post
102/sbin/ldconfig
103
104%postun
105/sbin/ldconfig
106
107%changelog
108* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.2.1-1
109- new upstream release.
110
111* Wed May 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.1.1-1
112- new upstream release.
113
114* Fri Oct 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.0.4-2
115- initial build for Vine Linux.
116
117* Sat Oct 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.4-1
118- New upstream release
119
120* Fri Sep 25 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.3-1
121- New upstream release
122- Removed oom test patch, it has been fixed upstream
123
124* Thu Sep 24 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-2
125- oom test also fails on 32bit ppc, so patch it out there as well
126
127* Tue Sep 22 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.2-1
128- New upstream release
129- Added a patch removing a non-critical test that fails on i386
130- Removed now included negative bitshift patch.
131
132* Wed Aug 19 2015 Ingvar Hagelund <ingvar@redpill-linpro.com> - 4.0.0-1
133- New upstream release
134- Removed the no-pprof patch, as jemalloc now comes with its own prof variant
135- Removed atomic.h patch for armv5tel. jemalloc now provides a specific
136  variant for armv5tel
137- Added a patch from upstream for errnous bitshift by negative amounts on pagesize >8KiB
138- Added -lrt to LDFLAGS for rhel<7
139
140* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-9
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
142
143* Mon Aug 18 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-8
144- valgrind-devel is not available on s390, closes #1131014
145
146* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-7
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
148
149* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-6
150- bz #1106933 fix only for fedora 21 and above
151
152* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-5
153- Added valgrind-devel to BuildRequires, fixing bz #974270
154
155* Fri Aug 15 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-4
156- Added an i686 build fixing bz #1106933
157
158* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.0-3
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
160
161* Tue Apr 01 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-2
162- Patch that removes explicit altivec on el5/ppc
163
164* Mon Mar 31 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.6.0-1
165- New upstream release. This release fixes a critical regression
166
167* Fri Mar 28 2014 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.5.1-1
168- New upstream release
169- Updated nopprof patch to match new release
170- Fixed a few bogus changelog entries
171
172* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.0-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
174
175* Fri Jun 07 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.4.0-1
176- New upstream release
177
178* Mon Mar 11 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.1-1
179- New upstream release
180- Dropped s390 patch, it's in upstream now.
181
182* Fri Jan 25 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.3.0-1
183- New upstream release
184 
185* Mon Nov 19 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.2.0-1
186- New upstream release
187 
188* Tue Oct 23 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.1.0-1
189- New upstream release
190- Removed ptmalloc_lock_all patch, it is merged upstream
191
192* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-3
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
194
195* Thu May 24 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-2
196- Added a patch from upstream, fixing a crash in ptmalloc_lock_all,
197  closing #824646
198
199* Mon May 14 2012 Ingvar Hagelund <ingvar@redpill-linpro.com> - 3.0.0-1
200- New upstream release
201- Updated no_pprof patch to match new release
202- Updated s390 patch to match new relase
203- Added make check
204- Added new script jemalloc.sh
205- Added a patch for atomic operations on epel5/ppc
206
207* Sat Apr 21 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.2.5-5
208- Improve ARM patch
209
210* Fri Apr 20 2012 Dennis Gilmore <dennis@ausil.us> - 2.2.5-4
211- no attomics on armv5tel
212
213* Wed Feb 08 2012 Dan Horák <dan[at]danny.cz> - 2.2.5-3
214- substitute version information in the header (#788517)
215
216* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-2
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
218
219* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.5-1
220- New upstream release, closes #75618
221
222* Sun Nov 06 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.4-1
223- New upstream release
224
225* Thu Oct 13 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.3-1
226- New upstream release, closes #735057
227
228* Mon Aug 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.2-1
229- New upstream release, closes #727103
230- Updated no_pprof patch for 2.2.2
231
232* Thu Mar 31 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.1-1
233- New upstream release
234
235* Sun Mar 27 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.2.0-1
236- New upstream release
237- Updated no_pprof patch for 2.2.0
238
239* Tue Mar 15 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.3-2
240- New upstream release
241
242* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
244
245* Tue Feb 01 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.1-1
246- New upstream release
247
248* Wed Jan 05 2011 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.1.0-1
249- New upstream release
250- Updated patch to remove pprof
251- Added html doc and xsltproc as a requirement to build it
252
253* Sat Dec 11 2010 Dan Horák <dan[at]danny.cz> - 2.0.1-3
254- fix build on s390
255
256* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
257- Added a patch that removes pprof, as it already exists in the
258  google-perftools package
259- Cosmetic fixes as requested in the package review (rhbz#653682)
260
261* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
262- First cut of an rpm distribution of jemalloc
Note: See TracBrowser for help on using the repository browser.