source: projects/specs/trunk/j/jasper/jasper-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:        jasper
4Version:     1.900.1
5Release:     7%{?_dist_release}
6Summary:     implementation of the JPEG-2000 standard, Part 1
7URL:         http://www.ece.uvic.ca/~mdadams/jasper/
8License:     Modified BSD (see LICENSE)
9Group:       System Environment/Libraries
10Source:      %{name}-%{version}.zip
11# Security fixes
12Patch100:    jasper-1.900.1_CVE-2007-2721.patch
13
14BuildRoot:   %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libjpeg-devel unzip
16BuildRequires: freeglut-devel
17Requires:    %{name}-libs = %{version}-%{release}
18
19
20Vendor:       Project Vine
21Distribution: Vine Linux
22
23%description
24JasPer is a collection of software (i.e., a library and application
25programs) for the coding and manipulation of images.  This software
26can handle image data in a variety of formats.  One such format
27supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
28
29%package devel
30Summary:     Include Files and Documentation for jasper
31Group:       Development/Libraries
32Requires:    %{name}-libs = %{version}-%{release}
33Requires:    libjpeg-devel
34
35%description devel
36This package contains libjasper, a library implementing the JPEG-2000
37image compression standard Part 1.
38
39%package libs
40Summary: Runtime libraries for %{name}
41Group:   System Environment/Libraries
42
43%description libs
44This package contains runtime libraries for JasPer.
45
46# compat32
47%package -n compat32-%{name}-devel
48Summary:     Include Files and Documentation for jasper
49Group:       Development/Libraries
50Requires:    %{name}-libs = %{version}-%{release}
51Requires:    compat32-libjpeg-devel
52
53%description -n compat32-%{name}-devel
54This package contains libjasper, a library implementing the JPEG-2000
55image compression standard Part 1.
56
57%package -n compat32-%{name}-libs
58Summary: Runtime libraries for %{name}
59Group:   System Environment/Libraries
60
61%description -n compat32-%{name}-libs
62This package contains runtime libraries for JasPer.
63
64
65%prep
66%setup -T -c %{name}-%{version}
67cd ..
68unzip %{SOURCE0}
69cd %{name}-%{version}
70
71# security fixes
72%patch100 -p1 -b .CVE-2007-2721
73
74%build
75./configure --prefix=%{_prefix} --libdir=%{_libdir} --mandir=%{_mandir} \
76            --enable-shared --disable-static
77make
78
79%install
80[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
81make install DESTDIR=$RPM_BUILD_ROOT
82
83# remove .la
84rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
85
86%clean
87[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
88
89%post libs -p /sbin/ldconfig
90
91%postun libs -p /sbin/ldconfig
92
93%post -n compat32-%{name}-libs -p /sbin/ldconfig
94
95%postun -n compat32-%{name}-libs -p /sbin/ldconfig
96
97%files
98%defattr(-,root,root)
99%doc COPYRIGHT ChangeLog INSTALL LICENSE NEWS README doc
100%{_bindir}/*
101%{_mandir}/man1/*
102
103%files libs
104%defattr(-,root,root)
105%{_libdir}/libjasper*.so.*
106
107%files devel
108%defattr(-,root,root)
109%{_includedir}/jasper
110%{_libdir}/libjasper*.so
111
112# compat32
113%if %{build_compat32}
114%files -n compat32-%{name}-libs
115%defattr(-,root,root)
116%{_libdir}/libjasper*.so.*
117
118%files -n compat32-%{name}-devel
119%defattr(-,root,root)
120%{_libdir}/libjasper*.so
121%endif
122
123%changelog
124* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
125- added compat32 subpackage for x86_64 arch support.
126
127* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
128- splited out runtime library to sub package
129- enable opengl again, add BuildRequires: freeglut-devel
130
131* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
132- remove .la
133- add --disable-static to configure option
134
135* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
136- added Patch0 from VinePlus/4.0
137  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
138  - add patch100 for fix CVE-2007-2721
139  - add Vendor/Distributin Tag
140
141* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
142- remove BuildPrereq: freeglut-devel and Requires freeglut
143- add --disable-opengl to configure option
144
145* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
146- add BuildPreReq: unzip (used in the %%pre section)
147
148* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
149- new upstream release
150
151* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
152- new upstream release
153- changed Group to System Environment/Libraries
154- added --mandir=%{_mandir}
155- added %post and %postun section
156
157* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
158- added --libdir=%{_libdir} configure option
159
160* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
161- build with freeglut
162- change BuildPrereq and Requires
163
164* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
165- new upstream version (jasper-1.701.0)
166
167* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
168- rebuild for VineSeedPlus
169
170* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
171- source upgrade
172- change spec to build for VineLinux
173
174* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
175- spec file created
Note: See TracBrowser for help on using the repository browser.