source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 5738

Revision 5738, 8.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python: add configure option
others: new upstream release

Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 0.121.3
4Release: 1%{?_dist_release}
5License: GPLv2 and LGPLv2
6Group: System Environment/Daemons
7Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
8URL: http://www.jackaudio.org
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires: alsa-lib-devel
12BuildRequires: libsndfile-devel >= 1.0.0
13BuildRequires: pkgconfig
14BuildRequires: doxygen
15BuildRequires: readline-devel, ncurses-devel
16BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
17BuildRequires: libfreebob-devel >= 1.0.0
18BuildRequires: libsamplerate-devel
19BuildRequires: celt-devel
20
21%define groupname jackuser
22
23Requires(pre): shadow-utils
24Requires(post): /sbin/ldconfig
25
26%description
27JACK is a low-latency audio server, written primarily for the Linux
28operating system. It can connect a number of different applications to
29an audio device, as well as allowing them to share audio between
30themselves. Its clients can run in their own processes (ie. as a
31normal application), or can they can run within a JACK server (ie. a
32"plugin").
33
34JACK is different from other audio server efforts in that it has been
35designed from the ground up to be suitable for professional audio
36work. This means that it focuses on two key areas: synchronous
37execution of all clients, and low latency operation.
38
39%package devel
40Summary: Development files for %{name}
41Summary(ja): %{name} の開発用ファイル
42Group: Development/Libraries
43Requires: %{name} = %{version}
44Requires: pkgconfig
45
46%description devel
47Development files for the Jack Audio Connection Kit.
48
49%package example-clients
50Summary: Example clients that use Jack
51Summary(ja): %{name} を利用したサンプルプログラム
52Group: Applications/Multimedia
53Requires: %{name} = %{version}
54
55%description example-clients
56Small example clients that use the Jack Audio Connection Kit.
57
58%prep
59%setup -q
60
61%build
62# x86_64 issue reported by Rudolf Kastl (not checked, but not bad).
63autoreconf --force --install
64
65%configure \
66    --with-html-dir=%{_docdir} \
67    --enable-freebob \
68    --disable-oss \
69    --disable-portaudio \
70    --with-default-tmpdir=/dev/shm
71make %{?_smp_mflags}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76# can't use the makeinstall macro, jack needs DESTDIR and prefix gets
77# added to it and messes up part of the install
78make install DESTDIR=$RPM_BUILD_ROOT
79
80# remove extra install of the documentation
81rm -fr $RPM_BUILD_ROOT%{_docdir}
82
83# remove *.la files
84rm -f $RPM_BUILD_ROOT%{_libdir}/jack/*.la
85rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
86
87# Fix timestamps to avoid multiarch conflicts
88find doc/reference -type f | xargs touch -r doc/reference.doxygen.in
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%pre
94getent group %groupname > /dev/null || groupadd -r %groupname
95exit 0
96
97%post
98/sbin/ldconfig
99
100# Add default limits for jackuser group
101grep -q %groupname /etc/security/limits.conf > /dev/null 2>&1 || cat >> /etc/security/limits.conf << EOF
102
103## Automatically appended by jack-audio-connection-kit
104@%groupname - rtprio 20
105@%groupname - memlock 4194304
106EOF
107
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root)
112%doc AUTHORS TODO COPYING*
113%{_bindir}/jackd
114%{_bindir}/jack_load
115%{_bindir}/jack_unload
116%{_bindir}/jack_freewheel
117%{_libdir}/jack/
118%{_mandir}/man1/jack*.1*
119%{_libdir}/libjack.so.*
120%{_libdir}/libjackserver.so.*
121
122%files devel
123%defattr(-,root,root)
124%doc doc/reference
125%{_includedir}/jack/
126%{_libdir}/libjack.so
127%{_libdir}/libjackserver.so
128%{_libdir}/pkgconfig/jack.pc
129
130%files example-clients
131%defattr(-,root,root)
132%{_bindir}/jack_alias
133%{_bindir}/jack_bufsize
134%{_bindir}/jack_connect
135%{_bindir}/jack_disconnect
136%{_bindir}/jack_evmon
137%{_bindir}/jack_impulse_grabber
138%{_bindir}/jack_iodelay
139%{_bindir}/jack_latent_client
140%{_bindir}/jack_load_test
141%{_bindir}/jack_lsp
142%{_bindir}/jack_metro
143%{_bindir}/jack_midiseq
144%{_bindir}/jack_midisine
145%{_bindir}/jack_midi_dump
146%{_bindir}/jack_monitor_client
147%{_bindir}/jack_netsource
148%{_bindir}/jack_rec
149%{_bindir}/jack_samplerate
150%{_bindir}/jack_server_control
151%{_bindir}/jack_session_notify
152%{_bindir}/jack_showtime
153%{_bindir}/jack_simple_client
154%{_bindir}/jack_simple_session_client
155%{_bindir}/jack_transport
156%{_bindir}/jack_transport_client
157%{_bindir}/jack_wait
158%{_bindir}/alsa_in
159%{_bindir}/alsa_out
160
161%changelog
162* Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
163- update to 0.121.3
164- add BuildRequires: celt-devel
165
166* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
167- rebuild with rpm-4.8.1 for pkg-config file
168- add BuildRequires: libsamplerate-devel
169
170* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
171- new upstream release
172
173* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
174- new upstream release
175- rebuild with ncurses-devel
176
177* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
178- initial build for Vine Linux
179
180* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
181- update to the last official release
182
183* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
184- update to the last official release (#429162)
185- shut up the postinstall script (#359291)
186
187* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
188- fix timestamps to avoid multiarch conflicts (#341621)
189
190* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
191- fix Source Forge's URL scheme
192
193* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
194- fix according to new guidelines:
195  - License tag
196  - group creation
197
198* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
199- update to the last official release
200- append defaults to the limits.conf (#221785, #235624)
201
202* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
203- drop libtermcap-devel build requirement (#231203)
204- create special jackuser group (#221785)
205
206* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
207- fix BuildRequires: libfreebob -> libfreebob-devel
208
209* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
210- rebuild with libfreebob (should closed #211751)
211
212* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
213- update to 0.102.20
214- drop patch0 (already in mainstream)
215- no pack jack_transport (build error)
216- pack new JACK MIDI files
217
218* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
219- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
220
221* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
222- use install instead of cp (#200835)
223
224* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
225- update URL
226- add BR: libtool
227
228* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
229- add BRs: autoconf, automake
230  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
231
232* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
233- remove --enable-stripped-jackd and --enable-optimize (use default flags)
234
235* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
236- uniform directories items at %files section
237
238* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
239- change License tag to GPL/LGPL
240- remove --enable-shared (it should be default)
241- add a -p flag to the line that copies README.Fedora
242
243* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
244- apply clock fix for AMD X2 CPUs (please, refer to
245  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
246
247* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
248- adjust spec after reviewing
249
250* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
251- reformatting README.Fedora to 72 symbols width
252
253* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
254- add README.Fedora
255- remove useless BRs
256
257* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
258- disable oss and portaudio engines
259- use /dev/shm as jack tmpdir
260- remove capabilities stuff
261
262* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
263- update to 0.101.1
264
265* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
266- update to 0.100.7 (#183912)
267- adjust BR (add versions)
268- replace files between examples and main packages
269- own jack tmpdir
270
271* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
272- no libs subpackage
273- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
274  - added configuration variable to build with/without capabilities
275  - added --enable-optimize flag to configure script
276  - disabled sse/mmx instructions in i386 build
277  - create temporary directory as /var/lib/jack/tmp
278  - create and erase tmp directory at install or uninstall
279  - try to umount the temporary directory before uninstalling the package
280
281* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
282- fix spec for extras injection
283
284* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
285- exclude *.la files
286- use dist tag
287
288* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
289- 0.100.0
290- no optimization
291
292* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
293- 0.99.1
294
295* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
296- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.