source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 521

Revision 521, 8.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 0.116.1
4Release: 1%{?_dist_release}
5License: GPLv2 and LGPLv2
6Group: System Environment/Daemons
7Source0: http://downloads.sourceforge.net/jackit/%{name}-%{version}.tar.gz
8URL: http://www.jackaudio.org
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires: alsa-lib-devel
12BuildRequires: libsndfile-devel >= 1.0.0
13BuildRequires: pkgconfig
14BuildRequires: doxygen
15BuildRequires: readline-devel, ncurses-devel
16BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
17BuildRequires: libfreebob-devel >= 1.0.0
18
19%define groupname jackuser
20
21Requires(pre): shadow-utils
22Requires(post): /sbin/ldconfig
23
24%description
25JACK is a low-latency audio server, written primarily for the Linux
26operating system. It can connect a number of different applications to
27an audio device, as well as allowing them to share audio between
28themselves. Its clients can run in their own processes (ie. as a
29normal application), or can they can run within a JACK server (ie. a
30"plugin").
31
32JACK is different from other audio server efforts in that it has been
33designed from the ground up to be suitable for professional audio
34work. This means that it focuses on two key areas: synchronous
35execution of all clients, and low latency operation.
36
37%package devel
38Summary: Development files for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group: Development/Libraries
41Requires: %{name} = %{version}
42Requires: pkgconfig
43
44%description devel
45Development files for the Jack Audio Connection Kit.
46
47%package example-clients
48Summary: Example clients that use Jack
49Summary(ja): %{name} を利用したサンプルプログラム
50Group: Applications/Multimedia
51Requires: %{name} = %{version}
52
53%description example-clients
54Small example clients that use the Jack Audio Connection Kit.
55
56%prep
57%setup -q
58
59%build
60# x86_64 issue reported by Rudolf Kastl (not checked, but not bad).
61autoreconf --force --install
62
63%configure \
64    --with-html-dir=%{_docdir} \
65    --enable-freebob \
66    --disable-oss \
67    --disable-portaudio \
68    --with-default-tmpdir=/dev/shm
69make %{?_smp_mflags}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74# can't use the makeinstall macro, jack needs DESTDIR and prefix gets
75# added to it and messes up part of the install
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# remove extra install of the documentation
79rm -fr $RPM_BUILD_ROOT%{_docdir}
80
81# remove *.la files
82rm -f $RPM_BUILD_ROOT%{_libdir}/jack/*.la
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84
85# Fix timestamps to avoid multiarch conflicts
86find doc/reference -type f | xargs touch -r doc/reference.doxygen.in
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%pre
92getent group %groupname > /dev/null || groupadd -r %groupname
93exit 0
94
95%post
96/sbin/ldconfig
97
98# Add default limits for jackuser group
99grep -q %groupname /etc/security/limits.conf > /dev/null 2>&1 || cat >> /etc/security/limits.conf << EOF
100
101## Automatically appended by jack-audio-connection-kit
102@%groupname - rtprio 20
103@%groupname - memlock 4194304
104EOF
105
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root)
110%doc AUTHORS TODO COPYING*
111%{_bindir}/jackd
112%{_bindir}/jack_load
113%{_bindir}/jack_unload
114%{_bindir}/jack_freewheel
115%{_libdir}/jack/
116%{_mandir}/man1/jack*.1*
117%{_libdir}/libjack.so.*
118%{_libdir}/libjackserver.so.*
119
120%files devel
121%defattr(-,root,root)
122%doc doc/reference
123%{_includedir}/jack/
124%{_libdir}/libjack.so
125%{_libdir}/libjackserver.so
126%{_libdir}/pkgconfig/jack.pc
127
128%files example-clients
129%defattr(-,root,root)
130%{_bindir}/jackrec
131%{_bindir}/jack_alias
132%{_bindir}/jack_connect
133%{_bindir}/jack_disconnect
134%{_bindir}/jack_evmon
135%{_bindir}/jack_impulse_grabber
136%{_bindir}/jack_lsp
137%{_bindir}/jack_metro
138%{_bindir}/jack_showtime
139%{_bindir}/jack_transport
140%{_bindir}/jack_monitor_client
141%{_bindir}/jack_simple_client
142%{_bindir}/jack_midiseq
143%{_bindir}/jack_midisine
144%{_bindir}/jack_netsource
145%{_bindir}/jack_transport_client
146%{_bindir}/alsa_in
147%{_bindir}/alsa_out
148
149%changelog
150* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
151- new upstream release
152- rebuild with ncurses-devel
153
154* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
155- initial build for Vine Linux
156
157* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
158- update to the last official release
159
160* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
161- update to the last official release (#429162)
162- shut up the postinstall script (#359291)
163
164* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
165- fix timestamps to avoid multiarch conflicts (#341621)
166
167* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
168- fix Source Forge's URL scheme
169
170* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
171- fix according to new guidelines:
172  - License tag
173  - group creation
174
175* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
176- update to the last official release
177- append defaults to the limits.conf (#221785, #235624)
178
179* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
180- drop libtermcap-devel build requirement (#231203)
181- create special jackuser group (#221785)
182
183* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
184- fix BuildRequires: libfreebob -> libfreebob-devel
185
186* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
187- rebuild with libfreebob (should closed #211751)
188
189* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
190- update to 0.102.20
191- drop patch0 (already in mainstream)
192- no pack jack_transport (build error)
193- pack new JACK MIDI files
194
195* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
196- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
197
198* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
199- use install instead of cp (#200835)
200
201* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
202- update URL
203- add BR: libtool
204
205* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
206- add BRs: autoconf, automake
207  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
208
209* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
210- remove --enable-stripped-jackd and --enable-optimize (use default flags)
211
212* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
213- uniform directories items at %files section
214
215* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
216- change License tag to GPL/LGPL
217- remove --enable-shared (it should be default)
218- add a -p flag to the line that copies README.Fedora
219
220* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
221- apply clock fix for AMD X2 CPUs (please, refer to
222  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
223
224* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
225- adjust spec after reviewing
226
227* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
228- reformatting README.Fedora to 72 symbols width
229
230* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
231- add README.Fedora
232- remove useless BRs
233
234* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
235- disable oss and portaudio engines
236- use /dev/shm as jack tmpdir
237- remove capabilities stuff
238
239* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
240- update to 0.101.1
241
242* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
243- update to 0.100.7 (#183912)
244- adjust BR (add versions)
245- replace files between examples and main packages
246- own jack tmpdir
247
248* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
249- no libs subpackage
250- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
251  - added configuration variable to build with/without capabilities
252  - added --enable-optimize flag to configure script
253  - disabled sse/mmx instructions in i386 build
254  - create temporary directory as /var/lib/jack/tmp
255  - create and erase tmp directory at install or uninstall
256  - try to umount the temporary directory before uninstalling the package
257
258* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
259- fix spec for extras injection
260
261* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
262- exclude *.la files
263- use dist tag
264
265* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
266- 0.100.0
267- no optimization
268
269* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
270- 0.99.1
271
272* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
273- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.