source: projects/specs/trunk/j/jack-audio-connection-kit/jack-audio-connection-kit-vl.spec @ 9482

Revision 9482, 12.1 KB checked in by inagaki, 9 years ago (diff)

2015-04-02 Ryoichi INAGAKI <ryo1@…>

  • gnuchess, gphoto, parted, xfsprogs: rebuilt
  • jack-audio-connection-kit: updated


Line 
1Summary: The Jack Audio Connection Kit
2Name: jack-audio-connection-kit
3Version: 1.9.10
4Release: 1%{?_dist_release}
5# The entire source (~500 files) is a mixture of these three licenses
6License: GPLv2 and GPLv2+ and LGPLv2+
7Group: System Environment/Daemons
8URL: http://www.jackaudio.org
9
10#Source0: http://www.jackaudio.org/downloads/%{name}-%{version}.tar.gz
11Source0: https://dl.dropbox.com/u/28869550/jack-%{version}.tar.bz2
12Source1: %{name}-README.Fedora
13Source2: %{name}-script.pa
14Source3: %{name}-limits.conf
15
16# No-date-footer hack to remove dates from doxygen documentation
17Patch0:        jack-audio-connection-kit-no_date_footer.patch
18# Build fix
19Patch1:        jack-doxygen-output-dir-fix.patch
20# We don't want the internal API documentation
21Patch2:        jack-apidoc-only.patch
22# Adjust default priority. RHBZ#795094
23Patch3:        jack-realtime-compat.patch
24# Enable renaming and reordering the jack ports RHBZ#887408
25Patch4:        jack-portnames.patch
26# Fix ppc64 mpd startup issue RHBZ#799552
27Patch5:        jack-ppc64-long.patch
28#Patch0:        jack-audio-connection-kit-0.124.1-freebob_driver.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: alsa-lib-devel
32BuildRequires: celt-devel
33BuildRequires: dbus-devel
34BuildRequires: doxygen
35BuildRequires: expat-devel
36BuildRequires: libfreebob-devel >= 1.0.0
37BuildRequires: libsamplerate-devel
38BuildRequires: libsndfile-devel >= 1.0.0
39BuildRequires: ncurses-devel
40BuildRequires: pkgconfig
41BuildRequires: python
42BuildRequires: readline-devel
43#BuildRequires: autoconf >= 2.59, automake >= 1.9.3, libtool
44#BuildRequires: libdb-devel
45#BuildRequires: libuuid-devel
46
47%global groupname jackuser
48%global pagroup   pulse-rt
49
50Requires(pre): shadow-utils
51Requires(post): /sbin/ldconfig
52
53%description
54JACK is a low-latency audio server, written primarily for the Linux
55operating system. It can connect a number of different applications to
56an audio device, as well as allowing them to share audio between
57themselves. Its clients can run in their own processes (ie. as a
58normal application), or can they can run within a JACK server (ie. a
59"plugin").
60
61JACK is different from other audio server efforts in that it has been
62designed from the ground up to be suitable for professional audio
63work. This means that it focuses on two key areas: synchronous
64execution of all clients, and low latency operation.
65
66%package dbus
67Summary:        Jack D-Bus launcher
68Group:          Applications/Multimedia
69Requires:       %{name} = %{version}-%{release}
70
71%description dbus
72Launcher to start Jack through D-Bus.
73
74
75%package devel
76Summary:        Development files for %{name}
77Summary(ja):    %{name} の開発用ファイル
78Group:          Development/Libraries
79Requires:       %{name} = %{version}-%{release}
80Requires:       pkgconfig
81
82%description devel
83Development files for the Jack Audio Connection Kit.
84
85%package example-clients
86Summary:        Example clients that use Jack
87Summary(ja):    %{name} を利用したサンプルプログラム
88Group:          Applications/Multimedia
89Requires:       %{name} = %{version}-%{release}
90
91%description example-clients
92Small example clients that use the Jack Audio Connection Kit.
93
94%prep
95%setup -q -n jack-%{version}
96%patch0 -p1 -b .nodate
97%patch1 -p1 -b .outdir
98%patch2 -p1 -b .nointernalapi
99%patch3 -p1 -b .priority
100%patch4 -p1 -b .portnames
101%patch5 -p1 -b .mpd
102
103# Fix encoding issues
104for file in ChangeLog README TODO; do
105    sed 's|\r||' $file > $file.tmp
106    iconv -f ISO-8859-1 -t UTF8 $file.tmp > $file.tmp2
107    touch -r $file $file.tmp2
108    mv -f $file.tmp2 $file
109done
110
111%build
112export CPPFLAGS="$RPM_OPT_FLAGS -O0"
113export PREFIX=%{_prefix}
114# Parallel build disabled as it fails sometimes
115./waf configure \
116      %{?_smp_mflags} \
117      --mandir=%{_mandir}/man1 \
118      --libdir=%{_libdir} \
119      --alsa \
120      --classic \
121      --clients 256 \
122      --dbus \
123      --doxygen \
124      --freebob \
125      --ports-per-application=2048
126
127./waf build %{?_smp_mflags} -v
128
129%install
130rm -rf $RPM_BUILD_ROOT
131./waf --destdir=$RPM_BUILD_ROOT install
132
133# move doxygen documentation to the right place
134mv $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit/reference .
135rm -rf $RPM_BUILD_ROOT%{_datadir}/jack-audio-connection-kit
136
137# install our limits to the /etc/security/limits.d
138mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d
139sed -e 's,@groupname@,%groupname,g; s,@pagroup@,%pagroup,g;' \
140    %{SOURCE3} > $RPM_BUILD_ROOT%{_sysconfdir}/security/limits.d/95-jack.conf
141
142# prepare README.Fedora for documentation including
143install -p -m644 %{SOURCE1} README.Fedora
144
145# install pulseaudio script for jack (as documentation part)
146install -p -m644 %{SOURCE2} jack.pa
147
148# For compatibility with jack1
149mv $RPM_BUILD_ROOT%{_bindir}/jack_rec $RPM_BUILD_ROOT%{_bindir}/jackrec
150
151# Fix permissions of the modules
152chmod 755 $RPM_BUILD_ROOT%{_libdir}/jack/*.so $RPM_BUILD_ROOT%{_libdir}/libjack*.so.*.*.*
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%pre
158getent group %groupname > /dev/null || groupadd -r %groupname
159exit 0
160
161%post -p /sbin/ldconfig
162
163%postun -p /sbin/ldconfig
164
165%files
166%defattr(-,root,root)
167%doc ChangeLog README README_NETJACK2 TODO
168%doc README.Fedora
169%doc jack.pa
170%config(noreplace) %{_sysconfdir}/security/limits.d/*.conf
171%{_bindir}/jackd
172%{_bindir}/jackrec
173%{_libdir}/jack/
174%{_libdir}/libjack.so.*
175%{_libdir}/libjacknet.so.*
176%{_libdir}/libjackserver.so.*
177%{_mandir}/man1/jackrec.1*
178%{_mandir}/man1/jackd*.1*
179
180%files dbus
181%defattr(-,root,root)
182%{_bindir}/jackdbus
183%{_datadir}/dbus-1/services/org.jackaudio.service
184%{_bindir}/jack_control
185
186%files devel
187%defattr(-,root,root)
188%doc reference/html/
189%{_includedir}/jack/
190%{_libdir}/libjack.so
191%{_libdir}/libjacknet.so
192%{_libdir}/libjackserver.so
193%{_libdir}/pkgconfig/jack.pc
194
195%files example-clients
196%defattr(-,root,root)
197%{_bindir}/alsa_in
198%{_bindir}/alsa_out
199%{_bindir}/jack_alias
200%{_bindir}/jack_bufsize
201%{_bindir}/jack_connect
202%{_bindir}/jack_disconnect
203%{_bindir}/jack_cpu_load
204%{_bindir}/jack_evmon
205%{_bindir}/jack_freewheel
206# These are not ready yet
207#{_bindir}/jack_impulse_grabber
208%exclude %{_mandir}/man1/jack_impulse_grabber.1*
209%{_bindir}/jack_latent_client
210%{_bindir}/jack_load
211%{_bindir}/jack_unload
212%{_bindir}/jack_lsp
213%{_bindir}/jack_metro
214%{_bindir}/jack_midi_dump
215%{_bindir}/jack_midi_latency_test
216%{_bindir}/jack_midiseq
217%{_bindir}/jack_midisine
218%{_bindir}/jack_monitor_client
219%{_bindir}/jack_net_master
220%{_bindir}/jack_net_slave
221%{_bindir}/jack_netsource
222%{_bindir}/jack_samplerate
223%{_bindir}/jack_server_control
224%{_bindir}/jack_session_notify
225%{_bindir}/jack_showtime
226%{_bindir}/jack_simple_client
227%{_bindir}/jack_simple_session_client
228%{_bindir}/jack_thru
229%{_bindir}/jack_transport
230%{_bindir}/jack_wait
231%{_bindir}/jack_zombie
232%{_mandir}/man1/alsa_*.1*
233%{_mandir}/man1/jack_bufsize.1*
234%{_mandir}/man1/jack_connect.1*
235%{_mandir}/man1/jack_disconnect.1*
236%{_mandir}/man1/jack_freewheel*.1*
237%{_mandir}/man1/jack_load*.1*
238%{_mandir}/man1/jack_unload*.1*
239%{_mandir}/man1/jack_lsp.1*
240%{_mandir}/man1/jack_metro.1*
241%{_mandir}/man1/jack_monitor_client.1*
242%{_mandir}/man1/jack_netsource.1*
243%{_mandir}/man1/jack_samplerate.1*
244%{_mandir}/man1/jack_showtime.1*
245%{_mandir}/man1/jack_simple_client.1*
246%{_mandir}/man1/jack_transport.1*
247%{_mandir}/man1/jack_wait.1*
248
249# tests
250%{_bindir}/jack_cpu
251%{_bindir}/jack_iodelay
252%{_bindir}/jack_multiple_metro
253%{_bindir}/jack_test
254%{_mandir}/man1/jack_iodelay.1*
255
256
257%changelog
258* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.9.10-1
259- updated to 1.9.10
260- built with readline 6.3
261- added dbus subpackage
262
263* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.124.1
264- update to 0.124.1
265- add BuildRequires: libdb-devel, libuuid-devel
266- add Patch0 (jack-audio-connection-kit-0.124.1-freebob_driver.patch)
267
268* Wed Feb 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.121.3
269- update to 0.121.3
270- add BuildRequires: celt-devel
271
272* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.118.0-2
273- rebuild with rpm-4.8.1 for pkg-config file
274- add BuildRequires: libsamplerate-devel
275
276* Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.118.0-1
277- new upstream release
278
279* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.116.1-1
280- new upstream release
281- rebuild with ncurses-devel
282
283* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.109.2-1
284- initial build for Vine Linux
285
286* Wed Feb 13 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.2-1.1
287- update to the last official release
288
289* Mon Jan 21 2008 Andy Shevchenko <andy@smile.org.ua> 0.109.0-1
290- update to the last official release (#429162)
291- shut up the postinstall script (#359291)
292
293* Sat Oct 20 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-5
294- fix timestamps to avoid multiarch conflicts (#341621)
295
296* Tue Sep 04 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-4
297- fix Source Forge's URL scheme
298
299* Thu Aug 16 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-3
300- fix according to new guidelines:
301  - License tag
302  - group creation
303
304* Wed May 23 2007 Andy Shevchenko <andy@smile.org.ua> 0.103.0-1
305- update to the last official release
306- append defaults to the limits.conf (#221785, #235624)
307
308* Wed Mar 07 2007 Andy Shevchenko <andy@smile.org.ua> 0.102.20-4
309- drop libtermcap-devel build requirement (#231203)
310- create special jackuser group (#221785)
311
312* Sat Oct 28 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-3
313- fix BuildRequires: libfreebob -> libfreebob-devel
314
315* Tue Oct 24 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.1
316- rebuild with libfreebob (should closed #211751)
317
318* Wed Oct 11 2006 Andy Shevchenko <andy@smile.org.ua> 0.102.20-2.0
319- update to 0.102.20
320- drop patch0 (already in mainstream)
321- no pack jack_transport (build error)
322- pack new JACK MIDI files
323
324* Tue Aug 29 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-13
325- http://fedoraproject.org/wiki/Extras/Schedule/FC6MassRebuild
326
327* Tue Aug 01 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-12
328- use install instead of cp (#200835)
329
330* Tue Jul 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-11
331- update URL
332- add BR: libtool
333
334* Tue Jun 20 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-10
335- add BRs: autoconf, automake
336  (http://fedoraproject.org/wiki/QA/FixBuildRequires)
337
338* Sat May 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-9
339- remove --enable-stripped-jackd and --enable-optimize (use default flags)
340
341* Fri May 19 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-8
342- uniform directories items at %files section
343
344* Wed May 17 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-7
345- change License tag to GPL/LGPL
346- remove --enable-shared (it should be default)
347- add a -p flag to the line that copies README.Fedora
348
349* Wed May 10 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-6
350- apply clock fix for AMD X2 CPUs (please, refer to
351  http://sourceforge.net/mailarchive/forum.php?thread_id=8085535&forum_id=3040)
352
353* Wed May 03 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-5
354- adjust spec after reviewing
355
356* Thu Apr 27 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-4
357- reformatting README.Fedora to 72 symbols width
358
359* Wed Apr 26 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-3
360- add README.Fedora
361- remove useless BRs
362
363* Mon Apr 24 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-2
364- disable oss and portaudio engines
365- use /dev/shm as jack tmpdir
366- remove capabilities stuff
367
368* Tue Apr 04 2006 Andy Shevchenko <andriy@asplinux.com.ua> 0.101.1-1
369- update to 0.101.1
370
371* Mon Mar 27 2006 Andy Shevchenko <andriy@asplinux.com.ua>
372- update to 0.100.7 (#183912)
373- adjust BR (add versions)
374- replace files between examples and main packages
375- own jack tmpdir
376
377* Fri Mar 17 2006 Andy Shevchenko <andriy@asplinux.com.ua>
378- no libs subpackage
379- From Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>:
380  - added configuration variable to build with/without capabilities
381  - added --enable-optimize flag to configure script
382  - disabled sse/mmx instructions in i386 build
383  - create temporary directory as /var/lib/jack/tmp
384  - create and erase tmp directory at install or uninstall
385  - try to umount the temporary directory before uninstalling the package
386
387* Fri Mar 03 2006 Andy Shevchenko <andriy@asplinux.com.ua>
388- fix spec for extras injection
389
390* Fri Nov 18 2005 Andy Shevchenko <andriy@asplinux.ru>
391- exclude *.la files
392- use dist tag
393
394* Fri Oct 14 2005 Andy Shevchenko <andriy@asplinux.ru>
395- 0.100.0
396- no optimization
397
398* Tue Sep 28 2004 Andy Shevchenko <andriy@asplinux.ru>
399- 0.99.1
400
401* Fri Aug 20 2004 Andy Shevchenko <andriy@asplinux.ru>
402- rebuild from Mandrake
Note: See TracBrowser for help on using the repository browser.