source: projects/specs/trunk/i/isight-firmware-tools/isight-firmware-tools-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# use udev feature until things go right...
2%define with_hal        0
3
4Summary:        Firmware extraction tools for Apple Built-in iSight camera
5Summary(ja):    Apple 内蔵 iSight カメラ用ファームウェア抽出プログラム
6Name:           isight-firmware-tools
7Version:        1.4.1
8Release:        1%{?_dist_release}
9License:        GPLv2+
10Group:          System Environment/Base
11URL:            http://bersace03.free.fr/ift/
12Source0:        %{name}-%{version}.tar.gz
13Source10:       %{name}-1.2_ja.po
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}
16
17%if %{with_hal}
18Requires:       hal
19%else
20Requires:       udev
21%endif
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25BuildRequires:  gettext
26BuildRequires:  glib2-devel
27BuildRequires:  libgcrypt-devel
28BuildRequires:  libusb-devel
29%if %{with_hal}
30BuildRequires:  hal-devel
31%else
32BuildRequires:  udev
33%endif
34BuildRequires:  perl(XML::Parser)
35
36
37%description
38iSight Firmware Tools provide tools to manipulate firmware for Built-in iSight
39cameras found on Apple machines since iMac G5 (November 2005).
40
41Before using Built-in iSight on Linux, you will need to extract the
42firmware to /lib/firmware/isight.fw as:
43
44    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
45
46AppleUSBVideoSupport driver file should be located in
47
48    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
49
50on your Mac OS X root partition.
51
52
53%description -l ja
54iSight Firmware Tools を使って、2005年11月発売の iMac G5 以降の
55Apple 社製コンピュータに内蔵されている iSight カメラ用のファームウェアを
56操作することができます。
57
58Linux で内蔵 iSight を使う前に、
59
60    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
61
62という風に実行してファームウェアを /lib/firmware/isight.fw として
63取り出す必要があります。この AppleUSBVideoSupport ドライバファイルは
64通常 Mac OS X ルートパーティションの
65
66    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
67
68に存在しているはずです。
69
70
71%prep
72%setup -q
73
74install -m 644 %{SOURCE10} po/ja.po
75echo "ja" >> po/LINGUAS
76
77sed --in-place --expression 's|@udevdir@|%{_libdir}/udev|g' src/isight.rules.in.in
78
79
80%build
81%if %{with_hal}
82%configure --enable-hal --disable-udev
83%else
84%configure --disable-hal --enable-udev
85%endif
86make %{?_smp_mflags}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
93
94rm -f $RPM_BUILD_ROOT%{_infodir}/dir
95
96# Use %doc instead.
97rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
98
99%find_lang %{name}
100
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105
106%post
107/sbin/install-info %{_infodir}/ift-export.info %{_infodir}/dir || :
108/sbin/install-info %{_infodir}/ift-extract.info %{_infodir}/dir || :
109
110
111%preun
112if [ $1 = 0 ]; then
113  /sbin/install-info --delete %{_infodir}/ift-export.info %{_infodir}/dir || :
114  /sbin/install-info --delete %{_infodir}/ift-extract.info %{_infodir}/dir || :
115fi
116
117
118%files -f %{name}.lang
119%defattr(-,root,root,-)
120%doc AUTHORS ChangeLog COPYING HOWTO NEWS README
121%{_bindir}/ift-export
122%{_bindir}/ift-extract
123%{_infodir}/ift-export.info.gz
124%{_infodir}/ift-extract.info.gz
125%if %{with_hal}
126%{_libdir}/hal/ift-callout
127%{_datadir}/hal/fdi/preprobe/20thirdparty/50-isight-firmware.fdi
128%else
129%{_libdir}/udev/ift-load
130%{_sysconfdir}/udev/rules.d/isight.rules
131%endif
132%{_mandir}/man1/ift-export.1.gz
133%{_mandir}/man1/ift-extract.1.gz
134
135
136%changelog
137* Sat May 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-1
138- new upstream release
139
140* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-2
141- switch back to udev support, until hal support gets stable
142
143* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
144- new upstream release
145
146* Thu Sep 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-4
147- now enable hal support; disable udev support
148
149* Fri May 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-3
150- fix broken path in isight.rules
151
152* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-2
153- enable udev / disable hal (until Vine's udev gets updated enough)
154- import Patch10 (for MacBookAir) and Source10 (ja.po) from Debian package
155
156* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-1
157- initial build for Vine Linux
158- spec in UTF-8
Note: See TracBrowser for help on using the repository browser.