source: projects/specs/trunk/i/isight-firmware-tools/isight-firmware-tools-vl.spec @ 1086

Revision 1086, 4.4 KB checked in by shaolin, 14 years ago (diff)
  • isight-firmware-tools
    • fix udev rules
Line 
1# use udev feature until things go right...
2%define with_hal        0
3
4Summary:        Firmware extraction tools for Apple Built-in iSight camera
5Summary(ja):    Apple 内蔵 iSight カメラ用ファームウェア抽出プログラム
6Name:           isight-firmware-tools
7Version:        1.4.1
8Release:        2%{?_dist_release}
9License:        GPLv2+
10Group:          System Environment/Base
11URL:            http://bersace03.free.fr/ift/
12Source0:        %{name}-%{version}.tar.gz
13Source10:       %{name}-1.2_ja.po
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}
16
17%if %{with_hal}
18Requires:       hal
19%else
20Requires:       udev
21%endif
22Requires(post): /sbin/install-info
23Requires(preun): /sbin/install-info
24
25BuildRequires:  gettext
26BuildRequires:  glib2-devel
27BuildRequires:  libgcrypt-devel
28BuildRequires:  libusb-devel
29%if %{with_hal}
30BuildRequires:  hal-devel
31%else
32BuildRequires:  udev
33%endif
34BuildRequires:  perl(XML::Parser)
35
36
37%description
38iSight Firmware Tools provide tools to manipulate firmware for Built-in iSight
39cameras found on Apple machines since iMac G5 (November 2005).
40
41Before using Built-in iSight on Linux, you will need to extract the
42firmware to /lib/firmware/isight.fw as:
43
44    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
45
46AppleUSBVideoSupport driver file should be located in
47
48    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
49
50on your Mac OS X root partition.
51
52
53%description -l ja
54iSight Firmware Tools を使って、2005年11月発売の iMac G5 以降の
55Apple 社製コンピュータに内蔵されている iSight カメラ用のファームウェアを
56操作することができます。
57
58Linux で内蔵 iSight を使う前に、
59
60    sudo ift-extract --apple-driver /path/to/AppleUSBVideoSupport
61
62という風に実行してファームウェアを /lib/firmware/isight.fw として
63取り出す必要があります。この AppleUSBVideoSupport ドライバファイルは
64通常 Mac OS X ルートパーティションの
65
66    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport
67
68に存在しているはずです。
69
70
71%prep
72%setup -q
73
74install -m 644 %{SOURCE10} po/ja.po
75echo "ja" >> po/LINGUAS
76
77sed -i -e 's|@udevdir@|%{_libdir}/udev|g' src/isight.rules.in.in
78sed -i -e 's|SYSFS|ATTRS|g' src/isight.rules.in.in
79
80
81%build
82%if %{with_hal}
83%configure --enable-hal --disable-udev
84%else
85%configure --disable-hal --enable-udev
86%endif
87make %{?_smp_mflags}
88
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
94
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97# Use %doc instead.
98rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
99
100%find_lang %{name}
101
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106
107%post
108/sbin/install-info %{_infodir}/ift-export.info %{_infodir}/dir || :
109/sbin/install-info %{_infodir}/ift-extract.info %{_infodir}/dir || :
110
111
112%preun
113if [ $1 = 0 ]; then
114  /sbin/install-info --delete %{_infodir}/ift-export.info %{_infodir}/dir || :
115  /sbin/install-info --delete %{_infodir}/ift-extract.info %{_infodir}/dir || :
116fi
117
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc AUTHORS ChangeLog COPYING HOWTO NEWS README
122%{_bindir}/ift-export
123%{_bindir}/ift-extract
124%{_infodir}/ift-export.info.gz
125%{_infodir}/ift-extract.info.gz
126%if %{with_hal}
127%{_libdir}/hal/ift-callout
128%{_datadir}/hal/fdi/preprobe/20thirdparty/50-isight-firmware.fdi
129%else
130%{_libdir}/udev/ift-load
131%{_sysconfdir}/udev/rules.d/isight.rules
132%endif
133%{_mandir}/man1/ift-export.1.gz
134%{_mandir}/man1/ift-extract.1.gz
135
136
137%changelog
138* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-2
139- replace SYSFS{} with ATTRS{} in the udev file to avoid warning
140
141* Sat May 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-1
142- new upstream release
143
144* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-2
145- switch back to udev support, until hal support gets stable
146
147* Thu Dec  4 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
148- new upstream release
149
150* Thu Sep 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-4
151- now enable hal support; disable udev support
152
153* Fri May 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-3
154- fix broken path in isight.rules
155
156* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-2
157- enable udev / disable hal (until Vine's udev gets updated enough)
158- import Patch10 (for MacBookAir) and Source10 (ja.po) from Debian package
159
160* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2-1
161- initial build for Vine Linux
162- spec in UTF-8
Note: See TracBrowser for help on using the repository browser.