source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 10300

Revision 10300, 17.0 KB checked in by tomop, 8 years ago (diff)

iproute-4.1.1-1

Line 
1%bcond_with tipc
2%define cbq_version v0.7.3
3
4Summary: Advanced IP routing and network device configuration tools
5Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
6Name: iproute
7Version: 4.1.1
8Release: 1%{?_dist_release}
9Group: Applications/System
10Source: http://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
11URL: http://kernel.org/pub/linux/utils/net/%{name}2/
12Source1: cbq-0000.example
13Source2: avpkt
14
15Vendor: Project Vine
16Distribution: Vine Linux
17
18# http://www.spinics.net/lists/netdev/msg325114.html
19Patch1:             iproute2-3.19.0-docs.patch
20
21# VINE
22Patch100: iproute2-3.14.0-platex.patch
23
24License: GPLv2+ and Public Domain
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26BuildRequires: bison flex
27BuildRequires: iptables-devel >= 1.4.10, libdb-devel
28BuildRequires: texlive-collection-fontsrecommended
29BuildRequires: texlive-collection-latexrecommended
30BuildRequires: texlive-collection-langafrican
31BuildRequires: texlive-collection-langarabic
32BuildRequires: texlive-collection-langchinese
33BuildRequires: texlive-collection-langczechslovak
34BuildRequires: texlive-collection-langenglish
35BuildRequires: texlive-collection-langeuropean
36BuildRequires: texlive-collection-langfrench
37BuildRequires: texlive-collection-langindic
38BuildRequires: texlive-collection-langitalian
39BuildRequires: texlive-collection-langkorean
40BuildRequires: texlive-collection-langpolish
41BuildRequires: texlive-collection-langportuguese
42BuildRequires: texlive-collection-langspanish
43BuildRequires: texlive-collection-langother
44BuildRequires: linuxdoc-tools pkgconfig psutils
45%if %{with tipc}
46BuildRequires: libmnl-devel
47%endif
48
49Requires: iptables >= 1.4.10
50
51%description
52The iproute package contains networking utilities (ip and rtmon, for
53example) which are designed to use the advanced networking
54capabilities of the Linux 2.4.x and 2.6.x kernel.
55
56%description -l ja
57このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
58ネットワーク技術を使うように設計された、ネットワーキングユーティリ
59ティ(ip, rtmon等々)が収録されています。
60
61%package doc
62Summary: ip and tc documentation with examples
63Summary(ja): ip, tcのドキュメントとサンプル
64Group: Applications/System
65License: GPLv2+
66
67%description doc
68The iproute documentation contains howtos and examples of settings.
69
70%package devel
71Summary: Libraries, includes, etc. to develop iptables
72Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
73Group: Development/Libraries
74Requires: %{name} = %{version}
75
76%description devel
77Libraries, include files, etc you can use to develop iproute2.
78
79
80%prep
81%setup -q -n iproute2-%{version}
82%patch1 -p1 -b .doc
83
84%patch100 -p1 -b .platex
85
86%build
87export CFLAGS="%{optflags}"
88export LIBDIR=/%{_libdir}
89export IPT_LIB_DIR=/%{_lib}/xtables
90./configure
91make %{?_smp_mflags}
92make -C doc
93
94%install
95[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
96
97mkdir -p \
98    %{buildroot}%{_includedir} \
99    %{buildroot}/sbin \
100    %{buildroot}%{_sbindir} \
101    %{buildroot}%{_mandir}/man3 \
102    %{buildroot}%{_mandir}/man7 \
103    %{buildroot}%{_mandir}/man8 \
104    %{buildroot}%{_libdir}/tc \
105    %{buildroot}%{_sysconfdir}/iproute2 \
106    %{buildroot}%{_sysconfdir}/sysconfig/cbq
107
108for binary in \
109    ip/ifcfg \
110    ip/ip \
111    ip/rtmon \
112    tc/tc
113    do install -m755 ${binary} %{buildroot}/sbin/
114done
115
116install -m755 examples/cbq.init-%{cbq_version} %{buildroot}/sbin/cbq
117
118for binary in \
119    bridge/bridge \
120    genl/genl \
121    ip/routef \
122    ip/routel \
123    ip/rtpr \
124%if %{with tipc}
125    tipc/tipc \
126%endif
127    misc/arpd \
128    misc/ifstat \
129    misc/lnstat \
130    misc/nstat \
131    misc/rtacct \
132    misc/ss
133    do install -m755 ${binary} %{buildroot}%{_sbindir}
134done
135
136cd %{buildroot}%{_sbindir}
137    ln -s lnstat ctstat
138    ln -s lnstat rtstat
139cd -
140
141# Libs
142install -m644 netem/*.dist %{buildroot}%{_libdir}/tc
143install -m755 tc/m_xt.so %{buildroot}%{_libdir}/tc
144cd %{buildroot}%{_libdir}/tc
145    ln -s m_xt.so m_ipt.so
146cd -
147
148# libnetlink
149install -m644 include/libnetlink.h %{buildroot}%{_includedir}
150install -m644 lib/libnetlink.a %{buildroot}%{_libdir}
151
152# Manpages
153iconv -f latin1 -t utf8 man/man8/ss.8 > man/man8/ss.8.utf8 &&
154    mv man/man8/ss.8.utf8 man/man8/ss.8
155install -m644 man/man3/*.3 %{buildroot}%{_mandir}/man3
156install -m644 man/man7/*.7 %{buildroot}%{_mandir}/man7
157install -m644 man/man8/*.8 %{buildroot}%{_mandir}/man8
158
159# Config files
160install -m644 etc/iproute2/* %{buildroot}%{_sysconfdir}/iproute2
161for config in \
162    %{SOURCE1} \
163    %{SOURCE2}
164    do install -m644 ${config} %{buildroot}%{_sysconfdir}/sysconfig/cbq
165done
166
167
168%clean
169[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
170
171
172%files
173%dir %{_sysconfdir}/iproute2
174%doc COPYING
175%doc README README.decnet README.iproute2+tc README.distribution README.lnstat
176%{_mandir}/man7/*
177%{_mandir}/man8/*
178%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/*
179/sbin/*
180%{_sbindir}/*
181%dir %{_libdir}/tc/
182%{_libdir}/tc/*
183%dir %{_sysconfdir}/sysconfig/cbq
184%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
185
186%files doc
187%doc COPYING
188%doc doc/*.ps
189%doc examples
190
191%files devel
192%doc COPYING
193%{_mandir}/man3/*
194%{_libdir}/libnetlink.a
195%{_includedir}/libnetlink.h
196
197
198%changelog
199* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.1-1
200- new upstream release.
201- dropped all patches and imported from fc23.
202
203* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.14.0-1
204- new upstream release.
205- replaced Patch100.
206
207* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
208- update to 2.6.38.1
209- build with iptables-1.4.10
210- add BR: iptables-devel
211
212* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
213- don't build/include documents. (almost same as man pages...)
214- remove BR: texlive ,linuxdoc-tools
215
216* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
217- rebuilt with rpm-4.8.1-3
218
219* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
220- rebuilt with gcc-4.4.3-3 on ppc
221
222* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
223- rebuilt with rpm-4.8.0-3 (on ppc)
224
225* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
226- new upstream release
227  - import patches from fedora package
228- build with db4-4.8
229
230* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
231- updated to 2.6.25 based on 2.6.25-1 from Fedora
232- build with db4-4.6.21
233- keep Patch100 from 2.6.16-1vl5
234-changelogs for previous Vine package as follows:
235  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
236  - apply new versioning policy.
237
238  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
239  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
240    (Patch10 not applied until VineSeed kernel goes higher versions)
241  - rebuilt with new toolchain and db4-4.3.x
242
243  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
244  - added Patch5 to make documents without errors
245
246  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
247  - update to 2.6.15-060110
248
249  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
250  - added BuildRequires: linuxdoc-tools
251
252  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
253  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
254
255  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
256  - new upstream release
257  - changed Group: of devel package
258  - applyed patches from Fedora development
259    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
260    - Took tons of manpages from debian, much more complete (#123952).
261  - added Japanese translation from spec translation project :-)
262
263  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
264  - 2.2.4-14vl2
265  - rename package name iproute to iproute2
266  - rebuild development version
267
268* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
269- update
270- remove patch for backward compatibility
271- add patch for AEAD compatibility
272
273* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
274- add creating ps file again. Fix was done in texlive
275
276* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
277- rebuild without tetex files. It isn't working in rawhide yet. Added
278        new source for ps files.
279- #431179 backward compatibility for previous iproute versions
280
281* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
282- rebuild with fix tetex and linuxdoc-tools -> manual pdf
283- clean unnecessary patches
284- add into spec *.so objects, new BR linux-atm-libs-devel
285
286* Wed Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
287- new version from upstrem 2.3.23
288
289* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
290- move files from /usr/lib/tc to /usr/share/tc
291- remove listing files twice
292
293* Thu Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
294- package review #225903
295
296* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
297- rebuild for new db4
298
299* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
300- upgrade to 2.6.22
301
302* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
303- fix broken tc-pfifo man page (#232891)
304
305* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
306- upgrade to 2.6.20
307
308* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
309- upgrade to 2.6.19
310
311* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
312- fix snapshot version
313
314* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
315- spec file cleanup
316- one more rebuilt against db4
317
318* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
319- fix defective manpage for tc-pfifo (#215399)
320
321* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
322- rebuilt against new db4
323
324* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
325- upgrade to upstream 2.6.18
326- initcwnd patch merged
327- bug fix for xfrm monitor
328- alignment fixes for cris
329- documentation corrections
330       
331* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
332- fix ip.8 man page, add initcwnd option
333
334* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
335- rebuilt for unwind info generation, broken in gcc-4.1.1-21
336
337* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
338- fix crash when resolving ip address
339
340* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
341- add LOWER_UP and DORMANT flags (#202199)
342- use dist tag
343
344* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
345- rebuild
346
347* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
348- improve handling of initcwnd value (#179719)
349
350* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
351- fix BuildRequires: flex (#193403)
352
353* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
354- upgrade to 2.6.16-060323
355- don't hardcode /usr/lib in tc (#186607)
356
357* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
358- own /usr/lib/tc (#181953)
359- obsoletes shapecfg (#182284)
360
361* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
362- bump again for double-long bug on ppc(64)
363
364* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
365- rebuilt for new gcc4.1 snapshot and glibc changes
366
367* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
368- upgrade to 2.6.15-060110
369
370* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
371- rebuilt
372
373* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
374- remove backup of config files (#175302)
375
376* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
377- use tc manpages and cbq.init from source tarball (#172851)
378
379* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
380- new upstream source
381
382* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
383- add warning to ip tunnel add command (#128107)
384
385* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
386- update from upstream (appears to fix #170111)
387
388* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
389- update from upstream
390- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
391
392* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
393- add RPM_OPT_FLAGS
394
395* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
396- forget to apply the patch :(
397
398* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
399- make ip help work again (#168449)
400
401* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
402- upgrade to ss050901 for 2.6.14 kernel headers
403
404* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
405- added /sbin/cbq script and sample configuration files (#166301)
406
407* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
408- upgrade to iproute2-050816
409
410* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
411- update to snapshot for 2.6.13+ kernel
412
413* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
414- removed useless initvar patch (#150798)
415- new upstream source
416
417* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
418- update to iproute-2.6.11
419
420* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
421- gcc4 rebuilt
422
423* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
424- update to iproute-2.6.10
425
426* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
427- added arpd into sbin
428
429* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
430- debug info removed from makefile and from spec (#140891)
431
432* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
433- source file updated from snapshot version
434- endian patch adding <endian.h>
435
436* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
437- added installation of netem module for tc
438
439* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
440- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
441
442* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
443- updated to iproute-2.6.9, spec file change, patches cleared
444
445* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
446- rebuilt
447
448* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
449- Took tons of manpages from debian, much more complete (#123952).
450
451* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
452- rebuilt
453
454* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
455- Built security errata version for FC1.
456
457* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
458- Fixed -f option for ss (#118355).
459- Small description fix (#110997).
460- Added initialization of some vars (#74961).
461- Added patch to initialize "default" rule as well (#60693).
462
463* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
464- rebuilt
465
466* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
467- Security errata for netlink (CAN-2003-0856).
468
469* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
470- Updated to latest version. Used by other distros, so seems stable. ;-)
471- Quite a few patches needed updating in that turn.
472- Added ss (#107363) and several other new nifty tools.
473
474* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
475- rebuilt
476
477* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
478- rebuilt
479
480* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
481- rebuilt
482
483* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
484- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
485
486* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
487- remove flags patch at author's request
488
489* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
490- automated rebuild
491
492* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
493- Don't forcibly strip binaries
494
495* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
496- Fixed missing diffserv and atm support in config (#57278).
497- Fixed inconsistent numeric base problem for command line (#65473).
498
499* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
500- Added patch to fix crosscompiling by Adrian Linkins.
501
502* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
503- Update to latest stable release 2.4.7-now-ss010824.
504- Added simple man page for ip.
505
506* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
507- allow setting of allmulti & promisc flags (#48669)
508
509* Mon Jul 02 2001 Than Ngo <than@redhat.com>
510- fix build problem in beehive if kernel-sources is not installed
511
512* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
513- updated to iproute2-2.2.4-now-ss001007.tar.gz
514- bzip2 source tar file
515- "License" replaces "Copyright"
516- added "BuildPrereq: tetex-latex tetex-dvips psutils"
517- rebuilt for 7.2
518
519* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
520- use the system headers - the included ones are broken
521- ETH_P_ECHO went away
522
523* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
524- test for specific KERNEL_INCLUDE directories.
525
526* Thu Oct 12 2000 Than Ngo <than@redhat.com>
527- rebuild for 7.1
528
529* Thu Oct 12 2000 Than Ngo <than@redhat.com>
530- add default configuration files for iproute (Bug #10549, #18887)
531
532* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
533- fix include-glibc/ to cope with glibc 2.2 new resolver headers
534
535* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
536- automatic rebuild
537
538* Sun Jun 18 2000 Than Ngo <than@redhat.de>
539- rebuilt in the new build environment
540- use RPM macros
541- handle RPM_OPT_FLAGS
542
543* Sat Jun 03 2000 Than Ngo <than@redhat.de>
544- fix iproute to build with new glibc
545
546* Fri May 26 2000 Ngo Than <than@redhat.de>
547- update to 2.2.4-now-ss000305
548- add configuration files
549
550* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
551- strip binaries
552
553* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
554- first build
Note: See TracBrowser for help on using the repository browser.