source: projects/specs/trunk/i/iproute/iproute-vl.spec @ 11249

Revision 11249, 18.3 KB checked in by tomop, 6 years ago (diff)

iproute-4.14.1-1

Line 
1%bcond_with tipc
2%bcond_with texdoc
3%define cbq_version v0.7.3
4
5Summary: Advanced IP routing and network device configuration tools
6Summary(ja): IP ルーティング,ネットワークデバイスの設定ツール
7Name: iproute
8Version: 4.14.1
9Release: 1%{?_dist_release}
10Group: Applications/System
11Source: https://kernel.org/pub/linux/utils/net/%{name}2/%{name}2-%{version}.tar.xz
12URL: http://kernel.org/pub/linux/utils/net/%{name}2/
13Source1: cbq-0000.example
14Source2: avpkt
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19# http://www.spinics.net/lists/netdev/msg325114.html
20Patch1:             iproute2-3.19.0-docs.patch
21
22# VINE
23Patch100: iproute2-3.14.0-platex.patch
24
25License: GPLv2+ and Public Domain
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27BuildRequires: bison flex
28BuildRequires: iptables-devel >= 1.4.10, libdb-devel
29BuildRequires: pkgconfig
30%if %{with texdoc}
31BuildRequires: texlive-collection-fontsrecommended
32BuildRequires: texlive-collection-latexrecommended
33BuildRequires: texlive-collection-langafrican
34BuildRequires: texlive-collection-langarabic
35BuildRequires: texlive-collection-langchinese
36BuildRequires: texlive-collection-langczechslovak
37BuildRequires: texlive-collection-langenglish
38BuildRequires: texlive-collection-langeuropean
39BuildRequires: texlive-collection-langfrench
40BuildRequires: texlive-collection-langindic
41BuildRequires: texlive-collection-langitalian
42BuildRequires: texlive-collection-langkorean
43BuildRequires: texlive-collection-langpolish
44BuildRequires: texlive-collection-langportuguese
45BuildRequires: texlive-collection-langspanish
46BuildRequires: texlive-collection-langother
47BuildRequires: linuxdoc-tools psutils
48%endif
49%if %{with tipc}
50BuildRequires: libmnl-devel
51%endif
52
53Requires: iptables >= 1.4.10
54
55%description
56The iproute package contains networking utilities (ip and rtmon, for
57example) which are designed to use the advanced networking
58capabilities of the Linux 2.4.x and 2.6.x kernel.
59
60%description -l ja
61このiprouteパッケージには、カーネル 2.4.x または 2.6.x の進歩した
62ネットワーク技術を使うように設計された、ネットワーキングユーティリ
63ティ(ip, rtmon等々)が収録されています。
64
65%package doc
66Summary: ip and tc documentation with examples
67Summary(ja): ip, tcのドキュメントとサンプル
68Group: Applications/System
69License: GPLv2+
70
71%description doc
72The iproute documentation contains howtos and examples of settings.
73
74%package devel
75Summary: Libraries, includes, etc. to develop iptables
76Summary(ja): iproute の開発用ライブラリ,ヘッダファイル
77Group: Development/Libraries
78Requires: %{name} = %{version}
79
80%description devel
81Libraries, include files, etc you can use to develop iproute2.
82
83
84%prep
85%setup -q -n iproute2-%{version}
86%if %{with texdoc}
87%patch1 -p1 -b .doc
88%patch100 -p1 -b .platex
89%endif
90
91%build
92export CFLAGS="%{optflags}"
93export LIBDIR=/%{_libdir}
94export IPT_LIB_DIR=/%{_lib}/xtables
95./configure
96make %{?_smp_mflags}
97%if %{with texdoc}
98#make -C doc
99%endif
100
101%install
102[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
103
104mkdir -p \
105    %{buildroot}%{_includedir} \
106    %{buildroot}/sbin \
107    %{buildroot}%{_sbindir} \
108    %{buildroot}%{_mandir}/man3 \
109    %{buildroot}%{_mandir}/man7 \
110    %{buildroot}%{_mandir}/man8 \
111    %{buildroot}%{_libdir}/tc \
112    %{buildroot}%{_sysconfdir}/iproute2/{rt_protos.d,rt_tables.d} \
113    %{buildroot}%{_sysconfdir}/sysconfig/cbq
114
115for binary in \
116    ip/ifcfg \
117    ip/ip \
118    ip/rtmon \
119    tc/tc
120    do install -m755 ${binary} %{buildroot}/sbin/
121done
122
123install -m755 examples/cbq.init-%{cbq_version} %{buildroot}/sbin/cbq
124
125for binary in \
126    bridge/bridge \
127    genl/genl \
128    ip/routef \
129    ip/routel \
130    ip/rtpr \
131%if %{with tipc}
132    tipc/tipc \
133%endif
134    misc/arpd \
135    misc/ifstat \
136    misc/lnstat \
137    misc/nstat \
138    misc/rtacct \
139    misc/ss
140    do install -m755 ${binary} %{buildroot}%{_sbindir}
141done
142
143cd %{buildroot}%{_sbindir}
144    ln -s lnstat ctstat
145    ln -s lnstat rtstat
146cd -
147
148# Libs
149install -m644 netem/*.dist %{buildroot}%{_libdir}/tc
150install -m755 tc/m_xt.so %{buildroot}%{_libdir}/tc
151cd %{buildroot}%{_libdir}/tc
152    ln -s m_xt.so m_ipt.so
153cd -
154
155# libnetlink
156install -m644 include/libnetlink.h %{buildroot}%{_includedir}
157install -m644 lib/libnetlink.a %{buildroot}%{_libdir}
158
159# Manpages
160iconv -f latin1 -t utf8 man/man8/ss.8 > man/man8/ss.8.utf8 &&
161    mv man/man8/ss.8.utf8 man/man8/ss.8
162install -m644 man/man3/*.3 %{buildroot}%{_mandir}/man3
163install -m644 man/man7/*.7 %{buildroot}%{_mandir}/man7
164install -m644 man/man8/*.8 %{buildroot}%{_mandir}/man8
165
166# Config files
167for f in `find etc/iproute2/ -maxdepth 1 -type f`;
168    do install -m644 $f %{buildroot}%{_sysconfdir}/iproute2
169done
170
171install -m644 etc/iproute2/rt_protos.d/* %{buildroot}%{_sysconfdir}/iproute2/rt_protos.d/
172
173install -m644 etc/iproute2/rt_tables.d/* %{buildroot}%{_sysconfdir}/iproute2/rt_tables.d/
174
175for config in \
176    %{SOURCE1} \
177    %{SOURCE2}
178    do install -m644 ${config} %{buildroot}%{_sysconfdir}/sysconfig/cbq
179done
180
181
182%clean
183[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
184
185
186%files
187%dir %{_sysconfdir}/iproute2
188%dir %{_sysconfdir}/iproute2/rt_protos.d
189%dir %{_sysconfdir}/iproute2/rt_tables.d
190%doc COPYING
191%doc README README.decnet README.iproute2+tc README.distribution README.lnstat
192%{_mandir}/man7/*
193%{_mandir}/man8/*
194%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/bpf_pinning
195%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/ematch_map
196%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/group
197%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/nl_protos
198%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_dsfield
199%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_protos
200%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_realms
201%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_scopes
202%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_tables
203%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_protos.d/*
204%attr(644,root,root) %config(noreplace) %{_sysconfdir}/iproute2/rt_tables.d/*
205/sbin/*
206%{_sbindir}/*
207%dir %{_libdir}/tc/
208%{_libdir}/tc/*
209%dir %{_sysconfdir}/sysconfig/cbq
210%config(noreplace) %{_sysconfdir}/sysconfig/cbq/*
211
212%files doc
213%doc COPYING
214%doc doc/*
215%doc examples
216
217%files devel
218%doc COPYING
219%{_mandir}/man3/*
220%{_libdir}/libnetlink.a
221%{_includedir}/libnetlink.h
222
223
224%changelog
225* Fri Dec 01 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.1-1
226- new upstream release.
227- dropped TeX docs.
228
229* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.1-1
230- new upstream release.
231- dropped all patches and imported from fc23.
232
233* Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.14.0-1
234- new upstream release.
235- replaced Patch100.
236
237* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.38-1
238- update to 2.6.38.1
239- build with iptables-1.4.10
240- add BR: iptables-devel
241
242* Mon Apr 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-5
243- don't build/include documents. (almost same as man pages...)
244- remove BR: texlive ,linuxdoc-tools
245
246* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.6.31-4
247- rebuilt with rpm-4.8.1-3
248
249* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-3
250- rebuilt with gcc-4.4.3-3 on ppc
251
252* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.31-2
253- rebuilt with rpm-4.8.0-3 (on ppc)
254
255* Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.31-1
256- new upstream release
257  - import patches from fedora package
258- build with db4-4.8
259
260* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.25-2
261- updated to 2.6.25 based on 2.6.25-1 from Fedora
262- build with db4-4.6.21
263- keep Patch100 from 2.6.16-1vl5
264-changelogs for previous Vine package as follows:
265  - Fri Apr 11 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.6.16-1
266  - apply new versioning policy.
267
268  - Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.16-0vl1
269  - updated to 2.6.16 and merged several patches from FC 2.6.16-6
270    (Patch10 not applied until VineSeed kernel goes higher versions)
271  - rebuilt with new toolchain and db4-4.3.x
272
273  - Fri Sep 15 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.15-0vl2
274  - added Patch5 to make documents without errors
275
276  - Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.15-0vl1
277  - update to 2.6.15-060110
278
279  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl3
280  - added BuildRequires: linuxdoc-tools
281
282  - Mon Jun  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl2
283  - lib*.a is moved to %{_libdir}/iproute2 (ad-hoc?)
284
285  - Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.6.11-1vl1
286  - new upstream release
287  - changed Group: of devel package
288  - applyed patches from Fedora development
289    - Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
290    - Took tons of manpages from debian, much more complete (#123952).
291  - added Japanese translation from spec translation project :-)
292
293  - Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
294  - 2.2.4-14vl2
295  - rename package name iproute to iproute2
296  - rebuild development version
297
298* Mon Apr 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.25-1
299- update
300- remove patch for backward compatibility
301- add patch for AEAD compatibility
302
303* Thu Feb 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-4
304- add creating ps file again. Fix was done in texlive
305
306* Wed Feb  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-3
307- rebuild without tetex files. It isn't working in rawhide yet. Added
308        new source for ps files.
309- #431179 backward compatibility for previous iproute versions
310
311* Mon Jan 21 2008 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-2
312- rebuild with fix tetex and linuxdoc-tools -> manual pdf
313- clean unnecessary patches
314- add into spec *.so objects, new BR linux-atm-libs-devel
315
316* Wed Oct 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.23-1
317- new version from upstrem 2.3.23
318
319* Tue Oct 23 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-5
320- move files from /usr/lib/tc to /usr/share/tc
321- remove listing files twice
322
323* Thu Aug 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 2.6.22-3
324- package review #225903
325
326* Mon Aug 27 2007 Jeremy Katz <katzj@redhat.com> - 2.6.22-2
327- rebuild for new db4
328
329* Wed Jul 11 2007 Radek Vokál <rvokal@redhat.com> - 2.6.22-1
330- upgrade to 2.6.22
331
332* Mon Mar 19 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-2
333- fix broken tc-pfifo man page (#232891)
334
335* Thu Mar 15 2007 Radek Vokál <rvokal@redhat.com> - 2.6.20-1
336- upgrade to 2.6.20
337
338* Fri Dec 15 2006 Radek Vokál <rvokal@redhat.com> - 2.6.19-1
339- upgrade to 2.6.19
340
341* Mon Dec 11 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-5
342- fix snapshot version
343
344* Fri Dec  1 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-4
345- spec file cleanup
346- one more rebuilt against db4
347
348* Thu Nov 16 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-3
349- fix defective manpage for tc-pfifo (#215399)
350
351* Mon Nov 13 2006 Radek Vokál <rvokal@redhat.com> - 2.6.18-2
352- rebuilt against new db4
353
354* Tue Oct  3 2006 Radek Vokal <rvokal@redhat.com> - 2.6.18-1
355- upgrade to upstream 2.6.18
356- initcwnd patch merged
357- bug fix for xfrm monitor
358- alignment fixes for cris
359- documentation corrections
360       
361* Mon Oct  2 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-7
362- fix ip.8 man page, add initcwnd option
363
364* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-6
365- rebuilt for unwind info generation, broken in gcc-4.1.1-21
366
367* Tue Sep 19 2006 Radek Vokal <rvokal@redhat.com> - 2.6.16-5
368- fix crash when resolving ip address
369
370* Mon Aug 21 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-4
371- add LOWER_UP and DORMANT flags (#202199)
372- use dist tag
373
374* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.6.16-3.1
375- rebuild
376
377* Mon Jun 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-3
378- improve handling of initcwnd value (#179719)
379
380* Sun May 28 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-2
381- fix BuildRequires: flex (#193403)
382
383* Sun Mar 26 2006 Radek Vokál <rvokal@redhat.com> - 2.6.16-1
384- upgrade to 2.6.16-060323
385- don't hardcode /usr/lib in tc (#186607)
386
387* Wed Feb 22 2006 Radek Vokál <rvokal@redhat.com> - 2.6.15-2
388- own /usr/lib/tc (#181953)
389- obsoletes shapecfg (#182284)
390
391* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.2
392- bump again for double-long bug on ppc(64)
393
394* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.6.15-1.1
395- rebuilt for new gcc4.1 snapshot and glibc changes
396
397* Tue Jan 17 2006 Radek Vokal <rvokal@redhat.com> 2.6.15-1
398- upgrade to 2.6.15-060110
399
400* Mon Dec 12 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-11
401- rebuilt
402
403* Fri Dec 09 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-10
404- remove backup of config files (#175302)
405
406* Fri Nov 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-9
407- use tc manpages and cbq.init from source tarball (#172851)
408
409* Thu Nov 10 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-8
410- new upstream source
411
412* Mon Oct 31 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-7
413- add warning to ip tunnel add command (#128107)
414
415* Fri Oct 07 2005 Bill Nottingham <notting@redhat.com> 2.6.14-6
416- update from upstream (appears to fix #170111)
417
418* Fri Oct 07 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-5
419- update from upstream
420- fixed host_len size for memcpy (#168903) <Matt_Domsch@dell.com>
421
422* Fri Sep 23 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-4
423- add RPM_OPT_FLAGS
424
425* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-3
426- forget to apply the patch :(
427
428* Mon Sep 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-2
429- make ip help work again (#168449)
430
431* Wed Sep 14 2005 Radek Vokal <rvokal@redhat.com> 2.6.14-1
432- upgrade to ss050901 for 2.6.14 kernel headers
433
434* Fri Aug 26 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-3
435- added /sbin/cbq script and sample configuration files (#166301)
436
437* Fri Aug 19 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-2
438- upgrade to iproute2-050816
439
440* Thu Aug 11 2005 Radek Vokal <rvokal@redhat.com> 2.6.13-1
441- update to snapshot for 2.6.13+ kernel
442
443* Tue May 24 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-2
444- removed useless initvar patch (#150798)
445- new upstream source
446
447* Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
448- update to iproute-2.6.11
449
450* Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
451- gcc4 rebuilt
452
453* Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
454- update to iproute-2.6.10
455
456* Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
457- added arpd into sbin
458
459* Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
460- debug info removed from makefile and from spec (#140891)
461
462* Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
463- source file updated from snapshot version
464- endian patch adding <endian.h>
465
466* Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
467- added installation of netem module for tc
468
469* Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
470- fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
471
472* Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
473- updated to iproute-2.6.9, spec file change, patches cleared
474
475* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
476- rebuilt
477
478* Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
479- Took tons of manpages from debian, much more complete (#123952).
480
481* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
482- rebuilt
483
484* Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
485- Built security errata version for FC1.
486
487* Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
488- Fixed -f option for ss (#118355).
489- Small description fix (#110997).
490- Added initialization of some vars (#74961).
491- Added patch to initialize "default" rule as well (#60693).
492
493* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
494- rebuilt
495
496* Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
497- Security errata for netlink (CAN-2003-0856).
498
499* Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
500- Updated to latest version. Used by other distros, so seems stable. ;-)
501- Quite a few patches needed updating in that turn.
502- Added ss (#107363) and several other new nifty tools.
503
504* Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
505- rebuilt
506
507* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
508- rebuilt
509
510* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
511- rebuilt
512
513* Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
514- Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
515
516* Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
517- remove flags patch at author's request
518
519* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
520- automated rebuild
521
522* Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
523- Don't forcibly strip binaries
524
525* Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
526- Fixed missing diffserv and atm support in config (#57278).
527- Fixed inconsistent numeric base problem for command line (#65473).
528
529* Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
530- Added patch to fix crosscompiling by Adrian Linkins.
531
532* Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
533- Update to latest stable release 2.4.7-now-ss010824.
534- Added simple man page for ip.
535
536* Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
537- allow setting of allmulti & promisc flags (#48669)
538
539* Mon Jul 02 2001 Than Ngo <than@redhat.com>
540- fix build problem in beehive if kernel-sources is not installed
541
542* Fri May 25 2001 Helge Deller <hdeller@redhat.de>
543- updated to iproute2-2.2.4-now-ss001007.tar.gz
544- bzip2 source tar file
545- "License" replaces "Copyright"
546- added "BuildPrereq: tetex-latex tetex-dvips psutils"
547- rebuilt for 7.2
548
549* Tue May  1 2001 Bill Nottingham <notting@redhat.com>
550- use the system headers - the included ones are broken
551- ETH_P_ECHO went away
552
553* Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
554- test for specific KERNEL_INCLUDE directories.
555
556* Thu Oct 12 2000 Than Ngo <than@redhat.com>
557- rebuild for 7.1
558
559* Thu Oct 12 2000 Than Ngo <than@redhat.com>
560- add default configuration files for iproute (Bug #10549, #18887)
561
562* Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
563- fix include-glibc/ to cope with glibc 2.2 new resolver headers
564
565* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
566- automatic rebuild
567
568* Sun Jun 18 2000 Than Ngo <than@redhat.de>
569- rebuilt in the new build environment
570- use RPM macros
571- handle RPM_OPT_FLAGS
572
573* Sat Jun 03 2000 Than Ngo <than@redhat.de>
574- fix iproute to build with new glibc
575
576* Fri May 26 2000 Ngo Than <than@redhat.de>
577- update to 2.2.4-now-ss000305
578- add configuration files
579
580* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
581- strip binaries
582
583* Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
584- first build
Note: See TracBrowser for help on using the repository browser.