source: projects/specs/trunk/i/ipmitool/ipmitool-vl.spec @ 9686

Revision 9686, 6.1 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-phone-manager: update
others: rebuild

Line 
1Name:         ipmitool
2Summary:      Utility for IPMI control
3Summary(ja):  IPMIコントロールユーティリティ
4Version:      1.8.11
5Release:      2%{?_dist_release}
6License:      BSD
7Group:        System Environment/Base
8URL:          http://ipmitool.sourceforge.net/
9Source0:      http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
10Source1:      openipmi-ipmievd.sysconf
11Buildroot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12BuildRequires: openssl-devel readline-devel ncurses-devel
13Requires(post): chkconfig
14Requires(preun): chkconfig
15Obsoletes: OpenIPMI-tools < 2.0.14-3
16Provides: OpenIPMI-tools = 2.0.14-3
17
18Patch1: ipmitool-1.8.10-ipmievd-init.patch
19Patch2: ipmitool-1.8.10-ipmievd-condrestart.patch
20Patch3: ipmitool-1.8.11-ipmieved-pidfile.patch
21Patch4: ipmitool-1.8.11-dell-oem.patch
22Patch5: ipmitool-1.8.11-dell-setled.patch
23Patch6: ipmitool-1.8.10-k-option.patch
24Patch7: ipmitool-1.8.11-set-kg-key.patch
25Patch8: ipmitool-1.8.11-set-kg-key2.patch
26Patch9: ipmitool-1.8.11-sol-payload-size.patch
27Patch10: ipmitool-1.8.11-dell-setled-updates.patch
28Patch11: ipmitool-1.8.11-dell-big-endian.patch
29Patch12: ipmitool-1.8.11-sol-leak.patch
30
31%description
32This package contains a utility for interfacing with devices that support
33the Intelligent Platform Management Interface specification.  IPMI is
34an open standard for machine health, inventory, and remote power control.
35
36This utility can communicate with IPMI-enabled devices through either a
37kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
38the IPMI specification.  IPMIv2 adds support for encrypted LAN
39communications and remote Serial-over-LAN functionality.
40
41It provides commands for reading the Sensor Data Repository (SDR) and
42displaying sensor values, displaying the contents of the System Event
43Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
44setting LAN configuration, and chassis power control.
45
46%prep
47
48%setup -q
49%patch1 -p1 -b .ipmievd-init
50%patch2 -p0 -b .condrestart
51%patch3 -p1 -b .ipmievd-pidfile
52%patch4 -p1 -b .delloem
53%patch5 -p1 -b .setled
54%patch6 -p1 -b .k-option
55%patch7 -p1 -b .set-kg
56%patch8 -p1 -b .set-kg2
57%patch9 -p1 -b .sol-payload-size
58%patch10 -p1 -b .setled-updates
59%patch11 -p1 -b .fixes
60%patch12 -p1 -b .sol-leak
61
62for f in AUTHORS ChangeLog; do
63    iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
64    mv ${f}.utf8 ${f}
65done
66
67%build
68# --disable-dependency-tracking speeds up the build
69# --enable-file-security adds some security checks
70# --disable-intf-free disables FreeIPMI support - we don't want to depend on
71#   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
72%configure --disable-dependency-tracking --enable-file-security --disable-intf-free
73make %{?_smp_mflags}
74
75%install
76rm -rf %{buildroot}
77make DESTDIR=%{buildroot} install
78
79install -Dpm 755 contrib/ipmievd.init.redhat %{buildroot}%{_initrddir}/ipmievd
80install -Dpm 644 %SOURCE1 %{buildroot}%{_sysconfdir}/sysconfig/ipmievd
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86/sbin/chkconfig --add ipmievd
87
88%preun
89if [ $1 = 0 ]; then
90   service ipmievd stop >/dev/null 2>&1
91   /sbin/chkconfig --del ipmievd
92fi
93
94%postun
95if [ "$1" -ge "1" ]; then
96    service ipmievd condrestart >/dev/null 2>&1 || :
97fi
98
99%files
100%defattr(-,root,root)
101%config(noreplace) %{_sysconfdir}/sysconfig/ipmievd
102%{_initrddir}/ipmievd
103%{_bindir}/*
104%{_sbindir}/*
105%{_mandir}/man*/*
106%doc %{_datadir}/doc/ipmitool
107%{_datadir}/ipmitool
108
109
110%changelog
111* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.11-2
112- rebuild with readline-6.3
113
114* Mon Jul 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.11-1
115- initial build for Vine Linux
116
117* Thu Aug 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-11
118- fixed delloem powermonitor on bigendian systems (#731718)
119- fixed memory leak in Serial-over-Lan module (#731977)
120
121* Wed Aug 10 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
122- added -Y option for ipmitool to hide Kg key from cmdline (#698647)
123- added 'channel setkg' command to set Kg encryption key on remote machine
124  (#726390)
125
126* Thu Aug  4 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
127- updated 'delloem setled' command to indicate SES status and drive
128  activities for a PCI-e SSD (#727314)
129
130* Mon Jul 25 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-9
131- rebuilt for RHEL 6.2 Fastrack
132
133* Thu Jul 14 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-8
134- fixed 'ipmi sol' sending wrong packets due to miscalculation of SOL
135  payload size (#675975)
136
137* Mon Feb  7 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-7
138- added 'delloem' command for Dell-specific IPMI extensions (#631649, #63793)
139
140* Wed Jun  2 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-6
141- Changed ipmievd to use /var/run/ipmievd.pid file by default (#596809)
142
143* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-5
144- Fixed exit code of ipmievd initscript with wrong arguments (#562186)
145
146* Fri Dec 11 2009 Dennis Gregorovic <dgregor@redhat.com> - 1.8.11-4.1
147- Rebuilt for RHEL 6
148
149* Mon Nov  2 2009 Jan Safranek  <jsafrane@redhat.com> 1.8.11-4
150- fix ipmievd initscript 'condrestart' action (#532188)
151
152* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.8.11-3
153- rebuilt with new openssl
154
155* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.11-2
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
157
158* Thu Feb 26 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-1
159- updated to new version
160
161* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.10-4
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
163
164* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> 1.8.10-3
165- rebuild with new openssl
166
167* Tue Oct 14 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-2
168- fix issues found during package review:
169  - clear Default-Start: line in the init script, the service should be
170    disabled by default
171  - added Obsoletes: OpenIPMI-tools
172  - compile with --disable-dependency-tracking to speed things up
173  - compile with --enable-file-security
174  - compile with --disable-intf-free, don't depend on FreeIPMI libraries
175    (FreeIPMI has its own ipmitool-like utility)
176
177* Mon Oct 13 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-1
178- package created, based on upstream .spec file
Note: See TracBrowser for help on using the repository browser.