source: projects/specs/trunk/i/ipmitool/ipmitool-vl.spec @ 12347

Revision 12347, 6.1 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

bluez-5.54-1

gthumb-3.8.3-1

ipmitool-1.8.18-1

python-urllib3-1.25.8-1

Line 
1Name:         ipmitool
2Summary:      Utility for IPMI control
3Summary(ja):  IPMIコントロールユーティリティ
4Version:      1.8.18
5Release:      1%{?_dist_release}
6Group:        System Environment/Base
7Vendor:       Project Vine
8Distribution: Vine Linux
9License:      BSD
10URL:          https://github.com/ipmitool/ipmitool
11%global       tagname IPMITOOL_%(echo %{version} | tr . _)
12Source0:      https://github.com/ipmitool/ipmitool/releases/download/%{tagname}/%{name}-%{version}.tar.bz2
13Source1:      openipmi-ipmievd.sysconf
14Buildroot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15BuildRequires: openssl-devel readline-devel ncurses-devel
16Requires(post): chkconfig
17Requires(preun): chkconfig
18Obsoletes: OpenIPMI-tools < 2.0.14-3
19Provides: OpenIPMI-tools = 2.0.14-3
20
21Patch1:       0001-CVE-2011-4339-OpenIPMI.patch
22# WARNING:  THIS PATCH MUST BE USED FOR RAWHIDE (f26+) BRANCH
23Patch2:       0002-openssl.patch
24Patch3:       0003-ipmitool-1.8.11-set-kg-key.patch
25Patch4:       0004-slowswid.patch
26Patch5:       0005-sensor-id-length.patch
27Patch6:       0006-enable-usb.patch
28Patch7:       0007-check-input.patch
29Patch8:       0008-add-extern.patch
30Patch9:       0009-best-cipher.patch
31Patch10:      0010-pef-missing-newline.patch
32Patch11:      0011-expand-sensor-name-column.patch
33Patch12:      0012-CVE-2020-5208.patch
34
35
36%description
37This package contains a utility for interfacing with devices that support
38the Intelligent Platform Management Interface specification.  IPMI is
39an open standard for machine health, inventory, and remote power control.
40
41This utility can communicate with IPMI-enabled devices through either a
42kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
43the IPMI specification.  IPMIv2 adds support for encrypted LAN
44communications and remote Serial-over-LAN functionality.
45
46It provides commands for reading the Sensor Data Repository (SDR) and
47displaying sensor values, displaying the contents of the System Event
48Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
49setting LAN configuration, and chassis power control.
50
51%prep
52
53%setup -q
54%autopatch -p1
55
56for f in AUTHORS ChangeLog; do
57    iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
58    mv ${f}.utf8 ${f}
59done
60
61autoreconf -ivf
62
63%build
64# --disable-dependency-tracking speeds up the build
65# --enable-file-security adds some security checks
66# --disable-intf-free disables FreeIPMI support - we don't want to depend on
67#   FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
68%configure --disable-dependency-tracking --enable-file-security --disable-intf-free
69make %{?_smp_mflags}
70
71%install
72rm -rf %{buildroot}
73make DESTDIR=%{buildroot} install
74
75install -Dpm 755 contrib/ipmievd.init.redhat %{buildroot}%{_initrddir}/ipmievd
76install -Dpm 644 %SOURCE1 %{buildroot}%{_sysconfdir}/sysconfig/ipmievd
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82/sbin/chkconfig --add ipmievd
83
84%preun
85if [ $1 = 0 ]; then
86   service ipmievd stop >/dev/null 2>&1
87   /sbin/chkconfig --del ipmievd
88fi
89
90%postun
91if [ "$1" -ge "1" ]; then
92    service ipmievd condrestart >/dev/null 2>&1 || :
93fi
94
95%files
96%defattr(-,root,root)
97%config(noreplace) %{_sysconfdir}/sysconfig/ipmievd
98%{_initrddir}/ipmievd
99%{_bindir}/*
100%{_sbindir}/*
101%{_mandir}/man*/*
102%doc %{_datadir}/doc/ipmitool
103%{_datadir}/ipmitool
104
105
106%changelog
107* Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.18-1
108- new upstream release.
109- replaced all patches.
110
111* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.11-2
112- rebuild with readline-6.3
113
114* Mon Jul 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.11-1
115- initial build for Vine Linux
116
117* Thu Aug 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-11
118- fixed delloem powermonitor on bigendian systems (#731718)
119- fixed memory leak in Serial-over-Lan module (#731977)
120
121* Wed Aug 10 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
122- added -Y option for ipmitool to hide Kg key from cmdline (#698647)
123- added 'channel setkg' command to set Kg encryption key on remote machine
124  (#726390)
125
126* Thu Aug  4 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
127- updated 'delloem setled' command to indicate SES status and drive
128  activities for a PCI-e SSD (#727314)
129
130* Mon Jul 25 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-9
131- rebuilt for RHEL 6.2 Fastrack
132
133* Thu Jul 14 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-8
134- fixed 'ipmi sol' sending wrong packets due to miscalculation of SOL
135  payload size (#675975)
136
137* Mon Feb  7 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-7
138- added 'delloem' command for Dell-specific IPMI extensions (#631649, #63793)
139
140* Wed Jun  2 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-6
141- Changed ipmievd to use /var/run/ipmievd.pid file by default (#596809)
142
143* Wed Mar  3 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-5
144- Fixed exit code of ipmievd initscript with wrong arguments (#562186)
145
146* Fri Dec 11 2009 Dennis Gregorovic <dgregor@redhat.com> - 1.8.11-4.1
147- Rebuilt for RHEL 6
148
149* Mon Nov  2 2009 Jan Safranek  <jsafrane@redhat.com> 1.8.11-4
150- fix ipmievd initscript 'condrestart' action (#532188)
151
152* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.8.11-3
153- rebuilt with new openssl
154
155* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.11-2
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
157
158* Thu Feb 26 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-1
159- updated to new version
160
161* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.10-4
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
163
164* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> 1.8.10-3
165- rebuild with new openssl
166
167* Tue Oct 14 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-2
168- fix issues found during package review:
169  - clear Default-Start: line in the init script, the service should be
170    disabled by default
171  - added Obsoletes: OpenIPMI-tools
172  - compile with --disable-dependency-tracking to speed things up
173  - compile with --enable-file-security
174  - compile with --disable-intf-free, don't depend on FreeIPMI libraries
175    (FreeIPMI has its own ipmitool-like utility)
176
177* Mon Oct 13 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-1
178- package created, based on upstream .spec file
Note: See TracBrowser for help on using the repository browser.