source: projects/specs/trunk/i/inkscape/inkscape-vl.spec @ 12291

Revision 12291, 9.2 KB checked in by ara_t, 5 years ago (diff)

inkscape: rebuild under VineSeed environment

RevLine 
[12129]1%define filever  A6N0YOn
[1987]2
[12129]3Name:     inkscape
4Summary:  A Vector Drawing Application
5Summary(ja):  ベクター描画アプリケーション
6Version:  0.92.4
[12291]7Release:  3%{?_dist_release}
[521]8
[12129]9Group:    Applications/Graphics
10License:  GPLv2+
11URL:      https://launchpad.net/inkscape
[941]12
[12129]13Source0:  https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}_%{filever}.tar.bz2
14
[11698]15# # to fix compile error with poppler>=0.58
16# Patch1000:  poppler-0.58.x.patch
17# Patch1001:  poppler-0.58.x-autotools.patch
[11313]18
[12271]19# # to fix compile error with poppler>=0.76.0
20# https://gitlab.com/inkscape/inkscape/issues/220
21Patch1002:  poppler-0.76.x.patch
[11313]22
[12129]23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
[521]25BuildRequires: gtk2-devel >= 2.8.0
[9791]26BuildRequires: gnome-vfs2-devel >= 2.0
[521]27BuildRequires: libxml2-devel >= 2.6.11
28BuildRequires: libxslt-devel >= 1.0.15
29BuildRequires: gc-devel >= 6.4
[9791]30BuildRequires: dbus-glib-devel
[521]31BuildRequires: libsigc++-devel >= 2.0.12
[9259]32BuildRequires: gtkmm2-devel >= 2.8.0
[521]33BuildRequires: libpng-devel >= 1.2.0
[8721]34BuildRequires: libwpg-devel
[9791]35BuildRequires: libexif-devel
36BuildRequires: libjpeg-turbo-devel
[12129]37BuildRequires: perl-XML-Parser
[6890]38BuildRequires: lcms2-devel
[2041]39BuildRequires: poppler-devel >= 0.14.2
[521]40BuildRequires: pango-devel, cairo-devel
41BuildRequires: gsl-devel
42BuildRequires: libboost-devel
[2041]43BuildRequires: popt-devel
44BuildRequires: ImageMagick-c++-devel
[9259]45BuildRequires: dos2unix
[12129]46BuildRequires: automake autoconf
47
[3965]48Requires:      python-lxml
49Requires:      perl-XML-RegExp
50Requires:      perl-XML-DOM
51Requires:      perl-XML-XQL
[9259]52# the package requires libperl.so, so it also has to require this:
53Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
[521]54
[9259]55# Filter out perl requires and provides
56# XXX: For now _all_
57%global __perl_provides %{nil}
58%global __perl_requires %{nil}
59
[7756]60Vendor: Project Vine
61Distribution: Vine Linux
62
[521]63%description
64Inkscape is a SVG based generic vector-drawing program for
65Linux/Unix/Windows/Mac.
66
67%description -l ja
68Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
69Linux/Unix/Windows/Mac で動作します。
70
71%prep
72%setup -q -n %{name}-%{version}
73
[11698]74# %patch1000 -p1
75# %patch1001 -p1
[12271]76%patch1002 -p1 -b .poppler0.76.x
[11313]77
[9259]78# https://bugs.launchpad.net/inkscape/+bug/314381
79# A couple of files have executable bits set,
80# despite not being executable
81find . -name '*.cpp' | xargs chmod -x
82find . -name '*.h' | xargs chmod -x
83find share/extensions -name '*.py' | xargs chmod -x
84
85# Fix end of line encodings
86dos2unix -k -q share/extensions/*.py
87
[521]88%build
[11313]89./autogen.sh
90
[9791]91export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
[521]92%configure \
[941]93    --with-gnome-vfs \
94    --with-inkjar \
[9791]95    --enable-poppler-cairo \
[12129]96    --disable-strict-build
[521]97
98make %{?_smp_mflags}
99
100%install
101rm -rf %{buildroot}
[1987]102
[6890]103make install DESTDIR=$RPM_BUILD_ROOT
[521]104
[1987]105rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
106
[521]107%find_lang %{name}
108
109%clean
110rm -rf %{buildroot}
111
[1987]112%post
113/sbin/ldconfig
114touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
115
116%postun
117if [ $1 -eq 0 ] ; then
118    update-desktop-database -q &> /dev/null
119    touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
120    gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
121fi
122
123%posttrans
124update-desktop-database -q &> /dev/null
125gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
126
127
[521]128%files -f %{name}.lang
129%defattr(-, root, root)
130%doc AUTHORS COPYING ChangeLog NEWS README
131%{_bindir}/inkscape
132%{_bindir}/inkview
[11313]133%{_datadir}/appdata/inkscape.appdata.xml
[521]134%{_datadir}/applications/*.desktop
[1987]135%{_datadir}/icons/hicolor/*
[521]136%{_datadir}/inkscape
137%{_mandir}/man1/*
[6011]138%{_mandir}/*/man1/*
[521]139
[12129]140
[521]141%changelog
[12291]142* Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-3
143- rebuild with OpenEXR-libs-2.4.0 (required by ImageMagick)
144
[12271]145* Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-2
146- rebuild with poppler-0.81.0 and gsl-2.6
147- add Patch1002 for poppler >= 0.76.0
148
149* Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-1
[12129]150- update to 0.92.4
151- drop unrecognized options: --with-python, --enable-lcms2
152
[11698]153* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
154- updated to 0.92.3
155- drop Patch1000,1001
156
[11313]157* Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
[11698]158- updated to 0.92.2
[11313]159
[10413]160* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
161- rebuild with gcc-5.4.0
162
[10266]163* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
164- rebuild with poppler-0.43.0
165
[9791]166* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
167- update to 0.91
168- remove old patches
169- add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
170
[9508]171* Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
172- rebuild with ImageMagick-6.9.1.1
173
[9259]174* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
175- rebuilt with libwpd 0.3.0
176- added Patch14 to build with libwpd 0.3.0
177
[8771]178* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
179- rebuild with poppler-0.26.2
180
[8721]181* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
182- new upstream release
183- add BuildRequires: libwpg-devel
184- remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
185
[8406]186* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
187- rebuild with poppler-0.24.5
188- add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
189
[8011]190* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
191- rebuild with ImageMagick-6.8.7.5
192
[7938]193* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
194- rebuild with poppler-0.24.2
195
[7766]196* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
197- rebuild with ImageMagick-6.8.6.8
198
[7756]199* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
200- new upstream release
201- remove Patch0 (inkscape-0.48.2-poppler_020.patch)
202
[6890]203* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
204- rebuild with poppler-0.20.4
205- add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
206- change BuildRequires: lcms2-devel instead of lcms-devel
207
[6011]208* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
209- new upstream release
210
[5879]211* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
212- rebuild with ImageMagick-6.7.5.10
213
[5568]214* Sat Feb  4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
215- new upstream release
216
[3965]217* Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
218- add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
219
[2998]220* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
221- new upstream release
222- built with poppler-0.16.3
223
[2041]224* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
225- rebuild with poppler-0.14.2
226- add BuildRequires: popt-devel, ImageMagick-c++-devel
227
[1987]228* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
229- new upstream release
230- rebuilt with ImageMagick-6.6.4.8
231
[941]232* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
233- added Patch0 for building with poppler-0.12.2+
234- rebuilt with new toolchain and ImageMagick-6.6.1.5
235- removed BR: libgnomeprint-devel, libgnomeprintui-devel
236
[521]237* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
238- rebuild with poppler-0.12.1
239
240* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
241- new upstream release
242- add BR: libboost-devel
243
244* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
245- update to 0.47pre2
246- drop obsolete patches
247- add BR: gsl-devel
248
249* Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
250- rebuild with poppler-0.10.2
251
252* Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
253- add Patch[1-6]
254
255* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
256- added inkscape-0.46-poppler-0.8.3.patch
257- spec in utf-8
258- added option %%{?_smp_mflags} at make
259
260* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
261- new upstream release
262
263* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
264- rebuild with new environment/toolchain
265
266* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
267- new upstream release
268
269* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
270- add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
271- update required version of gtk2-devel
272
273* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
274- new upstream release
275
276* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
277- new upstream release
278
279* Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
280- new upstream release
281
282* Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
283- new upstream release
284
285* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
286- new upstream release
287
288* Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
289- new upstream release
290
291* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
292- new upstream release
293- add Japanese summary and description
294- fixed dependancy of libsigc++12 to libsigc++ >= 2.0
295
296* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
297- fixed dependancy of libsigc++ to libsigc++12
298- fixed %files section
299
300* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
301- rebuild for Vine Linux
302- s/Copyright/License/
303- added Requires and BuildRequires
304
305* Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
306- Removing _libdir and TODO, updating description
307
308* Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
309- Fix up the spec file for current release
310
311* Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
312- Update to 0.2.6
313
314* Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
315- Update to 0.2.5
316- Changed SPEC to benefit from macros
Note: See TracBrowser for help on using the repository browser.