source: projects/specs/trunk/i/inkscape/inkscape-vl.spec @ 12555

Revision 12555, 10.0 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ImageMagick?-6.9.12.1-1

cmake-3.19.6-1

double-conversion-3.1.5-5

emacs-27.1-1

inkscape-1.0.2-1

potrace-1.16-1

pstoedit-3.75-2

Line 
1%global page_id  23820
2%global src_suffix 2021-01-15_e86c870879
3
4Name:           inkscape
5Summary:        A Vector Drawing Application
6Summary(ja):    ベクター描画アプリケーション
7Version:        1.0.2
8Release:        1%{?_dist_release}
9Group:          graphics
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        GPLv2+
14URL:            https://inkscape.org/
15Source0:        https://inkscape.org/ja/gallery/item/%{page_id}/inkscape-%{version}.tar.xz
16
17# # to fix compile error with poppler>=0.58
18# Patch1000:  poppler-0.58.x.patch
19# Patch1001:  poppler-0.58.x-autotools.patch
20
21# # to fix compile error with poppler>=0.76.0
22# https://gitlab.com/inkscape/inkscape/issues/220
23#Patch1002:  poppler-0.76.x.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27BuildRequires: cairo-devel
28BuildRequires: cmake
29BuildRequires: dos2unix
30BuildRequires: dbus-glib-devel
31BuildRequires: double-conversion-devel
32BuildRequires: gc-devel >= 6.4
33BuildRequires: gdl-devel
34BuildRequires: gsl-devel
35BuildRequires: gtkmm3-devel
36BuildRequires: ImageMagick-c++-devel
37BuildRequires: lcms2-devel
38BuildRequires: libboost-devel
39BuildRequires: libexif-devel
40BuildRequires: libjpeg-turbo-devel
41BuildRequires: libpng-devel >= 1.2.0
42BuildRequires: libsigc++-devel >= 2.0.12
43BuildRequires: libsoup-devel
44BuildRequires: libxml2-devel >= 2.6.11
45BuildRequires: libxslt-devel >= 1.0.15
46BuildRequires: libwpg-devel
47BuildRequires: pango-devel
48BuildRequires: perl-XML-Parser
49BuildRequires: poppler-devel >= 0.14.2
50BuildRequires: popt-devel
51BuildRequires: potrace-devel
52BuildRequires: python3-devel
53BuildRequires: python3-setuptools
54
55Requires:       python3
56Requires:       python3-lxml
57Requires:       python3-numpy
58#Requires:       python3-scour
59
60%description
61Inkscape is a SVG based generic vector-drawing program for
62Linux/Unix/Windows/Mac.
63
64%description -l ja
65Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
66Linux/Unix/Windows/Mac で動作します。
67
68
69%debug_package
70
71
72%prep
73%setup -q -n %{name}-%{version}_%{src_suffix}
74
75# %patch1000 -p1
76# %patch1001 -p1
77#patch1002 -p1 -b .poppler0.76.x
78
79# https://bugs.launchpad.net/inkscape/+bug/314381
80# A couple of files have executable bits set,
81# despite not being executable
82find . -name '*.cpp' | xargs chmod -x
83find . -name '*.h' | xargs chmod -x
84find share/extensions -name '*.py' | xargs chmod -x
85
86# Fix end of line encodings
87dos2unix -k -q share/extensions/*.py
88
89
90%build
91cmake \
92        -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
93        -DCMAKE_CXX_FLAGS_RELEASE:STRING="-DNDEBUG" \
94        -DCMAKE_Fortran_FLAGS_RELEASE:STRING="-DNDEBUG" \
95        -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
96        -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
97        -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
98        -DLIB_INSTALL_DIR:PATH=%{_libdir} \
99        -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
100        -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
101%if "%{_lib}" == "lib64"
102        -DLIB_SUFFIX=64 \
103%endif
104        -DBUILD_SHARED_LIBS:BOOL=OFF .
105
106make %{?_smp_mflags}
107
108
109%install
110rm -rf %{buildroot}
111
112make install DESTDIR=%{buildroot}
113find %{buildroot} -type f -name 'lib*.a' -delete
114
115rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
116
117%find_lang %{name} --with-man
118%find_lang inkview --with-man
119
120rm -rf $RPM_BUILD_ROOT%{_datadir}/inkscape/doc
121rm -f $RPM_BUILD_ROOT%{_datadir}/doc/inkscape/copyright
122
123
124%clean
125rm -rf %{buildroot}
126
127
128%post
129/sbin/ldconfig
130touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
131
132%postun
133if [ $1 -eq 0 ] ; then
134    update-desktop-database -q &> /dev/null
135    touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
136    gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
137fi
138
139%posttrans
140update-desktop-database -q &> /dev/null
141gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
142
143
144%files -f %{name}.lang -f inkview.lang
145%defattr(-, root, root)
146%license COPYING
147%doc AUTHORS NEWS* README*
148%{_bindir}/inkscape
149%{_bindir}/inkview
150%{_datadir}/inkscape
151%{_datadir}/metainfo/org.inkscape.Inkscape.appdata.xml
152%{_datadir}/applications/org.inkscape.Inkscape.desktop
153%{_datadir}/icons/hicolor/*/*/*.png
154%{_mandir}/man1/*
155%dir %{_datadir}/bash-completion
156%dir %{_datadir}/bash-completion/completions
157%{_datadir}/bash-completion/completions/inkscape
158
159
160%changelog
161* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.2-1
162- new upstream release.
163
164* Sun Oct 27 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-3
165- rebuild with OpenEXR-libs-2.4.0 (required by ImageMagick)
166
167* Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-2
168- rebuild with poppler-0.81.0 and gsl-2.6
169- add Patch1002 for poppler >= 0.76.0
170
171* Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.4-1
172- update to 0.92.4
173- drop unrecognized options: --with-python, --enable-lcms2
174
175* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
176- updated to 0.92.3
177- drop Patch1000,1001
178
179* Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
180- updated to 0.92.2
181
182* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
183- rebuild with gcc-5.4.0
184
185* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
186- rebuild with poppler-0.43.0
187
188* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
189- update to 0.91
190- remove old patches
191- add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
192
193* Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
194- rebuild with ImageMagick-6.9.1.1
195
196* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
197- rebuilt with libwpd 0.3.0
198- added Patch14 to build with libwpd 0.3.0
199
200* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
201- rebuild with poppler-0.26.2
202
203* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
204- new upstream release
205- add BuildRequires: libwpg-devel
206- remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
207
208* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
209- rebuild with poppler-0.24.5
210- add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
211
212* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
213- rebuild with ImageMagick-6.8.7.5
214
215* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
216- rebuild with poppler-0.24.2
217
218* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
219- rebuild with ImageMagick-6.8.6.8
220
221* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
222- new upstream release
223- remove Patch0 (inkscape-0.48.2-poppler_020.patch)
224
225* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
226- rebuild with poppler-0.20.4
227- add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
228- change BuildRequires: lcms2-devel instead of lcms-devel
229
230* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
231- new upstream release
232
233* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
234- rebuild with ImageMagick-6.7.5.10
235
236* Sat Feb  4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
237- new upstream release
238
239* Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
240- add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
241
242* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
243- new upstream release
244- built with poppler-0.16.3
245
246* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
247- rebuild with poppler-0.14.2
248- add BuildRequires: popt-devel, ImageMagick-c++-devel
249
250* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
251- new upstream release
252- rebuilt with ImageMagick-6.6.4.8
253
254* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
255- added Patch0 for building with poppler-0.12.2+
256- rebuilt with new toolchain and ImageMagick-6.6.1.5
257- removed BR: libgnomeprint-devel, libgnomeprintui-devel
258
259* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
260- rebuild with poppler-0.12.1
261
262* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
263- new upstream release
264- add BR: libboost-devel
265
266* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
267- update to 0.47pre2
268- drop obsolete patches
269- add BR: gsl-devel
270
271* Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
272- rebuild with poppler-0.10.2
273
274* Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
275- add Patch[1-6]
276
277* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
278- added inkscape-0.46-poppler-0.8.3.patch
279- spec in utf-8
280- added option %%{?_smp_mflags} at make
281
282* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
283- new upstream release
284
285* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
286- rebuild with new environment/toolchain
287
288* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
289- new upstream release
290
291* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
292- add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
293- update required version of gtk2-devel
294
295* Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
296- new upstream release
297
298* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
299- new upstream release
300
301* Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
302- new upstream release
303
304* Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
305- new upstream release
306
307* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
308- new upstream release
309
310* Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
311- new upstream release
312
313* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
314- new upstream release
315- add Japanese summary and description
316- fixed dependancy of libsigc++12 to libsigc++ >= 2.0
317
318* Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
319- fixed dependancy of libsigc++ to libsigc++12
320- fixed %files section
321
322* Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
323- rebuild for Vine Linux
324- s/Copyright/License/
325- added Requires and BuildRequires
326
327* Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
328- Removing _libdir and TODO, updating description
329
330* Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
331- Fix up the spec file for current release
332
333* Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
334- Update to 0.2.6
335
336* Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
337- Update to 0.2.5
338- Changed SPEC to benefit from macros
Note: See TracBrowser for help on using the repository browser.