source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 3557

Revision 3557, 9.4 KB checked in by iwaim, 13 years ago (diff)

ibus-1.3.9-4

Line 
1%define ver 1.3.9
2%define rel 4
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
13Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
14Requires: notify-python
15Requires: librsvg2
16Requires(pre): GConf2
17Requires(post): GConf2
18Requires(preun): GConf2
19Requires(post): glib2
20Requires(post,postun): coreutils, gtk2
21BuildRequires(install,check): desktop-file-utils
22BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
23BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
24BuildRequires: glib2-devel >= 2.0.0
25%if %{?_dist_release} != "vl5"
26BuildRequires: gtk3-devel >= 3.0.0
27%endif
28BuildRequires: GConf2-devel >= 2.12
29BuildRequires: perl >= 5.8.1 perl-XML-Parser
30Buildrequires: python >= 2.5
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32Provides: iBus
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: iwaim
37
38%description
39IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
40It provides full featured and user friendly input method user interface.
41It also may help developers to develop input method easily.
42
43%package devel
44Summary: Header files for iBus
45Group: Development/Libraries
46Requires: ibus == %{version}-%{release}
47Requires:   glib2-devel
48Requires:   dbus-devel
49Requires:   vala
50
51%description devel
52Header files for iBus.
53
54%if %{?_dist_release} != "vl5"
55%package gtk3
56Summary: Ibus im module for gtk3
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires(post): glib2
60
61%description gtk3
62The ibus-gtk3 contains ibus im module for gtk3.
63
64%endif
65
66%prep
67%setup -q
68%patch0 -p1
69%configure \
70        --disable-static \
71%if %{?_dist_release} != "vl5"
72        --enable-gtk3 \
73%endif
74        --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
75
76%build
77make %{?_smp_mflags}
78
79%install
80rm -rf %{buildroot}
81make DESTDIR=%{buildroot} install
82
83rm -rf %{buildroot}%{_libdir}/libibus.la
84rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
85%if %{?_dist_release} != "vl5"
86rm -rf %{buildroot}%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.la
87%endif
88
89rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
90
91%find_lang %{name}
92
93%clean
94rm -rf %{buildroot}
95
96%check
97#make check
98%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
99%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
100
101
102%post
103/sbin/ldconfig
104if [ -x %{_bindir}/update-desktop-database ] ; then
105%{_bindir}/update-desktop-database %{_datadir}/applications -q
106fi
107%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
108export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
110# recreate icon cache
111touch --no-create %{_datadir}/icons/hicolor || :
112[ -x %{_bindir}/gtk-update-icon-cache ] && \
113  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114
115
116%pre
117if [ "$1" -gt 1 ]; then
118    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
120fi
121
122
123%preun
124if [ "$1" -eq 0 ]; then
125    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
126    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
127fi
128
129
130%postun
131/sbin/ldconfig
132%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
133if [ -x %{_bindir}/update-desktop-database ] ; then
134%{_bindir}/update-desktop-database %{_datadir}/applications -q
135fi
136# recreate icon cache
137touch --no-create %{_datadir}/icons/hicolor || :
138[ -x %{_bindir}/gtk-update-icon-cache ] && \
139  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
140
141%if %{?_dist_release} != "vl5"
142%post gtk3
143%{_bindir}/gtk-query-immodules-3.0 --update-cache
144
145%postun gtk3
146%{_bindir}/gtk-query-immodules-3.0 --update-cache
147
148%endif
149
150%files -f %{name}.lang
151%defattr(-,root,root,-)
152%doc AUTHORS COPYING ChangeLog NEWS README
153%{_bindir}/ibus*
154%{_libdir}/libibus.so.*
155%{_libdir}/gtk-2.0/immodules/im-ibus.so
156%{_libexecdir}/ibus-gconf
157%{_libexecdir}/ibus-ui-gtk
158%{_libexecdir}/ibus-x11
159#%{python_sitearch}/ibus
160%{python_sitelib}/ibus
161%{_datadir}/applications/*
162%{_datadir}/ibus
163%{_datadir}/gtk-doc/html/ibus
164%{_datadir}/icons/hicolor/*/apps/*
165#%{_sysconfdir}/xdg/autostart/ibus.desktop
166%{_sysconfdir}/gconf/schemas/ibus.schemas
167
168%files devel
169%defattr(-,root,root,-)
170%{_libdir}/pkgconfig/ibus-1.0.pc
171%{_libdir}/libibus.so
172%{_includedir}/ibus-1.0
173%{_datadir}/vala/vapi/ibus-1.0.vapi
174%if %{?_dist_release} != "vl5"
175%{_libdir}/girepository-1.0/IBus-1.0.typelib
176%{_datadir}/gir-1.0/IBus-1.0.gir
177%endif
178
179%if %{?_dist_release} != "vl5"
180%files gtk3
181%defattr(-,root,root,-)
182%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
183%endif
184
185%changelog
186* Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.9-4vl6
187- drop {post,postun} script for gtk3 immodules in main package
188
189* Fri Apr  8 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.9-3vl6
190- drop GTK3 immodule file in main package
191
192* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.9-2
193- create -gtk3 sub package (VineSeed only)
194
195* Wed Dec 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.9-1
196- new upstream release
197- add files in devel sub package for VineSeed
198 - girepository-1.0/IBus-1.0.typelib
199 - gir-1.0/IBus-1.0.gir
200
201* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.7-2
202- rebuilt with rpm-4.8.1 for pkg-config
203
204* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
205- new upstream release
206- add support Vala on Vine Linux 5
207
208* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
209- new upstream release
210
211* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
212- new upstream release
213- update GTK immodule dir option for configure
214- add vapi file for VineSeed
215- add Requires: vala for devel package, VineSeed
216
217* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
218- update Requires: notify-python librsvg2
219- execute gconftool-2 on {post,pre,preun}
220- add Requires: Gconf2 on {post,pre,preun}
221- update Requires: glib2-devel dbus-devel for ibus-devel package
222- execute update-desktop-database on {post,postun}
223- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
224- add Requires: coreutils, gtk2 on {post,postun}
225- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
226
227* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
228- new upstream release
229- stop 'make check'
230
231* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
232- s/python_sitearch/python_sitelib/
233
234* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
235- new upstream release
236- execute 'make check'
237- clean up:
238  - drop unused git_source and vine_ja_po
239
240* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
241- new upstream release
242- stop 'make check'
243
244* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
245- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
246
247* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
248- new upstream release
249
250* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
251- new upstream release
252
253* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
254- new upstream release
255
256* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
257- new upstream release
258- add fix POFILES.in patch (Patch0)
259- update file list in %%files section
260- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
261
262* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
263- new upstream release
264
265* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
266- new upstream release
267- update %%files section
268- update BuildRequires
269- drop obsoleted configure option: --disable-qt4-immodule
270
271* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
272- new upstream release
273
274* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
275- new upstream release
276- add Packager tag
277
278* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
279- new upstream release
280
281* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
282- new upstream release
283- update BuildRequires
284  - add dbus-devel, intltool >= 0.40.0
285  - drop qt4-devel
286
287* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
288- new upstream release
289- drop defined python_sitearch rpm macro
290
291* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
292- new upstream release
293
294* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
295- new upstream release
296- drop Vine ja.po (SOURCE1)
297
298* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
299- new upstream release
300- update ja.po (SOURCE1)
301
302* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
303- new upstream release
304
305* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
306- add ja.po (SOURCE1): update
307- add ibus.desktop file in xdg autostart
308- add ibus.schemas file
309
310* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
311- set python_sitearch to arch independent path
312
313* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
314- new upstream release
315- add dbus-python version ( 0.83.0 and more ) in Requires
316- add BuildRequires: dbus-python-devel >= 0.83.0
317
318* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
319- new upstream release
320- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
321- generate devel sub package
322- stop creating qt4 immodule
323- drop .la files
324
325* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
326- initial release
Note: See TracBrowser for help on using the repository browser.