source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 3354

Revision 3354, 9.4 KB checked in by iwaim, 13 years ago (diff)

ibus-1.3.9-3

Line 
1%define ver 1.3.9
2%define rel 3
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
13Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
14Requires: notify-python
15Requires: librsvg2
16Requires(pre): GConf2
17Requires(post): GConf2
18Requires(preun): GConf2
19Requires(post): glib2
20Requires(post,postun): coreutils, gtk2
21BuildRequires(install,check): desktop-file-utils
22BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
23BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
24BuildRequires: glib2-devel >= 2.0.0
25%if %{?_dist_release} != "vl5"
26BuildRequires: gtk3-devel >= 3.0.0
27%endif
28BuildRequires: GConf2-devel >= 2.12
29BuildRequires: perl >= 5.8.1 perl-XML-Parser
30Buildrequires: python >= 2.5
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32Provides: iBus
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: iwaim
37
38%description
39IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
40It provides full featured and user friendly input method user interface.
41It also may help developers to develop input method easily.
42
43%package devel
44Summary: Header files for iBus
45Group: Development/Libraries
46Requires: ibus == %{version}-%{release}
47Requires:   glib2-devel
48Requires:   dbus-devel
49Requires:   vala
50
51%description devel
52Header files for iBus.
53
54%if %{?_dist_release} != "vl5"
55%package gtk3
56Summary: Ibus im module for gtk3
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires(post): glib2
60
61%description gtk3
62The ibus-gtk3 contains ibus im module for gtk3.
63
64%endif
65
66%prep
67%setup -q
68%patch0 -p1
69%configure \
70        --disable-static \
71%if %{?_dist_release} != "vl5"
72        --enable-gtk3 \
73%endif
74        --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
75
76%build
77make %{?_smp_mflags}
78
79%install
80rm -rf %{buildroot}
81make DESTDIR=%{buildroot} install
82
83rm -rf %{buildroot}%{_libdir}/libibus.la
84rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
85%if %{?_dist_release} != "vl5"
86rm -rf %{buildroot}%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.la
87%endif
88
89rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
90
91%find_lang %{name}
92
93%clean
94rm -rf %{buildroot}
95
96%check
97#make check
98%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
99%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
100
101
102%post
103/sbin/ldconfig
104if [ -x %{_bindir}/update-desktop-database ] ; then
105%{_bindir}/update-desktop-database %{_datadir}/applications -q
106fi
107%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
108%{_bindir}/gtk-query-immodules-3.0 --update-cache
109export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
111# recreate icon cache
112touch --no-create %{_datadir}/icons/hicolor || :
113[ -x %{_bindir}/gtk-update-icon-cache ] && \
114  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
115
116
117%pre
118if [ "$1" -gt 1 ]; then
119    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
120    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
121fi
122
123
124%preun
125if [ "$1" -eq 0 ]; then
126    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
128fi
129
130
131%postun
132/sbin/ldconfig
133%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
134%{_bindir}/gtk-query-immodules-3.0 --update-cache
135if [ -x %{_bindir}/update-desktop-database ] ; then
136%{_bindir}/update-desktop-database %{_datadir}/applications -q
137fi
138# recreate icon cache
139touch --no-create %{_datadir}/icons/hicolor || :
140[ -x %{_bindir}/gtk-update-icon-cache ] && \
141  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
142
143%if %{?_dist_release} != "vl5"
144%post gtk3
145%{_bindir}/gtk-query-immodules-3.0 --update-cache
146
147%postun gtk3
148%{_bindir}/gtk-query-immodules-3.0 --update-cache
149
150%endif
151
152%files -f %{name}.lang
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING ChangeLog NEWS README
155%{_bindir}/ibus*
156%{_libdir}/libibus.so.*
157%{_libdir}/gtk-2.0/immodules/im-ibus.so
158%{_libexecdir}/ibus-gconf
159%{_libexecdir}/ibus-ui-gtk
160%{_libexecdir}/ibus-x11
161#%{python_sitearch}/ibus
162%{python_sitelib}/ibus
163%{_datadir}/applications/*
164%{_datadir}/ibus
165%{_datadir}/gtk-doc/html/ibus
166%{_datadir}/icons/hicolor/*/apps/*
167#%{_sysconfdir}/xdg/autostart/ibus.desktop
168%{_sysconfdir}/gconf/schemas/ibus.schemas
169
170%files devel
171%defattr(-,root,root,-)
172%{_libdir}/pkgconfig/ibus-1.0.pc
173%{_libdir}/libibus.so
174%{_includedir}/ibus-1.0
175%{_datadir}/vala/vapi/ibus-1.0.vapi
176%if %{?_dist_release} != "vl5"
177%{_libdir}/girepository-1.0/IBus-1.0.typelib
178%{_datadir}/gir-1.0/IBus-1.0.gir
179%endif
180
181%if %{?_dist_release} != "vl5"
182%files gtk3
183%defattr(-,root,root,-)
184%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
185%endif
186
187%changelog
188* Fri Apr  8 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.9-3vl6
189- drop GTK3 immodule file in main package
190
191* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.9-2
192- create -gtk3 sub package (VineSeed only)
193
194* Wed Dec 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.9-1
195- new upstream release
196- add files in devel sub package for VineSeed
197 - girepository-1.0/IBus-1.0.typelib
198 - gir-1.0/IBus-1.0.gir
199
200* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.7-2
201- rebuilt with rpm-4.8.1 for pkg-config
202
203* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
204- new upstream release
205- add support Vala on Vine Linux 5
206
207* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
208- new upstream release
209
210* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
211- new upstream release
212- update GTK immodule dir option for configure
213- add vapi file for VineSeed
214- add Requires: vala for devel package, VineSeed
215
216* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
217- update Requires: notify-python librsvg2
218- execute gconftool-2 on {post,pre,preun}
219- add Requires: Gconf2 on {post,pre,preun}
220- update Requires: glib2-devel dbus-devel for ibus-devel package
221- execute update-desktop-database on {post,postun}
222- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
223- add Requires: coreutils, gtk2 on {post,postun}
224- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
225
226* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
227- new upstream release
228- stop 'make check'
229
230* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
231- s/python_sitearch/python_sitelib/
232
233* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
234- new upstream release
235- execute 'make check'
236- clean up:
237  - drop unused git_source and vine_ja_po
238
239* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
240- new upstream release
241- stop 'make check'
242
243* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
244- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
245
246* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
247- new upstream release
248
249* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
250- new upstream release
251
252* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
253- new upstream release
254
255* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
256- new upstream release
257- add fix POFILES.in patch (Patch0)
258- update file list in %%files section
259- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
260
261* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
262- new upstream release
263
264* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
265- new upstream release
266- update %%files section
267- update BuildRequires
268- drop obsoleted configure option: --disable-qt4-immodule
269
270* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
271- new upstream release
272
273* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
274- new upstream release
275- add Packager tag
276
277* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
278- new upstream release
279
280* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
281- new upstream release
282- update BuildRequires
283  - add dbus-devel, intltool >= 0.40.0
284  - drop qt4-devel
285
286* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
287- new upstream release
288- drop defined python_sitearch rpm macro
289
290* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
291- new upstream release
292
293* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
294- new upstream release
295- drop Vine ja.po (SOURCE1)
296
297* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
298- new upstream release
299- update ja.po (SOURCE1)
300
301* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
302- new upstream release
303
304* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
305- add ja.po (SOURCE1): update
306- add ibus.desktop file in xdg autostart
307- add ibus.schemas file
308
309* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
310- set python_sitearch to arch independent path
311
312* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
313- new upstream release
314- add dbus-python version ( 0.83.0 and more ) in Requires
315- add BuildRequires: dbus-python-devel >= 0.83.0
316
317* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
318- new upstream release
319- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
320- generate devel sub package
321- stop creating qt4 immodule
322- drop .la files
323
324* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
325- initial release
Note: See TracBrowser for help on using the repository browser.