source: projects/specs/trunk/i/ibus/ibus-vl.spec @ 2721

Revision 2721, 9.4 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release and new package: gtk3

Line 
1%define ver 1.3.9
2%define rel 2
3
4Summary: Intelligent Input Bus for Linux / Unix OS
5Name: ibus
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10URL: http://code.google.com/p/ibus/
11Source0: %{name}-%{version}.tar.gz
12Patch0: ibus-1.2.0.20091024-fixPOFILES.in.patch
13Requires: gtk2, pyxdg, iso-codes, dbus-python >= 0.83.0
14%if %{?_dist_release} != "vl5"
15Requires: gtk3
16%endif
17Requires: notify-python
18Requires: librsvg2
19Requires(pre): GConf2
20Requires(post): GConf2
21Requires(preun): GConf2
22Requires(post): glib2
23Requires(post,postun): coreutils, gtk2
24BuildRequires(install,check): desktop-file-utils
25BuildRequires: gettext >= 0.16.1, gtk2-devel, intltool >= 0.40.0
26BuildRequires: dbus-devel, dbus-python-devel >= 0.83.0
27BuildRequires: glib2-devel >= 2.0.0
28%if %{?_dist_release} != "vl5"
29BuildRequires: gtk3-devel >= 3.0.0
30%endif
31BuildRequires: GConf2-devel >= 2.12
32BuildRequires: perl >= 5.8.1 perl-XML-Parser
33Buildrequires: python >= 2.5
34Buildroot: %{_tmppath}/%{name}-%{version}-root
35Provides: iBus
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: iwaim
40
41%description
42IBus is an Intelligent Input Bus. It is a new input framework for Linux OS.
43It provides full featured and user friendly input method user interface.
44It also may help developers to develop input method easily.
45
46%package devel
47Summary: Header files for iBus
48Group: Development/Libraries
49Requires: ibus == %{version}-%{release}
50Requires:   glib2-devel
51Requires:   dbus-devel
52Requires:   vala
53
54%description devel
55Header files for iBus.
56
57%if %{?_dist_release} != "vl5"
58%package gtk3
59Summary: Ibus im module for gtk3
60Group: System Environment/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires(post): glib2
63
64%description gtk3
65The ibus-gtk3 contains ibus im module for gtk3.
66
67%endif
68
69%prep
70%setup -q
71%patch0 -p1
72%configure \
73        --disable-static \
74%if %{?_dist_release} != "vl5"
75        --enable-gtk3 \
76%endif
77        --with-gtk2-im-module-dir=%{_libdir}/gtk-2.0/immodules
78
79%build
80make %{?_smp_mflags}
81
82%install
83rm -rf %{buildroot}
84make DESTDIR=%{buildroot} install
85
86rm -rf %{buildroot}%{_libdir}/libibus.la
87rm -rf %{buildroot}%{_libdir}/gtk-2.0/immodules/im-ibus.la
88%if %{?_dist_release} != "vl5"
89rm -rf %{buildroot}%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.la
90%endif
91
92rm -rf %{buildroot}%{_sysconfdir}/xdg/autostart/ibus.desktop
93
94%find_lang %{name}
95
96%clean
97rm -rf %{buildroot}
98
99%check
100#make check
101%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus.desktop
102%{_bindir}/desktop-file-validate %{buildroot}/%{_datadir}/applications/ibus-setup.desktop
103
104
105%post
106/sbin/ldconfig
107if [ -x %{_bindir}/update-desktop-database ] ; then
108%{_bindir}/update-desktop-database %{_datadir}/applications -q
109fi
110%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
111%{_bindir}/gtk-query-immodules-3.0 --update-cache
112export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
113gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
114# recreate icon cache
115touch --no-create %{_datadir}/icons/hicolor || :
116[ -x %{_bindir}/gtk-update-icon-cache ] && \
117  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
118
119
120%pre
121if [ "$1" -gt 1 ]; then
122    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
123    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
124fi
125
126
127%preun
128if [ "$1" -eq 0 ]; then
129    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
130    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ibus.schemas >& /dev/null || :
131fi
132
133
134%postun
135/sbin/ldconfig
136%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
137%{_bindir}/gtk-query-immodules-3.0 --update-cache
138if [ -x %{_bindir}/update-desktop-database ] ; then
139%{_bindir}/update-desktop-database %{_datadir}/applications -q
140fi
141# recreate icon cache
142touch --no-create %{_datadir}/icons/hicolor || :
143[ -x %{_bindir}/gtk-update-icon-cache ] && \
144  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
145
146%if %{?_dist_release} != "vl5"
147%post gtk3
148%{_bindir}/gtk-query-immodules-3.0 --update-cache
149
150%postun gtk3
151%{_bindir}/gtk-query-immodules-3.0 --update-cache
152
153%endif
154
155%files -f %{name}.lang
156%defattr(-,root,root,-)
157%doc AUTHORS COPYING ChangeLog NEWS README
158%{_bindir}/ibus*
159%{_libdir}/libibus.so.*
160%{_libdir}/gtk-2.0/immodules/im-ibus.so
161%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
162%{_libexecdir}/ibus-gconf
163%{_libexecdir}/ibus-ui-gtk
164%{_libexecdir}/ibus-x11
165#%{python_sitearch}/ibus
166%{python_sitelib}/ibus
167%{_datadir}/applications/*
168%{_datadir}/ibus
169%{_datadir}/gtk-doc/html/ibus
170%{_datadir}/icons/hicolor/*/apps/*
171#%{_sysconfdir}/xdg/autostart/ibus.desktop
172%{_sysconfdir}/gconf/schemas/ibus.schemas
173
174%files devel
175%defattr(-,root,root,-)
176%{_libdir}/pkgconfig/ibus-1.0.pc
177%{_libdir}/libibus.so
178%{_includedir}/ibus-1.0
179%{_datadir}/vala/vapi/ibus-1.0.vapi
180%if %{?_dist_release} != "vl5"
181%{_libdir}/girepository-1.0/IBus-1.0.typelib
182%{_datadir}/gir-1.0/IBus-1.0.gir
183%endif
184
185%if %{?_dist_release} != "vl5"
186%files gtk3
187%defattr(-,root,root,-)
188%{_libdir}/gtk-3.0/3.0.0/immodules/im-ibus.so
189%endif
190
191%changelog
192* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.9-2
193- create -gtk3 sub package (VineSeed only)
194
195* Wed Dec 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.9-1
196- new upstream release
197- add files in devel sub package for VineSeed
198 - girepository-1.0/IBus-1.0.typelib
199 - gir-1.0/IBus-1.0.gir
200
201* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.7-2
202- rebuilt with rpm-4.8.1 for pkg-config
203
204* Mon Aug  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.7-1
205- new upstream release
206- add support Vala on Vine Linux 5
207
208* Fri Jul  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
209- new upstream release
210
211* Tue Jun 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.5-1
212- new upstream release
213- update GTK immodule dir option for configure
214- add vapi file for VineSeed
215- add Requires: vala for devel package, VineSeed
216
217* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-2
218- update Requires: notify-python librsvg2
219- execute gconftool-2 on {post,pre,preun}
220- add Requires: Gconf2 on {post,pre,preun}
221- update Requires: glib2-devel dbus-devel for ibus-devel package
222- execute update-desktop-database on {post,postun}
223- execute gtk-update-icon-cache on {post,postun}: <BTS:VineLinux:955>
224- add Requires: coreutils, gtk2 on {post,postun}
225- drop %%{_sysconfdir}/xdg/autostart/ibus.desktop file
226
227* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.4-1
228- new upstream release
229- stop 'make check'
230
231* Tue May 25 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.3-2
232- s/python_sitearch/python_sitelib/
233
234* Sat May 15 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.3-1
235- new upstream release
236- execute 'make check'
237- clean up:
238  - drop unused git_source and vine_ja_po
239
240* Fri Apr 16 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.1-1
241- new upstream release
242- stop 'make check'
243
244* Mon Jan 25 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-2
245- add BuildRequires: GConf2-devel >= 2.12: fix <BTS:VineLinux:901>
246
247* Fri Dec 18 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091215-1
248- new upstream release
249
250* Sat Dec  5 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091204-1
251- new upstream release
252
253* Sun Nov 29 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091124-1
254- new upstream release
255
256* Wed Nov  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20091024-1
257- new upstream release
258- add fix POFILES.in patch (Patch0)
259- update file list in %%files section
260- running ldconfig and gtk-query-immodules-2.0 in %%post and %%postun
261
262* Thu Oct  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090927-1
263- new upstream release
264
265* Thu Sep 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.2.0.20090915-1
266- new upstream release
267- update %%files section
268- update BuildRequires
269- drop obsoleted configure option: --disable-qt4-immodule
270
271* Fri Aug 28 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090812-1
272- new upstream release
273
274* Sat Jun 20 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090612-1
275- new upstream release
276- add Packager tag
277
278* Tue Jun  2 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090531-1
279- new upstream release
280
281* Sat May  9 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090508-1
282- new upstream release
283- update BuildRequires
284  - add dbus-devel, intltool >= 0.40.0
285  - drop qt4-devel
286
287* Sun Apr 26 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090423-1
288- new upstream release
289- drop defined python_sitearch rpm macro
290
291* Fri Apr 17 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090417-1
292- new upstream release
293
294* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090413-1
295- new upstream release
296- drop Vine ja.po (SOURCE1)
297
298* Wed Apr  8 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090407-1
299- new upstream release
300- update ja.po (SOURCE1)
301
302* Sat Apr  4 2009 IWAI, Masaharu <iwai@alib.jp> 1.1.0.20090331-1
303- new upstream release
304
305* Sat Mar 21 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-3
306- add ja.po (SOURCE1): update
307- add ibus.desktop file in xdg autostart
308- add ibus.schemas file
309
310* Fri Mar 20 2009 Shu KONNO <owa@bg.wakwak.com> - 1.1.0.20090311-2
311- set python_sitearch to arch independent path
312
313* Tue Mar 17 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090311-1
314- new upstream release
315- add dbus-python version ( 0.83.0 and more ) in Requires
316- add BuildRequires: dbus-python-devel >= 0.83.0
317
318* Mon Feb 23 2009 IWAI, Masaharu <iwai@alib.jp> - 1.1.0.20090217-1
319- new upstream release
320- add Requires: iso-codes, dbus-python: <BTS:VineLinux:656>
321- generate devel sub package
322- stop creating qt4 immodule
323- drop .la files
324
325* Mon Jan 26 2009 IWAI, Masaharu <iwai@alib.jp> - 0.1.1.20090126-1
326- initial release
Note: See TracBrowser for help on using the repository browser.