source: projects/specs/trunk/h/haveged/haveged-vl.spec @ 8792

Revision 8792, 5.6 KB checked in by tomop, 10 years ago (diff)

haveged-1.9.1-1

Line 
1Summary:        A Linux entropy source using the HAVEGE algorithm
2Summary(ja):    HAVEFE アルゴリズムを使った Linux のエントロピーソース
3Name:           haveged
4Version:        1.9.1
5Release:        1%{?_dist_release}
6License:        GPLv3+
7BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
8Group:          System Environment/Daemons
9URL:            http://www.irisa.fr/caps/projects/hipsor/
10Source0:        http://www.issihosts.com/haveged/%{name}-%{version}.tar.gz
11
12Requires(post):   chkconfig
13Requires(preun):  chkconfig, initscripts
14Requires(postun): initscripts
15
16BuildRequires:  automake gdb coreutils glibc-common
17
18%description
19A Linux entropy source using the HAVEGE algorithm
20
21Haveged is a user space entropy daemon which is not dependent upon the
22standard mechanisms for harvesting randomness for the system entropy
23pool. This is important in systems with high entropy needs or limited
24user interaction (e.g. headless servers).
25 
26Haveged uses HAVEGE (HArdware Volatile Entropy Gathering and Expansion)
27to maintain a 1M pool of random bytes used to fill /dev/random
28whenever the supply of random bits in /dev/random falls below the low
29water mark of the device. The principle inputs to haveged are the
30sizes of the processor instruction and data caches used to setup the
31HAVEGE collector. The haveged default is a 4kb data cache and a 16kb
32instruction cache. On machines with a cpuid instruction, haveged will
33attempt to select appropriate values from internal tables.
34
35%package devel
36Summary:   Headers and shared development libraries for HAVEGE algorithm
37Summary(ja):   Headers and shared development libraries for HAVEGE algorithm
38Group:     Development/Libraries
39Requires:  %{name} = %{version}-%{release}
40
41%description devel
42Headers and shared object symbolic links for the HAVEGE algorithm
43
44%prep
45%setup -q
46
47%build
48#autoreconf -fiv
49
50%configure --enable-init=sysv.redhat
51
52#SMP build is not working
53#make %{?_smp_mflags}
54make
55
56%check
57make check
58
59
60%install
61rm -rf %{buildroot}
62make install DESTDIR=%{buildroot} INSTALL="install -p"
63
64chmod 0644 COPYING README ChangeLog AUTHORS
65
66# We don't ship .la files.
67rm -rf %{buildroot}%{_libdir}/libhavege.*a
68
69%clean
70rm -rf %{buildroot}
71
72%post
73/sbin/chkconfig --add haveged
74
75%preun
76if [ "$1" -eq "0" ]; then
77  /sbin/service haveged stop >/dev/null 2>&1
78  /sbin/chkconfig --del haveged
79fi
80
81%postun
82if [ "$1" -ge "1" ]; then
83  /sbin/service haveged condrestart >/dev/null 2>&1
84fi
85
86%files
87%defattr(-, root, root, -)
88%doc COPYING README ChangeLog AUTHORS contrib/build/havege_sample.c
89%{_mandir}/man8/haveged.8*
90%{_sbindir}/haveged
91%{_libdir}/*so.*
92%{_sysconfdir}/init.d/haveged
93
94%files devel
95%defattr(-, root, root, -)
96%{_mandir}/man3/libhavege.3*
97%dir %{_includedir}/%{name}
98%{_includedir}/%{name}/havege.h
99%{_libdir}/*.so
100
101
102%changelog
103* Sat Jul 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.1-1
104- new upstream release.
105
106* Sun Mar 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7a-1
107- update to 1.7a
108
109* Sat Mar 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-1
110- initial build for Vine Linux
111
112* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-1
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
114
115* Sat Jan 19 2013 Jirka Hladky <hladky.jiri@gmail.com> - 1.7-0
116- Updated to the version 1.7
117- Version 1.7 brings developement libraries
118- Added devel package
119* Sat Oct 13 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-2
120- BZ 850144
121- Introduce new systemd-rpm macros in haveged spec file
122- Fedora 19 changes the way how to work with services in spec files.
123- It introduces new macros - systemd_post, systemd_preun and systemd_postun;
124- which replace scriptlets from Fedora 18 and older
125- see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
126
127* Tue Aug 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-1
128- Update to the version 1.5
129- Main new feature is a run time verification of the produced random numbers
130- PIDFILE set to /run/haveged.pid
131- converted README and man page to UTF-8. Informed the upstream to fix it.
132* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-3
133- PIDFile should be stored at /run instead of the default location /var/run
134- There is  long term plan that directory /var/run will not further exist in the future Fedora versions
135- Asked upstream to add -p <PID_FILE_location> switch to influence the location of the PID File
136- Set PIDFile=/var/run/haveged.pid This is needed as long -p option is not implemented
137- https://bugzilla.redhat.com/show_bug.cgi?id=770306#c10
138* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-2
139- Updated systemd service file, https://bugzilla.redhat.com/show_bug.cgi?id=770306
140* Tue Feb 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-1
141- Update to the version 1.4
142- Conversion to systemd, drop init script
143* Sun Nov 06 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-2
144- Fixed a bug on non x86 systems
145* Sat Nov 05 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-1
146- update from the upstream (1.3 stable)
147* Mon Oct 03 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-0
148-version 1.3 beta
149* Fri Sep 30 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-4
150- ppc64 build
151* Mon Sep 26 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-3
152- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c11
153* Sat Sep 24 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-2
154- Added comment to explain why we need use Fedora specific start script
155* Wed Sep 21 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-1
156- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c1
157* Wed Sep 07 2011  Jirka Hladky <hladky.jiri@gmail.com> - 1.2-0
158- Initial build
Note: See TracBrowser for help on using the repository browser.