source: projects/specs/trunk/h/haveged/haveged-vl.spec @ 12346

Revision 12346, 5.8 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

ca-certificates-2020.2.40-1

dmidecode-3.2-1

dnsmasq-2.80-2

golang-1.14.1-1

gthumb-3.8.3-1

haveged-1.9.8-1

iw-5.4-1

liblockfile-1.14-6

libnl3-3.5.0-1

libvisio-0.1.7-2

mailx-8.1.2.20180807-1

strace-5.5-1

tzdata-2019c-1

zlib-1.2.11-2

Line 
1Summary:        A Linux entropy source using the HAVEGE algorithm
2Summary(ja):    HAVEFE アルゴリズムを使った Linux のエントロピーソース
3Name:           haveged
4Version:        1.9.8
5Release:        1%{?_dist_release}
6Group:          System Environment/Daemons
7Vendor:         Project Vine
8Distribution:   Vine Linux
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
10
11License:        GPLv3+
12URL:            https://github.com/jirka-h/haveged
13Source0:        https://github.com/jirka-h/haveged/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
14
15Requires(post):   chkconfig
16Requires(preun):  chkconfig, initscripts
17Requires(postun): initscripts
18
19BuildRequires:  automake gdb coreutils glibc-common
20
21%description
22A Linux entropy source using the HAVEGE algorithm
23
24Haveged is a user space entropy daemon which is not dependent upon the
25standard mechanisms for harvesting randomness for the system entropy
26pool. This is important in systems with high entropy needs or limited
27user interaction (e.g. headless servers).
28 
29Haveged uses HAVEGE (HArdware Volatile Entropy Gathering and Expansion)
30to maintain a 1M pool of random bytes used to fill /dev/random
31whenever the supply of random bits in /dev/random falls below the low
32water mark of the device. The principle inputs to haveged are the
33sizes of the processor instruction and data caches used to setup the
34HAVEGE collector. The haveged default is a 4kb data cache and a 16kb
35instruction cache. On machines with a cpuid instruction, haveged will
36attempt to select appropriate values from internal tables.
37
38%package devel
39Summary:   Headers and shared development libraries for HAVEGE algorithm
40Summary(ja):   Headers and shared development libraries for HAVEGE algorithm
41Group:     Development/Libraries
42Requires:  %{name} = %{version}-%{release}
43
44%description devel
45Headers and shared object symbolic links for the HAVEGE algorithm
46
47%prep
48%setup -q
49
50%build
51#autoreconf -fiv
52
53%configure --enable-init=sysv.redhat
54
55#SMP build is not working
56#make %{?_smp_mflags}
57make
58
59%check
60make check
61
62
63%install
64rm -rf %{buildroot}
65make install DESTDIR=%{buildroot} INSTALL="install -p"
66
67chmod 0644 COPYING README ChangeLog AUTHORS
68
69# We don't ship .la files.
70rm -rf %{buildroot}%{_libdir}/libhavege.*a
71
72%clean
73rm -rf %{buildroot}
74
75%post
76/sbin/chkconfig --add haveged
77
78%preun
79if [ "$1" -eq "0" ]; then
80  /sbin/service haveged stop >/dev/null 2>&1
81  /sbin/chkconfig --del haveged
82fi
83
84%postun
85if [ "$1" -ge "1" ]; then
86  /sbin/service haveged condrestart >/dev/null 2>&1
87fi
88
89%files
90%defattr(-, root, root, -)
91%license COPYING
92%doc README ChangeLog AUTHORS contrib/build/havege_sample.c
93%{_mandir}/man8/haveged.8*
94%{_sbindir}/haveged
95%{_libdir}/*so.*
96%{_sysconfdir}/init.d/haveged
97
98%files devel
99%defattr(-, root, root, -)
100%{_mandir}/man3/libhavege.3*
101%dir %{_includedir}/%{name}
102%{_includedir}/%{name}/havege.h
103%{_libdir}/*.so
104
105
106%changelog
107* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.8-1
108- new upstream release.
109
110* Sat Jul 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.1-1
111- new upstream release.
112
113* Sun Mar 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7a-1
114- update to 1.7a
115
116* Sat Mar 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-1
117- initial build for Vine Linux
118
119* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-1
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
121
122* Sat Jan 19 2013 Jirka Hladky <hladky.jiri@gmail.com> - 1.7-0
123- Updated to the version 1.7
124- Version 1.7 brings developement libraries
125- Added devel package
126* Sat Oct 13 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-2
127- BZ 850144
128- Introduce new systemd-rpm macros in haveged spec file
129- Fedora 19 changes the way how to work with services in spec files.
130- It introduces new macros - systemd_post, systemd_preun and systemd_postun;
131- which replace scriptlets from Fedora 18 and older
132- see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
133
134* Tue Aug 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-1
135- Update to the version 1.5
136- Main new feature is a run time verification of the produced random numbers
137- PIDFILE set to /run/haveged.pid
138- converted README and man page to UTF-8. Informed the upstream to fix it.
139* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-3
140- PIDFile should be stored at /run instead of the default location /var/run
141- There is  long term plan that directory /var/run will not further exist in the future Fedora versions
142- Asked upstream to add -p <PID_FILE_location> switch to influence the location of the PID File
143- Set PIDFile=/var/run/haveged.pid This is needed as long -p option is not implemented
144- https://bugzilla.redhat.com/show_bug.cgi?id=770306#c10
145* Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-2
146- Updated systemd service file, https://bugzilla.redhat.com/show_bug.cgi?id=770306
147* Tue Feb 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-1
148- Update to the version 1.4
149- Conversion to systemd, drop init script
150* Sun Nov 06 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-2
151- Fixed a bug on non x86 systems
152* Sat Nov 05 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-1
153- update from the upstream (1.3 stable)
154* Mon Oct 03 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-0
155-version 1.3 beta
156* Fri Sep 30 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-4
157- ppc64 build
158* Mon Sep 26 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-3
159- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c11
160* Sat Sep 24 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-2
161- Added comment to explain why we need use Fedora specific start script
162* Wed Sep 21 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-1
163- Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c1
164* Wed Sep 07 2011  Jirka Hladky <hladky.jiri@gmail.com> - 1.2-0
165- Initial build
Note: See TracBrowser for help on using the repository browser.