source: projects/specs/trunk/g/gzip/gzip-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The GNU data compression program.
2Summary(ja): GNU データ圧縮プログラム
3Name: gzip
4Version: 1.3.13
5Release: 1%{?_dist_release}
6License: GPLv3+ and GFDL
7Group: Applications/Archiving
8URL: http://www.gzip.org/
9
10Source: ftp://alpha.gnu.org/gnu/gzip/gzip-%{version}.tar.gz
11Patch0: gzip-1.3.12-openbsd-owl-tmp.patch
12Patch1: gzip-1.3.5-zforce.patch
13Patch3: gzip-1.3.9-stderr.patch
14Patch4: gzip-1.3.10-zgreppipe.patch
15Patch5: gzip-1.3.13-rsync.patch
16Patch7: gzip-1.3.9-addsuffix.patch
17
18Patch14: gzip-1.3.5-cve-2006-4338.patch
19Patch15: gzip-1.3.13-cve-2006-4337.patch
20Patch16: gzip-1.3.5-cve-2006-4337_len.patch
21Patch19: gzip-1.3.12-CVE-2010-0001.patch
22
23
24Prereq: install-info
25Requires: mktemp less
26Buildroot: %{_tmppath}/%{name}-%{version}-root
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32The gzip package contains the popular GNU gzip data compression
33program. Gzipped files have a .gz extension.
34
35Gzip should be installed on your Red Hat Linux system, because it is a
36very commonly used data compression program.
37
38%description -l ja
39gzip パッケージには有名な GNU gzip データ圧縮プログラムが収められています.
40gzip で圧縮されたファイルには .gz の拡張子がつきます.
41
42gzip は大変一般的に使われる圧縮プログラムなので,Red Hat Linux システムには
43是非ともインストールされている必要があります.
44
45
46%prep
47%setup -q
48%patch0 -p1 -b .owl-tmp
49%patch1 -p1 -b .zforce
50%patch3 -p1 -b .stderr
51%patch4 -p1 -b .nixi
52%patch5 -p1 -b .rsync
53%patch7 -p1 -b .addsuffix
54
55%patch14 -p1 -b .4338
56%patch15 -p1 -b .4337
57%patch16 -p1 -b .4337_len
58
59%patch19 -p1 -b .CVE-2010-0001
60
61
62%build
63export DEFS="-DNO_ASM"
64export CPPFLAGS="-DHAVE_LSTAT"
65%configure  --bindir=/bin
66make %{?_smp_mflags}
67# make
68# make gzip.info
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%install
75rm -rf $RPM_BUILD_ROOT
76%makeinstall  bindir=$RPM_BUILD_ROOT/bin
77mkdir -p $RPM_BUILD_ROOT/usr/bin
78ln -sf ../../bin/gzip $RPM_BUILD_ROOT/usr/bin/gzip
79ln -sf ../../bin/gunzip $RPM_BUILD_ROOT/usr/bin/gunzip
80
81for i in  zcmp zegrep zforce zless znew gzexe zdiff zfgrep zgrep zmore ; do
82    mv $RPM_BUILD_ROOT/bin/$i $RPM_BUILD_ROOT/usr/bin/$i
83done
84
85gzip -9nf $RPM_BUILD_ROOT%{_infodir}/gzip.info*
86
87# we don't ship it, so let's remove it from ${RPM_BUILD_ROOT}
88rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
89# uncompress is a part of ncompress package
90rm -f ${RPM_BUILD_ROOT}/bin/uncompress
91
92cat > $RPM_BUILD_ROOT%{_bindir}/zless <<EOF
93#!/bin/sh
94/bin/zcat "\$@" | /usr/bin/less
95EOF
96chmod 755 $RPM_BUILD_ROOT%{_bindir}/zless
97
98
99%post
100/sbin/install-info %{_infodir}/gzip.info.gz %{_infodir}/dir
101
102
103%preun
104if [ $1 = 0 ]; then
105    /sbin/install-info --delete %{_infodir}/gzip.info.gz %{_infodir}/dir
106fi
107
108%files
109%defattr(-,root,root)
110%doc NEWS README AUTHORS ChangeLog THANKS TODO
111/bin/*
112%{_bindir}/*
113%{_mandir}/*/*
114%{_infodir}/gzip.info*
115
116
117%changelog
118* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.13-1
119- new upstream release
120
121* Fri Jan 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
122- add patch18 for fix CVE-2009-2624 (decompressing dynamic Huffman code)
123- add patch19 for fix CVE-2010-0001 (unlzw)
124
125* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.12-2
126- spec in utf-8
127
128* Wed Mar 26 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.12-1
129- new upstream release
130- drop old patches and update patches to fit new release
131- add Vendor/Distribution tag
132- add smp_mflags into make section
133- remove uncompress (uncompress is a part of ncompress package)
134- build under new versioning policy
135
136* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-6vl3
137- [security fix] add patches to fix several vulnerabilities
138  - cve-2006-4334 - null dereference problem
139  - cve-2006-4335 - buffer overflow problem
140  - cve-2006-4336 - buffer underflow problem
141  - cve-2006-4338 - infinite loop problem
142  - cve-2006-4337 - buffer overflow problem
143
144* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl2
145- changed Group to Applications/Archiving
146
147* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl1
148- based on 1.3.5-6 from Fedora
149  * Fri Apr 29 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-5
150  - fix bug 156269 - CAN-2005-1228 directory traversal bug
151   (using the patch from Ulf Harnhammar)
152  * Tue Apr 26 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-4
153  - fix bug 155746 - CAN-2005-0988 Race condition in gzip (patch9)
154  * Tue Mar 22 2005 Tomas Mraz <tmraz@redhat.com> 1.3.5-2
155  - upstream 1.3.5
156  - dropped long ago obsolete dirinfo patch
157  - escape file names in zgrep (#123012)
158  - make stack in match.S nonexecutable
159  * Mon Dec 13 2004 Ivana Varekova <varekova@redhat.com>
160  - fix bug #106551 problem with zmore which requires the suffix .gz
161    in file name
162  * Fri Jan 31 2003 Jeff Johnson <jbj@redhat.com> 1.3.3-9
163  - enlarge window buffer to avoid accessing beyond end-of-buffer
164    (#78413,#83095).
165  - re-enable rsync ready patch.
166
167* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.2-2vl2
168- rebuild with new toolchain
169- fix typo in %%changelog
170
171* Mon Jan 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-2vl1
172- based on 1.3.2-2 from Rawhide and rebuilt for Vine Linux
173
174* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
175- automated rebuild
176
177* Mon Nov 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.3.2-1
178- 1.3.2: no need for autoconf 2.5x hacks anymore
179
180* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
181- update to 1.3.1:
182        - disable patch2
183
184* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-16
185- replace tempfile patches with improved ones solar@openwall.com
186- Add less to the dependency chain - zless needs it
187
188* Thu Aug 23 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-15
189- Fix typo in comment in zgrep (#52465)
190- Copyright -> License
191
192* Tue Jun  5 2001 Trond Eivind Glomsr <teg@redhat.com>
193- Patch various uses of $$ in the bundled scripts
194
195* Mon Jun  4 2001 Trond Eivind Glomsr <teg@redhat.com>
196- Fix the SIGPIPE patch to avoid blank lines (#43319)
197
198* Thu Feb 08 2001 Philipp Knirsch <pknirsch@redhat.de>
199- Fixed buzilla bug #26680. Wrong skip value after mktemp patch and forced
200  overwrite for output file during decompression.
201
202* Tue Jan 30 2001 Trond Eivind Glomsr <teg@redhat.com>
203- trap SIGPIPE in zgrep, so "zgrep | less" gets a happy ending
204  (#24104)
205
206* Sun Dec 10 2000 Trond Eivind Glomsr <teg@redhat.com>
207- add HAVE_LSTAT define, to avoid it doing weird things to symlinks
208  instead of ignoring them as the docs say it should (#22045)
209
210* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
211- rebuild
212
213* Thu Nov 09 2000 Trond Eivind Glomsr <teg@redhat.com>
214- patch all scripts so usage error messages are written to
215  stderr (#20597)
216
217* Mon Oct 30 2000 Trond Eivind Glomsr <teg@redhat.com>
218- disable assembly, as it is faster without it (bug #19910)
219
220* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
221- automatic rebuild
222
223* Tue Jun 27 2000 Trond Eivind Glomsr <teg@redhat.com>
224- rebuild
225
226* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
227- Use %%{_mandir}, %%{_infodir},  %%configure, %%makeinstall
228  and %%{_tmppath}
229
230* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
231- Add root as default owner of the files, permits building
232  as non-root user
233
234* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
235- Build system handles stripping
236- Don't do thing the system does, like creating directories
237- use --bindir /bin
238- Added URL
239- skip unnecesarry sed step
240- Include THANKS, AUTHORS, ChangeLog, TODO
241
242* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
243- 1.3
244- handle RPM_OPT_FLAGS
245
246* Tue Feb 15 2000 Cristian Gafton <gafton@redhat.com>
247- handle compressed man pages even better
248
249* Tue Feb 08 2000 Cristian Gafton <gafton@redhat.com>
250- adopt patch from Paul Eggert to fix detection of the improper tables in
251  inflate.c(huft_build)
252- the latest released version 1.2.4a, which provides documentation updates
253  only. But it lets us use small revision numbers again
254- add an dirinfo entry for gzip.info so we can get rid of the ugly --entry
255  args to install-info
256
257* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
258- handle compressed manpages
259
260* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
261- Fix bug #7970
262
263* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
264- auto rebuild in the new build environment (release 14)
265
266* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
267- built against gliibc 2.1
268
269* Thu May 07 1998 Prospector System <bugs@redhat.com>
270- translations modified for de, fr, tr
271
272* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
273- added /usr/bin/gzip and /usr/bin/gunzip symlinks as some programs are too
274  brain dead to figure out they should be at least trying to use $PATH
275- added BuildRoot
276
277* Wed Jan 28 1998 Erik Troan <ewt@redhat.com>
278- fix /tmp races
279
280* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
281- uses install-info
282- applied patch for gzexe
283
284* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
285- built against glibc
286
287* Tue Apr 22 1997 Marc Ewing <marc@redhat.com>
288- (Entry added for Marc by Erik) fixed gzexe to use /bin/gzip
289
Note: See TracBrowser for help on using the repository browser.