source: projects/specs/trunk/g/gzip/gzip-vl.spec @ 12332

Revision 12332, 9.4 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

gzip-1.10-1

mingetty-1.08-3

passwd-0.80-1

webkitgtk4-2.28.0-1

Line 
1Summary: The GNU data compression program.
2Summary(ja): GNU データ圧縮プログラム
3Name: gzip
4Version: 1.10
5Release: 1%{?_dist_release}
6Group: Applications/Archiving
7License: GPLv3+ and GFDL
8URL: http://www.gzip.org/
9
10Source: https://ftp.gnu.org/gnu/gzip/gzip-%{version}.tar.xz
11Source1: https://www.gnu.org/licenses/fdl-1.3.txt
12
13# downstream solution for coloured z*grep (#1034839)
14Source100: colorzgrep.csh
15Source101: colorzgrep.sh
16
17Patch1: gnulib.patch
18Patch2: gzexe.patch
19
20Requires(post): install-info
21Requires(preun): install-info
22Requires: mktemp, less, coreutils
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: texinfo
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: daisuke
29
30%description
31The gzip package contains the popular GNU gzip data compression
32program. Gzipped files have a .gz extension.
33
34Gzip should be installed on your Red Hat Linux system, because it is a
35very commonly used data compression program.
36
37%description -l ja
38gzip パッケージには有名な GNU gzip データ圧縮プログラムが収められています.
39gzip で圧縮されたファイルには .gz の拡張子がつきます.
40
41gzip は大変一般的に使われる圧縮プログラムなので,Linux システムには
42是非ともインストールされている必要があります.
43
44
45%prep
46%setup -q
47
48#%patch1 -p1 -b .gnulib
49%patch2 -p1 -b .gzexe
50cp %{SOURCE1} .
51
52autoreconf
53
54%build
55export DEFS="NO_ASM"
56export CPPFLAGS="-DHAVE_LSTAT"
57export CC="%{__cc}"
58export CPP="%{__cpp}"
59export CXX="%{__cxx}"
60%configure  --bindir=/bin
61make %{?_smp_mflags}
62make check
63#make gzip.info
64
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%install
70rm -rf $RPM_BUILD_ROOT
71%makeinstall  bindir=$RPM_BUILD_ROOT/bin
72mkdir -p $RPM_BUILD_ROOT/usr/bin
73ln -sf ../../bin/gzip $RPM_BUILD_ROOT/usr/bin/gzip
74ln -sf ../../bin/gunzip $RPM_BUILD_ROOT/usr/bin/gunzip
75
76for i in  zcmp zegrep zforce zless znew gzexe zdiff zfgrep zgrep zmore ; do
77    mv $RPM_BUILD_ROOT/bin/$i $RPM_BUILD_ROOT/usr/bin/$i
78done
79
80gzip -9nf $RPM_BUILD_ROOT%{_infodir}/gzip.info*
81
82# we don't ship it, so let's remove it from ${RPM_BUILD_ROOT}
83rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
84# uncompress is a part of ncompress package
85rm -f ${RPM_BUILD_ROOT}/bin/uncompress
86
87cat > $RPM_BUILD_ROOT%{_bindir}/zless <<EOF
88#!/bin/sh
89/bin/zcat "\$@" | /usr/bin/less
90EOF
91chmod 755 $RPM_BUILD_ROOT%{_bindir}/zless
92
93# coloured z*grep (#1034839)
94%global profiledir %{_sysconfdir}/profile.d
95mkdir -p %{buildroot}%{profiledir}
96install -p -m 644 %{SOURCE100} %{buildroot}%{profiledir}
97install -p -m 644 %{SOURCE101} %{buildroot}%{profiledir}
98
99
100%post
101/sbin/install-info %{_infodir}/gzip.info.gz %{_infodir}/dir
102
103
104%preun
105if [ $1 = 0 ]; then
106    /sbin/install-info --delete %{_infodir}/gzip.info.gz %{_infodir}/dir
107fi
108
109%files
110%defattr(-,root,root)
111%license COPYING fdl-1.3.txt
112%doc NEWS README AUTHORS ChangeLog THANKS TODO
113/bin/*
114%{_bindir}/*
115%{_mandir}/*/*
116%{_infodir}/gzip.info*
117%{profiledir}/*
118
119
120%changelog
121* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10-1
122- new upstream release.
123- dropped all patches.
124- imported Patch1 and 2 from rawhide.
125- imported Source1, 100 and 101 from rawhide.
126
127* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
128- update to 1.6
129- add BR: texinfo
130
131* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
132- update to 1.5
133- remove unneeded patches
134
135* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.13-2
136- build on current VineSeed
137
138* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.13-1
139- new upstream release
140
141* Fri Jan 22 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
142- add patch18 for fix CVE-2009-2624 (decompressing dynamic Huffman code)
143- add patch19 for fix CVE-2010-0001 (unlzw)
144
145* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.12-2
146- spec in utf-8
147
148* Wed Mar 26 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.12-1
149- new upstream release
150- drop old patches and update patches to fit new release
151- add Vendor/Distribution tag
152- add smp_mflags into make section
153- remove uncompress (uncompress is a part of ncompress package)
154- build under new versioning policy
155
156* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-6vl3
157- [security fix] add patches to fix several vulnerabilities
158  - cve-2006-4334 - null dereference problem
159  - cve-2006-4335 - buffer overflow problem
160  - cve-2006-4336 - buffer underflow problem
161  - cve-2006-4338 - infinite loop problem
162  - cve-2006-4337 - buffer overflow problem
163
164* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl2
165- changed Group to Applications/Archiving
166
167* Fri May 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-6vl1
168- based on 1.3.5-6 from Fedora
169  * Fri Apr 29 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-5
170  - fix bug 156269 - CAN-2005-1228 directory traversal bug
171   (using the patch from Ulf Harnhammar)
172  * Tue Apr 26 2005 Ivana Varekova <varekova@redhat.com> 1.3.5-4
173  - fix bug 155746 - CAN-2005-0988 Race condition in gzip (patch9)
174  * Tue Mar 22 2005 Tomas Mraz <tmraz@redhat.com> 1.3.5-2
175  - upstream 1.3.5
176  - dropped long ago obsolete dirinfo patch
177  - escape file names in zgrep (#123012)
178  - make stack in match.S nonexecutable
179  * Mon Dec 13 2004 Ivana Varekova <varekova@redhat.com>
180  - fix bug #106551 problem with zmore which requires the suffix .gz
181    in file name
182  * Fri Jan 31 2003 Jeff Johnson <jbj@redhat.com> 1.3.3-9
183  - enlarge window buffer to avoid accessing beyond end-of-buffer
184    (#78413,#83095).
185  - re-enable rsync ready patch.
186
187* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.2-2vl2
188- rebuild with new toolchain
189- fix typo in %%changelog
190
191* Mon Jan 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-2vl1
192- based on 1.3.2-2 from Rawhide and rebuilt for Vine Linux
193
194* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
195- automated rebuild
196
197* Mon Nov 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.3.2-1
198- 1.3.2: no need for autoconf 2.5x hacks anymore
199
200* Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
201- update to 1.3.1:
202        - disable patch2
203
204* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-16
205- replace tempfile patches with improved ones solar@openwall.com
206- Add less to the dependency chain - zless needs it
207
208* Thu Aug 23 2001 Trond Eivind Glomsr <teg@redhat.com> 1.3.0-15
209- Fix typo in comment in zgrep (#52465)
210- Copyright -> License
211
212* Tue Jun  5 2001 Trond Eivind Glomsr <teg@redhat.com>
213- Patch various uses of $$ in the bundled scripts
214
215* Mon Jun  4 2001 Trond Eivind Glomsr <teg@redhat.com>
216- Fix the SIGPIPE patch to avoid blank lines (#43319)
217
218* Thu Feb 08 2001 Philipp Knirsch <pknirsch@redhat.de>
219- Fixed buzilla bug #26680. Wrong skip value after mktemp patch and forced
220  overwrite for output file during decompression.
221
222* Tue Jan 30 2001 Trond Eivind Glomsr <teg@redhat.com>
223- trap SIGPIPE in zgrep, so "zgrep | less" gets a happy ending
224  (#24104)
225
226* Sun Dec 10 2000 Trond Eivind Glomsr <teg@redhat.com>
227- add HAVE_LSTAT define, to avoid it doing weird things to symlinks
228  instead of ignoring them as the docs say it should (#22045)
229
230* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
231- rebuild
232
233* Thu Nov 09 2000 Trond Eivind Glomsr <teg@redhat.com>
234- patch all scripts so usage error messages are written to
235  stderr (#20597)
236
237* Mon Oct 30 2000 Trond Eivind Glomsr <teg@redhat.com>
238- disable assembly, as it is faster without it (bug #19910)
239
240* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
241- automatic rebuild
242
243* Tue Jun 27 2000 Trond Eivind Glomsr <teg@redhat.com>
244- rebuild
245
246* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
247- Use %%{_mandir}, %%{_infodir},  %%configure, %%makeinstall
248  and %%{_tmppath}
249
250* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
251- Add root as default owner of the files, permits building
252  as non-root user
253
254* Wed May 10 2000 Trond Eivind Glomsr <teg@redhat.com>
255- Build system handles stripping
256- Don't do thing the system does, like creating directories
257- use --bindir /bin
258- Added URL
259- skip unnecesarry sed step
260- Include THANKS, AUTHORS, ChangeLog, TODO
261
262* Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
263- 1.3
264- handle RPM_OPT_FLAGS
265
266* Tue Feb 15 2000 Cristian Gafton <gafton@redhat.com>
267- handle compressed man pages even better
268
269* Tue Feb 08 2000 Cristian Gafton <gafton@redhat.com>
270- adopt patch from Paul Eggert to fix detection of the improper tables in
271  inflate.c(huft_build)
272- the latest released version 1.2.4a, which provides documentation updates
273  only. But it lets us use small revision numbers again
274- add an dirinfo entry for gzip.info so we can get rid of the ugly --entry
275  args to install-info
276
277* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
278- handle compressed manpages
279
280* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
281- Fix bug #7970
282
283* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
284- auto rebuild in the new build environment (release 14)
285
286* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
287- built against gliibc 2.1
288
289* Thu May 07 1998 Prospector System <bugs@redhat.com>
290- translations modified for de, fr, tr
291
292* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
293- added /usr/bin/gzip and /usr/bin/gunzip symlinks as some programs are too
294  brain dead to figure out they should be at least trying to use $PATH
295- added BuildRoot
296
297* Wed Jan 28 1998 Erik Troan <ewt@redhat.com>
298- fix /tmp races
299
300* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
301- uses install-info
302- applied patch for gzexe
303
304* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
305- built against glibc
306
307* Tue Apr 22 1997 Marc Ewing <marc@redhat.com>
308- (Entry added for Marc by Erik) fixed gzexe to use /bin/gzip
309
Note: See TracBrowser for help on using the repository browser.