source: projects/specs/trunk/g/guile/guile-vl.spec @ 521

Revision 521, 11.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 1.8
3
4Version: 1.8.7
5Release: 1%{?_dist_release}
6
7Summary: A GNU implementation of Scheme for application extensibility.
8Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
9Name: guile
10Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
11Source2: http://ai.king.net.pl/guile-1.6-missing-tools.tar.gz
12Patch1: guile-1.6.7-rpath.patch
13Patch2: guile-1.6.0-unknown_arch.patch
14Patch3: guile-1.6.0-ppc64.patch
15Patch4: guile-1.6.7-ltdl.patch
16Patch5: guile-1.6.7-64bit.patch
17
18# following patchs are imported from fedora-dev
19#Patch11: guile-1.8.4-multilib.patch
20#Patch12: guile-1.8.4-testsuite.patch
21Patch14: guile-1.8.6-deplibs.patch
22
23License: GPL
24Group: Development/Languages
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
27BuildRequires: gmp-devel readline-devel emacs
28Requires(post): /sbin/install-info
29Requires(preun): /sbin/install-info
30Requires: coreutils
31
32
33Vendor:         Project Vine
34Distribution:   Vine Linux
35Packager:       yasumichi
36
37%description
38GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
39implementation of the Scheme programming language, written in C.  GUILE
40provides a machine-independent execution platform that can be linked in
41as a library during the building of extensible programs.
42
43Install the guile package if you'd like to add extensibility to programs
44that you are developing.
45
46%package devel
47Summary: Libraries and header files for the GUILE extensibility library.
48Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: gmp-devel
52
53%description devel
54The guile-devel package includes the libraries, header files, etc.,
55that you'll need to develop applications that are linked with the
56GUILE extensibility library.
57
58You need to install the guile-devel package if you want to develop
59applications that will be linked to GUILE.  You'll also need to
60install the guile package.
61
62%package -n compat32-%{name}
63Summary: A GNU implementation of Scheme for application extensibility.
64Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
65Group: Development/Languages
66Requires: %{name} = %{version}-%{release}
67
68%description -n compat32-%{name}
69GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
70implementation of the Scheme programming language, written in C.  GUILE
71provides a machine-independent execution platform that can be linked in
72as a library during the building of extensible programs.
73
74Install the guile package if you'd like to add extensibility to programs
75that you are developing.
76
77%package -n compat32-%{name}-devel
78Summary: Libraries and header files for the GUILE extensibility library.
79Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-%{name} = %{version}-%{release}
83Requires: compat32-gmp-devel
84
85%description -n compat32-%{name}-devel
86The guile-devel package includes the libraries, header files, etc.,
87that you'll need to develop applications that are linked with the
88GUILE extensibility library.
89
90You need to install the guile-devel package if you want to develop
91applications that will be linked to GUILE.  You'll also need to
92install the guile package.
93
94%prep
95%setup -q
96#%patch1 -p1 -b .rpath
97#%patch2 -p1 -b .unknown_arch
98#%patch3 -p1 -b .ppc64
99#%patch4 -p1 -b .ltdl
100#%patch5 -p1 -b .64bit
101
102#%patch11 -p1 -b .multilib
103#%patch12 -p1 -b .testsuite
104%patch14 -p1 -b .deplibs
105
106%build
107%configure --disable-static --disable-error-on-warning
108
109# Remove RPATH
110sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
111    {,guile-readline/}libtool
112
113make %{?_smp_mflags}
114
115
116%install
117rm -rf ${RPM_BUILD_ROOT}
118
119make DESTDIR=${RPM_BUILD_ROOT} install
120
121mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/guile/site
122
123rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*.la
124rm -f ${RPM_BUILD_ROOT}%{_infodir}/dir
125
126# Compress large documentation
127bzip2 NEWS
128
129for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
130    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
131done
132
133touch ${RPM_BUILD_ROOT}%{_datadir}/guile/%{mver}/slibcat
134ln -s ../../slib ${RPM_BUILD_ROOT}%{_datadir}/guile/%{mver}/slib
135
136
137%clean
138rm -rf ${RPM_BUILD_ROOT}
139
140%post
141/sbin/ldconfig
142/sbin/install-info  %{_infodir}/guile.info.gz %{_infodir}/dir
143/sbin/install-info  %{_infodir}/r5rs.info.gz %{_infodir}/dir
144/sbin/install-info  %{_infodir}/goops.info.gz %{_infodir}/dir
145/sbin/install-info  %{_infodir}/guile-tut.info.gz %{_infodir}/dir
146
147%postun -p /sbin/ldconfig
148
149%preun
150if [ "$1" = 0 ]; then
151    /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
152    /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
153    /sbin/install-info --delete %{_infodir}/goops.info.gz %{_infodir}/dir
154    /sbin/install-info --delete %{_infodir}/guile-tut.info.gz %{_infodir}/dir
155fi
156:
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159
160%postun -n compat32-%{name} -p /sbin/ldconfig
161
162%files
163%defattr(-,root,root,-)
164%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
165%{_bindir}/guile
166%{_bindir}/guile-tools
167%{_libdir}/libguile*.so.*
168%{_libdir}/libguilereadline-*.so
169%{_libdir}/libguile-srfi-srfi-*.so
170%dir %{_datadir}/guile
171%dir %{_datadir}/guile/%{mver}
172%{_datadir}/guile/%{mver}/ice-9
173%{_datadir}/guile/%{mver}/lang
174%{_datadir}/guile/%{mver}/oop
175%{_datadir}/guile/%{mver}/scripts
176%{_datadir}/guile/%{mver}/srfi
177%{_datadir}/guile/%{mver}/guile-procedures.txt
178%ghost %{_datadir}/guile/%{mver}/slibcat
179%ghost %{_datadir}/guile/%{mver}/slib
180%dir %{_datadir}/guile/site
181%dir %{_datadir}/emacs/site-lisp
182%{_datadir}/emacs/site-lisp/*.el
183%{_infodir}/*
184%{_mandir}/man1/guile.1*
185
186%files devel
187%defattr(-,root,root,-)
188%{_bindir}/guile-config
189%{_bindir}/guile-snarf
190%{_datadir}/aclocal/*
191%{_libdir}/libguile.so
192%{_libdir}/pkgconfig/*.pc
193%{_includedir}/guile
194%{_includedir}/libguile
195%{_includedir}/libguile.h
196
197# compat32
198%if %{build_compat32}
199%files -n compat32-%{name}
200%defattr(-,root,root,-)
201%{_libdir}/libguile*.so.*
202%{_libdir}/libguilereadline-*.so
203%{_libdir}/libguile-srfi-srfi-*.so
204
205%files -n compat32-%{name}-devel
206%defattr(-,root,root,-)
207%{_libdir}/libguile.so
208%{_libdir}/pkgconfig/*.pc
209%endif
210
211%changelog
212* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
213- new upstream release.
214- comment out Patch11,12.
215
216* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
217- added Requires: gmp-devel to guile-devel
218
219* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
220- added compat32 package for x86_64 arch support
221
222* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
223- rebuild with libtool-2.2.6a
224
225* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
226- new upstream release
227- import some patches from fedora development
228- drop some old patches
229- update spec based on fedora package
230- spec in utf-8
231
232* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
233- use macro for Release
234
235* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
236- apply new virsioning policy.
237- remove *.la
238
239* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
240- rebuilt with readline 5.1
241
242* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
243- added Patches from Fedora
244  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
245  - Fix dynamic linking on 64bit archs (#159971)
246  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
247  - Moved info files to base package as they are not devel related (#139948)
248  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
249  - Fixed guile-tools not finding guile lib dir (#142642)
250  - Added some nice tools (#142642)
251  - Removed smp build, seems to be broken atm
252
253* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
254- new upstream release
255- dropped patch2, 4, 6
256- added BuildPrereq: perl
257
258* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
259- rebuild with new toolchains
260- s/Copyright/License/
261- added srfi libs
262- patch for ppc64 from Fedora package
263
264* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
265- update to 1.6.4
266
267* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
268- rebuild with readline-4.3
269
270* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
271- based on Rawhide 1.6.0-4
272  - Included s390 as working arch as well, switch to general unknown arch patch
273  - rebuild to fix broken deps
274  - fix continuations.h on ia64
275- new upstream 1.6.3
276
277* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
278- porting for Vine Linux
279- remove 1.3 patches( not required  so that upstream upgrade )
280
281* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
282- Add version number to prereq for umb-scheme to get the post-install to
283  work properly.
284
285* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
286- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
287
288* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
289- automatic rebuild
290
291* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
292- Back down to 1.3.4.
293- Fix to actually link against the version of libguile in the package.
294
295* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
296- FHS fixups using the %%{makeinstall} macro.
297
298* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
299- fix preun-devel
300- call ldconfig directly in postun
301
302* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
303- rebuild with new readline
304- update to 1.3.4
305
306* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
307- using the same catalog as umb-scheme makes umb-scheme a prereq
308
309* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
310- readline is needed for %post
311
312* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
313- use the same catalog as umb-scheme
314
315* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
316- fix broken %postun
317
318* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
319- auto rebuild in the new build environment (release 6)
320
321* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
322- added .ansi patch to fix #endif
323
324* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
325- add patch for the scm stuff
326
327* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
328- integrate changes from rhcn version (#640)
329
330* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
331- call libtoolize first to get it to compile on the arm
332
333* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
334- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
335
336* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
337- guile-devel does depend on guile
338- remove devel dependancy on m4
339- move guile-snarf from guile to guile-devel
340- Converted to rhcn
341
342* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
343- update to 1.3.
344- don't strip libguile.so.*.0.0. (but set the execute bits).
345
346* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
347- spec file fixups
348
349* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
350- Updated for RH 5.2
351
352* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
353- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
354- added slib link
355
356* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
357- added %attr(-, root, root) for %doc,
358- in %post, %postun ldconfig runed as parameter "-p",
359- removed /bin/sh from requires,
360- added %description,
361- changes in %files.
362
363* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
364- all rewrited for using Buildroot,
365- added %postun,
366- removed making buid logs,
367- removed "--inclededir", added "--enable-dynamic-linking" to configure
368  parameters,
369- added striping shared libs and /usr/bin/guile,
370- added "Requires: /bin/sh" (for guile-snarf) in guile package and
371  "Requires: m4" for guile-devel,
372- added macro %{PACKAGE_VERSION} in "Source:" and %files,
373- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.