source: projects/specs/trunk/g/gtkwave/gtkwave-vl.spec @ 1220

Revision 1220, 13.3 KB checked in by inagaki, 14 years ago (diff)

NEW: electronics-menu, gerbv, geda-gaf, gtkwave, iverilog, pcb

Line 
1Summary:        Waveform Viewer
2Summary(ja):    波形ビューワ
3Name:           gtkwave
4Version:        3.3.7
5Release:        2%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/Engineering
8URL:            http://gtkwave.sourceforge.net/
9Source0:        http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
10Source1:        gtkwave.desktop
11Source2:        gtkwave-16.png
12Source3:        gtkwave-32.png
13Source4:        gtkwave-48.png
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gtk2-devel
17BuildRequires:  bzip2-devel
18BuildRequires:  Judy-devel
19%if %{?_dist_release} != "vl4" && %{?_dist_release} != "vl5"
20BuildRequires:  xz-devel
21%endif
22BuildRequires:  zlib-devel
23BuildRequires:  gperf
24BuildRequires:  flex
25BuildRequires:  desktop-file-utils
26
27BuildRequires:  /usr/include/tcl.h /usr/include/tk.h
28BuildRequires:  tcl >= 8.4
29
30%description
31GTKWave is a waveform viewer that can view VCD files produced by most Verilog
32simulation tools, as well as LXT files produced by certain Verilog simulation
33tools.
34
35%prep
36%setup -q -n gtkwave-%{version}%{?prerel}
37%{__cp} -p .gtkwaverc gtkwaverc.sample
38
39%build
40%{configure} --disable-dependency-tracking --enable-judy
41%{__make} %{_smp_mflags}
42
43%install
44%{__rm} -rf %{buildroot}
45%{__make} install \
46        DESTDIR=%{buildroot} \
47        pkgdatadir=%{_docdir}/gtkwave-%{version} \
48        INSTALL="%{__install} -p"
49
50# Icons and desktop entry
51/usr/bin/desktop-file-install --vendor "" --dir %{buildroot}%{_datadir}/applications %{SOURCE1}
52%{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
53%{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
54%{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
55
56# Include extra docs
57for extradoc in \
58        gtkwaverc.sample \
59        ANALOG_README.TXT \
60        CHANGELOG.TXT \
61        GNU.TXT \
62        LICENSE.TXT \
63        MIT.TXT \
64        SYSTEMVERILOG_README.TXT
65do
66        %{__install} -p -m 644 ${extradoc} %{buildroot}%{_docdir}/gtkwave-%{version}/
67done
68
69%clean
70%{__rm} -rf %{buildroot}
71
72%post
73touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
74
75%postun
76if [ $1 -eq 0 ] ; then
77        touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
78        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
79fi
80
81%posttrans
82gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
83
84%files
85%defattr(-,root,root,-)
86%doc %{_docdir}/gtkwave-%{version}/
87%{_bindir}/evcd2vcd
88%{_bindir}/fst2vcd
89%{_bindir}/ghwdump
90%{_bindir}/gtkwave
91%{_bindir}/lxt2miner
92%{_bindir}/lxt2vcd
93%{_bindir}/rtlbrowse
94%{_bindir}/shmidcat
95%{_bindir}/twinwave
96%{_bindir}/vcd2fst
97%{_bindir}/vcd2lxt
98%{_bindir}/vcd2lxt2
99%{_bindir}/vcd2vzt
100%{_bindir}/vermin
101%{_bindir}/vzt2vcd
102%{_bindir}/vztminer
103%{_datadir}/applications/gtkwave.desktop
104%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
105%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
106%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
107%{_mandir}/man1/evcd2vcd.1*
108%{_mandir}/man1/fst2vcd.1*
109%{_mandir}/man1/ghwdump.1*
110%{_mandir}/man1/gtkwave.1*
111%{_mandir}/man1/lxt2miner.1*
112%{_mandir}/man1/lxt2vcd.1*
113%{_mandir}/man1/rtlbrowse.1*
114%{_mandir}/man1/shmidcat.1*
115%{_mandir}/man1/twinwave.1*
116%{_mandir}/man1/vcd2fst.1*
117%{_mandir}/man1/vcd2lxt.1*
118%{_mandir}/man1/vcd2lxt2.1*
119%{_mandir}/man1/vcd2vzt.1*
120%{_mandir}/man1/vermin.1*
121%{_mandir}/man1/vzt2vcd.1*
122%{_mandir}/man1/vztminer.1*
123%{_mandir}/man5/gtkwaverc.5*
124
125%changelog
126* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
127- Initial build for Vine Linux
128
129* Sun Jun  6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
130- update to 3.3.7 (general bug and compiler warning fixes)
131- -n option not needed in desktop file
132
133* Tue May  4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
134- update to 3.3.6 (see CHANGELOG.TXT for details)
135- add desktop file and icons based on Mandriva package
136- BR: desktop-file-utils
137- add scriptlets to update icon cache
138- no longer need to fix permissions of lzma wrapper code
139
140* Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
141- update to 3.3.5 (see CHANGELOG.TXT for details)
142- add Judy-devel buildreq for improved memory usage efficiency
143
144* Mon Mar  8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
145- update to 3.3.4 (see CHANGELOG.TXT for details)
146
147* Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
148- update to 3.3.3
149- drop upstreamed dlopen linking patch
150- drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
151
152* Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
153- fix FTBFS due to missing -ldl linking for dlopen function (#565173)
154
155* Tue Jan  5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
156- update to 3.3.2 (speed up operation on networked filesystems)
157
158* Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
159- update to 3.3.0
160- added tk support
161- bundled old liblzma replaced by system xz (add BR: xz-devel)
162- tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
163
164* Fri Sep  4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
165- update to 3.2.3
166- fix permissions in bundled liblzma for debuginfo
167
168* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
169- drop patch for #515672, not needed with gcc 4.4.1-4
170
171* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
172- add patch to work around #515672 (internal compiler error on PPC)
173
174* Wed Aug  5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
175- update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
176- drop print-to-file patch, no longer needed
177
178* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
179- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
180
181* Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
182- add upstream patch for crash on print to file (#511858)
183
184* Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
185- update to 3.2.1
186
187* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
188- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
189
190* Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
191- update to 3.2.0
192
193* Mon Feb  2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
194- update to 3.2.0RC5
195
196* Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
197- update to 3.2.0RC4 (#481264)
198- new upstream URLs
199- buildreq /usr/include/tcl.h for embedded tcl support
200
201* Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
202- update to 3.1.13
203
204* Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
205- update to 3.1.12
206
207* Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
208- update to 3.1.11
209
210* Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
211- update to 3.1.10
212
213* Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
214- update to 3.1.9
215
216* Mon Apr  7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
217- update to 3.1.8
218
219* Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
220- update to 3.1.7
221
222* Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
223- update to 3.1.6
224
225* Fri Feb  1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
226- update to 3.1.4
227
228* Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
229- update to 3.1.3
230
231* Wed Jan  2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
232- update to 3.1.2
233
234* Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
235- update to 3.1.1
236
237* Tue Sep  4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
238- update to 3.1.0
239
240* Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
241- clarify license as GPL, version 2 or later
242
243* Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
244- update to 3.0.30
245
246* Fri Jun  8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
247- update to 3.0.29
248- spec file much-simplified as gtkwave is now fully autotooled
249- try to retain upstream timestamps as far as possible
250- use parallel make
251
252* Tue May  1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
253- update to 3.0.28
254- update source URL to master source
255
256* Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
257- update to 3.0.27
258- rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
259  (http://wolfpack.twu.net/Vertex/index.html)
260
261* Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
262- update to 3.0.26
263
264* Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
265- update to 3.0.25
266
267* Thu Apr  5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
268- update to 3.0.24
269
270* Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
271- update to 3.0.23
272
273* Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
274- update to 3.0.22
275
276* Mon Feb  5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
277- update to 3.0.21
278
279* Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
280- update to 3.0.20
281
282* Tue Jan  2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
283- update to 3.0.19
284
285* Tue Dec  5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
286- update to 3.0.18
287
288* Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
289- update to 3.0.17
290
291* Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
292- update to 3.0.16
293
294* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
295- update to 3.0.15
296
297* Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
298- update to 3.0.14
299
300* Mon Oct  9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
301- update to 3.0.13
302
303* Tue Oct  3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
304- rebuilt for unwind info generation, broken in gcc-4.1.1-21
305
306* Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
307- update to 3.0.12
308- create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
309  generated
310
311* Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
312- update to 3.0.11
313
314* Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
315- update to 3.0.10
316
317* Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
318- update to 3.0.9
319- tarball is now .tar.gz rather than .tgz
320
321* Mon Aug  7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
322- update to 3.0.8
323- new program and manpage: shmidcat
324
325* Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
326- update to 3.0.7
327- new program and manpage: twinwave
328
329* Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
330- update to 3.0.6
331
332* Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
333- update to 3.0.5
334- new program and manpage: ghwdump
335
336* Fri Jun  2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
337- update to 3.0.4
338
339* Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
340- update to 3.0.3
341
342* Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
343- adding missing buildreq flex
344
345* Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
346- update to 3.0.2
347
348* Tue May  9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
349- update to 3.0.1
350
351* Tue May  2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
352- update to 3.0.0
353- add examples directory as %%doc
354- add new buildreq gperf
355- tweak Makefile.in edits to handle Makefiles under contrib/
356- add new binaries rtlbrowse and vertex
357- add new manpages for rtlbrowse, vertex, and gtkwaverc
358- %%{_mandir} no longer needs to be created manually
359- configure script now accepts --libdir
360
361* Tue Mar  7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
362- update to 1.3.86
363
364* Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
365- update to 1.3.85
366
367* Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
368- update to 1.3.84
369- INSTALL now called INSTALL.TXT
370
371* Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
372- rebuild
373
374* Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
375- update to 1.3.83
376
377* Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
378- update to 1.3.82
379
380* Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
381- update to 1.3.81
382
383* Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
384- update to 1.3.80
385
386* Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
387- fix file permissions in debuginfo package
388
389* Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
390- update to 1.3.79
391
392* Wed Nov  9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
393- update to 1.3.78
394
395* Tue Nov  8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
396- update to 1.3.77
397- GHDL ghw support now included upstream, so remove patches
398
399* Mon Nov  7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
400- clean up for Fedora Extras:
401  - don't support GTK1 builds
402  - unconditionally remove buildroot in %%clean and %%install
403  - remove redundant glib2-devel buildreq
404  - add dist tag
405
406* Mon Nov  7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
407- add GHDL ghw support
408
409* Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
410- update to 1.3.76
411
412* Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
413- update to 1.3.73
414
415* Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
416- update to 1.3.72
417
418* Fri Oct  7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
419- update to 1.3.71
420
421* Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
422- update to 1.3.70
423- new program tla2vcd (with manpage)
424
425* Mon Sep  5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
426- update to 1.3.69
427- honour %%{optflags}
428- use system bzip and zlib libraries
429
430* Fri Sep  2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
431- update to 1.3.68
432
433* Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
434- update to 1.3.67
435
436* Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
437- update to 1.3.64
438- new programs lxt2miner & vztminer (with manpages)
439
440* Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
441- update to 1.3.63
442
443* Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
444- update to 1.3.62
445
446* Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
447- update to 1.3.58
448- include sample .gtkwaverc in doc area
449- update URL to point to new project home page
450
451* Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
452- update to 1.3.57
453- add support for building with gtk version 1 (build using: --without gtk2)
454
455* Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
456- initial RPM build
Note: See TracBrowser for help on using the repository browser.