source: projects/specs/trunk/g/gtkpod/gtkpod-vl.spec @ 9330

Revision 9330, 5.8 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • gtkpod, supertuxkart: updated


Line 
1%bcond_with mp4v2
2
3Name: gtkpod
4Version: 2.1.4
5Release: 1%{?_dist_release}
6Summary: Graphical song management program for Apple's iPod
7Summary(ja): Apple の iPod 用のグラフィカルな楽曲管理ツール
8#'
9
10Group: Applications/Multimedia
11# The help documentation is under GFDL, the rest of the code is GPLv2+
12License: GPLv2+ and GFDL
13URL: http://www.gtkpod.org/
14
15Source0: %{name}-%{version}.tar.gz
16Source1: %{name}-2.1.4-ja.po
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: anjuta-devel
20BuildRequires: brasero-devel
21BuildRequires: clutter-gtk-devel
22BuildRequires: curl-devel
23BuildRequires: desktop-file-utils
24BuildRequires: flac-devel >= 1.2.1
25BuildRequires: flex
26BuildRequires: gettext
27BuildRequires: gstreamer-devel
28BuildRequires: gstreamer-plugins-base-devel >= 0.10.25
29BuildRequires: gtk3-devel
30BuildRequires: intltool
31BuildRequires: libgpod-devel
32BuildRequires: libid3tag-devel
33BuildRequires: libmusicbrainz3-devel
34BuildRequires: libvorbis-devel >= 1.3.1
35BuildRequires: perl(XML::Parser)
36BuildRequires: pkgconfig
37BuildRequires: WebKit3-gtk-devel
38%if %{with mp4v2}
39BuildRequires: self-build-libmp4v2
40%endif
41
42# some of the scripts in %%{_datadir}/%%{name}/scripts use which
43Requires:       which
44Requires:       hicolor-icon-theme
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48
49%description
50gtkpod is a platform independent Graphical User Interface for Apple's
51iPod using GTK3. It supports all current iPod models, including
52the Mini, Photo, Shuffle, Nano, Video, Classic, Touch, and iPhone.
53
54%description -l ja
55gtkpodは、GTK3を利用したプラットフォームに依存しない Apple の iPod 用 GUI
56ツールです。 Mini, Photo, Shuffle, Nano, Video, Classic, Touch を含む
57iPod 及び iPhone に対応しています。
58
59#'
60%package devel
61Summary: Development files for the gtkpod
62Summary(ja): gtkpod の開発用ファイル
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67The gtkpod-devel package contains libraries and header files for
68developing extensions for gtkpod.
69
70%prep
71%setup -q
72cp -p %{SOURCE1} po/ja.po
73
74%build
75%configure \
76    --disable-static \
77%{?!with_mp4v2: --without-mp4}
78
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=$RPM_BUILD_ROOT
84
85desktop-file-install \
86    --delete-original \
87    --dir %{buildroot}%{_datadir}/applications \
88    --add-category="Audio" \
89    --add-category="Video" \
90    %{buildroot}%{_datadir}/applications/%{name}.desktop
91
92%find_lang %{name}
93
94# delete libtool files
95find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
101/sbin/ldconfig
102touch --no-create %{_datadir}/icons/hicolor
103
104%postun
105/sbin/ldconfig
106if [ $1 -eq 0 ] ; then
107    /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
108fi
109if [ $1 -eq 0 ] ; then
110    /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
111    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
112fi
113
114%posttrans
115/usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
116/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
117
118%files -f %{name}.lang
119%defattr(-,root,root)
120%doc AUTHORS ChangeLog* COPYING README TODO TROUBLESHOOTING
121%{_bindir}/gtkpod
122%{_libdir}/lib*.so.*
123%dir %{_libdir}/gtkpod
124%{_libdir}/gtkpod/*.plugin
125%{_libdir}/gtkpod/*.so
126%{_datadir}/gtkpod
127%{_datadir}/applications/*
128%{_datadir}/glib-2.0/schemas/*.gschema.xml
129%{_datadir}/icons/hicolor/*
130%{_mandir}/man1/%{name}*
131
132%files devel
133%defattr(-,root,root)
134%{_includedir}/gtkpod
135%{_libdir}/lib*.so
136%{_libdir}/pkgconfig/*.pc
137
138%changelog
139* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.4-1
140- updated to 2.1.4
141- updated SOURCE1
142- added devel subpackage
143
144* Fri Feb 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99.16-2
145- rebuild with Vine6 environment
146
147* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99.16-1
148- new upstream release
149- add BuildRequires: libglade2-devel
150- add Requires: desktop-file-utils
151
152* Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.14-2
153- build without libmp4v2 by default
154- add %%post/%%postun script to update desktop db and icon cache
155
156* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.14-1
157- new upstream release
158- spec in utf-8
159
160* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.12-1vl5
161- applied new versioning policy
162- fixed Icon path of gtkpod.desktop
163
164* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.99.12-0vl1
165- new upstream release
166- dropt gtkpod-0.99.8_libgpod-0.4.2.diff
167- added icons in %%files section
168- rebuilt with libgpod-0.6.0
169
170* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.8-0vl3
171- for VineSeedPlus
172- rebuilt with new toolchain and libgpod-0.4.2
173- add Patch0 (derived from FC)
174
175* Sun Jan  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.8-0vl1
176- new upstream release
177- added SOURCE1
178- rebuilt with libgpod-devel 0.4.0
179- moved gtkpod.desktop to %{_datadir}/applications <BTS:454>
180
181* Sun Jan  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.2-0vl2
182- rebuilt for VineSeed Plus
183
184* Sun Jan  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.2-0vl1
185- new upstream release
186
187* Fri Dec 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl3
188- rebuilt for VineSeed Plus
189
190* Fri Dec 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl2
191- rebuilt for VinePlus/3.0
192- added BuildRequires: curl-devel, flex
193
194* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl1
195- new upstream release.
196- add BuildRequires: libgpod-devel
197
198* Tue Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.94.0-0vl1
199-new upstream release.
200
201* Mon Jun 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl3
202-A revision %description -l ja
203-A revision %files
204-add %doc
205
206* Thu Jun 2 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl2
207-add macro
208-add BuildRequires
209
210* Tue May 17 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl1
211First release.
212
213- initial build for Vine Linux
214
215# end of file
Note: See TracBrowser for help on using the repository browser.