source: projects/specs/trunk/g/gtkpod/gtkpod-vl.spec @ 10570

Revision 10570, 6.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: gtkpod
2Version: 2.1.5
3Release: 2%{?_dist_release}
4Summary: Graphical song management program for Apple's iPod
5Summary(ja): Apple の iPod 用のグラフィカルな楽曲管理ツール
6#'
7
8Group: Applications/Multimedia
9# The help documentation is under GFDL, the rest of the code is GPLv2+
10License: GPLv2+ and GFDL
11URL: http://www.gtkpod.org/
12
13Source0: %{name}-%{version}.tar.gz
14Source1: %{name}-2.1.4-ja.po
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: anjuta-devel
18BuildRequires: brasero-devel
19BuildRequires: clutter-gtk-devel
20BuildRequires: curl-devel
21BuildRequires: desktop-file-utils
22BuildRequires: flac-devel >= 1.2.1
23BuildRequires: flex
24BuildRequires: gettext
25BuildRequires: gstreamer1-devel
26BuildRequires: gstreamer1-plugins-base-devel
27BuildRequires: gtk3-devel
28BuildRequires: intltool
29BuildRequires: libgpod-devel
30BuildRequires: libid3tag-devel
31BuildRequires: libmusicbrainz5-devel
32BuildRequires: libvorbis-devel >= 1.3.1
33BuildRequires: perl(XML::Parser)
34BuildRequires: pkgconfig
35BuildRequires: WebKit3-gtk-devel
36
37# some of the scripts in %%{_datadir}/%%{name}/scripts use which
38Requires:       which
39Requires:       hicolor-icon-theme
40
41Vendor:         Project Vine
42Distribution:   Vine Linux
43
44%description
45gtkpod is a platform independent Graphical User Interface for Apple's
46iPod using GTK3. It supports all current iPod models, including
47the Mini, Photo, Shuffle, Nano, Video, Classic, Touch, and iPhone.
48
49%description -l ja
50gtkpodは、GTK3を利用したプラットフォームに依存しない Apple の iPod 用 GUI
51ツールです。 Mini, Photo, Shuffle, Nano, Video, Classic, Touch を含む
52iPod 及び iPhone に対応しています。
53
54#'
55%package devel
56Summary: Development files for the gtkpod
57Summary(ja): gtkpod の開発用ファイル
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62The gtkpod-devel package contains libraries and header files for
63developing extensions for gtkpod.
64
65%prep
66%setup -q
67cp -p %{SOURCE1} po/ja.po
68
69%build
70%configure \
71    --disable-static
72
73make %{?_smp_mflags}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install DESTDIR=$RPM_BUILD_ROOT
78
79desktop-file-install \
80    --delete-original \
81    --dir %{buildroot}%{_datadir}/applications \
82    --add-category="Audio" \
83    --add-category="Video" \
84    %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86%find_lang %{name}
87
88# delete libtool files
89find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95/sbin/ldconfig
96touch --no-create %{_datadir}/icons/hicolor
97
98%postun
99/sbin/ldconfig
100if [ $1 -eq 0 ] ; then
101    /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
102fi
103if [ $1 -eq 0 ] ; then
104    /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
105    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
106fi
107
108%posttrans
109/usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
110/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
111
112%files -f %{name}.lang
113%defattr(-,root,root)
114%doc AUTHORS ChangeLog* COPYING README TODO TROUBLESHOOTING
115%{_bindir}/gtkpod
116%{_libdir}/lib*.so.*
117%dir %{_libdir}/gtkpod
118%{_libdir}/gtkpod/*.plugin
119%{_libdir}/gtkpod/*.so
120%{_datadir}/gtkpod
121%{_datadir}/applications/*
122%{_datadir}/glib-2.0/schemas/*.gschema.xml
123%{_datadir}/icons/hicolor/*
124%{_mandir}/man1/%{name}*
125
126%files devel
127%defattr(-,root,root)
128%{_includedir}/gtkpod
129%{_libdir}/lib*.so
130%{_libdir}/pkgconfig/*.pc
131
132%changelog
133* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.5-2
134- rebuild with gcc-5.4.0
135
136* Wed Jun 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.5-1
137- new upstream release
138- added BR: gstreamer1-devel, gstreamer1-plugins-base-devel
139- added BR: libmusicbrainz5-devel
140
141* Thu May 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.4-2
142- rebuilt with libimobiledevice 1.2.0 and libplist 1.12
143
144* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.4-1
145- updated to 2.1.4
146- updated SOURCE1
147- added devel subpackage
148
149* Fri Feb 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99.16-2
150- rebuild with Vine6 environment
151
152* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99.16-1
153- new upstream release
154- add BuildRequires: libglade2-devel
155- add Requires: desktop-file-utils
156
157* Sat Jul 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.14-2
158- build without libmp4v2 by default
159- add %%post/%%postun script to update desktop db and icon cache
160
161* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.14-1
162- new upstream release
163- spec in utf-8
164
165* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.12-1vl5
166- applied new versioning policy
167- fixed Icon path of gtkpod.desktop
168
169* Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.99.12-0vl1
170- new upstream release
171- dropt gtkpod-0.99.8_libgpod-0.4.2.diff
172- added icons in %%files section
173- rebuilt with libgpod-0.6.0
174
175* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.8-0vl3
176- for VineSeedPlus
177- rebuilt with new toolchain and libgpod-0.4.2
178- add Patch0 (derived from FC)
179
180* Sun Jan  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.8-0vl1
181- new upstream release
182- added SOURCE1
183- rebuilt with libgpod-devel 0.4.0
184- moved gtkpod.desktop to %{_datadir}/applications <BTS:454>
185
186* Sun Jan  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.2-0vl2
187- rebuilt for VineSeed Plus
188
189* Sun Jan  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.2-0vl1
190- new upstream release
191
192* Fri Dec 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl3
193- rebuilt for VineSeed Plus
194
195* Fri Dec 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl2
196- rebuilt for VinePlus/3.0
197- added BuildRequires: curl-devel, flex
198
199* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.0-0vl1
200- new upstream release.
201- add BuildRequires: libgpod-devel
202
203* Tue Aug 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.94.0-0vl1
204-new upstream release.
205
206* Mon Jun 16 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl3
207-A revision %description -l ja
208-A revision %files
209-add %doc
210
211* Thu Jun 2 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl2
212-add macro
213-add BuildRequires
214
215* Tue May 17 2005 TOSHI <toshi-52@s5.dion.ne.jp> 0.8.22-0vl1
216First release.
217
218- initial build for Vine Linux
219
220# end of file
Note: See TracBrowser for help on using the repository browser.