source: projects/specs/trunk/g/gtkmm2/gtkmm2-vl.spec @ 10413

Revision 10413, 7.3 KB checked in by Takemikaduchi, 8 years ago (diff)

gtkmm3,mm-common,pulseaudio: new upstream release
others: rebuild with gcc-5.4.0

Line 
1%define ver 2.4
2
3Summary: A C++ interface for the GTK+ (a GUI library for X).
4Summary(ja): GTK+ の C++ インターフェイス
5Name: gtkmm2
6Version: 2.24.4
7Release: 2%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10Source: ftp://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/gtkmm-%{version}.tar.xz
11
12URL: http://gtkmm.sourceforge.net/
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14Requires: glibmm >= 2.21.2
15Requires: pangomm >= 2.25.1.3
16Requires: atk >= 1.9.0
17Requires: gtk2 >= 2.17.11
18BuildRequires: glibmm-devel >= 2.21.2
19BuildRequires: cairomm-devel
20BuildRequires: pangomm-devel >= 2.25.1.3
21BuildRequires: atkmm-devel
22BuildRequires: gtk2-devel >= 2.17.11
23BuildRequires: libsigc++-devel >= 2.0.0
24BuildRequires: mm-common
25BuildRequires: autoconf
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30# from upstream
31Patch0: gtkmm-2.24.4-c++11.patch
32
33%description
34gtkmm (previously known as Gtk--) is the official C++ interface for the
35popular GUI library GTK+. Highlights include typesafe callbacks, widgets
36extensible via inheritance and a comprehensive set of widget classes that
37can be freely combined to quickly create complex user interfaces.
38
39The gtkmm devel package contains the static libraries and header files
40needed for developing GTK+ (GIMP ToolKit) applications in C++.
41
42
43%package        devel
44Summary:        Development tools for gtkmm applications.
45Summary(ja):    gtkmm アプリケーションの開発用ファイル
46Group:          Development/Libraries
47Requires:       %{name} = %{version}
48Requires:       gtk2-devel >= 2.17.11
49Requires:       glibmm-devel >= 2.21.2
50Requires:       cairomm-devel
51Requires:       pangomm-devel >= 2.25.1.3
52
53%description devel
54This package contains the headers that programmers will need to develop
55applications which will use Gtk--, the C++ interface to the GTK+
56(the Gimp ToolKit) GUI library.
57
58%prep
59%setup -q -n gtkmm-%{version}
60%patch0 -p1
61
62%build
63autoreconf -if
64%configure --disable-static
65# removing rpath
66sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
67sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
68
69make %{?_smp_mflags}
70
71%install
72[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
73
74make install DESTDIR=$RPM_BUILD_ROOT
75
76find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
77
78# Fix documentation installation, put everything under gtk-doc
79mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/gtkmm-%{ver}
80mv ${RPM_BUILD_ROOT}%{_docdir}/gtkmm-%{ver}/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/gtkmm-%{ver}/
81
82# devhelp path fix
83sed -i 's:doc/gtkmm-%{ver}:gtk-doc/html/gtkmm-%{ver}:g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/gtkmm-%{ver}/gtkmm-%{ver}.devhelp2
84
85# remove demos, examples
86rm -rf $RPM_BUILD_ROOT%{_datadir}/gtkmm-%{ver}/demo
87rm -rf $RPM_BUILD_ROOT%{_datadir}/gtkmm-%{ver}/examples
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%clean
94[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
95
96%files
97%defattr(-, root, root)
98%doc AUTHORS COPYING ChangeLog NEWS README
99%{_libdir}/lib*.so.*
100
101%files  devel
102%defattr(-, root, root)
103%{_includedir}/*
104#{_libdir}/*.la
105#{_libdir}/*.a
106%{_libdir}/*.so
107%{_libdir}/gtkmm-*
108%{_libdir}/gdkmm-*
109%{_libdir}/pkgconfig/*.pc
110
111%{_datadir}/gtk-doc/html/*
112%{_datadir}/devhelp/books/*
113
114%changelog
115* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.4-2
116- rebuild with gcc-5.4.0
117- add Patch0 (gtkmm-2.24.4-c++11.patch)
118
119* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.4-1
120- new upstream release
121
122* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
123- new upstream release
124
125* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
126- new upstream release
127- add BuildRequires: mm-common, autoconf
128
129* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
130- new upstream release
131- change BuildRequires: atkmm-devel instead of atk-devel
132
133* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.20.3-2
134- build with rpm-4.8.1-1 for pkg-config file
135
136* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.3-1
137- new upstream release
138
139* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.2-1
140- new upstream release
141
142* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.20.0-1
143- new upstream release
144
145* Mon Oct  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-1
146- new upstream release
147
148* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1
149- new upstream release
150- dropped Patch0
151
152* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-1vl5
153- new upstream release
154- added --disable-static to %%configure
155- added Patch0 for devhelp path fix
156- spec in UTF-8
157
158* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-1vl5
159- new upstream release
160- devel documents are installed into gtk-doc dir
161
162* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
163- new upstream release
164
165* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.10-0vl1
166- new upstream release
167- rebuild with new environment/toolchain
168
169* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.9-0vl1
170- new upstream release
171- added Requires/BuildRequires for cairomm
172
173* Tue Jan  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.10-0vl1
174- new upstream release
175
176* Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.9-0vl1
177- new upstream release
178
179* Sat Aug 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.8-0vl2
180- rebuilt with glibmm-2.12.0, pango-1.14.0, atk-1.12.1
181
182* Sat May 20 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.8-0vl1
183- new upstream release
184
185* Mon May 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.7-0vl1
186- new upstream release
187
188* Tue Apr 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.5-0vl1
189- new upstream release
190
191* Sat Feb  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
192- new upstream release
193
194* Sat Nov 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
195- new upstream release
196
197* Tue Sep 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
198- new upstream release
199
200* Wed Aug 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-0vl2
201- rebuild with libsigc++ 2.0.16, libtool 1.5.18
202- added Requires: pkgconfig
203- added Requires: glibmm-devel to devel package
204
205* Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-0vl1
206- new upstream release
207
208* Tue May 03 2005 Satoshi MACHINO <machino@vinelinux.org> 2.6.2-0vl1
209- new upstream release
210- changed Copylight to License
211
212* Sat Apr  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.1-0vl1
213- new upstream release
214- updated dependancy
215
216* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.11-0vl1
217- new upstream release
218
219* Sat Dec 11 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.8-0vl1
220- new upstream release
221
222* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.7-0vl1
223- new upstream release
224- fixed libraries dependancy
225- added Japanese summary
226
227* Tue Dec 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1vl1
228- rebuild for Vine Linux
229- based on Freshrpms
230
231* Wed Nov 12 2003 Matthias Saou <http://freshrpms.net/> - 2.2.8-1.fr
232- Update to 2.2.8.
233- Added devhelp book.
234- Rebuild for Fedora Core 1.
235
236* Tue Jul 22 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
237- Update to 2.2.5.
238
239* Fri May 23 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
240- Update to 2.2.3.
241
242* Thu May 22 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
243- Update to 2.2.2.
244
245* Sun May  4 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
246- Initial release based on the gtkmm 1.x spec file.
Note: See TracBrowser for help on using the repository browser.