source: projects/specs/trunk/g/gstreamer1-plugins-base/gstreamer1-plugins-base-vl.spec @ 7010

Revision 7010, 7.6 KB checked in by Takemikaduchi, 12 years ago (diff)

gstreamer-1.0.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 1.0
4
5%define _gst_ver        1.0.2
6%define _glib2_ver      2.34.0
7%define _gtk3_ver       3.6.0
8%define _gtk_doc_ver    1.3
9%define _qt4_ver        4.6
10%define _check_ver      0.9.2
11%define _python_ver     2.6
12%define _alsa_lib_ver   0.9.1
13%define _libogg_ver     1.0
14%define _libvorbis_ver  1.0
15%define _freetype2_ver  2.0.9
16
17%define po_package      gst-plugins-base-%{major}
18
19Summary:        GStreamer Streaming-media framework base plugins
20Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
21Name:           gstreamer1-plugins-base
22Version:        1.0.2
23Release:        1%{?_dist_release}
24License:        LGPL
25Group:          System Environment/Libraries
26URL:            http://gstreamer.freedesktop.org/
27Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Requires:       gstreamer1 >= %{_gst_ver}
31
32BuildRequires:  gstreamer1-devel >= %{_gst_ver}
33BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
34BuildRequires:  python >= %{_python_ver}, python-pyxml
35BuildRequires:  glib2-devel >= %{_glib2_ver}
36BuildRequires:  check >= %{_check_ver}
37BuildRequires:  gtk3-devel >= %{_gtk3_ver}
38BuildRequires:  qt4-devel >= %{_qt4_ver}
39BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
40BuildRequires:  cdparanoia-devel
41BuildRequires:  libogg-devel >= %{_libogg_ver}
42BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
43BuildRequires:  pango-devel
44BuildRequires:  freetype2-devel >= %{_freetype2_ver}
45BuildRequires:  fontconfig-devel
46BuildRequires:  libX11-devel
47BuildRequires:  libXv-devel
48BuildRequires:  libvisual-devel
49BuildRequires:  orc-devel
50BuildRequires:  gobject-introspection-devel
51
52Vendor:         Project Vine
53Distribution:   Vine Linux
54Packager:       Takemikaduchi
55
56%description
57GStreamer is a streaming-media framework, based on graphs of filters which
58operate on media data. Applications using this library can do anything
59from real-time sound processing to playing videos, and just about anything
60else media-related.  Its plugin-based architecture means that new data
61types or processing capabilities can be added simply by installing new
62plugins.
63
64This package contains a set of well-maintained base plugins.
65
66%package devel
67Summary:        Libraries/include files for GStreamer base plugins
68Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       gstreamer1-devel >= %{_gst_ver}
72
73%description devel
74GStreamer is a streaming-media framework, based on graphs of filters which
75operate on media data. Applications using this library can do anything
76from real-time sound processing to playing videos, and just about anything
77else media-related.  Its plugin-based architecture means that new data
78types or processing capabilities can be added simply by installing new
79plugins.
80
81This package contains GStreamer base plugins library depvelopment and header
82files.
83
84# compat32
85%package -n compat32-%{name}
86Summary:        GStreamer Streaming-media framework base plugins
87Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
88Group:          System Environment/Libraries
89Requires:       %{name} = %{version}-%{release}
90
91%description -n compat32-%{name}
92GStreamer is a streaming-media framework, based on graphs of filters which
93operate on media data. Applications using this library can do anything
94from real-time sound processing to playing videos, and just about anything
95else media-related.  Its plugin-based architecture means that new data
96types or processing capabilities can be added simply by installing new
97plugins.
98
99This package contains a set of well-maintained base plugins.
100
101%package -n compat32-%{name}-devel
102Summary:        Libraries/include files for GStreamer base plugins
103Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
104Group:          Development/Libraries
105Requires:       compat32-%{name} = %{version}-%{release}
106Requires:       %{name}-devel = %{version}-%{release}
107Requires:       compat32-gstreamer1-devel >= %{_gst_ver}
108
109%description -n compat32-%{name}-devel
110GStreamer is a streaming-media framework, based on graphs of filters which
111operate on media data. Applications using this library can do anything
112from real-time sound processing to playing videos, and just about anything
113else media-related.  Its plugin-based architecture means that new data
114types or processing capabilities can be added simply by installing new
115plugins.
116
117This package contains GStreamer base plugins library depvelopment and header
118files.
119
120
121%prep
122%setup -q -n gst-plugins-base-%{version}
123
124%build
125%ifarch alpha
126%define optflags -O2 -mieee -fPIC
127%endif
128
129%configure \
130        --with-package-name='Vine Linux gstreamer-plugins-base package' \
131        --enable-gtk-doc \
132        --disable-static \
133        --disable-debug \
134        --enable-orc \
135        --enable-introspection=yes
136
137make %{?_smp_mflags}
138
139%install
140[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
141make install DESTDIR=$RPM_BUILD_ROOT
142
143# Clean out files that should not be part of the rpm.
144rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
145rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
146
147%find_lang %{po_package}
148
149%clean
150[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%post -n compat32-%{name} -p /sbin/ldconfig
157
158%postun -n compat32-%{name} -p /sbin/ldconfig
159
160%files -f %{po_package}.lang
161%defattr(-,root,root)
162%doc AUTHORS ChangeLog COPYING* NEWS README RELEASE REQUIREMENTS
163
164# helper programs
165%{_bindir}/gst-*
166%{_mandir}/man1/gst-*
167
168%{_datadir}/gst-plugins-base/1.0/license-translations.dict
169
170# libraries
171%{_libdir}/libgst*-%{major}.so.*
172%{_libdir}/girepository-1.0/*.typelib
173
174# base plugins without external dependencies
175%{_libdir}/gstreamer-%{major}/libgstadder.so
176%{_libdir}/gstreamer-%{major}/libgstaudioconvert.so
177%{_libdir}/gstreamer-%{major}/libgstaudiorate.so
178%{_libdir}/gstreamer-%{major}/libgstaudioresample.so
179%{_libdir}/gstreamer-%{major}/libgstaudiotestsrc.so
180%{_libdir}/gstreamer-%{major}/libgstapp.so
181%{_libdir}/gstreamer-%{major}/libgstcdparanoia.so
182%{_libdir}/gstreamer-%{major}/libgstencodebin.so
183%{_libdir}/gstreamer-%{major}/libgstgio.so
184%{_libdir}/gstreamer-%{major}/libgstplayback.so
185%{_libdir}/gstreamer-%{major}/libgsttcp.so
186%{_libdir}/gstreamer-%{major}/libgsttypefindfunctions.so
187%{_libdir}/gstreamer-%{major}/libgstvideoconvert.so
188%{_libdir}/gstreamer-%{major}/libgstvideorate.so
189%{_libdir}/gstreamer-%{major}/libgstvideoscale.so
190%{_libdir}/gstreamer-%{major}/libgstvideotestsrc.so
191%{_libdir}/gstreamer-%{major}/libgstvolume.so
192%{_libdir}/gstreamer-%{major}/libgstximagesink.so
193%{_libdir}/gstreamer-%{major}/libgstxvimagesink.so
194
195# base plugins with external dependencies, but in the main package
196%{_libdir}/gstreamer-%{major}/libgstalsa.so
197%{_libdir}/gstreamer-%{major}/libgstpango.so
198%{_libdir}/gstreamer-%{major}/libgstlibvisual.so
199%{_libdir}/gstreamer-%{major}/libgstogg.so
200%{_libdir}/gstreamer-%{major}/libgsttheora.so
201%{_libdir}/gstreamer-%{major}/libgstvorbis.so
202
203%files devel
204%defattr(-,root,root)
205%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
206%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
207%{_datadir}/gir-1.0/*.gir
208%{_includedir}/gstreamer-%{major}/gst/*
209%{_libdir}/pkgconfig/*.pc
210%{_libdir}/libgst*-%{major}.so
211
212# compat32
213%if %{build_compat32}
214%files -n compat32-%{name}
215%defattr(-,root,root)
216%{_libdir}/libgst*-%{major}.so.*
217%{_libdir}/gstreamer-%{major}/*.so
218
219%files -n compat32-%{name}-devel
220%defattr(-,root,root)
221%{_libdir}/libgst*-%{major}.so
222%endif
223
224
225%changelog
226* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
227- new upstream release
228
229* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
230- new upstream release
231
232* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
233- initial build
Note: See TracBrowser for help on using the repository browser.