source: projects/specs/trunk/g/gstreamer1-plugins-base/gstreamer1-plugins-base-vl.spec @ 12381

Revision 12381, 8.7 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

gstreamer1-plugins-base-1.16.2-1

gstreamer1-plugins-good-1.16.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 1.0
4
5%define _gst_ver        1.16.0
6%define _glib2_ver      2.55.0
7%define _gtk3_ver       3.20.6
8%define _gtk_doc_ver    1.3
9%define _qt5_ver        5.6
10%define _check_ver      0.9.2
11%define _python_ver     2.7
12%define _alsa_lib_ver   0.9.1
13%define _libogg_ver     1.0
14%define _libvorbis_ver  1.0
15%define _freetype2_ver  2.0.9
16%define _orc_ver        0.4.22
17
18%define po_package      gst-plugins-base-%{major}
19
20Summary:        GStreamer Streaming-media framework base plugins
21Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
22Name:           gstreamer1-plugins-base
23Version:        1.16.2
24Release:        1%{?_dist_release}
25Group:          System Environment/Libraries
26Vendor:         Project Vine
27Distribution:   Vine Linux
28
29License:        LGPL
30URL:            https://gstreamer.freedesktop.org/
31Source:         https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34Requires:       gstreamer1 >= %{_gst_ver}
35
36BuildRequires:  gstreamer1-devel >= %{_gst_ver}
37BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
38BuildRequires:  python >= %{_python_ver}, python-pyxml
39BuildRequires:  glib2-devel >= %{_glib2_ver}
40BuildRequires:  check >= %{_check_ver}
41BuildRequires:  gtk3-devel >= %{_gtk3_ver}
42BuildRequires:  qt5-qtbase-devel >= %{_qt5_ver}
43BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
44BuildRequires:  cdparanoia-devel
45BuildRequires:  libogg-devel >= %{_libogg_ver}
46BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
47BuildRequires:  opus-devel
48BuildRequires:  pango-devel
49BuildRequires:  freetype2-devel >= %{_freetype2_ver}
50BuildRequires:  fontconfig-devel
51BuildRequires:  libX11-devel
52BuildRequires:  libXv-devel
53BuildRequires:  libvisual-devel
54BuildRequires:  orc-devel >= %{_orc_ver}
55BuildRequires:  gobject-introspection-devel
56
57
58%description
59GStreamer is a streaming-media framework, based on graphs of filters which
60operate on media data. Applications using this library can do anything
61from real-time sound processing to playing videos, and just about anything
62else media-related.  Its plugin-based architecture means that new data
63types or processing capabilities can be added simply by installing new
64plugins.
65
66This package contains a set of well-maintained base plugins.
67
68%package devel
69Summary:        Libraries/include files for GStreamer base plugins
70Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
71Group:          Development/Libraries
72Requires:       %{name} = %{version}-%{release}
73Requires:       gstreamer1-devel >= %{_gst_ver}
74
75%description devel
76GStreamer is a streaming-media framework, based on graphs of filters which
77operate on media data. Applications using this library can do anything
78from real-time sound processing to playing videos, and just about anything
79else media-related.  Its plugin-based architecture means that new data
80types or processing capabilities can be added simply by installing new
81plugins.
82
83This package contains GStreamer base plugins library depvelopment and header
84files.
85
86# compat32
87%package -n compat32-%{name}
88Summary:        GStreamer Streaming-media framework base plugins
89Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
90Group:          System Environment/Libraries
91Requires:       %{name} = %{version}-%{release}
92
93%description -n compat32-%{name}
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new
99plugins.
100
101This package contains a set of well-maintained base plugins.
102
103%package -n compat32-%{name}-devel
104Summary:        Libraries/include files for GStreamer base plugins
105Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
106Group:          Development/Libraries
107Requires:       compat32-%{name} = %{version}-%{release}
108Requires:       %{name}-devel = %{version}-%{release}
109Requires:       compat32-gstreamer1-devel >= %{_gst_ver}
110
111%description -n compat32-%{name}-devel
112GStreamer is a streaming-media framework, based on graphs of filters which
113operate on media data. Applications using this library can do anything
114from real-time sound processing to playing videos, and just about anything
115else media-related.  Its plugin-based architecture means that new data
116types or processing capabilities can be added simply by installing new
117plugins.
118
119This package contains GStreamer base plugins library depvelopment and header
120files.
121
122
123%prep
124%setup -q -n gst-plugins-base-%{version}
125
126%build
127%ifarch alpha
128%define optflags -O2 -mieee -fPIC
129%endif
130
131%configure \
132        --with-package-name='Vine Linux gstreamer-plugins-base package' \
133        --disable-static \
134        --disable-debug \
135        --enable-orc \
136        --enable-introspection=yes \
137        --enable-wayland=no
138
139make %{?_smp_mflags}
140
141%install
142[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
143make install DESTDIR=$RPM_BUILD_ROOT
144
145# Clean out files that should not be part of the rpm.
146rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
147rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
148
149%find_lang %{po_package}
150
151%clean
152[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
153
154%post -p /sbin/ldconfig
155
156%postun -p /sbin/ldconfig
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159
160%postun -n compat32-%{name} -p /sbin/ldconfig
161
162%files -f %{po_package}.lang
163%defattr(-,root,root)
164%license COPYING*
165%doc AUTHORS ChangeLog NEWS README RELEASE REQUIREMENTS
166
167# helper programs
168%{_bindir}/gst-*
169%{_mandir}/man1/gst-*
170
171%{_datadir}/gst-plugins-base/1.0/license-translations.dict
172
173# libraries
174%{_libdir}/libgst*-%{major}.so.*
175%{_libdir}/girepository-1.0/*.typelib
176%{_libdir}/gstreamer-%{major}/libgst*.so
177
178%files devel
179%defattr(-,root,root)
180%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
181%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
182%{_datadir}/gir-1.0/*.gir
183%dir %{_includedir}/gstreamer-%{major}
184%dir %{_includedir}/gstreamer-%{major}/gst
185%{_includedir}/gstreamer-%{major}/gst/*
186%dir %{_libdir}/gstreamer-%{major}
187%{_libdir}/gstreamer-%{major}/*
188%{_libdir}/pkgconfig/*.pc
189%{_libdir}/libgst*-%{major}.so
190
191# compat32
192%if %{build_compat32}
193%files -n compat32-%{name}
194%defattr(-,root,root)
195%{_libdir}/libgst*-%{major}.so.*
196%{_libdir}/gstreamer-%{major}/*.so
197
198%files -n compat32-%{name}-devel
199%defattr(-,root,root)
200%{_libdir}/libgst*-%{major}.so
201%endif
202
203
204%changelog
205* Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
206- new upstream release.
207
208* Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
209- new upstream release.
210- disabled to build docs.
211
212* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
213- new upstream release.
214
215* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
216- new upstream release
217
218* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
219- new upstream release
220
221* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
222- new upstream release
223
224* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
225- new upstream release
226
227* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
228- new upstream release
229
230* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
231- new upstream release
232
233* Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
234- new upstream release
235
236* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
237- new upstream release
238
239* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
240- new upstream release
241
242* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
243- new upstream release
244
245* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
246- new upstream release
247
248* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
249- new upstream release
250
251* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
252- new upstream release
253
254* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
255- new upstream release
256
257* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
258- new upstream release
259
260* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
261- new upstream release
262
263* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
264- new upstream release
265
266* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
267- new upstream release
268
269* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
270- new upstream release
271
272* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
273- new upstream release
274
275* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
276- new upstream release
277
278* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
279- new upstream release
280
281* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
282- initial build
Note: See TracBrowser for help on using the repository browser.