source: projects/specs/trunk/g/gstreamer1-plugins-base/gstreamer1-plugins-base-vl.spec @ 12121

Revision 12121, 8.6 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define major 1.0
4
5%define _gst_ver        1.16.0
6%define _glib2_ver      2.55.0
7%define _gtk3_ver       3.20.6
8%define _gtk_doc_ver    1.3
9%define _qt5_ver        5.6
10%define _check_ver      0.9.2
11%define _python_ver     2.7
12%define _alsa_lib_ver   0.9.1
13%define _libogg_ver     1.0
14%define _libvorbis_ver  1.0
15%define _freetype2_ver  2.0.9
16%define _orc_ver        0.4.22
17
18%define po_package      gst-plugins-base-%{major}
19
20Summary:        GStreamer Streaming-media framework base plugins
21Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
22Name:           gstreamer1-plugins-base
23Version:        1.16.0
24Release:        1%{?_dist_release}
25License:        LGPL
26Group:          System Environment/Libraries
27URL:            http://gstreamer.freedesktop.org/
28Source:         http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-%{version}.tar.xz
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31Requires:       gstreamer1 >= %{_gst_ver}
32
33BuildRequires:  gstreamer1-devel >= %{_gst_ver}
34BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
35BuildRequires:  python >= %{_python_ver}, python-pyxml
36BuildRequires:  glib2-devel >= %{_glib2_ver}
37BuildRequires:  check >= %{_check_ver}
38BuildRequires:  gtk3-devel >= %{_gtk3_ver}
39BuildRequires:  qt5-qtbase-devel >= %{_qt5_ver}
40BuildRequires:  alsa-lib-devel >= %{_alsa_lib_ver}
41BuildRequires:  cdparanoia-devel
42BuildRequires:  libogg-devel >= %{_libogg_ver}
43BuildRequires:  libtheora-devel, libvorbis-devel >= %{_libvorbis_ver}
44BuildRequires:  opus-devel
45BuildRequires:  pango-devel
46BuildRequires:  freetype2-devel >= %{_freetype2_ver}
47BuildRequires:  fontconfig-devel
48BuildRequires:  libX11-devel
49BuildRequires:  libXv-devel
50BuildRequires:  libvisual-devel
51BuildRequires:  orc-devel >= %{_orc_ver}
52BuildRequires:  gobject-introspection-devel
53
54Vendor:         Project Vine
55Distribution:   Vine Linux
56
57%description
58GStreamer is a streaming-media framework, based on graphs of filters which
59operate on media data. Applications using this library can do anything
60from real-time sound processing to playing videos, and just about anything
61else media-related.  Its plugin-based architecture means that new data
62types or processing capabilities can be added simply by installing new
63plugins.
64
65This package contains a set of well-maintained base plugins.
66
67%package devel
68Summary:        Libraries/include files for GStreamer base plugins
69Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
70Group:          Development/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       gstreamer1-devel >= %{_gst_ver}
73
74%description devel
75GStreamer is a streaming-media framework, based on graphs of filters which
76operate on media data. Applications using this library can do anything
77from real-time sound processing to playing videos, and just about anything
78else media-related.  Its plugin-based architecture means that new data
79types or processing capabilities can be added simply by installing new
80plugins.
81
82This package contains GStreamer base plugins library depvelopment and header
83files.
84
85# compat32
86%package -n compat32-%{name}
87Summary:        GStreamer Streaming-media framework base plugins
88Summary(ja):    GStreamer ストリーミングメディアフレームワーク用基本プラグイン
89Group:          System Environment/Libraries
90Requires:       %{name} = %{version}-%{release}
91
92%description -n compat32-%{name}
93GStreamer is a streaming-media framework, based on graphs of filters which
94operate on media data. Applications using this library can do anything
95from real-time sound processing to playing videos, and just about anything
96else media-related.  Its plugin-based architecture means that new data
97types or processing capabilities can be added simply by installing new
98plugins.
99
100This package contains a set of well-maintained base plugins.
101
102%package -n compat32-%{name}-devel
103Summary:        Libraries/include files for GStreamer base plugins
104Summary(ja):    GStreamer 基本プラグインの開発用ライブラリ
105Group:          Development/Libraries
106Requires:       compat32-%{name} = %{version}-%{release}
107Requires:       %{name}-devel = %{version}-%{release}
108Requires:       compat32-gstreamer1-devel >= %{_gst_ver}
109
110%description -n compat32-%{name}-devel
111GStreamer is a streaming-media framework, based on graphs of filters which
112operate on media data. Applications using this library can do anything
113from real-time sound processing to playing videos, and just about anything
114else media-related.  Its plugin-based architecture means that new data
115types or processing capabilities can be added simply by installing new
116plugins.
117
118This package contains GStreamer base plugins library depvelopment and header
119files.
120
121
122%prep
123%setup -q -n gst-plugins-base-%{version}
124
125%build
126%ifarch alpha
127%define optflags -O2 -mieee -fPIC
128%endif
129
130%configure \
131        --with-package-name='Vine Linux gstreamer-plugins-base package' \
132        --disable-static \
133        --disable-debug \
134        --enable-orc \
135        --enable-introspection=yes \
136        --enable-wayland=no
137
138make %{?_smp_mflags}
139
140%install
141[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
142make install DESTDIR=$RPM_BUILD_ROOT
143
144# Clean out files that should not be part of the rpm.
145rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.{a,la}
146rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
147
148%find_lang %{po_package}
149
150%clean
151[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
152
153%post -p /sbin/ldconfig
154
155%postun -p /sbin/ldconfig
156
157%post -n compat32-%{name} -p /sbin/ldconfig
158
159%postun -n compat32-%{name} -p /sbin/ldconfig
160
161%files -f %{po_package}.lang
162%defattr(-,root,root)
163%license COPYING*
164%doc AUTHORS ChangeLog NEWS README RELEASE REQUIREMENTS
165
166# helper programs
167%{_bindir}/gst-*
168%{_mandir}/man1/gst-*
169
170%{_datadir}/gst-plugins-base/1.0/license-translations.dict
171
172# libraries
173%{_libdir}/libgst*-%{major}.so.*
174%{_libdir}/girepository-1.0/*.typelib
175%{_libdir}/gstreamer-%{major}/libgst*.so
176
177%files devel
178%defattr(-,root,root)
179%{_datadir}/gtk-doc/html/gst-plugins-base-libs-%{major}
180%{_datadir}/gtk-doc/html/gst-plugins-base-plugins-%{major}
181%{_datadir}/gir-1.0/*.gir
182%dir %{_includedir}/gstreamer-%{major}
183%dir %{_includedir}/gstreamer-%{major}/gst
184%{_includedir}/gstreamer-%{major}/gst/*
185%dir %{_libdir}/gstreamer-%{major}
186%{_libdir}/gstreamer-%{major}/*
187%{_libdir}/pkgconfig/*.pc
188%{_libdir}/libgst*-%{major}.so
189
190# compat32
191%if %{build_compat32}
192%files -n compat32-%{name}
193%defattr(-,root,root)
194%{_libdir}/libgst*-%{major}.so.*
195%{_libdir}/gstreamer-%{major}/*.so
196
197%files -n compat32-%{name}-devel
198%defattr(-,root,root)
199%{_libdir}/libgst*-%{major}.so
200%endif
201
202
203%changelog
204* Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
205- new upstream release.
206- disabled to build docs.
207
208* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
209- new upstream release.
210
211* Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
212- new upstream release
213
214* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
215- new upstream release
216
217* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
218- new upstream release
219
220* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
221- new upstream release
222
223* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
224- new upstream release
225
226* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
227- new upstream release
228
229* Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
230- new upstream release
231
232* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
233- new upstream release
234
235* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
236- new upstream release
237
238* Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
239- new upstream release
240
241* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
242- new upstream release
243
244* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
245- new upstream release
246
247* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
248- new upstream release
249
250* Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
251- new upstream release
252
253* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
254- new upstream release
255
256* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
257- new upstream release
258
259* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
260- new upstream release
261
262* Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
263- new upstream release
264
265* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
266- new upstream release
267
268* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
269- new upstream release
270
271* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
272- new upstream release
273
274* Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
275- new upstream release
276
277* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
278- initial build
Note: See TracBrowser for help on using the repository browser.