source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 559

Revision 559, 14.5 KB checked in by inagaki, 14 years ago (diff)

2010-03-13 Ryoichi INAGAKI <ryo1@…>

updated gstreamer, gstreamer-plugins-base, gstreamer-plugins-good

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.8.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Version:        0.10.28
16Release:        1%{?_dist_release}
17Summary:        GStreamer streaming media framework runtime.
18Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
19Group:          System Environment/Libraries
20License:        LGPL
21URL:            http://gstreamer.freedesktop.org/
22Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  glib2-devel >= %{_glib2_ver}
26BuildRequires:  libxml2-devel >= %{_libxml2_ver}
27BuildRequires:  bison
28BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
29BuildRequires:  flex
30BuildRequires:  ghostscript
31BuildRequires:  check >= %{_check_ver}
32BuildRequires:  python >= %{_python_ver}, python-pyxml
33Requires:       glib2 >= %{_glib2_ver}
34Requires:       libxml2 >= %{_libxml2_ver}
35Obsoletes:      gstreamer-tools
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       inagaki
40
41%description
42GStreamer is a streaming-media framework, based on graphs of filters which
43operate on media data. Applications using this library can do anything
44from real-time sound processing to playing videos, and just about anything
45else media-related.  Its plugin-based architecture means that new data
46types or processing capabilities can be added simply by installing new
47plugins.
48
49%package devel
50Summary:        Libraries/header files for GStreamer streaming media framework.
51Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       glib2-devel >= %{_glib2_ver}
55Requires:       libxml2-devel >= %{_libxml2_ver}
56
57%description devel
58GStreamer is a streaming-media framework, based on graphs of filters which
59operate on media data. Applications using this library can do anything
60from real-time sound processing to playing videos, and just about anything
61else media-related.  Its plugin-based architecture means that new data
62types or processing capabilities can be added simply by installing new   
63plugins.
64
65This package contains the libraries and includes files necessary to develop
66applications and plugins for GStreamer.
67
68# compat32
69%package -n compat32-%{name}
70Summary:        GStreamer streaming media framework runtime.
71Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
72Group:          System Environment/Libraries
73
74%description -n compat32-%{name}
75GStreamer is a streaming-media framework, based on graphs of filters which
76operate on media data. Applications using this library can do anything
77from real-time sound processing to playing videos, and just about anything
78else media-related.  Its plugin-based architecture means that new data
79types or processing capabilities can be added simply by installing new
80plugins.
81
82%package -n compat32-%{name}-devel
83Summary:        Libraries/header files for GStreamer streaming media framework.
84Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
85Group:          Development/Libraries
86Requires:       compat32-%{name} = %{version}-%{release}
87Requires:       %{name}-devel = %{version}-%{release}
88Requires:       compat32-glib2-devel >= %{_glib2_ver}
89Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
90
91%description -n compat32-%{name}-devel
92GStreamer is a streaming-media framework, based on graphs of filters which
93operate on media data. Applications using this library can do anything
94from real-time sound processing to playing videos, and just about anything
95else media-related.  Its plugin-based architecture means that new data
96types or processing capabilities can be added simply by installing new   
97plugins.
98
99This package contains the libraries and includes files necessary to develop
100applications and plugins for GStreamer.
101
102%prep
103%setup -q
104
105%build
106%configure \
107        --with-package-name='Vine Linux gstreamer package' \
108        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
109        --disable-docbook --enable-gtk-doc \
110        --disable-static --disable-examples \
111        --disable-tests --disable-debug
112
113make %{?_smp_mflags}
114
115%install
116[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
117
118make install DESTDIR=$RPM_BUILD_ROOT
119
120mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
121
122rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
125
126%find_lang %{po_package}
127
128%clean
129[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%post -n compat32-%{name} -p /sbin/ldconfig
136
137%postun -n compat32-%{name} -p /sbin/ldconfig
138
139%files -f %{po_package}.lang
140%defattr(-, root, root)
141%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
142%doc TODO ABOUT-NLS
143%{_bindir}/*
144%dir %{_libdir}/gstreamer-%{major}
145%{_libdir}/gstreamer-%{major}/*.so*
146%{_libdir}/*.so.*
147%dir %{_libexecdir}/gstreamer-%{major}
148%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
149%{_mandir}/man1/*
150%dir %{_var}/cache/gstreamer-%{major}
151
152%files devel
153%defattr(-, root, root)
154%dir %{_includedir}/%{name}-%{major}
155%{_includedir}/%{name}-%{major}/*
156#{_libdir}/*.a
157%{_libdir}/*.so
158%{_libdir}/pkgconfig/gstreamer*.pc
159%{_datadir}/aclocal/*.m4
160%{_datadir}/gtk-doc/html/gstreamer-%{major}
161%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
162%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
163
164# compat32
165%if %{build_compat32}
166%files -n compat32-%{name}
167%defattr(-, root, root)
168%dir %{_libdir}/gstreamer-%{major}
169%{_libdir}/gstreamer-%{major}/*.so*
170%{_libdir}/*.so.*
171
172%files -n compat32-%{name}-devel
173%defattr(-, root, root)
174#{_libdir}/*.a
175%{_libdir}/*.so
176%{_libdir}/pkgconfig/gstreamer*.pc
177%endif
178
179%changelog
180* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
181- new upstream release
182- used make install instead of %%makeinstall
183
184* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
185- new upstream release
186- built with new toolchain
187
188* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
189- new upstream release
190
191* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
192- new upstream release
193
194* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
195- added compat32 package for x86_64 arch support
196
197* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
198- new upstream release
199- removed static librairies from devel package
200- added Packager tag
201
202* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
203- new upstream release
204- changed Group to System Environment/Libraries
205
206* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
207- new upstream release
208- spec in UTF-8
209
210* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
211- new upstream release
212
213* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
214- new upstream release
215
216* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
217- new upstream release
218
219* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
220- new upstream release
221
222* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
223- new upstream release
224
225* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
226- new upstream release
227
228* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
229- new upstream release
230- add Vendor/Distribution tag
231- add '-with-package-name' option to %%configure
232- use more macros
233
234* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
235- new upstream release
236
237* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
238- new upstream release
239
240* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
241- new upstream release
242
243* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
244- new upstream release
245
246* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
247- new upstream release
248
249* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
250- new upstream release
251
252* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
253- new upstream release
254
255* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
256- new upstream release
257
258* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
259- new upstream release
260
261* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
262- new upstream release
263  - change major to 0.10
264- update URLs
265- update versions: glibc >= 2.8, gtk-doc >= 1.3
266- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
267- remove from BuildRequires: popt, zlib-devel
268- remove obsolete options from %%configure
269- add --enable-gtk-doc to %%configure
270- add gtk-doc/html/gstreamer-* to gstreamer-devel package
271- add RELEASE to %%doc
272- remove REQUIREMENTS DOCBUILDING from %%doc
273- not exec gst-register-%%{major} at %%post
274
275* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
276- new upstream release
277
278* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
279- new upstream release
280
281* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
282- new upstream release
283- removed dependancy related to documentaion build
284
285* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
286- new upstream release
287
288* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
289- new upstream release
290
291* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
292- update alpha-noWerror patch (Patch10)
293
294* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
295- new upstream release
296
297* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
298- new upstream release
299
300* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
301- new upstream release
302
303* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
304- build without -Werror on alpha (Patch10)
305
306* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
307- new upstream release
308
309* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
310- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
311
312* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
313- fix broken %files entries..
314
315* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
316- new upstream release
317
318* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
319- build for Vine Linux
320
321* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
322- Add patch1 to fix C++ plugins on ia64
323
324* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
325- %post -p was wrong
326
327* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
328- explicitly add %{_libdir}/libgstreamer-{major}.so
329- explicitly add %{_libdir}/libgstcontrol-{major}.so
330
331* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
332- bump release
333
334* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
335- move .so files out of -devel
336
337* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
338- new version 0.5.0
339- require docbook-style-xsl
340- add gstreamer-tools package too
341- New patch to use the right docbook prefix.
342
343* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
344- downgrade to a release candidate.  Should work better on other arches
345- build without Werror
346
347* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
348- update to new version.  Remove ExcludeArch
349
350* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
351- excludearch some arches
352
353* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
354- import into CVS and build "officially"
355- use smp_mflags
356- temporarily disable docs build, doesn't seem to work
357
358* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
359- 0.4.2
360
361* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
362- 0.4.1
363
364* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
365- minor cleanups
366
367* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
368- moved header location
369
370* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
371- added popt
372- removed .la
373
374* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
375- added release of gstreamer to req of gstreamer-devel
376- changed location of API docs to be in gtk-doc like other gtk-doc stuff
377- reordered SPEC file
378
379* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
380- moved html docs to gtk-doc standard directory
381
382* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
383- move version defines of glib2 and libxml2 to configure.ac
384- add BuildRequires for these two libs
385
386* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
387- put html docs in canonical place, avoiding %doc erasure
388- added devhelp support, current install of it is hackish
389
390* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
391- Added documentation to build
392
393* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
394- added libgstbasicscheduler
395- renamed libgst to libgstreamer
396
397* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
398- Added configdir parameter as it seems the configdir gets weird otherwise
399
400* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
401- split off gstreamer-editor from core
402- removed gstreamer-gnome-apps
403
404* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
405- Cleaned up the spec file for the gstreamer core/plug-ins split
406- Improve spec file
407
408* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
409- Split of more plugins from the core and put them into their own modules
410- Includes colorspace, xfree and wav
411- Improved package Require lines
412- Added mp3encode (lame based) to the SPEC
413
414* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
415- Thomas merged mpeg plugins into one
416* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
417- More minor cleanups including some fixed descriptions from Andrew Mitchell
418
419* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
420- Added logging to the make statement
421
422* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
423- Updated in preparation for 0.3.0 release
424
425* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
426- Updated for 0.2.1 release
427- Split out the GUI packages into their own RPM
428- added new plugins (FLAC, festival, quicktime etc.)
429
430* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
431- Visualisation plugins bundled out togheter
432- Moved files sections up close to their respective descriptions
433
434* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
435- Split the package into separate RPMS,
436  putting most plugins out by themselves.
437
438* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
439- Updated with change suggestions from Dennis Bjorklund
440
441* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
442- updated to build -devel package as well
443
444* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
445- first draft of spec file
446
Note: See TracBrowser for help on using the repository browser.