source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 2219

Revision 2219, 15.2 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.20.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.30.2
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34BuildRequires:  gobject-introspection-devel
35Requires:       glib2 >= %{_glib2_ver}
36Requires:       libxml2 >= %{_libxml2_ver}
37Obsoletes:      gstreamer-tools
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       inagaki
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51%package devel
52Summary:        Libraries/header files for GStreamer streaming media framework.
53Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       glib2-devel >= %{_glib2_ver}
57Requires:       libxml2-devel >= %{_libxml2_ver}
58
59%description devel
60GStreamer is a streaming-media framework, based on graphs of filters which
61operate on media data. Applications using this library can do anything
62from real-time sound processing to playing videos, and just about anything
63else media-related.  Its plugin-based architecture means that new data
64types or processing capabilities can be added simply by installing new   
65plugins.
66
67This package contains the libraries and includes files necessary to develop
68applications and plugins for GStreamer.
69
70# compat32
71%package -n compat32-%{name}
72Summary:        GStreamer streaming media framework runtime.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
74Group:          System Environment/Libraries
75
76%description -n compat32-%{name}
77GStreamer is a streaming-media framework, based on graphs of filters which
78operate on media data. Applications using this library can do anything
79from real-time sound processing to playing videos, and just about anything
80else media-related.  Its plugin-based architecture means that new data
81types or processing capabilities can be added simply by installing new
82plugins.
83
84%package -n compat32-%{name}-devel
85Summary:        Libraries/header files for GStreamer streaming media framework.
86Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
87Group:          Development/Libraries
88Requires:       compat32-%{name} = %{version}-%{release}
89Requires:       %{name}-devel = %{version}-%{release}
90Requires:       compat32-glib2-devel >= %{_glib2_ver}
91Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
92
93%description -n compat32-%{name}-devel
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new   
99plugins.
100
101This package contains the libraries and includes files necessary to develop
102applications and plugins for GStreamer.
103
104%prep
105%setup -q
106
107%build
108%configure \
109        --with-package-name='Vine Linux gstreamer package' \
110        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
111        --enable-introspection=yes \
112        --disable-docbook --enable-gtk-doc \
113        --disable-static --disable-examples \
114        --disable-tests --disable-debug
115
116make %{?_smp_mflags}
117
118%install
119[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
120
121make install DESTDIR=$RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
127#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
128
129%find_lang %{po_package}
130
131%clean
132[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142%files -f %{po_package}.lang
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
145%doc TODO ABOUT-NLS
146%{_bindir}/*
147%dir %{_libdir}/gstreamer-%{major}
148%{_libdir}/gstreamer-%{major}/*.so*
149%{_libdir}/*.so.*
150%{_libdir}/girepository-1.0/*.typelib
151%dir %{_libexecdir}/gstreamer-%{major}
152%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
153%{_mandir}/man1/*
154%dir %{_var}/cache/gstreamer-%{major}
155
156%files devel
157%defattr(-, root, root)
158%dir %{_includedir}/%{name}-%{major}
159%{_includedir}/%{name}-%{major}/*
160#{_libdir}/*.a
161%{_libdir}/*.so
162%{_libdir}/pkgconfig/gstreamer*.pc
163%{_datadir}/aclocal/*.m4
164%{_datadir}/gtk-doc/html/gstreamer-%{major}
165%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
166%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
167%{_datadir}/gir-1.0/*.gir
168
169# compat32
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-, root, root)
173%dir %{_libdir}/gstreamer-%{major}
174%{_libdir}/gstreamer-%{major}/*.so*
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-, root, root)
179#{_libdir}/*.a
180%{_libdir}/*.so
181%{_libdir}/pkgconfig/gstreamer*.pc
182%endif
183
184%changelog
185* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
186- new upstream release
187- add BuildRequires: gobject-introspection-devel
188- add configure option (--enable-introspection=yes)
189- fix %files
190
191* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
192- build with rpm-4.8.1-1 for pkg-config file
193
194* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
195- new upstream release
196
197* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
198- new upstream release
199
200* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
201- new upstream release
202- used make install instead of %%makeinstall
203
204* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
205- new upstream release
206- built with new toolchain
207
208* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
209- new upstream release
210
211* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
212- new upstream release
213
214* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
215- added compat32 package for x86_64 arch support
216
217* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
218- new upstream release
219- removed static librairies from devel package
220- added Packager tag
221
222* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
223- new upstream release
224- changed Group to System Environment/Libraries
225
226* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
227- new upstream release
228- spec in UTF-8
229
230* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
231- new upstream release
232
233* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
234- new upstream release
235
236* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
237- new upstream release
238
239* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
240- new upstream release
241
242* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
243- new upstream release
244
245* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
246- new upstream release
247
248* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
249- new upstream release
250- add Vendor/Distribution tag
251- add '-with-package-name' option to %%configure
252- use more macros
253
254* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
255- new upstream release
256
257* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
258- new upstream release
259
260* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
261- new upstream release
262
263* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
264- new upstream release
265
266* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
267- new upstream release
268
269* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
270- new upstream release
271
272* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
273- new upstream release
274
275* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
276- new upstream release
277
278* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
279- new upstream release
280
281* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
282- new upstream release
283  - change major to 0.10
284- update URLs
285- update versions: glibc >= 2.8, gtk-doc >= 1.3
286- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
287- remove from BuildRequires: popt, zlib-devel
288- remove obsolete options from %%configure
289- add --enable-gtk-doc to %%configure
290- add gtk-doc/html/gstreamer-* to gstreamer-devel package
291- add RELEASE to %%doc
292- remove REQUIREMENTS DOCBUILDING from %%doc
293- not exec gst-register-%%{major} at %%post
294
295* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
296- new upstream release
297
298* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
299- new upstream release
300
301* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
302- new upstream release
303- removed dependancy related to documentaion build
304
305* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
306- new upstream release
307
308* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
309- new upstream release
310
311* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
312- update alpha-noWerror patch (Patch10)
313
314* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
315- new upstream release
316
317* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
318- new upstream release
319
320* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
321- new upstream release
322
323* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
324- build without -Werror on alpha (Patch10)
325
326* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
327- new upstream release
328
329* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
330- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
331
332* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
333- fix broken %files entries..
334
335* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
336- new upstream release
337
338* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
339- build for Vine Linux
340
341* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
342- Add patch1 to fix C++ plugins on ia64
343
344* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
345- %post -p was wrong
346
347* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
348- explicitly add %{_libdir}/libgstreamer-{major}.so
349- explicitly add %{_libdir}/libgstcontrol-{major}.so
350
351* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
352- bump release
353
354* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
355- move .so files out of -devel
356
357* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
358- new version 0.5.0
359- require docbook-style-xsl
360- add gstreamer-tools package too
361- New patch to use the right docbook prefix.
362
363* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
364- downgrade to a release candidate.  Should work better on other arches
365- build without Werror
366
367* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
368- update to new version.  Remove ExcludeArch
369
370* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
371- excludearch some arches
372
373* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
374- import into CVS and build "officially"
375- use smp_mflags
376- temporarily disable docs build, doesn't seem to work
377
378* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
379- 0.4.2
380
381* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
382- 0.4.1
383
384* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
385- minor cleanups
386
387* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
388- moved header location
389
390* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
391- added popt
392- removed .la
393
394* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
395- added release of gstreamer to req of gstreamer-devel
396- changed location of API docs to be in gtk-doc like other gtk-doc stuff
397- reordered SPEC file
398
399* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
400- moved html docs to gtk-doc standard directory
401
402* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
403- move version defines of glib2 and libxml2 to configure.ac
404- add BuildRequires for these two libs
405
406* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
407- put html docs in canonical place, avoiding %doc erasure
408- added devhelp support, current install of it is hackish
409
410* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
411- Added documentation to build
412
413* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
414- added libgstbasicscheduler
415- renamed libgst to libgstreamer
416
417* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
418- Added configdir parameter as it seems the configdir gets weird otherwise
419
420* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
421- split off gstreamer-editor from core
422- removed gstreamer-gnome-apps
423
424* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
425- Cleaned up the spec file for the gstreamer core/plug-ins split
426- Improve spec file
427
428* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
429- Split of more plugins from the core and put them into their own modules
430- Includes colorspace, xfree and wav
431- Improved package Require lines
432- Added mp3encode (lame based) to the SPEC
433
434* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
435- Thomas merged mpeg plugins into one
436* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
437- More minor cleanups including some fixed descriptions from Andrew Mitchell
438
439* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
440- Added logging to the make statement
441
442* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
443- Updated in preparation for 0.3.0 release
444
445* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
446- Updated for 0.2.1 release
447- Split out the GUI packages into their own RPM
448- added new plugins (FLAC, festival, quicktime etc.)
449
450* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
451- Visualisation plugins bundled out togheter
452- Moved files sections up close to their respective descriptions
453
454* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
455- Split the package into separate RPMS,
456  putting most plugins out by themselves.
457
458* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
459- Updated with change suggestions from Dennis Bjorklund
460
461* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
462- updated to build -devel package as well
463
464* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
465- first draft of spec file
466
Note: See TracBrowser for help on using the repository browser.