source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 1860

Revision 1860, 14.8 KB checked in by iwaim, 14 years ago (diff)

build with rpm 4.8.1-1; see [VineSeed:21799]

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.20.0
5%define _libxml2_ver    2.6.15
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.1
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.30
18Release:        2%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.bz2
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34Requires:       glib2 >= %{_glib2_ver}
35Requires:       libxml2 >= %{_libxml2_ver}
36Obsoletes:      gstreamer-tools
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       inagaki
41
42%description
43GStreamer is a streaming-media framework, based on graphs of filters which
44operate on media data. Applications using this library can do anything
45from real-time sound processing to playing videos, and just about anything
46else media-related.  Its plugin-based architecture means that new data
47types or processing capabilities can be added simply by installing new
48plugins.
49
50%package devel
51Summary:        Libraries/header files for GStreamer streaming media framework.
52Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
53Group:          Development/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       glib2-devel >= %{_glib2_ver}
56Requires:       libxml2-devel >= %{_libxml2_ver}
57
58%description devel
59GStreamer is a streaming-media framework, based on graphs of filters which
60operate on media data. Applications using this library can do anything
61from real-time sound processing to playing videos, and just about anything
62else media-related.  Its plugin-based architecture means that new data
63types or processing capabilities can be added simply by installing new   
64plugins.
65
66This package contains the libraries and includes files necessary to develop
67applications and plugins for GStreamer.
68
69# compat32
70%package -n compat32-%{name}
71Summary:        GStreamer streaming media framework runtime.
72Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
73Group:          System Environment/Libraries
74
75%description -n compat32-%{name}
76GStreamer is a streaming-media framework, based on graphs of filters which
77operate on media data. Applications using this library can do anything
78from real-time sound processing to playing videos, and just about anything
79else media-related.  Its plugin-based architecture means that new data
80types or processing capabilities can be added simply by installing new
81plugins.
82
83%package -n compat32-%{name}-devel
84Summary:        Libraries/header files for GStreamer streaming media framework.
85Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
86Group:          Development/Libraries
87Requires:       compat32-%{name} = %{version}-%{release}
88Requires:       %{name}-devel = %{version}-%{release}
89Requires:       compat32-glib2-devel >= %{_glib2_ver}
90Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
91
92%description -n compat32-%{name}-devel
93GStreamer is a streaming-media framework, based on graphs of filters which
94operate on media data. Applications using this library can do anything
95from real-time sound processing to playing videos, and just about anything
96else media-related.  Its plugin-based architecture means that new data
97types or processing capabilities can be added simply by installing new   
98plugins.
99
100This package contains the libraries and includes files necessary to develop
101applications and plugins for GStreamer.
102
103%prep
104%setup -q
105
106%build
107%configure \
108        --with-package-name='Vine Linux gstreamer package' \
109        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
110        --disable-docbook --enable-gtk-doc \
111        --disable-static --disable-examples \
112        --disable-tests --disable-debug
113
114make %{?_smp_mflags}
115
116%install
117[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT
120
121mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
122
123rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
125#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
126
127%find_lang %{po_package}
128
129%clean
130[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
131
132%post -p /sbin/ldconfig
133
134%postun -p /sbin/ldconfig
135
136%post -n compat32-%{name} -p /sbin/ldconfig
137
138%postun -n compat32-%{name} -p /sbin/ldconfig
139
140%files -f %{po_package}.lang
141%defattr(-, root, root)
142%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
143%doc TODO ABOUT-NLS
144%{_bindir}/*
145%dir %{_libdir}/gstreamer-%{major}
146%{_libdir}/gstreamer-%{major}/*.so*
147%{_libdir}/*.so.*
148%dir %{_libexecdir}/gstreamer-%{major}
149%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
150%{_mandir}/man1/*
151%dir %{_var}/cache/gstreamer-%{major}
152
153%files devel
154%defattr(-, root, root)
155%dir %{_includedir}/%{name}-%{major}
156%{_includedir}/%{name}-%{major}/*
157#{_libdir}/*.a
158%{_libdir}/*.so
159%{_libdir}/pkgconfig/gstreamer*.pc
160%{_datadir}/aclocal/*.m4
161%{_datadir}/gtk-doc/html/gstreamer-%{major}
162%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
163%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
164
165# compat32
166%if %{build_compat32}
167%files -n compat32-%{name}
168%defattr(-, root, root)
169%dir %{_libdir}/gstreamer-%{major}
170%{_libdir}/gstreamer-%{major}/*.so*
171%{_libdir}/*.so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-, root, root)
175#{_libdir}/*.a
176%{_libdir}/*.so
177%{_libdir}/pkgconfig/gstreamer*.pc
178%endif
179
180%changelog
181* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
182- build with rpm-4.8.1-1 for pkg-config file
183
184* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
185- new upstream release
186
187* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
188- new upstream release
189
190* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
191- new upstream release
192- used make install instead of %%makeinstall
193
194* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
195- new upstream release
196- built with new toolchain
197
198* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
199- new upstream release
200
201* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
202- new upstream release
203
204* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
205- added compat32 package for x86_64 arch support
206
207* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
208- new upstream release
209- removed static librairies from devel package
210- added Packager tag
211
212* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
213- new upstream release
214- changed Group to System Environment/Libraries
215
216* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
217- new upstream release
218- spec in UTF-8
219
220* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
221- new upstream release
222
223* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
224- new upstream release
225
226* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
227- new upstream release
228
229* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
230- new upstream release
231
232* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
233- new upstream release
234
235* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
236- new upstream release
237
238* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
239- new upstream release
240- add Vendor/Distribution tag
241- add '-with-package-name' option to %%configure
242- use more macros
243
244* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
245- new upstream release
246
247* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
248- new upstream release
249
250* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
251- new upstream release
252
253* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
254- new upstream release
255
256* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
257- new upstream release
258
259* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
260- new upstream release
261
262* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
263- new upstream release
264
265* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
266- new upstream release
267
268* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
269- new upstream release
270
271* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
272- new upstream release
273  - change major to 0.10
274- update URLs
275- update versions: glibc >= 2.8, gtk-doc >= 1.3
276- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
277- remove from BuildRequires: popt, zlib-devel
278- remove obsolete options from %%configure
279- add --enable-gtk-doc to %%configure
280- add gtk-doc/html/gstreamer-* to gstreamer-devel package
281- add RELEASE to %%doc
282- remove REQUIREMENTS DOCBUILDING from %%doc
283- not exec gst-register-%%{major} at %%post
284
285* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
286- new upstream release
287
288* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
289- new upstream release
290
291* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
292- new upstream release
293- removed dependancy related to documentaion build
294
295* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
296- new upstream release
297
298* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
299- new upstream release
300
301* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
302- update alpha-noWerror patch (Patch10)
303
304* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
305- new upstream release
306
307* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
308- new upstream release
309
310* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
311- new upstream release
312
313* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
314- build without -Werror on alpha (Patch10)
315
316* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
317- new upstream release
318
319* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
320- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
321
322* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
323- fix broken %files entries..
324
325* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
326- new upstream release
327
328* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
329- build for Vine Linux
330
331* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
332- Add patch1 to fix C++ plugins on ia64
333
334* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
335- %post -p was wrong
336
337* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
338- explicitly add %{_libdir}/libgstreamer-{major}.so
339- explicitly add %{_libdir}/libgstcontrol-{major}.so
340
341* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
342- bump release
343
344* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
345- move .so files out of -devel
346
347* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
348- new version 0.5.0
349- require docbook-style-xsl
350- add gstreamer-tools package too
351- New patch to use the right docbook prefix.
352
353* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
354- downgrade to a release candidate.  Should work better on other arches
355- build without Werror
356
357* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
358- update to new version.  Remove ExcludeArch
359
360* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
361- excludearch some arches
362
363* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
364- import into CVS and build "officially"
365- use smp_mflags
366- temporarily disable docs build, doesn't seem to work
367
368* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
369- 0.4.2
370
371* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
372- 0.4.1
373
374* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
375- minor cleanups
376
377* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
378- moved header location
379
380* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
381- added popt
382- removed .la
383
384* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
385- added release of gstreamer to req of gstreamer-devel
386- changed location of API docs to be in gtk-doc like other gtk-doc stuff
387- reordered SPEC file
388
389* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
390- moved html docs to gtk-doc standard directory
391
392* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
393- move version defines of glib2 and libxml2 to configure.ac
394- add BuildRequires for these two libs
395
396* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
397- put html docs in canonical place, avoiding %doc erasure
398- added devhelp support, current install of it is hackish
399
400* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
401- Added documentation to build
402
403* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
404- added libgstbasicscheduler
405- renamed libgst to libgstreamer
406
407* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
408- Added configdir parameter as it seems the configdir gets weird otherwise
409
410* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
411- split off gstreamer-editor from core
412- removed gstreamer-gnome-apps
413
414* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
415- Cleaned up the spec file for the gstreamer core/plug-ins split
416- Improve spec file
417
418* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
419- Split of more plugins from the core and put them into their own modules
420- Includes colorspace, xfree and wav
421- Improved package Require lines
422- Added mp3encode (lame based) to the SPEC
423
424* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
425- Thomas merged mpeg plugins into one
426* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
427- More minor cleanups including some fixed descriptions from Andrew Mitchell
428
429* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
430- Added logging to the make statement
431
432* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
433- Updated in preparation for 0.3.0 release
434
435* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
436- Updated for 0.2.1 release
437- Split out the GUI packages into their own RPM
438- added new plugins (FLAC, festival, quicktime etc.)
439
440* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
441- Visualisation plugins bundled out togheter
442- Moved files sections up close to their respective descriptions
443
444* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
445- Split the package into separate RPMS,
446  putting most plugins out by themselves.
447
448* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
449- Updated with change suggestions from Dennis Bjorklund
450
451* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
452- updated to build -devel package as well
453
454* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
455- first draft of spec file
456
Note: See TracBrowser for help on using the repository browser.